[SOLVED] XU4 WiFi dongle 3 stopped working after update

Moderators: mdrjr, odroid

[SOLVED] XU4 WiFi dongle 3 stopped working after update

Unread postby NicoX » Sat Sep 12, 2015 5:16 pm

All/odroid,
I have started a new thread as it is a new issue with my XU4.
I have received my XU4 earlier and was able to connect it to my Sony HD TV.
I did not have to change the boot.ini file.
After I got my screen working I run the odroid utility first. Thanks @phaseshifter for help.
phaseshifter wrote: .... run the odroid utility
first resize your root partition and then
update the kernel


Then I used this code to update
Code: Select all
    sudo -s
    apt-get update && apt-get upgrade && apt-get dist-upgrade


Then boom :cry: My WiFi Module 3 stopped working. http://www.hardkernel.com/main/products/prdt_info.php?g_code=G137447734369
I was browsing web and downloaded all updates of Ubuntu through WIFI dongle only.
I checked the blue LED in the dongle is not blinking. :cry:
I tried with different USB ports nothing, is this Gone?

@rooted asked me to try out
Code: Select all
dmesg
to see the out put.
Attaching response can any one help to fix it. :oops:

Regards
NicoX
Attachments
dmesg.txt
dmesg output XU4
(27.02 KiB) Downloaded 39 times
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby phaseshifter » Sat Sep 12, 2015 5:49 pm

you may need to start fresh over..isuggest that after you flash run this code only
Code: Select all
apt-get update && apt-get upgrade
do not include the "dist upgrade " i think this is where your problem started..
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2877
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby NicoX » Sat Sep 12, 2015 5:51 pm

Did
Code: Select all
 lsusb
if it can detect my Dongle 3.
No luck @phaseshifter .

I am starting from flashing and reinstalling .... You have any link handy?

NicoX
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby phaseshifter » Sat Sep 12, 2015 6:00 pm

ok once you have flashed a fresh image 15.04 if not post which op you are using...
..
1:run the odroid utility
resize your partition
reboot
2:run utility again
update your kernel
reboot
3: you should by now get the "software updater" come up on the screen
. do not go into the command line
if not start it and let it do all the updating 4 you
then you should be right to go
..if you still have problems then repost here i will do my best to help you.
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2877
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby NicoX » Sat Sep 12, 2015 6:05 pm

To All Odroid gods and phaseshifter,
Before coming to this forum other people said go for RPi as odroid may have less user base.
I came here and am glad I got lot of helping minds literally educating me to all new linux world.
phaseshifter wrote: i will do my best to help you.

Thanks a lot.

NicoX
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby NicoX » Sun Sep 13, 2015 3:37 am

I did not flash till now tried one code ....
Code: Select all
lsusb


The result is attached and I guess it found the Wifi dongle 3 as hardware.
I guess the dongle hardware is in good shape may reinstall will do the magic.
:arrow: In the attached look for Bus 001 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
:arrow: RTL8188CUS is the main chip for wifi dongle 3 right?
What do you guys say?
NicoX
Attachments
lsusb.txt
lsusb result
(805 Bytes) Downloaded 24 times
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby phaseshifter » Sun Sep 13, 2015 11:18 am

the dongle is being recognized..looks ok
so it must be a software problem i think
are you shure your wifi network can see the connection or find it on the router/modem end...

E.G move the xu4 closer to the router/modem it may be a distance issue..

try
Code: Select all
lsusb -t
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2877
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby odroid » Sun Sep 13, 2015 3:19 pm

NicoX wrote: :arrow: In the attached look for Bus 001 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
:arrow: RTL8188CUS is the main chip for wifi dongle 3 right?


Yes, the WiFi module 3 has the chip.
ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
User avatar
odroid
Site Admin
 
Posts: 28510
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby NicoX » Sun Sep 13, 2015 3:41 pm

Thanks both phaseshifter/odroid for your help.

phaseshifter wrote:the dongle is being recognized..looks ok
so it must be a software problem i think
are you shure your wifi network can see the connection or find it on the router/modem end...
E.G move the xu4 closer to the router/modem it may be a distance issue..
try
Code: Select all
lsusb -t

When I am booting inside Ubuntu it is showing no hardware attached found for networking.
I tried putting Odroid near to Router (I am using TP Link Router 3 antenna ... forgot the model number ;) ) ..... nothing.
:arrow: Trying
Code: Select all
lsusb -t
will revert.
:arrow: 2 Qs is there a place where I can get the meaning of the commands I use for Odroid (A link may be)?
I mean I could know what exactly your brains indicating me to debug :)

:arrow:
odroid wrote:Yes, the WiFi module 3 has the chip.
ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

What is this line meaning ID 0bda:8176 :lol: I only got the hardware name Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter.
I mean id ID meaning the ID for the port etc? Soory nooby question @odroid

Regards
NicoX
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby NicoX » Sun Sep 13, 2015 4:13 pm

Result of
Code: Select all
lsusb -t
attached. Really got a tangent from my head :(
NicoX
Attachments
lsusb -t.txt
lsusb -t result
(1.84 KiB) Downloaded 28 times
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby phaseshifter » Sun Sep 13, 2015 4:36 pm

it`s seeing both the eth port and the wlan have you got a cable attached to it
i think the problem could be it cannot define which port to connect with
i am lost i suggested just about my worth with this i hope somebody can shed some light 4 you

possible it could be that one or the other has priority over the network seldom seen
maybe both computers are trying to access the same connection however
i think i would be going with a fresh install may have to be
i cannot think of anything that other
than when you did the "dist-upgrade" you should have got a couple of command line questions these questions are specific in the way that the opp-system boot`s.
if you did not go with the default settings
then this is most likely the reason
you changed your setup configuration files
but unfortunately these are going to be very difficult to fix over the net
this is the reason i suggested a fresh install
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2877
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

[SOLVED] Re: XU4 WiFi dongle 3 stopped working after update

Unread postby NicoX » Sun Sep 13, 2015 5:23 pm

phaseshifter wrote:it`s seeing both the eth port and the wlan .....
this is the reason i suggested a fresh install

phaseshifter good news :D
Code: Select all
1. Press Alt+F2
2. Type [b]nm-applet [/b] and press Enter.

Now I can see another wifi networking icon in pallet.
I clicked on the new one and it had one option enable networking.
Enabled and internet is flowing in XU4. Dongle 3 is working fine :D :D

Just one more q to all.
Any command that will speed up the system? As a bit slow when I am moving windows seems like XU4 needs more RAM so frame dropping happening ;)

Regards
NicoX
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: XU4 WiFi dongle 3 stopped working after update

Unread postby phaseshifter » Sun Sep 13, 2015 6:09 pm

cool there is another way although
system
preferences
network connections
but the command line code is handy though
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2877
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: [SOLVED] Re: XU4 WiFi dongle 3 stopped working after upd

Unread postby odroid » Sun Sep 13, 2015 7:16 pm

NicoX wrote:Just one more q to all.
Any command that will speed up the system? As a bit slow when I am moving windows seems like XU4 needs more RAM so frame dropping happening ;)


Do you use Ubuntu 15.04 Mate? or Ubuntu 14.04 LXDE?
If you use the Mate desktop, disable showing window content while moving windows.
--- System --> Preferences --> Look and Feel --> MATE Tweak --> Windows --> Check "Don't show window contect while draggin them".
If you use the LXDE desktop, you might need to change the Windows Manager to metacity from openbox and reboot.
--- menu/settings/Default applications for LXSession –> Core applications –> Windows manager –> metacity
User avatar
odroid
Site Admin
 
Posts: 28510
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [SOLVED] Re: XU4 WiFi dongle 3 stopped working after upd

Unread postby NicoX » Fri Sep 25, 2015 11:53 pm

Sorry odroid I got late in responding.... Work pressure :(
odroid wrote:Do you use Ubuntu 15.04 Mate? or Ubuntu 14.04 LXDE?


I am using Ubuntu 15.04 Mate desktop, that got shipped with 64Gb eemc card.
I just updated and found my desktop is simple with one palate (default one) not like your as in video in link:
viewtopic.php?f=95&t=13353

My desktop does not have dock like a Mac Book. I think for that I need to install external software :)
But I think graphics is bit slow :(

Regards,
NicoX
Regards

NicoX
User avatar
NicoX
 
Posts: 62
Joined: Sat Aug 08, 2015 1:12 am
languages_spoken: english
ODROIDs: XU4

Re: [SOLVED] XU4 WiFi dongle 3 stopped working after update

Unread postby odroid » Mon Sep 28, 2015 10:38 am

The dock is not installed by default. As far as I remember, we installed the cairo-dock when we recorded the video.
User avatar
odroid
Site Admin
 
Posts: 28510
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [SOLVED] XU4 WiFi dongle 3 stopped working after update

Unread postby Samuel Low » Wed Feb 28, 2018 5:49 pm

Hi I don't mean to necro this thread but I followed the instructions in the manual and ran this:

sudo apt-get update && sudo apt-get upgrade && \
sudo apt-get dist-upgrade


From page 45 in the XU4 manual, and now my wifi adaptor is dead! The blue LED stopped switching on.

When I run lsusb, I can see my USB connection with the Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adaptor

But when I just cannot connect to the internet. Running ifconfig or iwconfig only shows me eth0 and l0, no wlan0 anymore.

Please help! I need to solve this issue I have to run lots of things before a deadline this week. Thank you...
Samuel Low
 
Posts: 17
Joined: Sun Feb 18, 2018 5:24 pm
languages_spoken: english
ODROIDs: XU4

Re: [SOLVED] XU4 WiFi dongle 3 stopped working after update

Unread postby odroid » Wed Feb 28, 2018 6:08 pm

@Samuel Low
Please don't hijack!
Open your own topic.
User avatar
odroid
Site Admin
 
Posts: 28510
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Hardware and peripherals

Who is online

Users browsing this forum: No registered users and 4 guests