WiFi module 3 does not connect after boot

Post Reply
Mzahana
Posts: 36
Joined: Mon Dec 15, 2014 3:08 am
languages_spoken: English, Arabic
ODROIDs: Odroid U3, C0, XU4
Contact:

WiFi module 3 does not connect after boot

Unread post by Mzahana » Mon Aug 20, 2018 7:47 pm

Hi.

I am using Wifi module 3 with ODROID XU4 and Ubuntu 16 minimal version.

I am trying to connect to my wifi access point (using dhcp).

I would like to get auto connection after boot. I am not able to do this and I have to use the following after login

Code: Select all

sudo ifdown wlan0
sudo ifup wlan0
My /etc/network/interface looks like:

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "MY_SSID"
wpa-psk "my_password"
Can you please help in debugging this issue?

Thanks.

moon.linux
Posts: 1161
Joined: Thu Oct 02, 2014 11:42 pm
languages_spoken: english
Contact:

Re: WiFi module 3 does not connect after boot

Unread post by moon.linux » Tue Aug 21, 2018 3:35 am

Please find the guide line to connect Wifi.
https://wiki.odroid.com/troubleshooting ... etup_nmcli

Mzahana
Posts: 36
Joined: Mon Dec 15, 2014 3:08 am
languages_spoken: English, Arabic
ODROIDs: Odroid U3, C0, XU4
Contact:

Re: WiFi module 3 does not connect after boot

Unread post by Mzahana » Tue Aug 21, 2018 6:21 am

Thanks. What is the recommended way to set a static IP?

moon.linux
Posts: 1161
Joined: Thu Oct 02, 2014 11:42 pm
languages_spoken: english
Contact:

Re: WiFi module 3 does not connect after boot

Unread post by moon.linux » Tue Aug 21, 2018 12:51 pm

You can add the static ip setting in /etc/network/interfaces and connect to wifi network.
Or you can map the mac address of the wifi card to static ip in your router setting,
so that DHCP request fetch up same ip address.

Mzahana
Posts: 36
Joined: Mon Dec 15, 2014 3:08 am
languages_spoken: English, Arabic
ODROIDs: Odroid U3, C0, XU4
Contact:

Re: WiFi module 3 does not connect after boot

Unread post by Mzahana » Tue Aug 21, 2018 1:52 pm

Thanks the nmcli command worked fine for me. Now, the board connects to Wifi automatically after boot.

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: mrlooneytoon and 1 guest