Support for BSD

Post Reply
arrigo
Posts: 5
Joined: Fri Jan 19, 2018 11:09 pm
languages_spoken: english,italian,french,spanish
Contact:

Support for BSD

Unread post by arrigo » Wed Jan 31, 2018 8:01 pm

Hi,

I am looking at a number of ARM devices to replace low-usage Intel systems I have in data centres which I would like to move in-house and the ideal replacement would be the ODROID-HC2 with a suitable HDD or SDD (they are all mail servers or low/medium traffic web servers). Unfortunately one of the key requirements is that one of the BSDs is supported (FreeBSD/NetBSD/OpenBSD) and currently I do not see suitable images for them.

Does anyone run BSD on ODROID SBCs, in particular the ones with a SATA port?

Thank you,

Arrigo

crashoverride
Posts: 4230
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Contact:

Re: Support for BSD

Unread post by crashoverride » Thu Feb 01, 2018 5:09 pm

On XU4, HC-x, MC-x you should be able to run FreeBSD (armv7) or any mainline linux kernel under the XEN hypervisor. I have not personally tested this but after installing XEN, any OS that supports it should be usable in a DOM-U and possibly even as DOM-0 on boards running "headless". There is no official support for this that I am aware of.

arrigo
Posts: 5
Joined: Fri Jan 19, 2018 11:09 pm
languages_spoken: english,italian,french,spanish
Contact:

Re: Support for BSD

Unread post by arrigo » Thu Feb 01, 2018 6:19 pm

Running under Xen is not really ideal but could be an interim solution - does anyone know if Hardkernel has reached out to the BSD community? They are very actively porting to aarch64 (ARM64) with a solid Raspberry Pi 3 port and a growing PINE64 port. The Hardkernel hardware is rather more interesting, especially concerning NAS usage, where a dual-SATA HC4 so that you can run FreeBSD with ZFS would be ideal.

Is there any chance you could send demo hardware to the FreeBSD/OpenBSD people? They are all at FOSDEM if Hardkernel has any representation there.

elatllat
Posts: 1137
Joined: Tue Sep 01, 2015 8:54 am
languages_spoken: english
ODROIDs: XU4, N1
Contact:

Re: Support for BSD

Unread post by elatllat » Sat Feb 10, 2018 4:17 pm

mouseless wrote:
...My personal favourite would also be the RK3399, but for different reasons:

This SOC has openBSD support.

Sure, this hasn't been mentioned much in this thread, but that is because there has never been much cooperation between HK and BSD. I'm sure if the proper booting software & licences would be provided, BSD support would be added quickly. OpenBSD even support the Raspberry 3, though it only runs on 1.2GHz/1GB RAM and 100Bit ethernet :cry:...
Odroid-N1 is using RK3399.

crashoverride might be correct even though I don't find this quote compelling;
crashoverride wrote:
mouseless wrote:I bet you yourself wouldn't want an odroid if linux there was only running inside a windows vm.
I am not the only one that you would lose that bet with. :D

These days, nobody runs BSD bare metal. Even "big metal" uses hypervisors now. In the case of a router or firewall, its preferred to run in a VM so that it can easily be maintained, monitored, security mitigated, restarted, etc. For any professional/business use, a VM is mandatory....

User avatar
rooted
Posts: 6286
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: Support for BSD

Unread post by rooted » Sun Feb 11, 2018 12:51 am

I agree, as long as the VM gives adequate performance I don't see any issue. I have that old school attitude of wanting to run the OS on 'bare metal' as well but VM's are the way to go for a lot of things that previously were done by dedicated hardware.

arrigo
Posts: 5
Joined: Fri Jan 19, 2018 11:09 pm
languages_spoken: english,italian,french,spanish
Contact:

Re: Support for BSD

Unread post by arrigo » Mon Feb 12, 2018 3:20 am

I'm very sorry but, as a security practitioner, running in a VM what I want to run securely is not an option. The underlying OS, i.e. Linux, does not give me the security guarantees I need for my application.

Nobody in their sane mind runs serious FreeBSD installations (e.g. database servers) in a VM, it would be quite stupid to run ZFS on anything but bare metal disks. I'm pretty sure that Netflix, which runs their whole service on FreeBSD, runs on bare metal…

So no, I am interested in running BSD bare-metal and not within a Linux VM. If this is of no interest I can look elsewhere, I am still trying to find replacements for my Intel servers and had considered the HC1 but I notice that competitors are also coming up with ARM-based boards which support SATA, some directly on-board, others via PCIe.

elatllat
Posts: 1137
Joined: Tue Sep 01, 2015 8:54 am
languages_spoken: english
ODROIDs: XU4, N1
Contact:

Re: Support for BSD

Unread post by elatllat » Mon Feb 12, 2018 11:16 am

I'll let you know how OpenBSD runs on the N1 whenever shipping gets it to me. I'll try the img / instructions here; https://www.openbsd.org/arm64.html

Ronaldleess
Posts: 59
Joined: Wed May 24, 2017 6:52 am
languages_spoken: english
ODROIDs: XU4 C1 C1+
Contact:

Re: Support for BSD

Unread post by Ronaldleess » Tue Mar 20, 2018 12:10 am

http://www.netbsd.org/~jmcneill/odroidxu4.txt

So, Mr Jared has the XU4 booting to multi-user with NetBSD. The guy is amazing. I haven't seen anything more about this however; so there must be some stumbling block. Maybe the exynos ethersphere is too tightly controlled with NDA etc.

That's what makes me think that a BSD port to Rockchip / Odroid N1 is more likely, more quickly, since there already is a port for a previous version.
I am The Umbrella Man

Seb
Posts: 9
Joined: Sun Jul 16, 2017 3:36 am
languages_spoken: english
Contact:

Re: Support for BSD

Unread post by Seb » Wed Aug 08, 2018 8:15 pm

I'm also interested in seeing FreeBSD run on these devices. Have you tried cross-compiling from an FreeBSD/amd64 system? That's probably your best bet. I'm using a server, running FreeBSD on bare metal funnily enough... currently in the middle of `svn checkout svn://svn.freebsd.org/base/head src`... gah, so boring. Eh, I could run it on this machine, but then I probably can't watch youtube while I'm running it.

If anyone here has tried something, what went wrong? Maybe we can help... I only ever successfully failed at porting the dark mod to armv7... but let's see...

I'm going to go ahead and assume 0x90800000 is our `loadaddr` -- <https://github.com/hardkernel/u-boot/co ... d7adf6d445>... so if you're following this guide you'll want to use `make buildworld TARGET_ARCH=armv7 UBLDR_LOADADDR=0x90800000 __MAKE_CONF=/dev/null srcconf=/dev/null -j6` (revise -j6) instead of `make buildworld TARGET_ARCH=armv6` and okay my world is BUILDING. So boring!

Welp, I'm going to watch youtube... I'll report back when I have details to share.

S199pWa1k9r
Posts: 1
Joined: Mon Jan 21, 2019 5:09 pm
languages_spoken: english
ODROIDs: ORDOID-HC2
Contact:

Re: Support for BSD

Unread post by S199pWa1k9r » Mon Jan 21, 2019 5:31 pm

Hi...
I'm trying to boot FreeBSD on ODRIOD-HC2, but so far unsuccessfully ...

Code: Select all

U-Boot 2018.11 (Jan 10 2019 - 13:55:24 +0300) for ODROID-HC1/HC2

CPU:   Exynos5422 @ 800 MHz
Model: Odroid XU3 based on EXYNOS5422
Board: Odroid XU3 based on EXYNOS5422
Type:  hc1
DRAM:  2 GiB
MMC:   EXYNOS DWMMC: 0, EXYNOS DWMMC: 2
Loading Environment from MMC... Card did not respond to voltage select!
*** Warning - No block device, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Hit any key to stop autoboot:  2  1  0 
MMC Device 1 not found
no mmc device at slot 1
Card did not respond to voltage select!
switch to partitions #0, OK
mmc2 is current device
Scanning mmc 2:1...
Found EFI removable media binary efi/boot/bootarm.efi
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
Card did not respond to voltage select!
Scanning disk mmc@12200000.blk...
Disk mmc@12200000.blk not ready
Scanning disk mmc@12220000.blk...
Found 3 disks
106292 bytes read in 14 ms (7.2 MiB/s)
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
## Starting EFI application at 42000000 ...

>> FreeBSD EFI boot block
   Loader path: /boot/loader.efi

   Initializing modules: ZFS UFS
   Load Path: /\efi\boot\bootarm.efi
   Load Device: /VenHw(e61d73b9-a384-4acc-aeab-82e828f3628b)/SD(2)/SD(0)/HD(1,0x01,0,0x81f,0xfff0)
   Probing 3 block devices.....* done
    ZFS found no pools
    UFS found 1 partition
Consoles: EFI console  
|/FreeBSD/arm EFI loader, Revision 1.1

   Command line arguments: l
   EFI version: 2.70
   EFI Firmware: Das U-Boot (rev 8216.4352)
   Console: efi (0)
   Load Device: /VenHw(e61d73b9-a384-4acc-aeab-82e828f3628b)/SD(2)/SD(0)/HD(2,0x01,0,0x10c00,0x1bdc00)
Trying ESP: /VenHw(e61d73b9-a384-4acc-aeab-82e828f3628b)/SD(2)/SD(0)/HD(2,0x01,0,0x10c00,0x1bdc00)
Setting currdev to disk0p2:
Loading /boot/defaults/loader.conf
Loading Kernel and Modules (Ctrl-C to Abort)
.
/boot/kernel/kernel text=0x56a4e4 data=0x53274+0x5188c syms=[0x4+0x61480+0x4+0x847f2]
/boot/dtb/exynos5422-odroidhc1.dtb size=0xf112

Hit [Enter] to boot immediately, or any other key for command prompt.
Booting [/boot/kernel/kernel] in 4 seconds... 
Booting [/boot/kernel/kernel] in 3 seconds... 
Booting [/boot/kernel/kernel] in 2 seconds... 
Booting [/boot/kernel/kernel] in 1 second... 
Booting [/boot/kernel/kernel]...               
Using DTB from loaded file '/boot/dtb/exynos5422-odroidhc1.dtb'.
Kernel entry at 0xae800180...
Kernel args: (null)
modulep: 0xc0716000
relocation_offset 0
Someone already tried it?

Post Reply

Return to “Other OS”

Who is online

Users browsing this forum: No registered users and 2 guests