OpenMediaVault setup EMMC

Moderators: odroid, mdrjr

OpenMediaVault setup EMMC

Unread postby Judibet » Fri May 19, 2017 5:19 pm

Hello,

I would like to setup OpenMediaVault in EMMC memory.

Before, I make a backup of the original EMMC content and I check how setup OpenMediaVault.
I founded this topic.

I tried this but it's not working:
Code: Select all
sudo dd if=Armbian_5.27_Odroidxu4_Debian_jessie_next_4.9.27.img of=/dev/sde bs=4096 && sudo sync

Then, I have a big problem: OpenMediaVault is not running and I have only one partition...

With the original image, I hade 2 partitions and it was working:
  1. /dev/sde1: boot (FAT16, 218 Mb)
  2. /dev/sde2: rotofs (ext4): 4,07 Gb)

OpenMediaVault Odroid XU4 images

How please can I setup OpenMediaVault in EMMC memory?
Thank you for helping ;).

Best regards,
Last edited by Judibet on Fri May 19, 2017 7:12 pm, edited 1 time in total.
User avatar
Judibet
 
Posts: 6
Joined: Fri May 19, 2017 4:35 pm
Location: EST-ENSEMBLE
languages_spoken: French, English
ODROIDs: Odroid XU4

Re: OpenMediaVault setup EMMC

Unread postby odroid » Fri May 19, 2017 5:30 pm

Refer this thread.
OMV team seems to be fixing the eMMC booting issue. Please try to help them.
http://forum.openmediavault.org/index.p ... /?pageNo=7
User avatar
odroid
Site Admin
 
Posts: 22777
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: OpenMediaVault setup EMMC

Unread postby Judibet » Fri May 19, 2017 6:14 pm

odroid wrote:Refer this thread.
OMV team seems to be fixing the eMMC booting issue. Please try to help them.
http://forum.openmediavault.org/index.p ... /?pageNo=7

Thank you for this very fast reply :-).

But it's not a joke, I could't write them (I don't know why and how do that).
And I tried with Xubuntu images: it's not working.
I retried with the original image and it's working.

I found this topic
And they use SD Card and flash eMMC after.

I had to do that?

I will try with this image.
User avatar
Judibet
 
Posts: 6
Joined: Fri May 19, 2017 4:35 pm
Location: EST-ENSEMBLE
languages_spoken: French, English
ODROIDs: Odroid XU4

Re: OpenMediaVault setup EMMC

Unread postby odroid » Fri May 19, 2017 6:23 pm

Refer this thread first.
viewtopic.php?f=53&t=2725
User avatar
odroid
Site Admin
 
Posts: 22777
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: OpenMediaVault setup EMMC

Unread postby Judibet » Fri May 19, 2017 6:55 pm

I read this topic before buyed the Odroid C4 :lol:.
I have already this:
Image
And this to :-).
Image
User avatar
Judibet
 
Posts: 6
Joined: Fri May 19, 2017 4:35 pm
Location: EST-ENSEMBLE
languages_spoken: French, English
ODROIDs: Odroid XU4

Re: OpenMediaVault setup EMMC

Unread postby odroid » Fri May 19, 2017 7:17 pm

To narrow down root causes,

1. Download this latest OS image.
http://odroid.com/dokuwiki/doku.php?id= ... e_20170510

2. Use Etcher to flash the OS.
http://odroid.com/dokuwiki/doku.php?id= ... ing_etcher
User avatar
odroid
Site Admin
 
Posts: 22777
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: OpenMediaVault setup EMMC

Unread postby Judibet » Sat May 20, 2017 9:14 pm

Hello,

I tried again and it's not working with OpenMediaVault for eMMC.
Code: Select all
sudo dd if=Armbian_5.27_Odroidxu4_Debian_jessie_next_4.9.28.img of=/dev/sde bs=4096 conv=fsync && sudo sync


I have nothing on screen.
Image is present on eMMC in /dev/sde1 (ext4).
I have to create /boot in FAT16 and rootfs ?

I tried a lot of things and only when I have the original image it's booting, with /boot and rootfs.

Do you please have and idea of how do this?

Note I can't write in OpenMediaVault forum.

Regards,
User avatar
Judibet
 
Posts: 6
Joined: Fri May 19, 2017 4:35 pm
Location: EST-ENSEMBLE
languages_spoken: French, English
ODROIDs: Odroid XU4

Re: OpenMediaVault setup EMMC

Unread postby Judibet » Sun May 21, 2017 12:38 am

I found this: I'm trying again...
User avatar
Judibet
 
Posts: 6
Joined: Fri May 19, 2017 4:35 pm
Location: EST-ENSEMBLE
languages_spoken: French, English
ODROIDs: Odroid XU4

Re: OpenMediaVault setup EMMC

Unread postby Judibet » Thu May 25, 2017 4:43 pm

Hello,

This image is working for me in eMMC.

Best regards,
User avatar
Judibet
 
Posts: 6
Joined: Fri May 19, 2017 4:35 pm
Location: EST-ENSEMBLE
languages_spoken: French, English
ODROIDs: Odroid XU4

Re: OpenMediaVault setup EMMC

Unread postby odroid » Thu May 25, 2017 4:48 pm

Right. But it has old Kernel 3.10 not 4.9.
User avatar
odroid
Site Admin
 
Posts: 22777
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Other OS

Who is online

Users browsing this forum: No registered users and 4 guests