OFFICIAL Ubuntu 14.04 for XU3

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

This is the first image for XU3 board.
Since a few people already received the board we are starting it.

Its the same Ubuntu 14.04 using Lubuntu that is shipped with U3.

This image comes with ODROID Utility and a new tool exclusive to XU3 that is the Energy Monitor.

After you boot the image for the first time PLEASE open ODROID Utility and resize your partition.
Reboot it to take effect.
Once you are on the Desktop again, Open ODROID Utility and update the kernel.


If you need any module or kernel configuration.. please post here -> http://forum.odroid.com/viewtopic.php?f ... 84&p=47597

Now to the download links:
http://odroid.in/ubuntu_14.04lts/

I hope you all enjoy this new product.

User avatar
odroid
Site Admin
Posts: 38309
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2112 times
Been thanked: 1263 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by odroid »

The Energy Monitor app source code was published in this link.
https://github.com/hardkernel/EnergyMonitor
It was written in Qt and qwt add-on library. ;)

THUNDER
Posts: 13
Joined: Wed Jul 30, 2014 6:47 pm
languages_spoken: English, Lithuanian
ODROIDs: XU3+VU
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by THUNDER »

Any plans to make an installer for it? Or maybe a guide how to build it and links to sources? Even a minimal version with nothing except apt and ssh would be very welcome.

I would really like to have a clean system instead of having to clean the udev, change users and remove things I don't need (which get overlooked quite easily).

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Yes.. I plan to make a Ubuntu Server version :)
That is quite clean :)

THUNDER
Posts: 13
Joined: Wed Jul 30, 2014 6:47 pm
languages_spoken: English, Lithuanian
ODROIDs: XU3+VU
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by THUNDER »

That's exactly what I need!

Replacing the default user and changing root pass is the way to go!

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Ubuntu Server image is now online :) same download link

ariel
Posts: 18
Joined: Mon Aug 25, 2014 10:37 pm
languages_spoken: english
ODROIDs: odroid xu3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by ariel »

Why I can not change the system language to Spanish ???

I deleted all languages ​​but I demá still appears in English, there other repositories to add ??

Thank you

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Preferences -> Language Support

Install the languages if it asks to

mfouad
Posts: 11
Joined: Sun Mar 23, 2014 8:30 pm
languages_spoken: english
ODROIDs: 2 X Odroid-U3, Odroid-XU3 , Odroid-N2
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mfouad »

First , Thanks for the great effort.
Firefox is not playing videos on youtube on this release, where chromium does. Sound is there image is black. And firefox was playing it on U3 in a previous release but in all cases it seems there is no H/W acceleration.
Is there a solution for this? having youtube + mali + firefox + U3 or XU3?
This is happening even if I install flash extension.

After updating the graphics driver via the ODROID utility
glmark2-es2 score is ~ 70 where it is 90 for the U3 should it be better than U3 as it has better GPU?

Thanks again.

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Hi,

There's no HW acceleration for U3/XU3 on Firefox/Chrome.
If they do it is software only.

I have no idea why it works on A but not on B.

As far as the GLmark2 score.. it still high :( it should be locked to 60fps.
Thats our goal.

ibarzel
Posts: 15
Joined: Tue Aug 26, 2014 7:08 pm
languages_spoken: english
ODROIDs: Odroid-X2
Odroid-XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by ibarzel »

To mfouad, video playback is possible on firefox if you set gstreamer to false at about:config.
Copied from another topic.

mfouad
Posts: 11
Joined: Sun Mar 23, 2014 8:30 pm
languages_spoken: english
ODROIDs: 2 X Odroid-U3, Odroid-XU3 , Odroid-N2
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mfouad »

@ibarzel,
Thanks for the response , I tried it and it worked. Put about:config in the address bar, then search for media.gstreamer and set it to false.
Restart -or in my case I had to kill the process- and it works.
@ mdrjr,
Probably not directly related to the topic , but
- There is no browser under X which can utilize the GPU of U3/XU3 specially in running youtube videos?
- please suggest a forum to start a thread to try to make this happen? I'm banging my head with wayland / weston and cannot even to get it to run wayland-backend.

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Once again. The GPU has nothing to do with video decoding.
Video decoding is done by a different block called MFC as there are skilled people working on it.

ecth
Posts: 45
Joined: Wed Jul 09, 2014 2:22 am
languages_spoken: english, german, russian
ODROIDs: XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by ecth »

So people are on it and it should work after some time?
Actually I love everything with this Ubuntu but the missing Video Decoding and maybe automatic energysaving settings. Afaik it always uses A15 cores as long as they're free. Or am I wrong? But that's okay. Still ~1W in idle with FullHD-Monitor connected :)

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Yes.. In fact it already works.. but we do have two issues to be fixed.

1. Is the order that some stuff must be sent to the MFC (we already have it fixed)
2. Is that from time to time there's a small lag on the video.. very small.. we tough in the begging that it was because we was software decoding it..
But it isn't. The same happens with MFC as well..
So we are working on fixing this but ATM we have no clues on that.. ANNDDD I'm at an Airport now :)

ecth
Posts: 45
Joined: Wed Jul 09, 2014 2:22 am
languages_spoken: english, german, russian
ODROIDs: XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by ecth »

Well still that sounds like great news :)
Looking forward for further updates. Will just check videos everytime something updated :D

Atm on Youtube videos stutter a lot. But YouTube-Videos embedded into other sites run quite good! :O Hat a 1080p-Vid yesterday on Tom's Hardware or something like that and it was at least "enjoyable" ^^

tldr: keep up the good work! :)

User avatar
OverSun
Posts: 1493
Joined: Mon Apr 29, 2013 5:12 pm
languages_spoken: english
Has thanked: 0
Been thanked: 19 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by OverSun »

mdrjr wrote:Yes.. In fact it already works.. but we do have two issues to be fixed.

2. Is that from time to time there's a small lag on the video.. very small.. we tough in the begging that it was because we was software decoding it..
But it isn't. The same happens with MFC as well..
So we are working on fixing this but ATM we have no clues on that.. ANNDDD I'm at an Airport now :)
FYI I have my output finally soldered for XU3 and I don't have this issue on direct fbdev drivers. My videos are smooth as butter.

^ That was a wrong assumption, but now I know the reason.

Video is smooth when there is no audio device. I ran everything first without pulseaudio and didn't have sound at all and everything was perfectly smooth. But when I get it to the sound, I see the issue you described.
Last edited by OverSun on Sun Oct 19, 2014 11:09 pm, edited 1 time in total.

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Ohhhhhhh.. That's rather WAY to interesting! :P
Can you test with ARM X11 drivers and see if the same thing happens, if it fixes it ?

If it does them its my drivers being bad and I can fix it :P

User avatar
OverSun
Posts: 1493
Joined: Mon Apr 29, 2013 5:12 pm
languages_spoken: english
Has thanked: 0
Been thanked: 19 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by OverSun »

OverSun wrote:
mdrjr wrote:Yes.. In fact it already works.. but we do have two issues to be fixed.

2. Is that from time to time there's a small lag on the video.. very small.. we tough in the begging that it was because we was software decoding it..
But it isn't. The same happens with MFC as well..
So we are working on fixing this but ATM we have no clues on that.. ANNDDD I'm at an Airport now :)
FYI I have my output finally soldered for XU3 and I don't have this issue on direct fbdev drivers. My videos are smooth as butter.
^ That was a wrong assumption, but now I know the reason.

Video is smooth when there is no audio device. I ran everything first without pulseaudio and didn't have sound at all and everything was perfectly smooth. But when I get it to the sound, I see the issue you described.

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

That's a rather interesting find^2.

Knowing the source of an specific issue helps a lot on debugging it :P
So Audio might be the problem :P

User avatar
OverSun
Posts: 1493
Joined: Mon Apr 29, 2013 5:12 pm
languages_spoken: english
Has thanked: 0
Been thanked: 19 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by OverSun »

Got it.
In System -> Audio Settings, need to set "Output Configuration" to "Fixed" and "Limit Sampling rate" to 44.1. And then it seems fine. For 44.1 videos as well as 48Khz

Obviously this is some sampling-resampling-sync issue between XBMC<->pulseadio, in which I'm not a good user at all, therefore it could be fixed much more elegant in pulseaudio settings I assume.

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Wait.. are you saying that this fixes the issue? Limiting the rate to 44.1kHz? If you lock it at 48kHz the issue returns ?

Just let me know because that can lead to a fix :P

User avatar
OverSun
Posts: 1493
Joined: Mon Apr 29, 2013 5:12 pm
languages_spoken: english
Has thanked: 0
Been thanked: 19 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by OverSun »

Yes. When it is set to 48k the audio is wrong and little stalls are there. This is true also if you set everything to Auto (or how it is called, "compatible"?). It is fine when you set it to Fixed, Resample to 44.1

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

OverSun wrote:Yes. When it is set to 48k the audio is wrong and little stalls are there. This is true also if you set everything to Auto (or how it is called, "compatible"?). It is fine when you set it to Fixed, Resample to 44.1
Thank you for this valuable data :) It will sure help us to fix this faster

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 60 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by memeka »

wow, good find OverSun.... that's a really nice find :)
So I guess things should be working now....

@mdrjr -- did you test the 3.17 kernel? I thought I saw everything was working on it now... (including gpios, mali, mfc, etc...)

@OverSun -- a bit unrelated, just wanted to know if you noticed this: after running XBMC for a while (let's say 24 hours), when playing a video, if you PAUSE then when you resume there is a 2-3 seconds lag when the audio is running but not the video. Then everything is OK. This was not happening a while ago... Not sure if it's related to XBMC code since I only have the XU running it ATM so maybe could be something else? (e.g. hybris) ...

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

@memka no I haven't tested it yet.. probably only next week :(

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Bump, XU3 updated image with working XBMC and MFC.

User avatar
recliq
Posts: 125
Joined: Mon Feb 25, 2013 6:07 pm
languages_spoken: english, german
ODROIDs: 2xU2 + U3 + XU3 + 2xXU4 + C2 + H2 + N2p + OGS
Location: Germany
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by recliq »

Just gave the latest image a shot and noticed that it has still the DPMS bug (X freezes when DPMS is activated).
What about adding this to default xorg.conf until it is fixed in driver?

Code: Select all

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Sure... Sorry that I missed.. I'll add that as part of the Xorg configuration stuff on ODROID Utility :)

User avatar
recliq
Posts: 125
Joined: Mon Feb 25, 2013 6:07 pm
languages_spoken: english, german
ODROIDs: 2xU2 + U3 + XU3 + 2xXU4 + C2 + H2 + N2p + OGS
Location: Germany
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by recliq »

I have some questions regarding EGL configuration on XU3.

1) It seems update-alternatives doesn't work regarding switching from mesa to mali config... As far as I understood it should update the links in /usr/lib/arm-linux-gnueabihf to the respecting libraries in mesa-egl or mali-egl but it doesn't, it's always pointing to mesa-egl.

I noticed this while testing ssppss which is linked to /usr/lib/arm-linux-gnueabihf/libEGL.so and which was painfully slow, whereas es2_info, glmark-es2, etc... seem to be linked to /usr/lib/arm-linux-gnueabihf/mali-egl/libEGL.so so they are always using the mali library.

2) Before the update I had glmark-es2 results of ~160FPS now I only get ~65FPS, did something change? Looks like the driver version didn't change...

User avatar
OverSun
Posts: 1493
Joined: Mon Apr 29, 2013 5:12 pm
languages_spoken: english
Has thanked: 0
Been thanked: 19 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by OverSun »

memeka wrote:@OverSun -- a bit unrelated, just wanted to know if you noticed this: after running XBMC for a while (let's say 24 hours), when playing a video, if you PAUSE then when you resume there is a 2-3 seconds lag when the audio is running but not the video. Then everything is OK. This was not happening a while ago... Not sure if it's related to XBMC code since I only have the XU running it ATM so maybe could be something else? (e.g. hybris) ...
Don't have this on my -XU. I'm running it 24/7 on XBMC, practically I'm rebooting it only for kernel update. Everything is running perfect for me.

gripped
Posts: 691
Joined: Tue May 21, 2013 11:34 pm
languages_spoken: english
ODROIDs: U2 XU U3 XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by gripped »

mdrjr wrote:Bump, XU3 updated image with working XBMC and MFC.
Is the source code for xbmc , that the version in the image was compiled from, uploaded anywhere ?

cnaumer
Posts: 14
Joined: Tue Oct 07, 2014 3:51 am
languages_spoken: english
ODROIDs: XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by cnaumer »

mdrjr wrote:Bump, XU3 updated image with working XBMC and MFC.
Any Chance to geht the xbmc in an already running image as an update?

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 60 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by memeka »

gripped wrote:
mdrjr wrote:Bump, XU3 updated image with working XBMC and MFC.
Is the source code for xbmc , that the version in the image was compiled from, uploaded anywhere ?
I will update soon my repository with the patch for XU3.
I posted on a thread here somewhere the instructions to make it work... just never commited :D

gripped
Posts: 691
Joined: Tue May 21, 2013 11:34 pm
languages_spoken: english
ODROIDs: U2 XU U3 XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by gripped »

memeka wrote:
gripped wrote:
mdrjr wrote:Bump, XU3 updated image with working XBMC and MFC.
Is the source code for xbmc , that the version in the image was compiled from, uploaded anywhere ?
I will update soon my repository with the patch for XU3.
I posted on a thread here somewhere the instructions to make it work... just never commited :D
OK Cheers :)

Hominidae
Posts: 203
Joined: Sun Sep 07, 2014 2:34 am
languages_spoken: english
ODROIDs: XU3, C1
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by Hominidae »

...OK, tested the newest image and kernel...

- XBMC seems to play FullHD material fine now
- USB3 disks not detected
- no CEC (libcec) with xbmc
Is cec supported at all on the XU3?
...pretty sure I've seen it advertised....bought the recommended HDMI cable with it (but from pollin in Germany)
not sure where the problem might be, my TV and "old" HTPC can do it.

kiwi_jonathan
Posts: 63
Joined: Sat Jul 12, 2014 3:38 am
languages_spoken: english
ODROIDs: Ue
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by kiwi_jonathan »

I compared the new image to my copy of the previous XU3 image, after doing an "apt-get update; apt-get upgrade".
I unzipped the image, used kpartx to mount the partitions inside the new image. I copied the kernel, device-tree blob, and uInitrd from the old image into the new image. I used "sudo chroot <new-image-root> dpkg -i" to compare packages on the two images; and "diff -r" on /{,usr}/{bin,sbin,lib}.

The only substantive difference is that the openjdk-7-yre on the new image is a little old. Could you update it, please?
(I personally would find the nfs-client code very useful to have, but it's easy enough to add.)

Hominidae
Posts: 203
Joined: Sun Sep 07, 2014 2:34 am
languages_spoken: english
ODROIDs: XU3, C1
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by Hominidae »

..when I first booted into the newest image, software-updater popped up and offered an update for openjdk-7.
IMHO there is no need to maintain non-odroid specific stuff in the image as long as default update path/ubunbtu-repos and utilities can be used.

kiwi_jonathan
Posts: 63
Joined: Sat Jul 12, 2014 3:38 am
languages_spoken: english
ODROIDs: Ue
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by kiwi_jonathan »

Such local updates get clobbered every time you reflash the image. OTOH maybe Ubuntu pushed that updat, just after the image was cut.
(I thought it was older, but I could be wrong)

Hominidae
Posts: 203
Joined: Sun Sep 07, 2014 2:34 am
languages_spoken: english
ODROIDs: XU3, C1
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by Hominidae »

.....the official image is a good starting point, but for most the install will have its own lifecycle, won't it?
What I do in order to have my own re-start point, should I need to re-flash, is to persist a state/backup of my own

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Hominidae wrote:.....the official image is a good starting point, but for most the install will have its own lifecycle, won't it?
What I do in order to have my own re-start point, should I need to re-flash, is to persist a state/backup of my own
Hominidae,

Images are often posted as a form to help people that can't build/handle certain stuff.
Also, lets say in this case we added XBMC its a example :)

But there's nothing much changed really...
just a new kernel and upgraded packages apart from the XBMC...

Hominidae
Posts: 203
Joined: Sun Sep 07, 2014 2:34 am
languages_spoken: english
ODROIDs: XU3, C1
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by Hominidae »

....I actually didn't want to express the opposite of what you said.
It's a good thing to ship updates that are dependent to the hardware, but I would not expect you to update the image every time the standard ubuntu distro changes/updates
This is something every user should be able to maintain...this is not a windoze world after all.

Hominidae
Posts: 203
Joined: Sun Sep 07, 2014 2:34 am
languages_spoken: english
ODROIDs: XU3, C1
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by Hominidae »

@mdrjr:

...can you please comment on the XU3 and cec capabilities from my post above http://forum.odroid.com/viewtopic.php?f ... =20#p55527 ?

THX!

mdrjr
Site Admin
Posts: 11799
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 43 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by mdrjr »

Hominidae wrote:...OK, tested the newest image and kernel...

- XBMC seems to play FullHD material fine now
- USB3 disks not detected
- no CEC (libcec) with xbmc
Is cec supported at all on the XU3?
...pretty sure I've seen it advertised....bought the recommended HDMI cable with it (but from pollin in Germany)
not sure where the problem might be, my TV and "old" HTPC can do it.
- USB3 still a issue on XU3 that we are investigating the actual cause of that.
- CEC:
CEC is supported on Exynos 5422 but we don't have the driver for it yet (well we have one tied to the HDMI drivers used on Android, so this will be the case again of untying those drivers to be used freely. That should take a while).

Hominidae
Posts: 203
Joined: Sun Sep 07, 2014 2:34 am
languages_spoken: english
ODROIDs: XU3, C1
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by Hominidae »

...thanks mdrj for that info....I can wait for cec drivers...glad that the HW has got the capability...cec is *the* WAF for anything HTPC/xbmc related stuff, IMHO :mrgreen:

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 60 times
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by memeka »

I did not test this image... but on my image, MFC crashes (with kernel panic) quite often (esp if you skip forward/backwards)...
Anyone else sees this behaviour?

cnaumer
Posts: 14
Joined: Tue Oct 07, 2014 3:51 am
languages_spoken: english
ODROIDs: XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by cnaumer »

memeka wrote:
gripped wrote:
mdrjr wrote:Bump, XU3 updated image with working XBMC and MFC.
Is the source code for xbmc , that the version in the image was compiled from, uploaded anywhere ?
I will update soon my repository with the patch for XU3.
I posted on a thread here somewhere the instructions to make it work... just never commited :D
Could you post the link to your repository? I would like to enable the PVR-plugins in XBMC and as far as I understood I need to compile them as there are no packages available for the arm-platform.
Thanks in adnvance.

Regards

Bohemund
Posts: 44
Joined: Fri Nov 29, 2013 9:48 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by Bohemund »

I tried this with VDR and VNSI - it didn't work. The Plugin was not able to connect to the VDR Backend. I would be very happy, if you succeed - pls post a guide when it's working. At the moment the only solution for PVR i found with the XU3 is the 12.04 image with Kaffeine. Picture Quality is very poor this way, but recording is ok.

cnaumer
Posts: 14
Joined: Tue Oct 07, 2014 3:51 am
languages_spoken: english
ODROIDs: XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by cnaumer »

Tvheadend is working for me. It is just the integration in xbmc that I haven't got to work. Tvheadend works as expected.

Regards

jeffvan
Posts: 7
Joined: Sat Nov 15, 2014 3:10 pm
languages_spoken: english
ODROIDs: XU3 Lite
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Ubuntu 14.04 for XU3

Post by jeffvan »

Is it possible to add SWAP into the kernel. It appears that /proc/swaps is missing due to the kernel lacking the feature. It would be great to have this in the server.

Thank you!!!

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 2 guests