no samba access

Moderators: mdrjr, odroid

no samba access

Unread postby hfb » Sat Aug 12, 2017 6:03 am

Hello All,

after new setup to 16.04 I can't access my XU4 via Samba. With old installation 15.10 it worked. Compared the smb.conf, found no differences. smbclient //server/share on the XU4 works. But the share does neither show up under Windows, nor can I connect via smbclient (same username as the local one) from a remote Linux (after entering password a timeout is signaled), nor works a mount entry in my fstab I used with the old OS version of XU4. The smb.conf is mostly like shipped. Only workgroup is changed and the share defined. Testparm shows no errors.

My desktop PC runs ubuntu16.04.3LTS. To me there seem to be no important differences in that smb.conf. But these shares show up in windows and I can connect via smb-extensions ot total commander with my tablet (android). I even tried to set the same options in the gobal section on my XU4. No change.

I want to avoid presenting the whole smb.conf. So please ask for that parts you need, if you want to help.
hfb
User avatar
hfb
 
Posts: 90
Joined: Mon Apr 25, 2016 2:00 am
languages_spoken: english,, deutsch
ODROIDs: XU4 LinuxMate

Re: no samba access

Unread postby odroid » Sat Aug 12, 2017 11:41 am

You might need to check [Shared] part in your smb.conf file.
Code: Select all
[Shared]
comment = CloudShell-2 File Server
path = /media/hdd
guest ok = yes
browseable = yes
create mask = 0644
directory mask = 0755
read only = no
writable = yes
force user = cloudshell


Show your full smb.conf file and some other people can give an idea probably.
User avatar
odroid
Site Admin
 
Posts: 23972
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Ubuntu

Who is online

Users browsing this forum: No registered users and 1 guest