boot.ini resetting in LineageOS

Moderators: odroid, mdrjr

boot.ini resetting in LineageOS

Unread postby robothornet » Tue Nov 20, 2018 8:39 pm

Hi there,

I just began tinkering with my Odroid XU4. I have a VU7 touchscreen and I am running LineageOS-15.1 Android 8.1 Oreo from a SD card.
I managed to activate the VU7 by adding the line "setenv disable_vu7 "false" to the boot.ini (found in the root directory of the SD card.
However, after a few reboots, the touchscreen stops working. The reason seems to be that the boot.ini is reset (the added line is missing from the boot.ini).
Upon re-entering the line "setenv disable_vu7 "false" to the boot.ini, the screen works again until the boot.ini resets again.

Does anyone know how to fix this behaviour? I there a way to "lock" the settings in the boot.ini?
robothornet
 
Posts: 2
Joined: Tue Nov 20, 2018 8:29 pm
languages_spoken: english

Re: boot.ini resetting in LineageOS

Unread postby voodik » Wed Nov 21, 2018 10:55 am

Hi,

boot.ini rewriting when you save some new setting in Odroid Utility.
BTW,
Now i am working on new Odroid Utility i will try make it to preserve custom parameters.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: boot.ini resetting in LineageOS

Unread postby robothornet » Wed Nov 21, 2018 5:30 pm

Hi voodik,

thank you for your input! I don't think the Odroid Utility is to blame for the reset, I didn't save any settings in there. I will try to reproduce the error without the Odroid utility.
Preserving custom parameters in the Odroid Utility is a very cool feature nonetheless, thank you!
robothornet
 
Posts: 2
Joined: Tue Nov 20, 2018 8:29 pm
languages_spoken: english


Return to Android

Who is online

Users browsing this forum: No registered users and 2 guests