XU4 Ethernet dropping.

Post Reply
Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

XU4 Ethernet dropping.

Unread post by Riiio » Wed Aug 03, 2016 7:23 pm

Hello!

I have another issue for you, this time with the Ethernet port.
I struggled to find many similar issues on the forums.
Upon first load, and as long as the PC isn't connected to the network, the ethernet will establish the connection. I can then plug the PC to the network and I have no issues, it runs perfectly. Fantastic product.

However, the ethernet has been dropping out quite regularly and I can't seem to find a clear source of the problem.
If you reboot, Make any changes to PC or Odroid network, switch or try to use internet.. the ethernet port produces the following log using UART.

Code: Select all

47.468803] [c0] init: Starting service 'wpa_supplicant'...
[   47.545164] [c0] init: Service 'wpa_supplicant' (pid 5405) exited with status 255
[   47.731617] [c2] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[   54.487819] [c2] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[   63.780907] [c0] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
[   63.838654] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.842099] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.846962] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.851640] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.856402] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.861154] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.865929] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.870699] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.875471] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   63.880236] [c0] r8152 6-1:1.0 eth0: Rx status -71
[   68.841104] [c0] net_ratelimit: 54163 callbacks suppressed
Full Copy of the Log file can be found attached.

Now this is where it gets strange.
If we SU>IPADDR, we are still producing an ip address. We cannot successfully ping and the port is still recognised even when we disconnect the ethernet cable from the router https://postimg.org/image/gbjjt8osh/

We have encountered the problem now using 4.4.2, 4.4.4 and the 6.1 CM build, updated via updater etc.
We have tried two different Routers, one Sky model and one BT model. Both domestic home network hubs.
After extensive testing, I couldn't narrow down what was causing the issue. It might be of worthy mention that I use OSC messages from a program called "Lemur" as a part of my set up.

I have ordered a 2 port switch and a 5 port switch to try eliminate the possibility of the router being the issue.
I have also just received my C2 board and will attempt the same project on that and post here results.

Any ideas on your end? Ethernet is pretty vital to my work.
Regards
Attachments
Eth0 Error.txt
(209.91 KiB) Downloaded 75 times

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: XU4 Ethernet dropping.

Unread post by odroid » Thu Aug 04, 2016 10:49 am

It seems to be random packet protocol error.
Consider using a CAT5E or CAT6 Ethernet cable with new switches too.

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Thu Aug 04, 2016 4:22 pm

Further Updates next week.

Until then, the C2 has worked without issue.

thanks Odroid

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Mon Aug 15, 2016 11:03 pm

Hello!

The C2 continues to work without issue. Top product. Thanks.

Regarding the XU4, I've now tried at expense to locate if the issue is our end.

I have tried it with 2 switches, 2 home broadband routers.
6 different cables, 3 different XU4 OS...
The XU4 is still responding with the following.

Code: Select all

cfg
ip6tnl0  DOWN                                   0.0.0.0/0   0x00000080 00:00:00:00:00:00
lo       UP                                   127.0.0.1/8   0x00000049 00:00:00:00:00:00
sit0     DOWN                                   0.0.0.0/0   0x00000080 00:00:00:00:00:00
eth0     UP                                 192.168.1.6/24  0x00001043 00:1e:06:30:4a:e0
root@odroidxu3:/ # [ 5680.698313] [c0] net_ratelimit: 59052 callbacks suppressed
[ 5680.702338] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.707192] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.711959] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.716731] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.721506] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.726280] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.731057] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.735820] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.740591] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5680.745370] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.708267] [c0] net_ratelimit: 58944 callbacks suppressed
[ 5685.712283] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.717134] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.721910] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.726683] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.731454] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.736226] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.741003] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.745767] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.750539] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5685.755317] [c0] r8152 6-1:1.0 eth0: Rx status -71
[ 5690.718269] [c0] net_ratelimit: 59173 callbacks suppressed
I'm now convinced the problem is not on our end.
Where do I go from here? the Ethernet is a vital part of my work.
I'd be much happier returning it for the c2 model.

Regards

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: XU4 Ethernet dropping.

Unread post by odroid » Tue Aug 16, 2016 2:01 pm

We couldn't reproduce the issue on our side.
We will keep checking what/why causes the problem on XU4.

Anyway, do you want to replace the XU4 with C2 boards?

User avatar
Brian.K
Posts: 246
Joined: Tue Sep 15, 2015 7:30 pm
languages_spoken: English, Korean
ODROIDs: XU4, C1+, C2
Location: South Korea
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Brian.K » Tue Aug 16, 2016 3:36 pm

This problem looks like the network configuration or environment issue.
Do you use the IPv6? If not, please try to disable IPv6.

Code: Select all

$ su
# mount -o rw,remount /
# vi /init.rc
(Inset below's command at 99 line.)
write /proc/sys/net/ipv6/conf/all/disable_ipv6 1 
# reboot

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Tue Aug 16, 2016 4:54 pm

Thankyou Brian, I will try now.

Odroid if there is anyway I can help, let me know.

Would be happy to return for C2 models.
Lets see if Brians idea will work first.

User avatar
Brian.K
Posts: 246
Joined: Tue Sep 15, 2015 7:30 pm
languages_spoken: English, Korean
ODROIDs: XU4, C1+, C2
Location: South Korea
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Brian.K » Tue Aug 16, 2016 5:15 pm

* https://bbs.archlinux.org/viewtopic.php?id=212848
* https://patchwork.ozlabs.org/patch/405194

According to the reference links, it is r8152 driver does not support usb 3.0 or usb 3.0 hub which has the RTL8153 plugged is unplugged.
But, the r8152 driver version in the XU4 Android is 2.04. It means r8152 driver suppots usb 3.0. So, I think the XU4 board has some problem about usb 3.0 hub port.

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Wed Aug 17, 2016 12:31 am

I think so.

No change when init.rc changed.

I don't know where to go from here.
Replace the board?

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: XU4 Ethernet dropping.

Unread post by odroid » Wed Aug 17, 2016 10:19 am

We need to check your XU4 board.
Did you purchase the XU4 from us directly?
If yes, contact "odroid at hardkernel dot com" with a link of this thread.
She will help your RMA process.

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Wed Aug 17, 2016 8:44 pm

Indeed I did. Will email her now.
Such a shame, the XU4 is perfect otherwise.
Please keep me posted if there is any progression on the issue.

Thanks.

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Fri Aug 19, 2016 4:43 pm

Sorry, I am not very happy about this.
The issue is with a generic Ethernet port that should work out of the box like described on the product.

As the problem is not my own, I am still expected to pay shipping and potentially extra for repair as stated in your above email?

How much is the shipping and tax from S. Korea to UK?
I have already spent an amount of time and money trying to fix an issue that is Odroids.
It might work out cheaper and more beneficial not to send it back.

I need more information about the return and the cost of return.

Regards.

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: XU4 Ethernet dropping.

Unread post by odroid » Fri Aug 19, 2016 5:24 pm

Miscommunication.. a sort of..

Did you purchase the XU4 from UK distributor?
In that case, you can ask the RMA to the distributor.

But, you told me you bought it from us directly.
It seems to be wrong because our sale people told me your order number is not ours.
It made me confused.

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Sat Aug 20, 2016 4:52 pm

It seems! :)

I did from Liymo, the distributor on the Odroid website. Sorry for the misunderstanding.

I shall contact them Monday, the office is closed the weekend.

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Wed Sep 07, 2016 5:53 am

Just to say that issue is solved.
Sent for repair and returned in working order.

Kind regards

topaz
Posts: 18
Joined: Wed Sep 12, 2018 12:57 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by topaz » Fri Sep 14, 2018 3:45 am

Hey Rillo, not sure if are still posting here or still use Odroid with Lemur but just asking if you do.

I wanted to ask some q's about how the C2 is working with Lemur ?

best
Matt

Riiio
Posts: 29
Joined: Thu Jun 30, 2016 12:56 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Ethernet dropping.

Unread post by Riiio » Mon Dec 02, 2019 1:22 am

I wasn't emailled about the above responce topaz, if you're still interested, email or pm.

The issue has come back, all these years later.
Got to try switch and cabling first, will start a new forum if continues.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 1 guest