XU4Q Freezing after playing videos

Post Reply
boarder
Posts: 13
Joined: Mon Sep 24, 2018 12:58 am
languages_spoken: english, french, portuguese
ODROIDs: xu4
Has thanked: 0
Been thanked: 0
Contact:

XU4Q Freezing after playing videos

Unread post by boarder » Wed Jul 10, 2019 2:06 am

Hi folks.

I'm using an odroid XU4Q connected to a TV, displaying videos with an Android APP that I build (random videos).

The CPU is getting ~80c+ during videos displays, then the odroid freeze.... black screen and does not turn on any more.

Already tried with different boards and differents emmc card. I have some spare odroids here....

Anyone have an advise? What is the maximum operation temp of XU4Q?

Maybe XU4Q is not recommended for display videos? Already tried MP4, GIFs and etc...

Other curious thing, sometimes it freezes (black screen), Im able to reboot without flash again, but no videos appears, no MP4, no youtube, nothing. Like everything works on OS Android but not videos...

Android 6.0.1

Any advise?

Thank you!
Last edited by boarder on Thu Jul 11, 2019 11:02 pm, edited 1 time in total.

User avatar
odroid
Site Admin
Posts: 31297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 44 times
Been thanked: 179 times
Contact:

Re: XU4Q Freezing after playing ~3hours+ video

Unread post by odroid » Wed Jul 10, 2019 9:40 am

CPU temperature could be up to 90C when ran a bitcoin mining test with full CPU+GPU utilization last year.

How was the red and blue LEDs on your XU4Q board?
Which power supply do you use?

boarder
Posts: 13
Joined: Mon Sep 24, 2018 12:58 am
languages_spoken: english, french, portuguese
ODROIDs: xu4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q Freezing after playing ~3hours+ video

Unread post by boarder » Wed Jul 10, 2019 10:06 pm

odroid wrote:
Wed Jul 10, 2019 9:40 am
CPU temperature could be up to 90C when ran a bitcoin mining test with full CPU+GPU utilization last year.

How was the red and blue LEDs on your XU4Q board?
Which power supply do you use?
@odroid

The leds are operating normal! video: https://bit.ly/2YLEXV8

The power supply are the original 5V/4A link: https://bit.ly/2xMfxut

The curious thing, is that even youtube does not play anymore after this "crash". video here: https://bit.ly/2S78GFr it stays black the video, but all OS Android works...

And more curious, is if I flash again the emmc everything returns to operate normal...

Other scenario is that is not even possible to open a video. If I open the video (even with odroid cooler - 52c) the odroid reboot... flash again - solved...

Already tried resize video (from 20mb to 1mb), changing resolution from HD to 640x480...

No idea what happens :(

Any advise?

Thank you.

boarder
Posts: 13
Joined: Mon Sep 24, 2018 12:58 am
languages_spoken: english, french, portuguese
ODROIDs: xu4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q Freezing after playing ~3hours+ video

Unread post by boarder » Wed Jul 10, 2019 11:04 pm

I was looking the dmesg, maybe its OS issue and not hardware? Or the hardware make it crash...

I'm not expert on log understanding issues.... log link: http://bit.ly/2XEEnfh

187.399613] [c3] [d:0, c:0] s5p_mfc_open:1727: MFC open completed [1:1] dev = dd084810, ctx = dbca4800
[ 187.405037] [c0] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
[ 187.418433] [c2] [d:0, c:0] vidioc_s_fmt_vid_out_mplane:1401: Dec input codec(0): H264 Encoded Stream
[ 187.421045] [c0] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
[ 187.433519] [c7] [d:0, c:0] vidioc_s_fmt_vid_cap_mplane:1358: Dec output pixelformat : 4:2:0 2 Planes Y/CbCr
[ 187.437041] [c0] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
[ 187.450337] [c7] [d:0, c:0] s5p_mfc_dec_calc_dpb_size:708: SEQ Done: Movie dimensions 480x720, buffer dimensions: 480x720
[ 187.453032] [c0] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
[ 187.469040] [c0] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
189.879278] [c0] Mali<ERROR, BASE_MMU>: In file: /data/XU3/Marshmallow/2MML/kernel/hardkernel/odroidxu3_new_rel/drivers/gpu/arm/midgard/mali_kbase_mmu.c line: 1378 function:kbase_mmu_report_fault_and_kill
[ 189.895917] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
[ 189.902675] [c0] Unhandled Page fault in AS0 at VA 0x00000000B356A088
[ 189.902675] raw fault status 0x300002C3
[ 189.902675] decoded fault status: SLAVE FAULT
[ 189.902675] exception type 0xC3: TRANSLATION_FAULT
[ 189.902675] access type 0x2: READ
[ 189.902675] source id 0x3000
[ 189.927589] [c0] r8152 6-1:1.0 eth0: Stop submitting intr, status -71
[ 189.934318] [c0]
[ 189.935924] [c0] Mali<ERROR, BASE_JM>: In file: /data/XU3/Marshmallow/2MML/kernel/hardkernel/odroidxu3_new_rel/drivers/gpu/arm/midgard/mali_kbase_jm.c line: 176 function:kbase_job_done_slot
[ 189.952617] t6xx: GPU fault 0x43 from job slot 0
[ 189.957386] [c0]

boarder
Posts: 13
Joined: Mon Sep 24, 2018 12:58 am
languages_spoken: english, french, portuguese
ODROIDs: xu4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q Freezing after playing ~3hours+ video

Unread post by boarder » Thu Jul 11, 2019 12:19 am

And other information, seems that maybe is not related with heat...

I just got one more Odroid to test, a brand new Odroid, that I just open 30m ago from package flashed Android 6.0.

On the first try video playback I got this issue:

http://bit.ly/2S6mdNp - black video screen, on app list the video appers, after swtich back plays for 0.5 seconds and black again..

thats crazy!

User avatar
odroid
Site Admin
Posts: 31297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 44 times
Been thanked: 179 times
Contact:

Re: XU4Q Freezing after playing ~3hours+ video

Unread post by odroid » Thu Jul 11, 2019 10:52 am

Thank you for the various test and videos.
It seems to be a software issue.

I have a couple of more questions.
Why don't use Android 8.x or 7.x?
Do you use an eMMC or SD card?

boarder
Posts: 13
Joined: Mon Sep 24, 2018 12:58 am
languages_spoken: english, french, portuguese
ODROIDs: xu4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q Freezing after playing ~3hours+ video

Unread post by boarder » Thu Jul 11, 2019 11:00 pm

odroid wrote:
Thu Jul 11, 2019 10:52 am
Thank you for the various test and videos.
It seems to be a software issue.

I have a couple of more questions.
Why don't use Android 8.x or 7.x?
Do you use an eMMC or SD card?
Hi! I use Android 6.x because besides the video, I have to use an application that is compatible with android 6.x only =(

And I use eMMC!

This is the kernel version.
Linux version 3.10.9-g9d1fa90e5a6e-dirty (root@ubuntu) (gcc version 4.8 (GCC) ) #1 SMP PREEMPT Fri Oct 26 12:33:02 WITA 2018 - Lineage 13

Seems to be really software issue, because I leave on Android 7.1 the whole night, and no issues.. CPU is cooler, smoth, no freezes at all...

Would be possible to fix that on Android 6.x?

User avatar
odroid
Site Admin
Posts: 31297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 44 times
Been thanked: 179 times
Contact:

Re: XU4Q Freezing after playing videos

Unread post by odroid » Fri Jul 12, 2019 8:00 am

Since Voodik(user) has focused on 8.x development, there might be no hope. Sorry about that.

boarder
Posts: 13
Joined: Mon Sep 24, 2018 12:58 am
languages_spoken: english, french, portuguese
ODROIDs: xu4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q Freezing after playing videos

Unread post by boarder » Sat Jul 13, 2019 2:34 am

odroid wrote:
Fri Jul 12, 2019 8:00 am
Since Voodik(user) has focused on 8.x development, there might be no hope. Sorry about that.
Got it =/

Will try to figure out =)

Thank you very much for all help and analysis :)

Post Reply

Return to “Android”

Who is online

Users browsing this forum: Google [Bot] and 3 guests