[Issue] XU4 constantly hangs and reboots

Post Reply
SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

[Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Thu Mar 07, 2019 6:22 am

After a week of hassle with Italian Customs, I have finally became a "happy" owner of XU4 kit.

Following official Wiki in a few moments I had android 4.4.4 image on, which was later upgraded to LineAge OS 15.1 from Voodik dated Feb. 2019.
XU4 was bought to serve as an Android TV, however my happiness lasted slightly over a day.

My setup is simple and consists, except for the Unify Logitech receiver, from Hardkernel supplied parts:
- XU4 board;
- eMMC 16GB (orange);
- 4A power supply;
- WiFi USB module 5A;
- RTC backup battery.

As software I had Amazon Prime Video installed, Kodi and MX Player. All come from official Google Play Market.

The issue is and it started with Google Play that was trying to install Netflix. XU4 in the middle of installation/downloading would just hang and then reboot. I have tried several times to install Netflix and system would hang again and reboot. After numerous attempts, the app was installed. When tried to install ATV launcher, it would do just the same.

XU4 worked fine yesterday evening and today in the morning. When I tried to turn it on again at noon, it would hang again with no reason and reboot. It worsened later on being stuck in constant boot loop; i.e. arrive to the home screnn, hang and go in reboot again.

I thought it is a problem with Voodik OS, so I downloaded Android 4.4.4 (v.6.6) and installed it. Google Play and Amazon Prime Video were installed. Prime Video was badly performing. It glitched, movies were suffering constant judder and then... bang, system hanged and rebooted. And the story repeated: boot.. home screen.. hang.. reboot.

Using Etcher tried different version of Android: official Odroid 4.4.4 earlier versions, Voodik OS 15.1, 14.1 and even 12. All ended with same result, XU4 aftern OS first boot would load until home screen is seen and then hang and reboot again.

I though that may be CPU is overheated due dried thermal paste. Nope, all seemed ok there.

I am not a developer - so have no idea were to look or how to troubleshoot. I am not a nube either. So with little help from you guys (hardkernel), I would be happy to identify the problem.

Hope that it is not a hardware issue as I saw it is reported quite often on the forum. Look forward for your assistance.

User avatar
odroid
Site Admin
Posts: 31322
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 47 times
Been thanked: 180 times
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by odroid » Thu Mar 07, 2019 10:35 am

Since Netflix officially doesn't support the open source platforms, it can't run on XU4 Android OS,.
But there is a report from a forum user who could use an old netflix apk which could play up to 720p.
viewtopic.php?f=94&t=28622&p=242996&hil ... pk#p242996

What happened until you installed Netflix?
Did your XU4 hang and reboot?

Can you please try this Ubuntu OS image to check the hardware issue?
ubuntu-18.04.1-4.14-mate-odroid-xu4-20181203.img.xz

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Thu Mar 07, 2019 6:41 pm

Hello odroid and thanks for quick reply.

Same thing happened with other apps like MX Player and Kodi. Others I haven't tried as I don't need them. Netflix is not a must, as I just cancelled subscription.

This morning I erased the eMMC and have reinstalled Android 4.4.4 (v.6.6) and.. well, hanged and rebooted and continued to do same over and over again.

I will give another try with the image you mentioned below. Is there anything in particular I have to look for when booting Ubuntu?

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Fri Mar 08, 2019 7:25 am

Well, it hang with Ubuntu OS as well.

At first boot, it stayed like 10-15 seconds on login screen and rebooted.
After second boot I was able to enter the OS and connect to Wi-Fi network. Immediately after when I closed the connection windows, it hang and after about a minute it rebooted.
After third boot it showed only cursor; I could not even get to the login screen.

In all above situations the heart beat blue led went completely off when system hang. You can see that in the attached photos.

Please advise how to proceed.
Attachments
IMAG0736.jpg
IMAG0736.jpg (74.57 KiB) Viewed 947 times
IMAG0735.jpg
IMAG0735.jpg (53.56 KiB) Viewed 947 times
IMAG0730.jpg
IMAG0730.jpg (111.9 KiB) Viewed 947 times

User avatar
rooted
Posts: 6543
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 50 times
Been thanked: 15 times
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by rooted » Fri Mar 08, 2019 10:06 am

Seems to be a bad power supply or the XU4.

User avatar
odroid
Site Admin
Posts: 31322
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 47 times
Been thanked: 180 times
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by odroid » Fri Mar 08, 2019 1:15 pm

Did you use this PSU? or different shape?
https://www.hardkernel.com/shop/5v-4a-p ... eu-plug-2/

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Fri Mar 08, 2019 3:57 pm

rooted wrote:
Fri Mar 08, 2019 10:06 am
Seems to be a bad power supply or the XU4.
If it is power supply, will search for another one and retry. And.. I guess there is nothing I can do, if XU4 is faulty, right?!
odroid wrote:
Fri Mar 08, 2019 1:15 pm
Did you use this PSU? or different shape? [..]
Exactly this one.

To ease further questions about hardware configuration, here is my order ref. #HK1902196228.

nikodemus
Posts: 25
Joined: Fri Mar 08, 2019 2:15 pm
languages_spoken: german, english
ODROIDs: C1, C2, XU4, N2
Has thanked: 2 times
Been thanked: 1 time
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by nikodemus » Fri Mar 08, 2019 4:24 pm

What in your case is surprising, your board was working half a day and then is refusing cooperation. That does not look like a hardware error to me. I would retry with a good card reader and another SD card.

I would recommend

- strip off all unneccessary hardware including wifi and emmc
- use a good card reader
- try another power supply
- every ubuntu image from the hardkernel site is well tested and should be ok
- set cpu freq to 1Ghz on all cores (only for test purposes)
echo 1000000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
echo 1000000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
echo 1000000 > /sys/devices/system/cpu/cpu4/cpufreq/scaling_min_freq
echo 1000000 > /sys/devices/system/cpu/cpu4/cpufreq/scaling_max_freq
(With my first C1 the board stoped after 10 minutes. Investigations proofed that ondemand switching from 500 to 1500Mhz was too much for the board, using 800 to 1500 Mhz solved the issue. On XU4 the freq is up to 2Ghz, so we should lower it for testing)

play around until you are sure its working stable, before installing additional software
(dont forget sudo apt update).

User avatar
odroid
Site Admin
Posts: 31322
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 47 times
Been thanked: 180 times
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by odroid » Fri Mar 08, 2019 5:34 pm

I think we need to test your board and accessories.
Please send an email to "odroid at hardkernel dot com" with a link of this thread for the RMA process.
She will reply early next since it is already Friday evening in Korea.
Sorry for the inconvenience causes.

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Fri Mar 08, 2019 5:51 pm

nikodemus wrote:
Fri Mar 08, 2019 4:24 pm
What in your case is surprising [...]
That seemed strange to me too and that's why first checked cpu cooler and thermal paste.
nikodemus wrote:
Fri Mar 08, 2019 4:24 pm
[...] I would retry with a good card reader and another SD card.[...]
I haven't used any SD cards yet. So my second suspission is the eMMC.
Image

Is there any way to check provided 16Gb eMMC? I have the usb reader/writer for it.

Image
nikodemus wrote:
Fri Mar 08, 2019 4:24 pm
[...] I would recommend [...] play around [...]
Here where all fun begins.. Will try it out and update.

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Fri Mar 08, 2019 5:57 pm

odroid wrote:
Fri Mar 08, 2019 5:34 pm
I think we need to test your board and accessories [...]
Will try Nickodemus advice first. Hope that eMMC is the problem, which I believe would be an easy replacement.
odroid wrote:
Fri Mar 08, 2019 5:34 pm
[...] Sorry for the inconvenience causes.
No worries mate. S**t happens... ;)

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Tue Mar 12, 2019 8:27 am

I am back...

Friday evening I "played" to much with frequencies limit, making XU4 go crazy, which simply shut off power to USB. :D
Being desperate I left all as is over the week-end and today XU4 showed signs of life again.

What nikodemus suggested seemed to help at first, but not for long...
After about half an hour, XU4 hang - as usual. With all CPU's limited 1GHz, XU4 was mostly unusable anyway. Youtube would judder constantly even on 460i. On 720p and up, it was impossible to watch anything too.

While playing a Youtube video, right before it hang again, a screeen popped up with an error (see below). Finally, at least something to start from...
IMAG0790w.jpg
IMAG0790w.jpg (404.19 KiB) Viewed 788 times
IMAG0788w.jpg
IMAG0788w.jpg (150.34 KiB) Viewed 788 times
From what I have observed, it seems that there is an issue with the board. If system starts to hang constantly, you get to a point where it won't even get to the desktop screen. If left for half an hour (to cool off I presume), XU4 would start again like nothing ever happened before. I thought may be it is an issue with eMMC or SD card, but again... if left for a half an hour to rest, XU4 would start normally again.

I could not find any relation between freezing XU4 and power consumption. The tests I made later where using a lab power supply that could deliver up to 3Amp current with a stable 5.1V. During use consumption would jump between 0,5A to 2,2A. Provided original power supply would have no problem with that as it can supply up to 4 Amps, which is great.
IMAG0738w.jpg
IMAG0738w.jpg (86.61 KiB) Viewed 786 times
It looks like it is a warranty case here...

nikodemus
Posts: 25
Joined: Fri Mar 08, 2019 2:15 pm
languages_spoken: german, english
ODROIDs: C1, C2, XU4, N2
Has thanked: 2 times
Been thanked: 1 time
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by nikodemus » Tue Mar 12, 2019 4:19 pm

Its a pity, i have no further ideas for you.
The XU4 should run rockstable even when overheating.

For your information, there are still 2 frequencies that can be adjusted (but i dont expect that will have an effect here).

https://wiki.odroid.com/odroid-xu4/appl ... untu_guide

#Power Settings for GPU
#lower gpu frequency from 600000000 to 177000000
echo powersave > /sys/devices/platform/11800000.mali\:/devfreq/11800000.mali\:/governor

User avatar
memeka
Posts: 4313
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 0
Been thanked: 12 times
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by memeka » Tue Mar 12, 2019 4:43 pm

I would disable swap :)

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Wed Mar 13, 2019 2:21 am

Well, nikodemus, can't get into the system anymore. USB power is missing again. :D

I have attached a video so you guys can take a look on your own. Just remove "zip" extension.
VIDEO0043.avi.zip
It is a video file with zip extension, just to be able to upload to forum.
(9.83 MiB) Downloaded 15 times

nikodemus
Posts: 25
Joined: Fri Mar 08, 2019 2:15 pm
languages_spoken: german, english
ODROIDs: C1, C2, XU4, N2
Has thanked: 2 times
Been thanked: 1 time
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by nikodemus » Wed Mar 13, 2019 7:34 am

The clip shows ubuntu is running for 5 sec then you plugin your wifistick. After this the ubuntu screen shuts down and heartbeat stops.

It looks a little like wifi has to do with it, but thats not sure :?:

If you cannot login to Ubuntu any longer, the reason may be that the system on your emmc was damaged due to a crash before.

As you described in your last posts you did not get your system to run for longer than 30 minutes and after the crash you had to wait another 30 minutes. Both is not normal for the XU4 which is well tested and a very reliable board.

So indeed you have the choice to follow the suggestion of the site admin to contact the korean technical support, or directly head to your dealer to declare a warranty issue. When the board leaves factory there will be performed a short functional test, but there is not enough time to test for stability, so errors like yours will not be discovered.

If you get infos from the korean support, i would be interested to see your post ;)

User avatar
odroid
Site Admin
Posts: 31322
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 47 times
Been thanked: 180 times
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by odroid » Wed Mar 13, 2019 9:25 am

Please keep measuring the voltage on 5V rail of 30pin header with a DMM while board starts.
https://wiki.odroid.com/odroid-xu4/hard ... _2x15_pins
It must be stable at 4.8Volt at least in the boot process.

If you see lower than 4.8Volt even very short period, you might need to use a thicker DC wire or better DC plug.
In that case, this thread must be helpful.
viewtopic.php?f=93&t=33365

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Thu Mar 14, 2019 10:47 pm

Dear Odroid, I followed your advice with following setup: XU4 with USB Logitech Unify receiver, Realtek Wi-Fi card and original supplied eMMC.

Original power supply output was 5,23 V. During load (at boot) voltage periodically dropped to 4,9 Volts, but quickly went up.

With same setup, my lab power supply set at 5,09 V, had voltage dropping down to 4,88-4,89.
Taking into consideration that a digital multimeter is not capable of catching immediate, short-term voltage drops (even set in Min/Max mode), I have decided to increase voltage to 5,40 Volts. In this situation voltage at boot and further on did not drop anywhere below 5,08.

Current consumption in both cases was the same, jumping between 0,56 to 1,7 Amps. Although noticed that with higher voltage, minimum current was at 0,76 A.

In any of the above cases, XU4 would hang anyways. First time at cold boot, I managed to start Chromium and have a video running in YouTube for about 10 seconds. Further my attempts ended with XU4 hanging every time between Log In screen and Desktop.

Just as a reminder, I used Ubuntu image you have advised above with CPU frequency limited at 1,0 GHz, as per Nikodemus advice.
With my lab power supply I used multistrand, 1,5 mm thick copper wires with a length about 1,2 meters. This type of wires was used to change internal wiring of some old speakers I have brought back to life some time ago.

Thread you have reffered shows clearly (on the photo) that they guy used a 0,5 mm thick wires from power supply. No wonder he had issues.
My case is different as well as encountered issues.

If there are no further advice or suggestions, I guess it is about time for a RMA.

SERGi-k
Posts: 10
Joined: Thu Mar 07, 2019 5:43 am
languages_spoken: english, italian, russian, romanian, german
ODROIDs: Odroid XU4
Location: Alessandria, Italy
Has thanked: 0
Been thanked: 0
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by SERGi-k » Fri Mar 15, 2019 12:05 am

nikodemus wrote:
Wed Mar 13, 2019 7:34 am
[...] It looks a little like wifi has to do with it, but thats not sure :?: [...]
I've used both Hardkernel supplied one and another based on Realtek chipset. Last is proven through time to work stable with no issues.
nikodemus wrote:
Wed Mar 13, 2019 7:34 am
[...] If you cannot login to Ubuntu any longer, the reason may be that the system on your emmc was damaged due to a crash before.[...]
Had the same thought earlier, my dear Nikodemus. Thanks for pointing out. I have already tried to completely wipe the eMMC as well as the microSD card (32GB and 64GB), same issue happened.
nikodemus wrote:
Wed Mar 13, 2019 7:34 am
[...] As you described in your last posts you did not get your system to run for longer than 30 minutes and after the crash you had to wait another 30 minutes. Both is not normal for the XU4 which is well tested and a very reliable board. [...]
Only first evening it worked for about 4 hours. I watched a Prime Video show. Then in the morning it would simply hang. All night the unit was disconnected from its power supply.
nikodemus wrote:
Wed Mar 13, 2019 7:34 am
[...] If you get infos from the korean support, i would be interested to see your post ;)
I just wrote them.. I am eager to to see how the case will be handled, as the unit was bought directly from Korea.

User avatar
odroid
Site Admin
Posts: 31322
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 47 times
Been thanked: 180 times
Contact:

Re: [Issue] XU4 constantly hangs and reboots

Unread post by odroid » Mon Mar 18, 2019 11:52 am

I think you already did as much as you could.
Please proceed the RMA process from sending an email as I told you.
I think you have to send us all the items together to find a real root cause.
Sorry for the inconvenience.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 4 guests