LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Dominic86
Posts: 23
Joined: Thu Jan 03, 2019 7:49 pm
languages_spoken: Italian, english
ODROIDs: ODROID-XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Dominic86 » Mon Feb 04, 2019 8:11 am

Sorry Voodik, but it still doesn't work...
Attachments
log2.txt
(595.45 KiB) Downloaded 9 times

User avatar
voodik
Posts: 1451
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Mon Feb 04, 2019 4:06 pm

Dominic86 wrote:
Mon Feb 04, 2019 8:11 am
Sorry Voodik, but it still doesn't work...
can you disconnect/connect your USB dongle, and dump dmesg again ?

P.S.
you can use this command to dump logs directly from odroid to ix.io and post link here.
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

Dominic86
Posts: 23
Joined: Thu Jan 03, 2019 7:49 pm
languages_spoken: Italian, english
ODROIDs: ODROID-XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Dominic86 » Tue Feb 05, 2019 9:10 am


User avatar
voodik
Posts: 1451
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Thu Feb 07, 2019 4:02 pm

Dominic86 wrote:
Tue Feb 05, 2019 9:10 am
http://ix.io/1xx2

Thanks!
It seems your dongle does not detected by kernel driver ?
Can you check it on some Linux distribution and dump logs ?
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

Dominic86
Posts: 23
Joined: Thu Jan 03, 2019 7:49 pm
languages_spoken: Italian, english
ODROIDs: ODROID-XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Dominic86 » Thu Feb 07, 2019 7:52 pm

Could be good also a laptop with LinuxMint for the dump log or only Odroid?

User avatar
mad_ady
Posts: 5228
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by mad_ady » Thu Feb 07, 2019 11:01 pm

Laptop should be fine

Dominic86
Posts: 23
Joined: Thu Jan 03, 2019 7:49 pm
languages_spoken: Italian, english
ODROIDs: ODROID-XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Dominic86 » Sat Feb 09, 2019 8:58 am

http://ix.io/1Ayn
The laptop has also an integrated bluetooth

Sailor
Posts: 7
Joined: Wed Nov 14, 2018 4:09 am
languages_spoken: english
ODROIDs: 2 x C2, XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Sailor » Sat Feb 09, 2019 8:13 pm

juanitomaille wrote:Graphics is broken for me!

My wife mocked me Image

I can't tell you more besause I can't navigate in system.
Touchscreen works.

In the center of image it's my launcher. ImageImage

Envoyé de mon CLT-L09 en utilisant Tapatalk
Did you ever fix this?
Mine still does this.
It’s when I try 800x480. I have to re-install everything from scratch to get out of it.

Mark B.

User avatar
voodik
Posts: 1451
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Mon Feb 11, 2019 3:26 am

Update :!:
20190210 Alpha-v0.7
Fixed USB storage not mounting as public media.
Android merged with upstream.
Android minor fixes.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

Dominic86
Posts: 23
Joined: Thu Jan 03, 2019 7:49 pm
languages_spoken: Italian, english
ODROIDs: ODROID-XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Dominic86 » Mon Feb 11, 2019 8:49 am

Updated, but bluetooth still doesn't work...

SlimDNS
Posts: 1
Joined: Wed Feb 13, 2019 6:22 pm
languages_spoken: english, german
ODROIDs: Odroid XU4 on Android
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by SlimDNS » Wed Feb 13, 2019 6:37 pm

Hello Odroid-Friends,

1) I found an issue with the Odroid Utility. I have rool-access already enabled and I'm trying to set the CPU governor from "on demand" to "performance" but it's automatically reset to "on demand" after every reboot.
Is that an kwnown issue or am I doing something wrong?

2) After that I tried "No-Frills CPU Control" to change the governor, as a workaround and it shows, that the CPU frequency ist set to 1400Mhz and can't be set any higher. Shouldn't the CPU frequency be 1700/2000 Mhz?!? I'm confused.

Could somebody help me to understand?

Please excuse my bad english! Greetings from Germany!

nosk8fx
Posts: 1
Joined: Thu Feb 14, 2019 7:30 pm
languages_spoken: english
ODROIDs: XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by nosk8fx » Thu Feb 14, 2019 10:39 pm

Hello,

first of all, thank you for the builds from voodik.

I got Lineage and Google Play perfectly working on XU4, but I'm having some issues with video/audio, when trying to make video calls (tried with Skype, Messenger, both standard and lite versions, also Hangouts).
I have standard webcam connected to USB, and HDMI goes to the TV (along with audio output). I tried with and without separate microphone connected to another USB, although webcam has the microphone built-in.

For example, just an audio call normally works good, and both parties can hear each other. But when trying to do the video call, either only video or only audio works. There are occasions I can see and hear the other person, but he/she only sees me, but doesn't hear me. I never got the video call working ok, always something is missing.

I noticed Skype is very bad for video calls (too much going on in the background, I guess), Messenger is better, but Hangouts is great, very fast (I guess Google optimized this).

Am I doing something wrong? Are there any specific settings for XU4, that would make this work? I got 1920x1080x60Hz resolution and performance governor.
Currently I'm using v0.6, but I didn't see any updates in v0.7 regarding video/audio.

Thanks for any info.

Regards

Post Reply

Return to “Android”

Who is online

Users browsing this forum: zaphodb and 4 guests