LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Moderators: odroid, mdrjr

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby voodik » Thu May 03, 2018 8:46 am

sub263 wrote:
voodik wrote:
sub263 wrote:Voodik,

I am trying to build image but ending up with following error(attached)


$git clone https://github.com/voodik/android_kerne ... idxu3_beta -b los-14.1_5422

$ repo init -u git://github.com/voodik/android.git -b cm-14.1_5422
$ repo sync
$ ./build.sh odroidxu3

Any help. I already tried increasing java heap size with no success

Your RAM amount ?


8GB and this machine is standalone linux machine not a virtual machine.

I also have a problems when using 8GB RAM, so i updated my PC RAM.
Google this error you can find a lot of solutions, you need to try which one can help you.
Or add more RAM
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
User avatar
voodik
 
Posts: 1351
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby woalk » Mon May 07, 2018 4:59 am

Is there anything I can do to enable Bluetooth headset controls? Using the headset's controls when connected to a Pixel running Oreo works fine, but using the controls connected to the ODROID does nothing for me. Audio output works as expected though.
woalk
 
Posts: 2
Joined: Sat Aug 19, 2017 6:51 pm
languages_spoken: English, German
ODROIDs: XU4

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby brunno78 » Tue May 08, 2018 10:14 pm

Hello voodik.

Its possible to adding shortcuts setting from original odroid utility to lineageos?

I need launch aplication from usb keyboard. (for examlpe F10 key >> google maps, F11 key >> waze, F12 key >> power of odroid)

Thanks for answer..

HB
brunno78
 
Posts: 7
Joined: Wed Mar 16, 2016 4:06 am
languages_spoken: english, slovak
ODROIDs: Odroid XU4

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby drtechdom » Fri May 11, 2018 11:06 am

Just tried to get back to this project after I saw that you added the reverse touch screen. I changed the reverse touch screen option in the /system/build.prop and it seems to hose the system... It won't boot with that flag turned to true, I am reinstall it at the moment as its not ping-able either.

Any ideas, did I do something wrong or miss a step?

adb pull /system/build.prop
changed the flag
remounted /system as rw
adb push build.prop /system
remount /system ro
restarted
hosed.... :(

also is there a way to take the touch screen out of mouse mode and put it into touch mode?
drtechdom
 
Posts: 6
Joined: Sat Sep 02, 2017 10:07 am
languages_spoken: english

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby voodik » Tue May 15, 2018 4:25 am

drtechdom wrote:Just tried to get back to this project after I saw that you added the reverse touch screen. I changed the reverse touch screen option in the /system/build.prop and it seems to hose the system... It won't boot with that flag turned to true, I am reinstall it at the moment as its not ping-able either.

Any ideas, did I do something wrong or miss a step?

adb pull /system/build.prop
changed the flag
remounted /system as rw
adb push build.prop /system
remount /system ro
restarted
hosed.... :(

also is there a way to take the touch screen out of mouse mode and put it into touch mode?

Just pulled, edited and pushed back build.prop whithout any issue.
Please try to edit with other text editor. e.g. Notepad++

To use your touch screen in non mouse mode, just rename /system/usr/idc/Vendor_04DD_Product_9570.idc file according your touch VID/PID
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
User avatar
voodik
 
Posts: 1351
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby drtechdom » Tue May 15, 2018 10:09 am

voodik wrote:
drtechdom wrote:Just tried to get back to this project after I saw that you added the reverse touch screen. I changed the reverse touch screen option in the /system/build.prop and it seems to hose the system... It won't boot with that flag turned to true, I am reinstall it at the moment as its not ping-able either.

Any ideas, did I do something wrong or miss a step?

adb pull /system/build.prop
changed the flag
remounted /system as rw
adb push build.prop /system
remount /system ro
restarted
hosed.... :(

also is there a way to take the touch screen out of mouse mode and put it into touch mode?

Just pulled, edited and pushed back build.prop whithout any issue.
Please try to edit with other text editor. e.g. Notepad++

To use your touch screen in non mouse mode, just rename /system/usr/idc/Vendor_04DD_Product_9570.idc file according your touch VID/PID



Just tried both, my device is Bus 002 Device 002: ID 04e7:0020.... I copied Vendor_04DD_Product_9570.idc to Vender_04E7_Product_0020.idc and also change the flag of reverse touch screen to true using jed as I run Ubuntu... The system boots now so it must have been an issue with text editor as you said... but my touch screen is still a mouse and backwards.. What am I doing wrong? :\
drtechdom
 
Posts: 6
Joined: Sat Sep 02, 2017 10:07 am
languages_spoken: english

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby kafan1986 » Fri May 18, 2018 5:32 pm

@voodik: Can you take a look at this issue viewtopic.php?f=94&t=31017
kafan1986
 
Posts: 16
Joined: Tue Feb 27, 2018 8:05 am
languages_spoken: english

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby cliffyfromboro » Sat May 26, 2018 6:46 am

Does anyone in here have this to boot on USB HDD? Or does anyone know how I would go about having on USB HDD? Even with a top speed SD card it is barely usable and at the minute I am not planning on buying an eMMC module just yet. I have Linux (OGST & Ubuntu) on HDD's and they run amazingly well with a USB3.0 HDD dock.
cliffyfromboro
 
Posts: 15
Joined: Wed May 16, 2018 3:17 am
languages_spoken: english

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby back2future » Thu May 31, 2018 4:59 pm

Would it help if one could compile this special Android U-boot, containing fdisk, fastboot, fatformat from source? Are there sources without downloading an entirely Android source code archive?
Thx
naturally beYOnd spectrum
back2future
 
Posts: 61
Joined: Sun Jul 23, 2017 3:19 pm
languages_spoken: english

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby Miamijerry » Mon Jun 04, 2018 11:10 am

Help please. Running a Sunfounder 10.1 touch screen and I want to rotate the screen 90 degrees (Portrait). I tried the utility included in the image, but it always boots in landscape (and the setting in the utility is back to "0" rotation, instead of 90), also play store apps can not force the screen to portrait.
Miamijerry
 
Posts: 2
Joined: Fri Jun 01, 2018 11:54 am
languages_spoken: english
ODROIDs: XU4Q

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby voodik » Mon Jun 04, 2018 8:54 pm

Miamijerry wrote:Help please. Running a Sunfounder 10.1 touch screen and I want to rotate the screen 90 degrees (Portrait). I tried the utility included in the image, but it always boots in landscape (and the setting in the utility is back to "0" rotation, instead of 90), also play store apps can not force the screen to portrait.

Are you updated to latest version ?
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
User avatar
voodik
 
Posts: 1351
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby Miamijerry » Tue Jun 05, 2018 7:13 am

voodik wrote:
Miamijerry wrote:Help please. Running a Sunfounder 10.1 touch screen and I want to rotate the screen 90 degrees (Portrait). I tried the utility included in the image, but it always boots in landscape (and the setting in the utility is back to "0" rotation, instead of 90), also play store apps can not force the screen to portrait.

Are you updated to latest version ?


I updated just now, to "alpha-1.8.15.04.18/update.zip" rebooted, changed rotation to 90, and it still does not save or rotate.

SOLVED - Installed the SD2EMMC image, went straight to utility and selected 270 rotation, reboot, perfect. (Most likely original problem was my playing with rotation apps).

Thanks
Miamijerry
 
Posts: 2
Joined: Fri Jun 01, 2018 11:54 am
languages_spoken: english
ODROIDs: XU4Q

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby teathief » Tue Jun 05, 2018 5:03 pm

Thank you for this wonderful android build for the XU3-4's.
I've been playing with it for awhile and it is rock solid for what I use it for (mostly kodi, retroarch, and some android gaming).

I'm having trouble with some apps (netflix for one) seeing the rooting method (Lineage's own rooting solution) would it be possible to use Magisk Mask
with this system so apps cannot see root?

It's easy enough to install on a modifiable phone but I'm not sure what the steps would be for this system and if the LineageOS rooting method
would have to be removed first (and then removing root permissions I might need to install Magisk in the first place).

Also if its easy to install it and I'm just missing it, anyone have a link to a guide that works for a system without TWRP?

I believe I tried the FlashFire method but I don't remember if I did, and I'm not even sure I should have with the Lineage root method already installed.

The war on root is getting kinda ugly and if you have root you really need a way to hide that fact nowadays.

Would you be willing to consider switching the root method used on these builds to Magisk if it works well on this system?

It also has some really useful modules installable through it like Xposed Framework (among others) even though I'm not sure how well all the modules work on LineageOS.
teathief
 
Posts: 2
Joined: Tue Jun 05, 2018 4:42 pm
languages_spoken: English
ODROIDs: XU4

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby juanitomaille » Mon Jun 11, 2018 4:22 pm

Hey guys, I have a bug with 14.1 or maybe a limit.

I bought a 8 USB port HUB.
Firstly, my USB DAC doesn't work on hub, only directly.
Same with USB touchscreen
Same with (not really sure) my GPS module
WIfi, bluetooth, cheap sound card, webcam, radio module OK in the hub

But, for exemple, when I plug cheap sound card, I'm loosing Wifi, even after reboot and unplug sound card. I need to physically change USB port with some stability problem after, resolved only with new Lineage install.

Some questions :
Is the direct plug for some device is a known limit ?
My USB hub is a cheap hub but it's only wires no ? It work or not, it can't come from that ?
Is it a bug ?

I precise that my Hub is alimented and Odroid + touchscreen + hub are plugged on a 10A adapteur for testing and mesured around 12W with all plugged

Thanks

EDIT : I willl try with 15.1 if a have time
juanitomaille
 
Posts: 22
Joined: Thu Dec 21, 2017 12:25 am
languages_spoken: english, french
ODROIDs: XU4

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby kafan1986 » Wed Jun 13, 2018 12:50 pm

juanitomaille wrote:Hey guys, I have a bug with 14.1 or maybe a limit.

I bought a 8 USB port HUB.
Firstly, my USB DAC doesn't work on hub, only directly.
Same with USB touchscreen
Same with (not really sure) my GPS module
WIfi, bluetooth, cheap sound card, webcam, radio module OK in the hub

But, for exemple, when I plug cheap sound card, I'm loosing Wifi, even after reboot and unplug sound card. I need to physically change USB port with some stability problem after, resolved only with new Lineage install.

Some questions :
Is the direct plug for some device is a known limit ?
My USB hub is a cheap hub but it's only wires no ? It work or not, it can't come from that ?
Is it a bug ?

I precise that my Hub is alimented and Odroid + touchscreen + hub are plugged on a 10A adapteur for testing and mesured around 12W with all plugged

Thanks

EDIT : I willl try with 15.1 if a have time


Is your hub externally powered? 8 ports are quite a few, the hub might not be providing enough power to connected devices.
kafan1986
 
Posts: 16
Joined: Tue Feb 27, 2018 8:05 am
languages_spoken: english

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby juanitomaille » Wed Jun 13, 2018 4:37 pm

Yes, I anticiped that and power it with 10A 5V source, I think the original one was 2A.

Maybe the problem is internal with power limitation by electronic to not exceed 2A ?

Which is illogical is that also devices plugged directly to XU4 have problem (when many other are plugged)
In USB standard,the power is distributed regardless of how they are plugged (hub or directly)?

I will measure amperage and buy a second alimented hub...
Which is crazy is current of each device : GPS 70mA, BLE dongle 30mA, Webcam 320mA....
juanitomaille
 
Posts: 22
Joined: Thu Dec 21, 2017 12:25 am
languages_spoken: english, french
ODROIDs: XU4

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby tomop123 » Sat Jun 16, 2018 5:27 pm

Hi,
I'm having terrible trouble with the netflix - any version I was able to install (4.16 from netflix's website or AndroidTV 5.2.0) is showing me "Sorry, we could not reach the Netflix service. (-1009)."
The internet is working fine for other uses - chrome, youtube. I've tried to disconnect ethernet cable and use just wifi dongle, but it's the sam. I'm using the latest version, but with loboris's multi boot solution.
tomop123
 
Posts: 4
Joined: Tue Jun 06, 2017 7:29 am
languages_spoken: english
ODROIDs: XU4

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby teathief » Tue Jun 19, 2018 10:45 am

tomop123 wrote:Hi,
I'm having terrible trouble with the netflix - any version I was able to install (4.16 from netflix's website or AndroidTV 5.2.0) is showing me "Sorry, we could not reach the Netflix service. (-1009)."
The internet is working fine for other uses - chrome, youtube. I've tried to disconnect ethernet cable and use just wifi dongle, but it's the sam. I'm using the latest version, but with loboris's multi boot solution.


Your using a version of the Netflix app that was before it could check for the presence of root and refuse to run?

If that is the case sounds like they updated the Netflix service so that old version no longer works.

I don't know if there is anything else that stops Netflix from running besides the root built into these builds.

I'd like to figure out how to remove the Lineage root system packed into these builds by default and put Magisk Mask in here for its ability to hide root from apps.

That requires more then I know about Android images.
Last edited by teathief on Tue Jun 19, 2018 1:13 pm, edited 3 times in total.
teathief
 
Posts: 2
Joined: Tue Jun 05, 2018 4:42 pm
languages_spoken: English
ODROIDs: XU4

Re: LineageOS-14.1 Android 7.1.1 Nougat for ODROID-XU3/XU4

Unread postby tomop123 » Thu Jun 21, 2018 11:48 pm

teathief wrote:
tomop123 wrote:Hi,
I'm having terrible trouble with the netflix - any version I was able to install (4.16 from netflix's website or AndroidTV 5.2.0) is showing me "Sorry, we could not reach the Netflix service. (-1009)."
The internet is working fine for other uses - chrome, youtube. I've tried to disconnect ethernet cable and use just wifi dongle, but it's the sam. I'm using the latest version, but with loboris's multi boot solution.


Your using a version of the Netflix app that was before it could check for the presence of root and refuse to run?

If that is the case sounds like they updated the Netflix service so that old version no longer works.

I don't know if there is anything else that stops Netflix from running besides the root built into these builds.

I'd like to figure out how to remove the Lineage root system packed into these builds by default and put Magisk Mask in here for its ability to hide root from apps.

That requires more then I know about Android images.


Well, latest news I've heard were stating that you can't find the Netflix on Google Store, if the device is rooted. I've found the apk on the 3rd party website and managed to install it successfully. The app runs and tries to load the service, but end up with the error above.
tomop123
 
Posts: 4
Joined: Tue Jun 06, 2017 7:29 am
languages_spoken: english
ODROIDs: XU4

Previous

Return to Android

Who is online

Users browsing this forum: voodik and 4 guests