Beginner question, Android image on MC1?

Moderators: mdrjr, odroid

Beginner question, Android image on MC1?

Unread postby chrillzRed » Thu Nov 16, 2017 4:29 am

Hello,

I have ordered a Odroid-MC1 and I am reading up on how to set it up.

I noticed that it can run LineageOS using the image from this thread: viewtopic.php?f=94&t=23911 (since its fully software compatible with the XU4).

Can i access it via SSH like an ordinary ubuntu image? Since i have no HDMI on the MC1 a am unsure how to interact with the android OS running on it?

Thanks!
chrillzRed
 
Posts: 9
Joined: Thu Nov 16, 2017 4:23 am
languages_spoken: english
ODROIDs: Odroid-MC1

Re: Beginner question, Android image on MC1?

Unread postby odroid » Thu Nov 16, 2017 9:34 am

We've never thought about a headless Android application.
Can you tell me why you want to run Android on a cluster computer?

I think you can use a USB-UART kit for shell access.
https://wiki.odroid.com/accessory/devel ... b_uart_kit
Or ADB over Ethernet.
https://wiki.odroid.com/odroid-xu4/trou ... over_tcpip
User avatar
odroid
Site Admin
 
Posts: 26416
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Beginner question, Android image on MC1?

Unread postby chrillzRed » Thu Nov 16, 2017 4:17 pm

odroid wrote:We've never thought about a headless Android application.
Can you tell me why you want to run Android on a cluster computer?

I think you can use a USB-UART kit for shell access.
https://wiki.odroid.com/accessory/devel ... b_uart_kit
Or ADB over Ethernet.
https://wiki.odroid.com/odroid-xu4/trou ... over_tcpip


I was thinking about running some android BOINC projects on the MC1 (https://play.google.com/store/apps/deta ... oinc&hl=en). There are several projects that have work packages for android ARM but sadly not for Linux ARM. Therefore i was looking for a way to get android on it and controlling it remotely :)

I will read up on ADB over ethernet, thanks for pointing me in the right direction!

Edit: Is it still true that the MC1 is software compatible with the XU4 and therefore its possible to install an android image?
chrillzRed
 
Posts: 9
Joined: Thu Nov 16, 2017 4:23 am
languages_spoken: english
ODROIDs: Odroid-MC1

Re: Beginner question, Android image on MC1?

Unread postby mad_ady » Thu Nov 16, 2017 7:50 pm

Yes, you can install android on it. It might be worthwile to find a vnc server that can be started from adb...
User avatar
mad_ady
 
Posts: 3239
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2

Re: Beginner question, Android image on MC1?

Unread postby additude » Sat Jan 27, 2018 7:13 pm

I was just wondering if you got this android setup working on your MC1 ?
additude
 
Posts: 8
Joined: Sat Dec 02, 2017 8:02 pm
languages_spoken: english

Re: Beginner question, Android image on MC1?

Unread postby odroid » Sun Jan 28, 2018 10:35 am

The latest update included the VNC server.
viewtopic.php?f=94&t=23911&start=1000#p211457
User avatar
odroid
Site Admin
 
Posts: 26416
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Beginner question, Android image on MC1?

Unread postby voodik » Sun Jan 28, 2018 7:49 pm

At this moment Android 7 doesn't boot on MC1.
Console output is freezing just after u-boot.
This makes debugging almost impossible.
I will try with Kitkat image to understand where is the problem.
You can help me buy new PC Here ;)
BTC: 3AB1bcKpvsobcjaSxG2iTLDGft2Rqsh7an
User avatar
voodik
 
Posts: 1291
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: Beginner question, Android image on MC1?

Unread postby feyhua » Tue Feb 06, 2018 7:04 pm

Hello.
I tried to install android 4.4.4 on MC1 and the result is the same, through UART it is seen that u-boot was booted, but after the line "Starting kernel ..." console output freezes, and after about a minute the board reboots.
I also tried to disable hot-plug-detective (setenv hpd "0") in bootargs - this did not bring any result. Does anyone have any thoughts about this?
feyhua
 
Posts: 1
Joined: Tue Feb 06, 2018 12:00 am
languages_spoken: english, russian
ODROIDs: XU4, MC1

Re: Beginner question, Android image on MC1?

Unread postby odroid » Tue Feb 06, 2018 8:06 pm

We will try 4.4.4 on MC1 board tomorrow.
User avatar
odroid
Site Admin
 
Posts: 26416
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Beginner question, Android image on MC1?

Unread postby odroid » Wed Feb 07, 2018 6:28 pm

We tried it and we could reproduce the issue. :(
We will investigate what is wrong.
User avatar
odroid
Site Admin
 
Posts: 26416
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Beginner question, Android image on MC1?

Unread postby Luke.go » Thu Feb 08, 2018 12:19 pm

Hi there!

Can you test your mc1 with new android kernel that compiled by the attached config file?

In my test, it works, but first few times it be rebooted.
but after few times, it works. :)

EDITED:

Oh.. sorry. the file was collapsed. please download again and apply it to kernel and rebuild that.
Attachments
config.tar
(100 KiB) Downloaded 6 times
Last edited by Luke.go on Wed Feb 14, 2018 9:13 am, edited 1 time in total.
Luke.go
 
Posts: 168
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english

Re: Beginner question, Android image on MC1?

Unread postby michaeltex » Fri Feb 09, 2018 5:37 pm

I'm also trying to solve the problem of launching an android on MC1.
Tried all possible images, the result is the same.
It gets stuck on the kernel load and reboots in a circle.
(UART log screenshot) http://prntscr.com/ic90s2
michaeltex
 
Posts: 6
Joined: Fri Feb 09, 2018 5:16 pm
languages_spoken: english
ODROIDs: ODROID XU4, ODROID MC1

Re: Beginner question, Android image on MC1?

Unread postby michaeltex » Fri Feb 09, 2018 5:44 pm

Luke.go wrote:Hi there!

Can you test your mc1 with new android kernel that compiled by the attached config file?

In my test, it works, but first few times it be rebooted.
but after few times, it works. :)


HI.
Thanks but I did not understand how to apply the file.
But I opened the file in a hex editor and it was empty, only zeros.
(screenshot) http://prntscr.com/ic955l
I think this will not help me.
Or is it a mistake?
michaeltex
 
Posts: 6
Joined: Fri Feb 09, 2018 5:16 pm
languages_spoken: english
ODROIDs: ODROID XU4, ODROID MC1

Re: Beginner question, Android image on MC1?

Unread postby michaeltex » Tue Feb 13, 2018 9:59 pm

I have been working on solving the problem for many days.
Tried all possible images.
Nothing works.
I tried to build my own kernel, but it does not work either.
Why Hardkernel on the site says that "The OS is compatible with the ODROID-XU4" if it is not so?
I have equipment that does not work as it should.
And the developer ignores my problem.
I ask for help in this matter.
michaeltex
 
Posts: 6
Joined: Fri Feb 09, 2018 5:16 pm
languages_spoken: english
ODROIDs: ODROID XU4, ODROID MC1

Re: Beginner question, Android image on MC1?

Unread postby odroid » Tue Feb 13, 2018 10:40 pm

Once the apply Luke.go's kernel configuration patch, the official Android 4.4.4 should work.
User avatar
odroid
Site Admin
 
Posts: 26416
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Beginner question, Android image on MC1?

Unread postby michaeltex » Tue Feb 13, 2018 11:08 pm

I wrote, the file that Luke.go gave was empty.
The file is filled with zeros.
(screenshot) http://prntscr.com/ic955l
michaeltex
 
Posts: 6
Joined: Fri Feb 09, 2018 5:16 pm
languages_spoken: english
ODROIDs: ODROID XU4, ODROID MC1

Re: Beginner question, Android image on MC1?

Unread postby michaeltex » Wed Feb 14, 2018 1:39 am

I have included a low-level debug kernel build.
Kernel stuck after "6[c0] Clock enables : TOP, MIF"
(screenshot) http://prntscr.com/ie7rnp
I do not know what to do next =(
michaeltex
 
Posts: 6
Joined: Fri Feb 09, 2018 5:16 pm
languages_spoken: english
ODROIDs: ODROID XU4, ODROID MC1

Re: Beginner question, Android image on MC1?

Unread postby Luke.go » Wed Feb 14, 2018 9:14 am

I changed the file. please redownlaod the file.
Luke.go
 
Posts: 168
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english

Re: Beginner question, Android image on MC1?

Unread postby michaeltex » Wed Feb 14, 2018 9:31 pm

Luke.go wrote:I changed the file. please redownlaod the file.

Luke.go, thanks so much all works =)
Many times thanks.
michaeltex
 
Posts: 6
Joined: Fri Feb 09, 2018 5:16 pm
languages_spoken: english
ODROIDs: ODROID XU4, ODROID MC1

Re: Beginner question, Android image on MC1?

Unread postby podroid » Mon Feb 19, 2018 3:26 am

FIrst off, I am so so frustrated that I dont even know where to begin.

I have been playing around with SBC's android roots and linux for several years but apparently I'm still a moron.

I bought 2 xu4Qs and images for both android and linux. NEITHER ONE WORKS.

I keep getting image errors on flashing that say "Image is installed but we have detected possible errors that might prevent it from booting"

so I bought 2 new SDcards 16gb and re-downloaded the image from hardkernal wiki. unpacked the image, flashed it, tried to boot.....NOTHING.

WTF.

someone please tell me how to flash a drive or load a pistol....either one will make me happy at this point.

ok, now Im done venting, waiting for your reply :}
podroid
 
Posts: 2
Joined: Mon Feb 19, 2018 3:14 am
languages_spoken: english
ODROIDs: XU4Q

Re: Beginner question, Android image on MC1?

Unread postby podroid » Mon Feb 19, 2018 3:34 am

by the by I do have one of the hardkernel linux images loading in command line, but the upgrade to 16.04 caused it to brick at login. I have spent 2 weeks removing and reloading files, resetting unity, etc etc etc but nothing works. I have watched endless videos on flashing and installing images for both ubuntu and android but nothing works.

do I have bad Xu4s? bad cards? bad brain cells?
podroid
 
Posts: 2
Joined: Mon Feb 19, 2018 3:14 am
languages_spoken: english
ODROIDs: XU4Q

Re: Beginner question, Android image on MC1?

Unread postby voodik » Mon Feb 19, 2018 3:54 am

podroid wrote:by the by I do have one of the hardkernel linux images loading in command line, but the upgrade to 16.04 caused it to brick at login. I have spent 2 weeks removing and reloading files, resetting unity, etc etc etc but nothing works. I have watched endless videos on flashing and installing images for both ubuntu and android but nothing works.

do I have bad Xu4s? bad cards? bad brain cells?

Read this
viewtopic.php?f=94&t=23911&start=1000#p209782
You can help me buy new PC Here ;)
BTC: 3AB1bcKpvsobcjaSxG2iTLDGft2Rqsh7an
User avatar
voodik
 
Posts: 1291
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: Beginner question, Android image on MC1?

Unread postby mad_ady » Mon Feb 19, 2018 3:54 am

What (exact) images have you flashed to the sd cards and what tools did you use (etcher)?
What is the position of the boot switch?
User avatar
mad_ady
 
Posts: 3239
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2


Return to Android

Who is online

Users browsing this forum: No registered users and 5 guests