Page 1 of 1

Game Emulators with media server

Posted: Tue Oct 08, 2019 12:32 am
by mattmaz
I am new to using an ODROID, and I am trying to use a single XU4 for two purposes. The first is a retro-gaming box. The second is a Plex server for movies stored on a NAS drive. I can get one or the other to work well, but not both.

For gaming, I have tried Lakka, Gamestation Turbo, and Retro Arena images. They all seem to work well for gaming. But, when I try to enable a remote desktop and install Plex, it doesn't seem to work. Lakka and Retro Arena don't seem to let me enable remote desktop. Gamestation Turbo will allow the remote desktop, but hangs up when I try to use the installer for the Plex .deb package.

I tried working from the other way as well. I used an image file for Ubuntu Mate 18.04. Remote desktop and Plex installed and were working well. I wasn't able to then install RetroPie. I was using the how-to guide from the RetroPi WIKI ( The blocking point was the step where the TTY startup file was edited. My system would always create a new file, rather than edit an existing one. (sudo systemctl edit getty@tty1)

Am I asking too much from the XU4? Should I just have a dedicated unit for each of the two functions? I won't need to use both functions at the same time. I just want them both installed together.

Is there a way to make this work? I would be happy if I just had an Ubuntu desktop with an icon to pick for the game emulation.

Thanks for any assistance.


Re: Game Emulators with media server

Posted: Tue Oct 08, 2019 2:52 am
by mad_ady
You may want to try meveric's ogst image which should combine both features

Re: Game Emulators with media server

Posted: Tue Oct 08, 2019 9:14 am
by odroid
I think he already tried the OGST (Gamestation Turbo).

Re: Game Emulators with media server

Posted: Tue Oct 08, 2019 1:20 pm
by mad_ady
Oh, sorry I missed that...
Anyway, trying to install plex on ogst should be easier than installing emulators on ubuntu...

Re: Game Emulators with media server

Posted: Tue Oct 08, 2019 7:53 pm
by escalade
My Lakka/RetroPie style fork of LibreELEC has Plex included.

Re: Game Emulators with media server

Posted: Sat Oct 12, 2019 2:02 am
by mattmaz
I did try OGST, but it would just lock up when I tried to install Plex. Right now I was able to get what I need working by using the standard Ubuntu 18.04 image and install individual emulators (PCSXR and FCEUX) from the Synaptic Package Manager.

I will try the Lakka/Retropie with Plex included. I had Lakka running stand alone for a while, and I liked the interface.

Now I just need to create an image of what is running today so I won't need to start over again.


Re: Game Emulators with media server

Posted: Tue Feb 11, 2020 4:19 pm
by HaCkThApLaNeT
Got it to work by sudo nano into the tty file. Couldnt get it to work via the official way, always created a new file for me too.

I built the official image successfully but it wont run anything. Get the error fbset command not found. So installed fbset. Now it just goes black. At least i deciphered the retropie website on the build. Took me 10 times before i realized whoever wrote it left out some crucial steps to get it officially built.

Sorry if this is a repeat. I could not find anything on anyone doing the official build from the website and getting it to take.

Re: Game Emulators with media server

Posted: Fri Feb 14, 2020 4:53 pm
by o_lampe
Wouldn't it be easier to have two SD-cards or EMMC and SD-card with their apps and then switch to the app you need?