[URGENT] Smart Power devices burned down

Post Reply
allenfarcas
Posts: 6
Joined: Wed Feb 10, 2021 2:30 pm
languages_spoken: english
ODROIDs: ODROID MC1, SmartPower2
Has thanked: 0
Been thanked: 0
Contact:

[URGENT] Smart Power devices burned down

Post by allenfarcas »

Hello,

I completed order #HK2101106037 and received the ODROID MC1 and Smart Power 2. I flashed the SP2 and then plugged it in.It started smoking and never worked again. I thought this was just my "bad luck".
David Korts (the faculty member that places orders) placed order #HK2101150552 for 54 Smart Power 2 devices needed for teaching students in a new class using ODROID MC1 devices. I personally updated the firmware on all of them and all worked just fine. This was last week. This week we started setting up the MC1 boards with SmartPower 2. I put a batch of 35 devices as a start. I am very sorry that 17 of them had the exact same smoking behavior when I plugged in the power cable into the Smart Power device.

On all devices Component U3 started smoking and inflating (see photos) and Component U5 on some devices did not look good at all. As these devices are at the core of our teaching class we would like to request replacements for them (both for my personal order #HK2101106037 and for the order placed from the faculty through David Korts #HK2101150552). I am even afraid to test the rest of the SmartPower devices (aka plug them to power, but I need to know the exact number of devices that is not working. Currently those are only with updated Firmware. I can even record what happens, if any of them will not power on at all).

Again: I just updated the firmware through microUSB and then set them in the lab. I went and just attached the LCD display and plugged the Smart Power 2 to power (without even connecting it to anything else). It just burned, out oof my control. All power adapters used were only the ones officially received in the Smart Power 2 package.

Please help us solve this issue as fast as possible as the entire course depends on these devices.

Thank you very much!
Attachments
IMG_1756.jpeg
IMG_1756.jpeg (955.81 KiB) Viewed 1668 times
IMG_1755.jpeg
IMG_1755.jpeg (978.06 KiB) Viewed 1668 times
IMG_1754.jpeg
IMG_1754.jpeg (902.11 KiB) Viewed 1668 times
IMG_1753.jpeg
IMG_1753.jpeg (935.33 KiB) Viewed 1668 times
IMG_1752.jpeg
IMG_1752.jpeg (915.66 KiB) Viewed 1668 times

User avatar
odroid
Site Admin
Posts: 38033
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1999 times
Been thanked: 1206 times
Contact:

Re: [URGENT] Smart Power devices burned down

Post by odroid »

Very high defective rate :o. First of all, sorry for the serious problem caused.

In fact, we've shipped around 2000 Smart Power 2 devices and we received about ~15 units from users who had the similar problem.
But, we couldn't find a real root cause of the burning down problem because we couldn't reproduce the issue in our lab.
We guessed those DCDC switching components could be damaged/burned when there is no load or uncertain DC input noise appears.

Therefore, we added a couple of TVS protection diodes to the Smart Power boards for another customer who met a similar problem in Taiwan.
With the modified Smart Power boards, they have used it without problem over several months so far.

We will send you 20 modified Smart Power units on Monday because Korea has a Lunar New Year holiday by end of this week.
Once your test result is acceptable with the modified boards, we will replace/modify your remaining boards as soon as possible.

allenfarcas
Posts: 6
Joined: Wed Feb 10, 2021 2:30 pm
languages_spoken: english
ODROIDs: ODROID MC1, SmartPower2
Has thanked: 0
Been thanked: 0
Contact:

Re: [URGENT] Smart Power devices burned down

Post by allenfarcas »

Thank you so much!

Please send them at the address mentioned for the order #HK2101106037 so they will arrive directly at my home To upload the firmware and test them.

For testability purposes, I can share exactly the process I have applied to all Smart Power 2 (the firmware uploading) so you can replicate the experiment. The thing is, in the lab, 3 of them worked perfectly. We unplugged the devices and after one hour we plugged them back again, just to find out all three of them burned out! I double checked to see if we did not do anything wrong, but I do not thing we were statically charged or anything like that since we touched the metal table before handling them. Do you thing static charge impacts this high rate? I will wear a static wristband just in case, to make sure I eliminate all possibilities from my end to damage the Smart Power 2.

Thank you again!

User avatar
odroid
Site Admin
Posts: 38033
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1999 times
Been thanked: 1206 times
Contact:

Re: [URGENT] Smart Power devices burned down

Post by odroid »

We've returned from long holiday and we've started modifying 20 boards.
But it probably takes several hours and we can ship it to the address in #HK2101106037 order tomorrow only via Fedex or DHL.

Thank you for sharing the process. But I have an important question.
Did you connect the MC1 (four MC1-Solo units) to a single Smart Power 2?
Since MC1-Solo max current is around 3Amp, the total peak current could be 12Amp.
But Smart Power 2 maximum output current is only 5Amp.
Or, did you use four Smart Power 2 boards with one MC1?

allenfarcas
Posts: 6
Joined: Wed Feb 10, 2021 2:30 pm
languages_spoken: english
ODROIDs: ODROID MC1, SmartPower2
Has thanked: 0
Been thanked: 0
Contact:

Re: [URGENT] Smart Power devices burned down

Post by allenfarcas »

Thank you for your reply,

Smart Power 2 (SP2) was not connected to anything. I just plugged the power cord into it and burned. I figured one thing. A few years back, my professor bought 16 MC1-Solo units and 16 SP2. The SP2 had a power adapter from Channel Well Technology (CWT for short) KPL-060H-VI, and now we received a power supply from CullPower (CP for short), model ICP65-150-4000. Every time I plug in the SP2 into the CWT, it is ok, and when I plug it into CP, many of the SP2 just die. If the SP2 works with CWT it is not 100% sure it will work (and not burn) with CP power adapter, but if a SP2 works with CP it will surely work with CWT (at least from the connections I made until now). You can see photos attached. I repeat: nothing is attached to the SP2. I just plugged them in and they did not work.

These past days I found other 10 were knocked out... I really think something is not right with either the CP power adapter/ power brick) or the SP2 itself. I am not sure where is the mistake but I am sure we will get to the bottom of it. If you have any other suggestion regarding the power adapter and if any replacement of that one could solve this issue would be great. I can confirm all SP2 devices worked since I plugged them to my computer to flash them with the latest firmware and change their names to put them in a specific order. (They had a LCD screen attached so I could see their name and IP.) But other than that, no other interaction with them except the "last one" for the majority of the devices... plugging them in to power.
Attachments
IMG_1810.jpeg
IMG_1810.jpeg (926.79 KiB) Viewed 1597 times
IMG_1809.jpeg
IMG_1809.jpeg (1.05 MiB) Viewed 1597 times

allenfarcas
Posts: 6
Joined: Wed Feb 10, 2021 2:30 pm
languages_spoken: english
ODROIDs: ODROID MC1, SmartPower2
Has thanked: 0
Been thanked: 0
Contact:

Re: [URGENT] Smart Power devices burned down

Post by allenfarcas »

P.S.: We are connecting the SP2 with the MC1-Solo one-to-one. Each MC1 device will have its own SP2, because students can access only one MC1 and they need to be able to measure its power with the attached SP2. This is the setup we are using. But again, the SP2 devices were disconnected when plugged to power.

User avatar
odroid
Site Admin
Posts: 38033
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1999 times
Been thanked: 1206 times
Contact:

Re: [URGENT] Smart Power devices burned down

Post by odroid »

Thank you for the detail explanation and we could reproduce the issue finally with the new ICP65-150-4000 PSU. :o
We suspected the new PSU has much higher voltage transient. We couldn't guess the different PSU made the disaster. :oops:

Therefore, we added a TVS-Diode component near the DCDC converter IC on the SP2 board.
After that we couldn't reproduce the issue so far.

We will send you 20 modified samples tomorrow for your test and confirmation first.

User avatar
odroid
Site Admin
Posts: 38033
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1999 times
Been thanked: 1206 times
Contact:

Re: [URGENT] Smart Power devices burned down

Post by odroid »

@allenfarcas,
I heard you probably received the package today. It took quite longer than normal due to the cold weather problem in Texas.
I hope you are safe and you can test the samples soon.

allenfarcas
Posts: 6
Joined: Wed Feb 10, 2021 2:30 pm
languages_spoken: english
ODROIDs: ODROID MC1, SmartPower2
Has thanked: 0
Been thanked: 0
Contact:

Re: [URGENT] Smart Power devices burned down

Post by allenfarcas »

Thank you so much for your reply. Yes, I took the devices to the lab and heavily tested them and I can confirm all 20 are robust. Unfortunately, the same plug in plug out experiments we did with them failed on all other smart power 2 devices. We would kindly request a return of all other 51 SP2 devices that are not working due to these issues because we need to have very soon 70 devices online with a reliable power source. If need be, we can send all those broken devices back to you.

Let me know if you need anything else.

Gratefully,
Allen

User avatar
odroid
Site Admin
Posts: 38033
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1999 times
Been thanked: 1206 times
Contact:

Re: [URGENT] Smart Power devices burned down

Post by odroid »

Thank you for the heavy test and confirmation.
Just send us all 51 units to us and we will repair/modify the SP2 devices.

You can find our shipping address on the very bottom area of our homepage.
https://www.hardkernel.com/

allenfarcas
Posts: 6
Joined: Wed Feb 10, 2021 2:30 pm
languages_spoken: english
ODROIDs: ODROID MC1, SmartPower2
Has thanked: 0
Been thanked: 0
Contact:

Re: [URGENT] Smart Power devices burned down

Post by allenfarcas »

We have shipped all 51 units and a burned LCD module which was unfortunate to be attached to the first Smart Power 2 device we powered on.
We are deeply grateful for your support. Currently, the class is doing okay with the Smart Power 2 devices you send but the next homework (which will be given in 2 weeks) will need the rest of the devices, as we will connect each team to 2 or 3 MC1s.
I would like to ask you when we should expect the Smart Power 2 devices to be shipped from your side?

Gratefully,
Allen

User avatar
odroid
Site Admin
Posts: 38033
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1999 times
Been thanked: 1206 times
Contact:

Re: [URGENT] Smart Power devices burned down

Post by odroid »

Allen,
Give us a tracking number of the parcel via PM.
Then we need to check when we can receive/modify/ship the units since SmartPower2 was sold out in the last week.
The next batch production schedule is quite uncertain due to the semiconductor shortage problem these days.

Post Reply

Return to “Smart Power”

Who is online

Users browsing this forum: No registered users and 1 guest