Odroid U3+ emmc card won't boot

Post Reply
pzmatek
Posts: 4
Joined: Tue Oct 11, 2016 3:20 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Odroid U3+ emmc card won't boot

Unread post by pzmatek » Mon Apr 15, 2019 11:08 pm

Hi Everybody,

I've got a few old but good odroids U3+. They work fine using micro sd but can't get them to work with emmc cards.
I've got two orange 8GB emmc's - one is red box and the second one is blue dot. I was trying to find some information about the compatibility of these cards
https://wiki.odroid.com/accessory/emmc/ ... rom_the_50
but I must admit I got lost and finally I don't know if it's possible to make them work with my devices.

Firstly when I connected them the blue light didn't even react. When I made the recovery procedure from here viewtopic.php?f=53&t=6173#p49359
I've got the dimmed blue light. When I connected to the serial console I got the messages like below:


----------------------------------------------------------------------------------------
CPU: S5PC220 [Samsung SOC on SMP Platform Base on ARM CortexA9]
APLL = 1000MHz, MPLL = 880MHz
DRAM: 2 GiB

PMIC VERSION : 0x00, CHIP REV : 3
TrustZone Enabled BSP
BL1 version: 20121128


Checking Boot Mode ... EMMC4.41
REVISION: 2.0
[ERROR] response timeout error : 00000104 cmd 1
[ERROR] response timeout error : 00000104 cmd 1
MMC Device 0: 0 MB
MMC Device 1: 0 MB
MMC Device 2 not found
[ERROR] response timeout error : 00000104 cmd 17
mmc read failed
*** Warning - using default environment

USB3503 NINT = OUTPUT LOW!
ModeKey Check... run normal_boot
No ethernet found.
Hit any key to stop autoboot: 0
do_fat_cfgload : cmd = fatload mmc 0:1 0x41000000 boot.ini
** Bad device size - mmc 0 **
[ERROR] response timeout error : 00000104 cmd 1
[ERROR] response timeout error : 00000104 cmd 1
>>> Load Boot Script from mmc 0:1 <<<
** Bad device size - mmc 0 **
>>> Load Boot Script from mmc 0:2 <<<
** Bad device size - mmc 0 **
>>> Run Default Bootcmd <<<
reading kernel..device 0 Start 2455, Count 16384
MMC read: dev # 0, block # 2455, count 16384 ... [ERROR] response timeout error : 00000104 cmd 18
mmc read failed
-19 blocks read: ERROR
completed
reading RFS..device 0 Count 18839, Start 2048
MMC read: dev # 0, block # 18839, count 2048 ... [ERROR] response timeout error : 00000104 cmd 18
mmc read failed
-19 blocks read: ERROR
completed
Wrong Image Format for bootm command
ERROR: can't get kernel image!
----------------------------------------------------------------------------------------

I put a fresh image to the cards using Win32DiskImager-odroid-v1.3 but still have the same messages.
Please take a look at this and let me know what you think.

Cheers

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Odroid U3+ emmc card won't boot

Unread post by odroid » Tue Apr 16, 2019 8:15 am

As far as I remember, the Orange eMMC is not compatible with U2/U3/X/X2.

BTW, did you try this recovery process?
viewtopic.php?f=53&t=969

pzmatek
Posts: 4
Joined: Tue Oct 11, 2016 3:20 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid U3+ emmc card won't boot

Unread post by pzmatek » Tue Apr 16, 2019 6:48 pm

Yes, I recovered the card using the method you posted and using an image from here https://odroid.com/dokuwiki/doku.php?id ... ecovery_u3
After that when I start the device I got the messages from above. When I put some image on the card the messages are the same. Looks like U3 can't recognize these cards and can't read from them.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest