Heavy WiFi problems

Moderators: mdrjr, odroid

Heavy WiFi problems

Unread postby useo6 » Wed May 31, 2017 5:33 am

Hi everyone,

I'm having heavy problems connecting to my WiFi network using my Odroid U3 (Ubuntu 16.04 LTS) and a WiFi USB Dongle (https://www.buyraspberrypi.com.au/shop/ ... pberry-pi/).
The dongle is detected successfully:

odroid@odroid:~$ lsusb
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 003: ID 0424:3503 Standard Microsystems Corp.
Bus 001 Device 002: ID 0424:9730 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
odroid@odroid:~$ iwconfig
wlxe84e0613f212 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

lo no wireless extensions.

eth0 no wireless extensions.

odroid@odroid:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 3a:02:dd:67:b6:01
inet addr:192.168.2.100 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::3802:ddff:fe67:b601/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2072 errors:0 dropped:0 overruns:0 frame:0
TX packets:2128 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:150449 (150.4 KB) TX bytes:598508 (598.5 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:97 errors:0 dropped:0 overruns:0 frame:0
TX packets:97 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7633 (7.6 KB) TX bytes:7633 (7.6 KB)

wlxe84e0613f212 Link encap:Ethernet HWaddr e8:4e:06:13:f2:12
inet6 addr: fe80::ea4e:6ff:fe13:f212/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:51 errors:0 dropped:0 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6885 (6.8 KB) TX bytes:7750 (7.7 KB)


Now, I'm scanning the network:

odroid@odroid:~$ sudo ifconfig wlxe84e0613f212 up
odroid@odroid:~$ sudo iwlist wlxe84e0613f212 scan
wlxe84e0613f212 Scan completed :
Cell 01 - Address: 88:03:55:E9:E8:64
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=65/70 Signal level=-45 dBm
Encryption key:on
...
Cell 02 - Address: 74:31:70:D7:42:48
Channel:5
Frequency:2.432 GHz (Channel 5)
Quality=43/70 Signal level=-67 dBm
Encryption key:on
...


Everything seems to be ok. I also found my own WLAN network and figured out that it uses WPA2 Version 1.
[...]
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
[...]


But now, when I create the according network{} structure using "wpa_supplicant" command and trying to connect to my network, it simply fails (see attachment):

odroid@odroid:~$ sudo wpa_passphrase discordia | sudo tee /etc/wpa_supplicant.conf
odroid@odroid:~$ sudo wpa_supplicant -i wlxe84e0613f212 -c /etc/wpa_supplicant.conf -d > wpa_supplicant.log

[...]
wlxe84e0613f212: 2: c8:0e:14:9a:4c:c1 ssid='OTC-012392' wpa_ie_len=0 rsn_ie_len=20 caps=0x431 level=-85 wps
wlxe84e0613f212: skip - disabled temporarily for 9 second(s)
wlxe84e0613f212: No suitable network found
[...]


Does anyone know what I'm doing wrong? I've absolutely no ideas anymore. It very very sad and the last chance for all of my 7 Odroid U3 boards. Otherwise I'll sell them all (because of some other problems, e.g. sometimes not booting/detecting eth0 so that I've to reinstall/configure the entire Linux on the eMMC) :(
Last year, I already tried to use a WiFi dongle on my Odroid boards and after some days, I failed, too. I decided to simply use eth0. But today, it's not possible anymore to use eth0. So I've to use a WiFi dongle.

I've 6 different WiFi dongles and none of them is working out of the box, although 2 of them are detected directly. That's very very annoying.
Attachments
wpa_supplicant.log
(69.12 KiB) Downloaded 26 times
useo6
 
Posts: 4
Joined: Mon May 01, 2017 11:36 pm
languages_spoken: english
ODROIDs: 6xU3

Re: Heavy WiFi problems

Unread postby odroid » Wed May 31, 2017 10:49 am

Our latest Ubuntu image had some issues with WiFi connection but we couldn't fix it.
Please try this meveric's Debian image.
viewtopic.php?f=79&t=17770
User avatar
odroid
Site Admin
 
Posts: 28497
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Heavy WiFi problems

Unread postby colas2 » Thu Sep 14, 2017 9:51 am

Hi
I have issues with the odroid wifi module 3 with ubuntu 16.04.03. I see the interface "enx48022ab502b7" when I do : $ sudo ifconfig -a. But when I tried $ sudo ifconfig enx48022ab502b7 up I got : SIOCSIFFLAGS: Operation not permitted. I tried to edit the file /etc/network/interface with different guides without any success. My kernel seem to by up-to-date.

Do you think that this kind of issue can be solve by using the meveric's debian distribution ?
colas2
 
Posts: 2
Joined: Wed Apr 15, 2015 4:52 am
languages_spoken: french, english
ODROIDs: Odroid-U3

Re: Heavy WiFi problems

Unread postby meveric » Thu Sep 14, 2017 2:13 pm

As far as I know the Wifi module 3 was supported out of the box from the Kernel, so it should work fine hardware wise on Debian as well.
It normally should be found as wlan0 and with that should be easily to configure, either by network manager if you use a desktop image or /etc/network/interfaces on a server image.
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.
User avatar
meveric
 
Posts: 8981
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1

Re: Heavy WiFi problems

Unread postby colas2 » Fri Sep 15, 2017 10:12 am

No succest for the configuration of the wifi for the module 3. I will open a new treat for this. I fear that the problem is not trivial.
colas2
 
Posts: 2
Joined: Wed Apr 15, 2015 4:52 am
languages_spoken: french, english
ODROIDs: Odroid-U3


Return to Issues

Who is online

Users browsing this forum: No registered users and 1 guest