help u3 install update problem

Moderators: mdrjr, odroid

help u3 install update problem

Unread postby phaseshifter » Sat Jun 09, 2018 1:42 am

Code: Select all
root@odroid:/home/odroid# apt update && apt upgrade && apt dist-upgradeHit:1 http://ppa.launchpad.net/saiarcot895/myppa/ubuntu xenial InRelease
Hit:2 http://ports.ubuntu.com/ubuntu-ports xenial InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease
Hit:4 http://ports.ubuntu.com/ubuntu-ports xenial-backports InRelease
Hit:5 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease
Hit:6 http://ports.ubuntu.com/ubuntu-ports xenial-proposed InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
5 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libgles1-mesa libllvm3.8 libmircommon5 libqmi-glib1 libqpdf17 snap-confine
  ubuntu-core-launcher
Use 'apt autoremove' to remove them.
The following packages have been kept back:
  chromium-browser chromium-browser-l10n chromium-chromedriver
  chromium-codecs-ffmpeg-extra firefox
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
7 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "en
en",
   LC_ALL = (unset),
   LC_TIME = "en",
   LC_MONETARY = "en",
   LC_ADDRESS = "en",
   LC_TELEPHONE = "en",
   LC_NAME = "en",
   LC_MEASUREMENT = "en",
   LC_IDENTIFICATION = "en",
   LC_NUMERIC = "en",
   LC_PAPER = "en",
   LANG = "aa_ER"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("aa_ER").
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up keyboard-configuration (1.108ubuntu15.4) ...
locale: Cannot set LC_ALL to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/var/lib/dpkg/info/keyboard-configuration.config: 1: eval: en: not found
dpkg: error processing package keyboard-configuration (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of console-setup:
 console-setup depends on keyboard-configuration (= 1.108ubuntu15.4); however:
  Package keyboard-configuration is not configured yet.

dpkg: error processing package console-setup (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kbd:
 kbd depends on console-setup | console-setup-mini; however:
  Package console-setup is not configured yet.
  Package console-setup-mini is not installed.

dpkg: error processing package kbd (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of console-setup-linux:
 console-setup-linux depends on kbd (>= 1.15-1ubuntu3); however:
  Package kbd is not configured yet.
 console-setup-linux depends on keyboard-configuration (= 1.108ubuntu15.4No apport report written because the error message indicates its a followup error from a previous failure.
                   No apport report written because the error message indicates its a followup error from a previous failure.
                                             No apport report written because MaxReports is reached already
                           No apport report written because MaxReports is reached already
         No apport report written because MaxReports is reached already
                                                                       No apport report written because MaxReports is reached already
                                                     ); however:
  Package keyboard-configuration is not configured yet.

dpkg: error processing package console-setup-linux (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on console-setup; however:
  Package console-setup is not configured yet.
 ubuntu-minimal depends on kbd; however:
  Package kbd is not configured yet.

dpkg: error processing package ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
 xserver-xorg-core depends on keyboard-configuration; however:
  Package keyboard-configuration is not configured yet.

dpkg: error processing package xserver-xorg-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-amdgpu:
 xserver-xorg-video-amdgpu depends on xorg-video-abi-20; however:
  Package xorg-video-abi-20 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-20 is not configured yet.
 xserver-xorg-video-amdgpu depends on xserver-xorg-core (>= 2:1.17.99.902); however:
  Package xserver-xorg-core is not configured yet.

dpkg: error processing package xserver-xorg-video-amdgpu (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 keyboard-configuration
 console-setup
 kbd
 console-setup-linux
 ubuntu-minimal
 xserver-xorg-core
 xserver-xorg-video-amdgpu
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@odroid:/home/odroid#

odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2854
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: help u3 install update problem

Unread postby rooted » Sat Jun 09, 2018 2:19 am

Try to reconfigure your locale first.

Code: Select all
sudo dpkg-reconfigure locales


It appears you have installed some X86/64 package

Code: Select all
 xserver-xorg-video-amdgpu


This should not be installed?
User avatar
rooted
 
Posts: 5174
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: help u3 install update problem

Unread postby phaseshifter » Mon Jun 11, 2018 4:23 am

This fixed it for me..

Code: Select all
sudo apt-get install --reinstall language-pack-en
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2854
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: help u3 install update problem

Unread postby phaseshifter » Tue Jun 12, 2018 9:36 am

nope it`s still buggy..dunno does not bother me that much it falls back to.."en_us..utf-8 " or something ..i`ll post it next i install something..soz forgot..was more interested in what i done...
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2854
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well


Return to Issues

Who is online

Users browsing this forum: No registered users and 2 guests