s5p_mfc Firmware is not present

Moderators: mdrjr, odroid

s5p_mfc Firmware is not present

Unread postby sl33kr » Thu Jun 09, 2016 6:05 pm

Hello,
I have an ODROID-U3 running Arch linux and I'm getting s5p_mfc_alloc_and_load_firmware:44 Firware is not present in the /lib/firmware directory nor compiled in kernel.

This started happening after I did an upgrade of Arch a few months back.

I'm running Kernel 3.8.13.30-3-ARCH and systemd 229-3.

I have tried copying s5p_mfc.fw to mfc_fw.bin as suggested from:
viewtopic.php?f=65&t=3724

I have seen a suggestion to downgrade systemd also on the odroid forums but the post is quite old:
viewtopic.php?f=73&t=2907

I also found https://archlinuxarm.org/forum/viewtopi ... =47&t=7996 however this talks about being on kernel 3.4 but I'm on 3.8 and doesn't really seem show any solutions.

I downloaded the latest iso and did a clean install of Arch but have the same problem.

Can anyone help please? Is downgrading systemd the way to go?
sl33kr
 
Posts: 8
Joined: Fri Jan 31, 2014 12:34 pm
languages_spoken: english
ODROIDs: U3

Re: s5p_mfc Firmware is not present

Unread postby meveric » Thu Jun 09, 2016 9:06 pm

not sure under ARCH, but in Debian Jessie I have to do the following:
Code: Select all
apt-get install -y firmware-samsung
mkdir -p /lib/firmware/s5p-mfc
cp /lib/firmware/s5p-mfc.fw /lib/firmware/s5p-mfc-v6.fw  /lib/firmware/s5p-mfc/
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.
User avatar
meveric
 
Posts: 8882
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1

Re: s5p_mfc Firmware is not present

Unread postby sl33kr » Mon Jun 13, 2016 4:48 pm

Hey Meveric,
Thank you very much! Sorry for taking so long too get back to you.

I couldn't find firmware-samsung for Arch, however the files were still in the /lib/firmware directory. Creating the sub directory and copying the files in seems to have stopped the errors!

My main reason for doing this was, I seemed to be having problems with hanging on restart and the LAN intermittently stopping/dropping packets. So will see if this fixes those.

I'm still getting the below, which I was hoping this would fix as well. Is this even something I should worry about?

Code: Select all
Jun 13 17:02:03 alarm kernel: exynos-mixer s5p-mixer: stop latency exceeded, new value 1000 ns
Jun 13 17:02:03 alarm kernel: exynos-hdmi exynos4-hdmi: stop latency exceeded, new value 500 ns
Jun 13 17:02:03 alarm kernel: exynos-mixer s5p-mixer: start latency exceeded, new value 542 ns
Jun 13 17:02:03 alarm kernel: exynos-mixer s5p-mixer: state save latency exceeded, new value 49943762 ns
Jun 13 17:02:03 alarm kernel: exynos-hdmi exynos4-hdmi: start latency exceeded, new value 667 ns
Jun 13 17:02:03 alarm kernel: exynos-hdmi exynos4-hdmi: state save latency exceeded, new value 24219441 ns
Jun 13 17:02:03 alarm kernel: pd-tv: Power-off latency exceeded, new value 833 ns
Jun 13 17:08:47 alarm kernel: pd-tv: Power-on latency exceeded, new value 2041 ns
Jun 13 17:19:17 alarm kernel: exynos-mixer s5p-mixer: state save latency exceeded, new value 49963788 ns
Jun 13 17:31:01 alarm kernel: pd-tv: Power-on latency exceeded, new value 199334 ns
Jun 13 17:41:03 alarm kernel: exynos-hdmi exynos4-hdmi: stop latency exceeded, new value 708 ns
Jun 13 17:41:03 alarm kernel: exynos-hdmi exynos4-hdmi: start latency exceeded, new value 792 ns
Jun 13 17:41:03 alarm kernel: exynos-hdmi exynos4-hdmi: state save latency exceeded, new value 24515044 ns
Jun 13 17:41:03 alarm kernel: exynos-hdmi exynos4-hdmi: stop latency exceeded, new value 750 ns
Jun 13 17:41:03 alarm kernel: pd-tv: Power-off latency exceeded, new value 1000 ns
sl33kr
 
Posts: 8
Joined: Fri Jan 31, 2014 12:34 pm
languages_spoken: english
ODROIDs: U3

Re: s5p_mfc Firmware is not present

Unread postby andrewufrank » Fri Apr 06, 2018 4:35 pm

i have installed the stretch version from mev
Linux feltre 4.14.32+ #1 SMP PREEMPT Thu Apr 5 12:46:33 UTC 2018 armv7l GNU/Linux
and updated, upgraded and dist-upgraded.
i ran the 3 lines from the instruction above and checked that the firmware is indeed in the directory specified, nevertheless is see in /var/sys/log:
Code: Select all
Running under secure firmware.
Apr  6 09:24:20 localhost kernel: [    3.329115] s5p-mfc 11000000.codec: preallocated 16 MiB buffer for the firmware and context buffers
Apr  6 09:24:20 localhost kernel: [    3.336818] (NULL device *): Direct firmware load for s5p-mfc-v8.fw failed with error -2
Apr  6 09:24:20 localhost kernel: [    3.344793] s5p_mfc_load_firmware:73: Firmware is not present in the /lib/firmware directory nor compiled in kernel

what is wrong?
thank you for the good work - debian from mev works very well!
andrewufrank
 
Posts: 22
Joined: Sun Nov 15, 2015 6:16 pm
languages_spoken: english
ODROIDs: xu4

Re: s5p_mfc Firmware is not present

Unread postby odroid » Fri Apr 06, 2018 4:38 pm

This place is old U3 sub-forum.
Post the question on XU4 sub-forum.
viewforum.php?f=92
User avatar
odroid
Site Admin
 
Posts: 28218
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Issues

Who is online

Users browsing this forum: No registered users and 2 guests