U3 does not boot from SD-card, when EMMC is pluged in

Post Reply
kultex
Posts: 35
Joined: Tue Feb 24, 2015 5:33 pm
languages_spoken: english
ODROIDs: Odroid U3
Has thanked: 0
Been thanked: 0
Contact:

U3 does not boot from SD-card, when EMMC is pluged in

Post by kultex » Fri May 15, 2020 5:10 am

My U3 was running long time as always on family desktop until a lightning ruined the HDMI output - the rest of tthe U3 works without any problems. So I use it now as a web application with nginx and postgeSQL. It had best performance compared to Rock64 and Raspberry 4 - this was now a year ago.

It runs under Arch from SD-card and the database is on the EMMC. But I had the problem, that the U3 does not boot, from the Sd-card, when the Odroid-EMMC is plugged in.

I changed to the EMMC Modul from the Rock64 and then the U3 with the EMMC from the Rock64 boots without any problem and the EMMC is recogniced.

After one year of running, we sometimes have the problem, that the EMMC Modul from the Rock crashes. So I would like to change back to the Odroid EMMC Modul, because I never had any problem. But it does not boot, even when the EMMC ic completly empty.

Do I have to update uboot or do you have any other idea to get it working?

User avatar
odroid
Site Admin
Posts: 34195
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 701 times
Been thanked: 625 times
Contact:

Re: U3 does not boot from SD-card, when EMMC is pluged in

Post by odroid » Fri May 15, 2020 11:25 am

Try this method to check if the eMMC was really broken or not.
viewtopic.php?f=53&t=969

kultex
Posts: 35
Joined: Tue Feb 24, 2015 5:33 pm
languages_spoken: english
ODROIDs: Odroid U3
Has thanked: 0
Been thanked: 0
Contact:

Re: U3 does not boot from SD-card, when EMMC is pluged in

Post by kultex » Fri May 15, 2020 3:37 pm

no both emmcs are not dead - the emmc from the rock64, which is used now, starts to get bad sectors and is no more writeable. Its not clear when. It can happen after two weeks or after 3 month. We have to umount, then run e2fsck, which prints a lot of errors, but afterwards it is ok.

But I want to change back to the original emmc, to see, if those errors will happen also there.

So my question: Is it not possible to boot the U3 from SD-card, when the original EMMC is plugged in?

I think U3 boots with the rock64 emmc from SD-card, because uboot does not the recognize the emmc, which is version number 1 and the old hardkernel version is 0.3 (when I remember right, I dont have it at home)

User avatar
odroid
Site Admin
Posts: 34195
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 701 times
Been thanked: 625 times
Contact:

Re: U3 does not boot from SD-card, when EMMC is pluged in

Post by odroid » Fri May 15, 2020 3:44 pm

If the boot loader in the hidden partition in your eMMC was corrupted, you need to run the recovery process in my previous link.

eMMC boot priority is higher than SD-card.

kultex
Posts: 35
Joined: Tue Feb 24, 2015 5:33 pm
languages_spoken: english
ODROIDs: Odroid U3
Has thanked: 0
Been thanked: 0
Contact:

Re: U3 does not boot from SD-card, when EMMC is pluged in

Post by kultex » Fri May 15, 2020 8:37 pm

I dont think, that this is the problem, because the rock64 boots without any problem from SD-card, when the Hardkernel EMMC is plugged in.

But I will try it

kultex
Posts: 35
Joined: Tue Feb 24, 2015 5:33 pm
languages_spoken: english
ODROIDs: Odroid U3
Has thanked: 0
Been thanked: 0
Contact:

Re: U3 does not boot from SD-card, when EMMC is pluged in

Post by kultex » Sun May 17, 2020 9:16 pm

As I thought - it does not change anything

some more ideas, how to make it possible?

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 2 guests