OpenELEC for Odroid-U2/U3/XU3/C1

Moderators: odroid, mdrjr

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Chicco » Sun Mar 06, 2016 1:43 am

Muchapo wrote: YES! I'd like to know the details, thank you!


No problem.

[step#1]
On the lircd.conf (/storage/.config/) set the key for the poweroff, like this:
Code: Select all
# brand:                       Meliconi
# model no. of remote control: Pratico 2 Light
# code remote for TV: 1731
# devices being controlled by this remote:
#

begin remote

  name  "devinput"
  bits           16
  flags SPACE_ENC|CONST_LENGTH
  eps            30
  aeps          100

  header       8963  4541
  one           547  1704
  zero          547   556
  ptrail        553
  pre_data_bits   16
  pre_data       0x8E71
  gap          107631
  toggle_bit_mask 0x0

      begin codes
         KEY_POWER                0x8E7152AD
     end codes

end remote


[step#2]
In the same folder (/storage/.config) create a file .lircrc with:
Code: Select all
begin

     button = KEY_POWER
     prog = irexec
     config = /usr/sbin/poweroff  &

end


[step#3]
Ever in the folder /storage/.config/ create a file autostart.sh and it must be obviously executable:
Code: Select all
#!/bin/sh
/usr/bin/irexec -d /storage/.config/.lircrc


[step#4]
Reboot the system

Very simple. Remember, the first time you send the command openelec run only a reboot, while the second time you get a real poweroff (only the red led remains on). Now you can cut off the power peacefully.
I am using this way for some time without encountering problems.
Bye
Fred
Chicco
 
Posts: 2
Joined: Tue Mar 01, 2016 6:58 pm
languages_spoken: english
ODROIDs: ODROID C1+

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby VERSUS » Mon Mar 07, 2016 5:51 pm

odroid wrote:@VERSUS
It is worth to update/recover the hidden sector in your eMMC.
viewtopic.php?f=53&t=969

Also try the Win32DiskImage V1.3 with the VERIFY function.
http://odroid.com/dokuwiki/doku.php?id= ... diskimager


I tried both suggested solutions but none of them worked.

I also did another test that shows its not an emmc card problem but an image problem. I flashed 6.0.2 to my emmc and then placed it on the Micro SD adapter of my U3 using the emmc to sd adapter and OpenElec boots up and works fine.

So this means that something is missing from the images after 4.1.6 to support Emmc boot on our U3's.

Can Zalaare or someone else that has the coding skills check this out please??

I tried running Openelec from my micro SD card but it's so much slower that makes the whole device feel sluggish and useless.

Is anyone else here using Openelec verion 5.xxxx and UP on Emmc on Odroid U3 ???

Please help. Thanks
VERSUS
 
Posts: 21
Joined: Sat Mar 15, 2014 12:23 am
languages_spoken: english
ODROIDs: U3

C1+ / C2

Unread postby ne0zone75 » Tue Mar 08, 2016 7:39 am

Hi,

First of all, let me thank you for all your great work ! Now and AFAIK, S805 is capable of hardware support for H.265 decoding up to 1080p... is this feature enabled in your builds for C1+ ?

Also, i would like to know if C2 support is upcoming from you ?

Thank you !
ne0zone75
 
Posts: 68
Joined: Mon Mar 07, 2016 5:03 pm
Location: France
languages_spoken: english french
ODROIDs: C1+ / C2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby rooted » Tue Mar 08, 2016 7:52 am

Yes h265 hardware decoding is enabled for the C1/+
User avatar
rooted
 
Posts: 3488
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1
C1+
C2
XU3 Lite
XU4
VU7+
HiFi Shield 2
Smart Power (original)

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby ne0zone75 » Tue Mar 08, 2016 9:03 am

@rooted,

Thanks for your answer. It is good news !

@zalaare,

I've just noticed that you do have a device tree for the C2 in your odroid-7.0 GitHub sources... Yeah ! More good news ! BTW, device trees have moved to '.openelec' directory... is there a new way to launch the build ?

Regards

EDIT : i've made a symbolic link located in my home directory which heads to my sources root directory elsewhere and now i am able to launch building process as usual.
ne0zone75
 
Posts: 68
Joined: Mon Mar 07, 2016 5:03 pm
Location: France
languages_spoken: english french
ODROIDs: C1+ / C2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby zlo2k » Wed Mar 09, 2016 2:09 am

Hi all, i have u3 with cooler heatsink. Is possible to controll fan speed in OpenElec ? Because fan is start and stop every second :)
I try use this manual
https://geertschuring.wordpress.com/201 ... odroid-u3/
but in manual mode fan work 100% and not respond to change pwm param..
Sorry for my english. Thank you.
zlo2k
 
Posts: 1
Joined: Tue Apr 14, 2015 7:41 pm
languages_spoken: english
ODROIDs: u3 c1

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Sat Mar 12, 2016 6:14 am

We'll finally it's arrived my new XU4, just wanted to find out if anyone has managed to get openelec 6.0.x to boot off eMMC?
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Arben » Sat Mar 12, 2016 8:33 am

Hi,

first of all thanks to zalaare for all the amazing work!

My issue: I'm trying now pretty long to get DTS/DD/passthrough, ... working. Unfortunately I see in the kodi config only "Default (ODROID-HDMI Analog)" without a possibility to change this. I can change the number of channels and activate in a movie passthrough in the audio options, but then nothing is received at the TV/receiver (tested both).

Tests with aplay and speaker-test didn't result in multichannel output - always only 2ch output. Additionally speaker-test seems to be buggy, because it accepts only channel 1=^FrontLeft. All other ones are invalid.

I found a possible solution by changing the /etc/asound.conf from

Code: Select all
pcm.!default {
  type plug
  slave {
    pcm "hw:0,0"
  }
}
ctl.!default {
  type hw
  card 0
}


to

Code: Select all
pcm.!default {
       type hw
        card 0
        device 0
        format S16_LE
}

ctl.!default {
        type hw
        card 0
}


This fix was mentioned by mdrjr in this post http://forum.odroid.com/viewtopic.php?f=112&t=16033 for fixing the issue on ubuntu. The fix can be seen here: https://github.com/mdrjr/odroid-utility/blob/master/odroidc_hdmipass.sh

Unfortunately the fs is ro and I couldn't remount it rw. Therefore I couldn't change asound.conf and test, if this is working or not.

Perhaps somebody can give me a hint on one or some of these questions:
Can anybody confirm that this enables passthrough for DTS and/or DD?
How can I mount the fs rw to test the fix myself?
Is there another solution to get passthrough working?
Is it possible to fix the audio device selection in kodi to change in the GUI analog and digital output?

Of course, I'm willing to make tests and provide traces if needed.

Thanks in advance for any help on this!

BR, Arben

Configuration:
ODROID C1 with HW-mod for working CEC
OE 6.0.2 via updates from 5.x.x (don't remeber exactly, but tried also a 6.0.2 image with the same result)
LG TV
DENON AVR
Possibility for UART traces (probably with connected TV)


BTW: I read several threads including this one, but couldn't find a solution getting this working.
Arben
 
Posts: 7
Joined: Sat Mar 12, 2016 8:05 am
languages_spoken: english, albanian, german, bavarian
ODROIDs: C1

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby delusion666 » Sun Mar 13, 2016 4:03 am

VERSUS wrote:I also did another test that shows its not an emmc card problem but an image problem. I flashed 6.0.2 to my emmc and then placed it on the Micro SD adapter of my U3 using the emmc to sd adapter and OpenElec boots up and works fine.


I have the same problem as @VERSUS.
Also, Ubuntu boots OK from the emmc so clearly it's an OpenElec image problem.

@zalaare are you into this? Or can you give us any hint on what could it be?
delusion666
 
Posts: 3
Joined: Thu May 29, 2014 4:11 am
languages_spoken: english
ODROIDs: U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Santos180 » Mon Mar 14, 2016 7:35 am

Could you release a version of OpenELEC for ODROID C2?

PLEASE
&
THANK YOU
Santos180
 
Posts: 2
Joined: Tue Mar 08, 2016 4:16 pm
languages_spoken: English
ODROIDs: ODROID C2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Geebrown » Mon Mar 14, 2016 9:52 am

@zalaare + other contributors to Openelec on Odroid

Just had to say thanks for your great work. I'm a noob at this but went from flashing the image to streaming HD video over wi-fi in less than 20 mins.

Worked for me 'out of the box' on my U3 (chose 5.0.8.0 as there is a Kodi Ipad remote control app that only goes up to Kodi Helix).

Marvelous!
Geebrown
 
Posts: 3
Joined: Wed Oct 22, 2014 8:50 pm
languages_spoken: english
ODROIDs: U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby zalaare » Mon Mar 14, 2016 11:11 pm

Arben wrote:Hi,

I found a possible solution by changing the /etc/asound.conf from

Code: Select all
pcm.!default {
  type plug
  slave {
    pcm "hw:0,0"
  }
}
ctl.!default {
  type hw
  card 0
}


to

Code: Select all
pcm.!default {
       type hw
        card 0
        device 0
        format S16_LE
}

ctl.!default {
        type hw
        card 0
}


I can add a script to switch this automatically, BUT as soon as I looked at the code I immediately note that your references don't match and so I stopped.
See Current Code
zalaare
 
Posts: 181
Joined: Mon May 12, 2014 10:07 am
languages_spoken: english
ODROIDs: U3 Community | XU3 | XU4 | C1 | C1+

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Tue Mar 15, 2016 2:15 am

Hi,

Anyone managed to get 6.#.#.# to boot directly off the eMMC card?
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Arben » Tue Mar 15, 2016 3:53 am

zalaare wrote:I can add a script to switch this automatically, BUT as soon as I looked at the code I immediately note that your references don't match and so I stopped.
See Current Code


Hello zalaare,

thanks for having a look on it and of course you're absolutely right! I added the wrong reference caused by a stupid copy&paste error. The current implementation is just as you said. The copy&paste error came because while writing the post, I was testing in parallel the OE image from wrxtasy. And unfortunately I copied his asound.conf. Sorry for that, I didn't wanted to cause you unneeded work!
Btw. in wrxtasys OE the passthrough configuration is available in the GUI in the settings menu as expected and passthrough option can be set together with DD and DTS. But still the receiver doesn't see DD or DTS.

However, the target config, which I posted, is what I wanted to test:
Code: Select all
pcm.!default {
       type hw
        card 0
        device 0
        format S16_LE
}

ctl.!default {
        type hw
        card 0
}


Meanwhile I found a guide how to modify a squashfs. I will try to test the mentioned modifications with this method and share my results here - if anyone is interested.

Meanwhile my questions still besides: Did anyone get DD/DTS passthrough and/or output working? If yes, how?

BR, Arben

Edit 02.04.2016:
Some days ago I came back from vacation and tested the change. Unfortunately with no improvement. Then I tried again wrxtasys OE version - and it worked. It seemed, that I had some wrong settings last time I tested it. Unfortunately I can't test these settings in zalaares OE version, because they aren't available in the OE GUI.

Even I like your work zalaare and would like to use it further, unfortunately I have to switch to wrxtasys OE version to get DD and DTS. But thank you very much for all your effort and perhaps I'll come back to you, when my C2s arrive ;)
Last edited by Arben on Sat Apr 02, 2016 11:33 pm, edited 1 time in total.
Arben
 
Posts: 7
Joined: Sat Mar 12, 2016 8:05 am
languages_spoken: english, albanian, german, bavarian
ODROIDs: C1

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby VERSUS » Wed Mar 16, 2016 12:25 am

CAn someone please help us, the guys that want to have Openelec on U2/3 on our Emmc card?? It seems its not just me but other guys as well.

The problem occurred from 4.1.6 onwards. I can provide 4.1.6 img file for those who want to run OpenElec from an Emmc card but this is XBMC 13.2 version and most add ons are not and will be not supported for this one. I am uploading it as we speak on Google Drive and i will share the link for those interested.

But can Zalaare or someone else tell us waht was different in 4.1.6 and previous that supported Emmc ?? and what changed afterwards ???

Thanks in advance !!!
VERSUS
 
Posts: 21
Joined: Sat Mar 15, 2014 12:23 am
languages_spoken: english
ODROIDs: U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby VERSUS » Wed Mar 16, 2016 5:13 pm

The 4.1.6 image file that supports Emmc on U2/U3 : https://drive.google.com/file/d/0Bw4dMz ... sp=sharing

Please help us on newer images not supporting Emmc's !!!!
VERSUS
 
Posts: 21
Joined: Sat Mar 15, 2014 12:23 am
languages_spoken: english
ODROIDs: U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Sat Mar 19, 2016 6:49 pm

Hi all,

i have a XU4 running 6.0.2 from Class 10 SD Card and CEC disabled (no need for it), everything is running and playing perfect.

I only have one issue, every morning when i switch on my TV all i see is a blackscreen, but TV is still picking up HDMI signal, it looks like the Odroid/Openelec has gone into sleep/hibernation mode from sitting on idle for a couple of hours, im currently using a 2.4Ghz Remote, but this does nothing when i press keys, the only way i can get it out of "sleepmode" is switching it off and on at the plug, has anyone else had this issue, if so can you help to resolve it or is there an option to change te current sleep/hibernation mode on Openelec ?.

Kind Regards
NickDG
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby averagejoe » Wed Mar 23, 2016 4:38 pm

Hey,

Only get a solid blue light when trying to boot with the eMMC directly connected.
When using the eMMC-MicroSD adapter (deliverd with the ODROID), plugged into the ODROID it boots and works - even the CEC

PS: Is it possible to run LibreOffice and a Browser (like Chromium) on OpenELEC, or is it XBMC only?

ODROID U3(+)
eMMC 8GB
OpenELEC 6.0.2.0 (ODROID U2/U3) (flashed and verfied with Win32 Disk Imager for ODROID Ver 1.3 )

The eMMC contains (after flashing): INITRD (2,98MB), KERNEL (2,26MB), SYSEM (100MB) as well as boot.ini (2,63KB)
averagejoe
 
Posts: 4
Joined: Mon Mar 21, 2016 9:16 pm
languages_spoken: english

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby VERSUS » Thu Mar 24, 2016 6:48 pm

AverageJoe, if you read above you will see that all of us using EMMC are facing the same issue. We are hoping that maybe someone would tell us what was different in version 4.1.6 and emmc was supported just fine but unfortunately no one seems to be helping up until now.
VERSUS
 
Posts: 21
Joined: Sat Mar 15, 2014 12:23 am
languages_spoken: english
ODROIDs: U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby pyr0t0n » Sun Mar 27, 2016 9:23 pm

I flashed a clean 6.0.2.0 image on my U3 today but after starting Kodi the GUI is flickering... any solutions for this?
pyr0t0n
 
Posts: 4
Joined: Sat Apr 12, 2014 8:43 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby albanibr » Tue Mar 29, 2016 9:45 am

zalaare
you are working in a odroid C2 version?
is possible to pay a beer for the hard work?

thanks!!
albanibr
 
Posts: 34
Joined: Fri Aug 07, 2015 1:58 am
Location: Brazil
languages_spoken: english, portuguese
ODROIDs: C2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Tue Apr 12, 2016 11:29 pm

HI All,

things have gone very quiet on here why ?, i hope we haven't lost all support for the Odroid devices.
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Fri Apr 15, 2016 5:02 pm

Hi , anyone have the issue of XU4 going to sleep after a few hours of idle ? I'm currently running 6.0.2
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby zalaare » Tue Apr 19, 2016 11:07 pm

Status Begin:

I've been working with LibreELEC and have been trying to solidify my plan of action on how to continue to build my ELEC projects. I want to be able to build my projects on OpenELEC and LibreELEC as wanted so I'm attempting to move my work into new repo's that are just the project directory. When done it should be as easy as checking out {Open,Libre}ELEC git trees from the official git and then adding my submodule to the project dir. With OE it will require patches to the buildsystem and I don't know how committed I am to trying to support it for the long term. LE should work easily enough for now. This isn't done completely and I poke at this day-2-day.

I've been working with the LE team to get their Virtual project a bit more flushed out and a lot of what time I have has gone that way.

The summer season is coming and I'm up to my ear-brows IRL at work and at home. My time on my hobbies is getting smaller by the day.

I have been thinking of dropping support for the C1/C2 since wrxtasy has a build and it is redundant work. He is more than on top of the game and I just don't have as much time to spend on it.

:End Status
zalaare
 
Posts: 181
Joined: Mon May 12, 2014 10:07 am
languages_spoken: english
ODROIDs: U3 Community | XU3 | XU4 | C1 | C1+

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Saruk » Sat Apr 23, 2016 12:11 am

I just want to say thanks Zalaare. It works great on my U3!
Just wondering. I have an Odroid U3 and was wondering if anyone has tried putting the update file for a RPI 2 in the update folder? Will it crash it or is there another way to update it?
Saruk
 
Posts: 11
Joined: Tue Mar 25, 2014 4:37 am
languages_spoken: english
ODROIDs: Odroid - U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby BeeHopper » Sun Apr 24, 2016 8:50 pm

Do i understand, that there will be a libreeleec Version for the u3?
BeeHopper
 
Posts: 2
Joined: Wed Apr 15, 2015 12:47 am
languages_spoken: german (english)
ODROIDs: U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby ne0zone75 » Sun Apr 24, 2016 10:16 pm

zalaare wrote:Status Begin:

I've been working with LibreELEC and have been trying to solidify my plan of action on how to continue to build my ELEC projects. I want to be able to build my projects on OpenELEC and LibreELEC as wanted so I'm attempting to move my work into new repo's that are just the project directory. When done it should be as easy as checking out {Open,Libre}ELEC git trees from the official git and then adding my submodule to the project dir. With OE it will require patches to the buildsystem and I don't know how committed I am to trying to support it for the long term. LE should work easily enough for now. This isn't done completely and I poke at this day-2-day.

I've been working with the LE team to get their Virtual project a bit more flushed out and a lot of what time I have has gone that way.

The summer season is coming and I'm up to my ear-brows IRL at work and at home. My time on my hobbies is getting smaller by the day.

I have been thinking of dropping support for the C1/C2 since wrxtasy has a build and it is redundant work. He is more than on top of the game and I just don't have as much time to spend on it.

:End Status

I am quite new to ODROIDs world but i know how maintaining DEV projects up to date can be time consuming.

Thank you for all your work and i hope that you will manage to find enough time to do what you want to do by the way you want to...

All the best

Tapatalked from my SM-G903F
ne0zone75
 
Posts: 68
Joined: Mon Mar 07, 2016 5:03 pm
Location: France
languages_spoken: english french
ODROIDs: C1+ / C2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby crossover » Mon Apr 25, 2016 9:40 am

@zalaare,
I've been really happy with your OpenELEC images on my odroid boards.
We hope you will be back when you have spare time. Many thanks.
crossover
 
Posts: 101
Joined: Wed Jul 22, 2015 2:23 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, USB-IO, Tinkering kits

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Smmstev0 » Wed Apr 27, 2016 9:26 pm

Hello,
I just picked up a Xu4 and im trying to install openelec 6.0.2.0 on my SD card. I write the image to the SD card verify it and every thing and it boots up and restarts like it's resizing the partition, but never outputs a display to my Samsung smart tv. Am i missing a step where i have to modify something in the .ini file? Please help.
Thanks
Smmstev0
 
Posts: 1
Joined: Wed Apr 27, 2016 9:16 pm
languages_spoken: english
ODROIDs: Odroid XU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby TuN » Fri Apr 29, 2016 6:18 am

Hello!

I've installed OpenELEC 6.0.2.0 on my Odroid C1+, and it's quite faster than LUbuntu 14.04 that I've used before.
I'm having 2 issues though:

1. USB-SPDIF Sound Card ( http://www.hardkernel.com/main/products ... 0081048224 ), that I can't get to work. Device is visible in Kodi - Sound output configuration, but I can't get any sound coming out of it.
Is there something I could do? The USB-SPDIF was working normally in LUbuntu 14.04.

2. I always get an error when trying to reboot or shutdown the Odroid:
http://i.imgur.com/DbPLnB6.jpg
If I remove the power from the device and then plug it back in, it doesn't show any errors.
I'm using Samsung 32GB EVO Class 10 microSD Card

I'm willing to install some older/newer version of OpenELEC if it will solve my USB-SPDIF issue.

Thanks a lot in advance!
TuN
 
Posts: 1
Joined: Fri Apr 29, 2016 6:06 am
languages_spoken: english
ODROIDs: Odroid C1+

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby 2004RuN » Tue May 03, 2016 2:47 pm

Hi to all.

After upgrading my C1+ from 6.0.0 to 6.0.2 my C1+ was began to loose connection to HDD. I've try differrent HDD and change the port and cable but still the same. I've fresh install the image 6.0.2 and still the same. Then try 6.0.1 and 6.0.0 and still the same - it keep loosing the connection from disks. Also the CEC is not working any more. I've enabled it in boot.ini but my LG TV shows CEC on HDMI1 input with name Odroid C1 but my C1 is connected on HDMI2. On HDMI1 input theres no video on TV.
I don't know what to do any more. Any suggestions?

Now another fresh install of 6.0.2 HDD is working, but sound 5.1 is not and video playback isn't also. Some kind of error when trying to play videos from HDD.

Fresh install of 6.0.0 HDD is sometimes working other times not. Sometimes on videoplayback HDD is disconnected and then reconnected by him self ??? I Have no clue?

Back on version 5.95.5.
2004RuN
 
Posts: 17
Joined: Fri Jan 15, 2016 4:38 am
languages_spoken: english

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Saruk » Thu May 12, 2016 9:50 pm

Well, it looks like this thread is dying. Sadly support for the U3 is slipping away. Where is a good place to find detailed instructions and scripts for building my own openELEC and libreELEC? I'd like to learn what it takes to build my own.
Saruk
 
Posts: 11
Joined: Tue Mar 25, 2014 4:37 am
languages_spoken: english
ODROIDs: Odroid - U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Mon May 23, 2016 3:22 am

Hi all,

Not sure of anyone is having this issues if tried searching for some info on this thread about it but nothing, I'm running a XU4 and a Samsung H6400 smart LED , when I put the tv off its throws the XU4 into what looks like standby mode , I can still SSH to the XU4 but looks like the HDMI signal has been disabled even if I press buttons on the remote nothing happens the only way to fix it is by rebooting the device via SSH or unplugging and plugging it in again, anyone else have this issue and is there maybe a way I can stop it ?
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Saruk » Mon May 23, 2016 9:13 pm

NickDG wrote:Hi all,

Not sure of anyone is having this issues if tried searching for some info on this thread about it but nothing, I'm running a XU4 and a Samsung H6400 smart LED , when I put the tv off its throws the XU4 into what looks like standby mode , I can still SSH to the XU4 but looks like the HDMI signal has been disabled even if I press buttons on the remote nothing happens the only way to fix it is by rebooting the device via SSH or unplugging and plugging it in again, anyone else have this issue and is there maybe a way I can stop it ?



I'm having the same issue. Also, sometimes when starting another show I'll get a black screen with sound. I have to reboot mine to get the video back.
Saruk
 
Posts: 11
Joined: Tue Mar 25, 2014 4:37 am
languages_spoken: english
ODROIDs: Odroid - U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Sat May 28, 2016 4:40 am

Hmmmm ok thanks Saruk, I thought it was the only one , I've tried disabling CEC on both my TV and kodi but for some reason it still puts the kodi /XU4 into standby
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

XU4 - OpenELEC 6.0.2.0

Unread postby Drew » Mon May 30, 2016 5:45 am

On some devices this works great, but on others I get a green screen with no sound. I can see everything, but the colors are totally off, almost everything turns green (including areas that should be totally black), and the image quality is awful and jittery. This starts immediately when the first splash image comes up indicating the kernel is starting.

Am I supposed to be messing with boot.ini? I've tried a few resolutions and refresh rates with setenv video_output, but it doesn't seem to be doing anything. Everything here except the Vizio is supposed to support 1080p, so I'm not sure what the problem is. Any recommendations?

Works with:
├> Viewsonic VP2770 (computer monitor, no audio)
├> Pioneer VSX-1020 (receiver, passed through to Samsung TV)
└> Sharp Aquos (unknown model number c. 2012, I'm not pulling that monstrosity off my wall)

Doesn't work with:
├> Denon AVR-1613 (receiver passed through to aforementioned Aquos)
├> Panisonic TH-4250PXU (plasma TV c. 2005)
└> Vizio VO320E (probably because it only supports 720p)
User avatar
Drew
 
Posts: 5
Joined: Wed Aug 19, 2015 9:00 am
languages_spoken: English
ODROIDs: XU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby rikc » Wed Jul 20, 2016 2:54 pm

Confirming the eMMC boot problem with an XU4 here. Files are the same but on my 64GB eMMC there is a 40gb primary partition after the fat partition. On the 4GB microSD this is 3.36GB (the rest of the allocated space). Trying to boot over the microSD with the eMMC does not work for me (contrary to the user who reported this for the U3). When trying to boot off eMMC no display is provided, but the fan spins. When trying to boot via the adapter nothing happens at all. Booting directy off the microSD works fine.
rikc
 
Posts: 9
Joined: Mon Aug 17, 2015 10:43 pm
languages_spoken: english, dutch, german, french
ODROIDs: XU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Pico » Wed Aug 24, 2016 10:11 am

Is there any list of wifi adapters/chips that are supported by this?
Pico
 
Posts: 1
Joined: Sun Jan 12, 2014 3:48 pm
languages_spoken: english

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby jaws75 » Sun Sep 11, 2016 4:43 pm

HI guys,
I am new of OpenELEC, I tired on my Odroid U2 and it works fine!!
I have one issue:
- I was not able to install the transmission-daemon, it means that wen I launch the client on Kodi it fails because doesn't find the daeon active. How can I install the transmission-daemon on OpenELEC 6.0.2?

Anyone tried LibreELEC on Odroid U2 (http://freeweb.mine.nu/zalaare/LibreELEC/), I saw some images ... anyone had chance to test them?
Thanks!
jaws75
 
Posts: 1
Joined: Sun Sep 11, 2016 4:22 pm
languages_spoken: english

Odroid U2

Unread postby AeFFe » Sun Sep 25, 2016 7:20 am

Same issue. OpenELEC 6.0 does not boot from eemc and U2
My U2 is no more supported?

Please an answer in any case.

AeFFE
AeFFe
 
Posts: 239
Joined: Wed May 08, 2013 5:05 pm
languages_spoken: english
ODROIDs: oDroid-U2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby AeFFe » Tue Sep 27, 2016 4:07 pm

No answer? Does it mean that there will be no way to have OpenELEC 6.0 booting from an emmc?

AeFFe
AeFFe
 
Posts: 239
Joined: Wed May 08, 2013 5:05 pm
languages_spoken: english
ODROIDs: oDroid-U2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby Indigo » Tue Sep 27, 2016 4:32 pm

I've give up using OpenElec, or anything Kodi-related actually, on my Odroid and went back to using my RPI3 for this.
Also, most of OE developers went to make LibreElec.
So maybe try LibreElec? I've seen some image floating around this forum. Maybe there will be more support...
Indigo
 
Posts: 3
Joined: Wed Feb 17, 2016 4:03 am
languages_spoken: english;french
ODROIDs: ODROID XU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby AeFFe » Tue Sep 27, 2016 9:05 pm

I have an oDroid U2/emmc card, not an RPI3. Does LibreElec run over oDroid U2/emmc?

I agree, It is very disappointing to have nor positive neither negative answers.

Aeffe
AeFFe
 
Posts: 239
Joined: Wed May 08, 2013 5:05 pm
languages_spoken: english
ODROIDs: oDroid-U2

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby zefor » Fri Oct 14, 2016 8:45 am

Does anybody know how i can build libreelec 7.0.2 from the "ENTIRE BIN" link for the XU3? I was going to use the instructions from first page but alas, no project folder.
zefor
 
Posts: 51
Joined: Mon Dec 29, 2014 9:45 pm
languages_spoken: english
ODROIDs: Odroid-xu3 lite
3 Odroid-XU4's

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby fidel74 » Thu Nov 03, 2016 7:06 pm

any chance to see jarvis on U3?
fidel74
 
Posts: 4
Joined: Wed Dec 31, 2014 2:06 am
languages_spoken: english
ODROIDs: Odroid U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby shano » Fri Feb 10, 2017 6:41 pm

I'm going to OpenELEC 6.0.2.0 on my U3
Can anyone confirm if CEC will work with it?
shano
 
Posts: 6
Joined: Mon Jun 30, 2014 8:00 pm
Location: Ireland
languages_spoken: English, Irish
ODROIDs: U3 - Squeezebox / LMS

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby cy1clown » Thu Mar 02, 2017 2:42 am

For those trying to use this on the XU4 with an eMMC. My eMMC did not work out of the box. I found out that if you start with the 5.8.0.0 image and then upgrade one step at a time you can get 6.0.2.0 working. Just got this running so have not checked to see if everything is working or not but looks good.

Will there be any upgrades for this?

Thanks
Jon
cy1clown
 
Posts: 67
Joined: Sat Dec 28, 2013 6:38 am
languages_spoken: English

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby NickDG » Wed Mar 15, 2017 3:41 am

cy1clown wrote:For those trying to use this on the XU4 with an eMMC. My eMMC did not work out of the box. I found out that if you start with the 5.8.0.0 image and then upgrade one step at a time you can get 6.0.2.0 working. Just got this running so have not checked to see if everything is working or not but looks good.

Will there be any upgrades for this?

Thanks
Jon


Hi Jon,

can you confirm everything is working, on your XU4 via EMMC, also when you say upgrading every step, did you upgrade to every single upgrade in the below order ?

OpenELEC 5.95.5.0
OpenELEC 6.0.0.0
OpenELEC 6.0.1.0
OpenELEC 6.0.2.0
NickDG
 
Posts: 25
Joined: Sat Apr 11, 2015 12:04 am
languages_spoken: english
ODROIDs: ODROIDXU3
ODROIDXU4

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby hansan » Mon Mar 20, 2017 6:55 am

Just to let you know. I think that I know why some Openelec versions are working on SD and not on the eMMC. The boot process on the eMMC is happening form a special boot "block/partition". That means that when you write the openelec image you are actually not updating the u-boot version. This can give issues when the new image does use a feature of a newer u-boot. Like a different boot.ini identifier or kernel image type etc.

What worked for me is (mis)using an emmc recovery image to write the newer u-boot to the boot partition of the emmc.
And recovery image can be found here http://odroid.com/dokuwiki/doku.php?id=en:emmc_recovery or with a search on the forum http://forum.odroid.com/viewtopic.php?f=53&t=969
Then compile Openelec from source. (Not strictly needed only the u-boot package and the hk-bootloader package are mandatory).
The needed files are:
Code: Select all
hansan@Desk-computer:~$ ls build.OpenELEC-Odroid.U2.arm-6.0.2/image/system/usr/share/bootloader/
bl1  bl2  tzsw  u-boot  update.sh

These have to be copied with a .bin extension to the recovery image on the sd card to get this:
Code: Select all
hansan@Desk-computer:~$ ls -l /media/hansan/48E0-7CDF/*
-rw-r--r-- 1 hansan hansan 2701 Jun 28  2014 /media/hansan/48E0-7CDF/boot.ini

/media/hansan/48E0-7CDF/update:
total 662
-rw-r--r-- 1 hansan hansan  15360 Mär 18 12:37 bl1.bin
-rw-r--r-- 1 hansan hansan  14592 Mär 18 12:37 bl2.bin
-rw-r--r-- 1 hansan hansan   1392 Jun 28  2014 sd_fusing.sh
-rw-r--r-- 1 hansan hansan 159744 Mär 18 12:37 tzsw.bin
-rw-r--r-- 1 hansan hansan 478121 Mär 18 12:37 u-boot.bin
-rw-r--r-- 1 hansan hansan   2105 Mär 18 12:37 update.sh

Follow the instruction of the recovery image to update the bootloader for the eMMC. And next write the openelec image to the eMMC. This resulted for me in a working combination.
hansan
 
Posts: 2
Joined: Fri Jan 03, 2014 6:47 am
languages_spoken: English, Dutch, German, Japanese
ODROIDs: ODROID-U3

Re: OpenELEC for Odroid-U2/U3/XU3/C1

Unread postby deterboy » Thu Mar 30, 2017 7:06 pm

hello,
first thank you for all. i have a xu3
i see you have posted on this site http://freeweb.mine.nu/zalaare/OpenELEC/ an openelec 7
but it's impossible for me to launch it. it doesn't work.
openelec 6.0.2 works but not the openelec 7 . Is it normal ?

i have also try on a multiboot image, a obtain a message Error, it can't found "INITRD"
deterboy
 
Posts: 1
Joined: Thu Mar 30, 2017 6:57 pm
languages_spoken: english
ODROIDs: xu3

PreviousNext

Return to Other OS

Who is online

Users browsing this forum: No registered users and 1 guest