How to disable CPU boot/shutdown kernel messages?

Moderators: mdrjr, odroid

How to disable CPU boot/shutdown kernel messages?

Unread postby Panzerknacker » Tue May 27, 2014 9:26 pm

How can I disable these kernel messages:
They clutter my dmesg.

Code: Select all
[96124.268389] CPU2: Booted secondary processor
[96125.175963] CPU2: shutdown
[96175.973256] CPU2: Booted secondary processor
[96176.876194] CPU2: shutdown


I am running latest 3.8.13.23 with some additional modules compiled on U3 itself with ondemand governor.

Code: Select all
root@odroidu3:/usr/src/linux# uname -a
Linux odroidu3 3.8.13.23 #34 SMP PREEMPT Mon May 26 10:52:30 CEST 2014 armv7l GNU/Linux
User avatar
Panzerknacker
 
Posts: 239
Joined: Sat Feb 22, 2014 10:08 pm
languages_spoken: German, English
ODROIDs: U3, X, XU, XU3, XU4, W

Re: How to disable CPU boot/shutdown kernel messages?

Unread postby mdrjr » Tue May 27, 2014 9:31 pm

Two options...

Either you disable the CPU DVFS on the kernel
or
edit arch/arm/kernel/smp.c and comment those messages.
mdrjr
Site Admin
 
Posts: 11690
Joined: Fri Feb 22, 2013 11:34 pm
Location: Brazil
languages_spoken: english, portuguese
ODROIDs: -

Re: How to disable CPU boot/shutdown kernel messages?

Unread postby Panzerknacker » Tue May 27, 2014 9:54 pm

mdrjr wrote:Two options...

edit arch/arm/kernel/smp.c and comment those messages.


Code: Select all
printk(KERN_NOTICE "CPU%u: shutdown\n", cpu);


Is it possible to suppress KERN_NOTICE messages in general within kernel.config?
User avatar
Panzerknacker
 
Posts: 239
Joined: Sat Feb 22, 2014 10:08 pm
languages_spoken: German, English
ODROIDs: U3, X, XU, XU3, XU4, W

Re: How to disable CPU boot/shutdown kernel messages?

Unread postby mdrjr » Tue May 27, 2014 9:58 pm

mdrjr
Site Admin
 
Posts: 11690
Joined: Fri Feb 22, 2013 11:34 pm
Location: Brazil
languages_spoken: english, portuguese
ODROIDs: -

Re: How to disable CPU boot/shutdown kernel messages?

Unread postby Panzerknacker » Tue May 27, 2014 10:21 pm

Thanks!
User avatar
Panzerknacker
 
Posts: 239
Joined: Sat Feb 22, 2014 10:08 pm
languages_spoken: German, English
ODROIDs: U3, X, XU, XU3, XU4, W

Re: How to disable CPU boot/shutdown kernel messages?

Unread postby elemental » Wed Oct 12, 2016 11:01 pm

This is what helped me. The sysctl levels did not work:

https://www.ahsanscorner.com/content/20 ... e-messages

The content for convenience is:
My Odroid servers "kern.log" is basically swamped with these messages "Booted secondary processor" and "shutdown" that occur at every minute. Tried tweaking the "/etc/sysctl.conf" specifically the kernel.printk line to say "kernel.printk = 3 3 1 3". 3 is supposed to be error level but still these notice messages seemed to get printed some how.

Finally this is what got rid of them by drastic measures.

Create a new file called "10-kernel.conf" under "/etc/rsyslog.d" directory and copy the following contents into it and restart rsyslogd via the command "systemctl restart rsyslog.service"

if ( $syslogtag contains 'kernel:' and ($msg contains 'Booted secondary processor' or ( ($msg contains 'CPU1' or $msg contains 'CPU2' or $msg contains 'CPU3' or $msg contains 'CPU4' ) and ($msg contains 'shutdown') ) ) then ~

The above will filter out these message and they won't no longer appear in your logs.
elemental
 
Posts: 83
Joined: Mon Apr 22, 2013 7:54 pm
languages_spoken: english
ODROIDs: Odroid U2 running on micro-sd


Return to Other OS

Who is online

Users browsing this forum: No registered users and 1 guest