CM-11.0 for U3 2014-08-18 Alpha 0.4

Moderators: odroid, mdrjr


Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby bluc » Tue Aug 12, 2014 11:45 am

Sorted out my Bluetooth my usb hub seems to only be patially working not the Bluetooth dongle after all. My gps and flash drive work fine but Bluetooth and mouse via the hub don't work weird. Was working fine two days ago with all devices plugged in.

Sent from my To Be Filled By O.E.M. using Tapatalk
bluc
 
Posts: 93
Joined: Sun Apr 28, 2013 2:24 pm
languages_spoken: english

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby nrgizer79 » Tue Aug 12, 2014 4:20 pm

Hello all!
I tryed this image:
1. Bluetooth work
2. Wifi work
3. GPS work
4. Chalkboard 7" open frame (id 04d8:f724) - multitouch not work
5. Kernel version 3.0.51 - not 3.4.5

dmesg:
Code: Select all
<6>[ 1695.030233] usb 1-3.2: new full speed USB device number 12 using s5p-ehci
<6>[ 1695.143445] input: Chalkboard Electronics HID Multi-touch as /devices/platform/s5p-ehci/usb1/1-3/1-3.2/1-3.2:1.0/input/input4
<6>[ 1695.149471] generic-usb 0003:04D8:F724.0003: input: USB HID v1.12 Device [Chalkboard Electronics HID Multi-touch] on usb-s5p-ehci-3.2/input0


logcat:
Code: Select all
08-12 11:30:16.427 I/EventHub( 1794): Removing device Chalkboard Electronics HID Multi-touch due to epoll hang-up event.
08-12 11:30:16.427 I/EventHub( 1794): Removed device: path=/dev/input/event2 name=Chalkboard Electronics HID Multi-touch id=2 fd=95 classes=0x80000004
08-12 11:30:16.492 I/EventHub( 1794): Removing device '/dev/input/event2' due to inotify event
08-12 11:30:16.492 I/InputReader( 1794): Device removed: id=2, name='Chalkboard Electronics HID Multi-touch', sources=0x00006002
08-12 11:30:18.812 D/KitKat_RIL_RK_V3.1( 1391): onUnsolicited <<<<<<<<<<<<<<<<< ^RSSI:12
08-12 11:30:22.127 D/EventHub( 1794): No input device configuration file found for device 'Chalkboard Electronics HID Multi-touch'.
08-12 11:30:22.127 I/EventHub( 1794): New device: id=5, fd=173, path='/dev/input/event2', name='Chalkboard Electronics HID Multi-touch', classes=0x80000004, configuration='', keyLayout='', keyCharacterMap='', builtinKeyboard=false, usingSuspendBlockIoctl=false, usingClockIoctl=false
08-12 11:30:22.127 I/InputReader( 1794): Device reconfigured: id=5, name='Chalkboard Electronics HID Multi-touch', size 1280x720, orientation 0, mode 4, display id 0
08-12 11:30:22.127 I/InputReader( 1794): Device added: id=5, name='Chalkboard Electronics HID Multi-touch', sources=0x00006002
08-12 11:30:22.137 W/ContextImpl( 1794): Calling a method in the system process without a qualified user: android.app.ContextImpl.sendBroadcast:1187 com.android.server.usb.UsbSettingsManager.deviceAttached:621 com.android.server.usb.UsbHostManager.usbDeviceAdded:156 com.android.server.usb.UsbHostManager.monitorUsbHostBus:-2 com.android.server.usb.UsbHostManager.access$000:38


P.S.: i compile kernel for multitoach with original ODROID source, it worked.
nrgizer79
 
Posts: 40
Joined: Wed May 07, 2014 7:50 pm
languages_spoken: english, russian
ODROIDs: ODROID U3 + 8Gb emmc

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby voodik » Wed Aug 13, 2014 6:58 pm

5. Kernel version 3.0.51 - not 3.4.5
Sorry my mistake, i copy pasted all from XU thread :oops:

All people who have chalks screen, after updating firmware to 1.6 USB vid/pid changed to 0eef:7200, you need compile custom kernel with new vid/pids.
Unfortunately i am bisy for 1-2 days, after that I release new build with lot of fixes end enhancements.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby nrgizer79 » Wed Aug 13, 2014 7:55 pm

I did not update the firmware to 1.6.
Chalkboard 7" open frame (id 04d8:f724), firmware 1.5
Not work.
nrgizer79
 
Posts: 40
Joined: Wed May 07, 2014 7:50 pm
languages_spoken: english, russian
ODROIDs: ODROID U3 + 8Gb emmc

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby voodik » Wed Aug 13, 2014 7:59 pm

nrgizer79 wrote:I did not update the firmware to 1.6.
Chalkboard 7" open frame (id 04d8:f724), firmware 1.5
Not work.

Please sometimes read the thread, i add 1.5/1.6 vid/pid in next build ..
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby stadros83 » Wed Aug 13, 2014 9:16 pm

When we install a new build, do you think it's better to make a factory reset ?
stadros83
 
Posts: 87
Joined: Tue Apr 08, 2014 1:42 am
languages_spoken: english/french

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby Mugga » Wed Aug 13, 2014 10:14 pm

stadros83 wrote:When we install a new build, do you think it's better to make a factory reset ?


Therefor you check the box "format userdata" when installing the update, like voodik already mentioned on the second page.
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby justice » Fri Aug 15, 2014 4:30 pm

I seem to be having trouble setting it to 1080 through the Odroid Utility. Am I missing something? Sorry if it's a dumb question.
justice
 
Posts: 58
Joined: Thu Mar 07, 2013 5:58 am
languages_spoken: english
ODROIDs: Odroid U2, Odroid U3, Odroid XU Lite, ODroid C1

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby bluc » Sat Aug 16, 2014 9:30 am

justice wrote:I seem to be having trouble setting it to 1080 through the Odroid Utility. Am I missing something? Sorry if it's a dumb question.


Did you tick the two boxes resolution "1920x1080" and "hdmi phy" 1080p then click on apply and then apply and reboot up the top?

Sent from my To Be Filled By O.E.M. using Tapatalk

Sent from my To Be Filled By O.E.M. using Tapatalk
bluc
 
Posts: 93
Joined: Sun Apr 28, 2013 2:24 pm
languages_spoken: english

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby spcano01 » Sun Aug 17, 2014 8:57 am

Only installed xbmc 13.2 rc1 and gapps, and it seems that the longer it goes without reboot, it starts skipping and just operating very slowly. Twice, went to a full green screen. Only way to solve both slowdown and green screen was reboot. After fresh boot, runs awesome.

Anyone else seeing this? Again after days of uptime and probably paused for majority of time.
spcano01
 
Posts: 70
Joined: Wed Jan 08, 2014 2:17 am
languages_spoken: english
ODROIDs: XU-Lite

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby bluc » Sun Aug 17, 2014 9:42 am

When streaming audio to a bluetooth speaker if I skip songs I get a lot of audio distortion any ideas?
bluc
 
Posts: 93
Joined: Sun Apr 28, 2013 2:24 pm
languages_spoken: english

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby jgg » Sun Aug 17, 2014 1:44 pm

voodik wrote:Doglio92
yes, open updater, click "Get the last version" > Continue > paste CM-11 url
Code: Select all
http://oph.mdrjr.net/voodik/4412/Android/08-08-2014/ODROID-U/update.zip

click download > validate> extract > check format userdata > restart for update


Hi,

can you provide a full install version, please? For unknown reasons, ODROID UPDATE Utility never work for me. After the restart, it always fails. The blue led is blinking but I see no signal from HDMI. On the first restart, I waited for at least 20mins before I do power down and power on. Repeated a few times but still the same. Blue led blinking but no HDMI signal. The same thing also happened when I tried to use Odroid image update. End up I always have to download the full image and install.

Thank you.
jgg
 
Posts: 11
Joined: Fri Dec 27, 2013 11:12 am
languages_spoken: english

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby odroid » Mon Aug 18, 2014 1:47 am

Install this latest official image first.
http://dn.odroid.com/4412/Android/4.4.4 ... /ODROID-U/

And follow below instuction.
1. Run the ODROID Updater and press "Get the latest version" button.
2. Type the URL in the first post(OP) in this thread.
3. Press "Download" button (It takes long time to complete the download)
4. Press "Validate file" button
5. Press "Extract" button (It takes long time to complete the extraction)
6. Check "Format userdata"
7. Press "Restart for Update" button (It takes long time to complete the first booting)

Do you use eMMC? or SD?
User avatar
odroid
Site Admin
 
Posts: 29098
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby errorflash » Mon Aug 18, 2014 5:23 pm

WOW!

Look & Feel is fantastic from Cyanogen Mod.

My Wlan does'nt work and the Touchscreen too. (http://www.ebay.de/itm/360645237951 and http://www.ebay.de/itm/360704931255)

Can anybody publish a manual for add a functional GPS Modul /Stick / USB Device in Cyanogenmod?
errorflash
 
Posts: 5
Joined: Wed Jun 18, 2014 3:05 am
languages_spoken: english, german
ODROIDs: U3

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby nrgizer79 » Mon Aug 18, 2014 6:05 pm

Hi!

voodik wrote:
nrgizer79 wrote:I did not update the firmware to 1.6.
Chalkboard 7" open frame (id 04d8:f724), firmware 1.5
Not work.

Please sometimes read the thread, i add 1.5/1.6 vid/pid in next build ..

When you present us a new build ?
If you have not time, may be you can give a source files ?
nrgizer79
 
Posts: 40
Joined: Wed May 07, 2014 7:50 pm
languages_spoken: english, russian
ODROIDs: ODROID U3 + 8Gb emmc

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby voodik » Mon Aug 18, 2014 7:42 pm

nrgizer79 wrote:Hi!

voodik wrote:
nrgizer79 wrote:I did not update the firmware to 1.6.
Chalkboard 7" open frame (id 04d8:f724), firmware 1.5
Not work.

Please sometimes read the thread, i add 1.5/1.6 vid/pid in next build ..

When you present us a new build ?
If you have not time, may be you can give a source files ?


Today ;)
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby jgg » Mon Aug 18, 2014 9:27 pm

odroid wrote:Install this latest official image first.
http://dn.odroid.com/4412/Android/4.4.4 ... /ODROID-U/

And follow below instuction.
1. Run the ODROID Updater and press "Get the latest version" button.
2. Type the URL in the first post(OP) in this thread.
3. Press "Download" button (It takes long time to complete the download)
4. Press "Validate file" button
5. Press "Extract" button (It takes long time to complete the extraction)
6. Check "Format userdata"
7. Press "Restart for Update" button (It takes long time to complete the first booting)

Do you use eMMC? or SD?


I'm using SD and it's working now! Thanks!
jgg
 
Posts: 11
Joined: Fri Dec 27, 2013 11:12 am
languages_spoken: english

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby voodik » Tue Aug 19, 2014 7:41 am

:idea:

Kernel: add SELinux
Kernel: added Calk-Elec vid/pid to hid module
Kernel: add Easycap module (edit init.odroidu.rc to load automatically)
Camera Hal: added properties ro.hardkernel.camera.width and ro.hardkernel.camera.height (for Easycap set them to 640 480)
Audio Hal: fix wrong sample rate with Easycap connected
Android: Removed safe headset volume warning.
Vold: added auto-detect Emmc/Sdcard boot
Wifi: added WiFi 148f:5370 support (Not tested, maybe doesn't work because this build is using Realtek nl80211 private lib)
Wifi: added Realtek pid 817a
Wifi: fixed Wi-Fi hotspot.
Libril: libril-rk29-dataonly updated to new version (3.3) maybe some fixes and new modems support added.

After flash disable Battery status from settings
Settings>Status bar>Battery status style>Hidden
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby Mugga » Tue Aug 19, 2014 9:32 am

Thx for the new build.
Just did a fresh install with the new Alpha build.

-USB DAC is now working, even with input. Soundquality isn't that good, and mic input via dac got very poor quality. Also the sound is accelerated when playing via the dac. Hearing music via the headphone jack got normal playback speed. But this behaviour is also in the offical 4.4.4 version
-wifi 148f:5370 isn't working
-surfaceslinger bug seems gone (http://forum.odroid.com/viewtopic.php?f=78&t=6088#p48793)
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby spcano01 » Tue Aug 19, 2014 12:18 pm

Is anyone using this image and playing video either via MX or XBMC? I have the initial on 2 different U3s, one using XBMC and the other using MX Player. Both start fanstastically, but then gradually slow down to unusable. The first one seems to take a couple of days, but this one using MXPlayer happens by the end of a video. Any ideas? Going to update, and see if it fixes it with the MX Player one. Either way, amazing image and work!!!
spcano01
 
Posts: 70
Joined: Wed Jan 08, 2014 2:17 am
languages_spoken: english
ODROIDs: XU-Lite

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby odroid » Tue Aug 19, 2014 12:30 pm

spcano01 wrote:Is anyone using this image and playing video either via MX or XBMC? I have the initial on 2 different U3s, one using XBMC and the other using MX Player. Both start fanstastically, but then gradually slow down to unusable. The first one seems to take a couple of days, but this one using MXPlayer happens by the end of a video. Any ideas? Going to update, and see if it fixes it with the MX Player one. Either way, amazing image and work!!!

It is worth to try the CPU performance governor mode via ODROID-Utility.
User avatar
odroid
Site Admin
 
Posts: 29098
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby spcano01 » Tue Aug 19, 2014 2:21 pm

I did that, among a few other items. The performance menu under settings seem to help. Maybe a memory leak - as the purge memory seemed to keep it going strong for over 30 min now.
spcano01
 
Posts: 70
Joined: Wed Jan 08, 2014 2:17 am
languages_spoken: english
ODROIDs: XU-Lite

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby odroid » Tue Aug 19, 2014 5:04 pm

Another possible root cause could be the thermal throttling by heavy CPU load if you don't use the cooling fan.
User avatar
odroid
Site Admin
 
Posts: 29098
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby voodik » Wed Aug 20, 2014 1:22 am

wifi 148f:5370 isn't working


I forgot to add rt5370sta.cal to /system/etc/firmware/

Could you try wifi with this file ?

https://github.com/voodik/android_devic ... 370sta.cal
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby Mugga » Wed Aug 20, 2014 2:29 am

voodik wrote:
wifi 148f:5370 isn't working


I forgot to add rt5370sta.cal to /system/etc/firmware/

Could you try wifi with this file ?

https://github.com/voodik/android_devic ... 370sta.cal


Tried it, but doesn't work for me. But maybe I got the wrong permissions. Even tough the firmware folder wasn't there, I had to create it.
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: CM-11.0 for U3 2014-08-08 Alpha 0.0001

Unread postby Doglio92 » Wed Aug 20, 2014 2:35 am

voodik wrote:
Not Working:
- WiFi USB ALLNET ALL0234NanoV2 [148f:5370]


1. Wifi will be fixed in next build.


Hi, wonderfull release!!!

However my wifi doesn't work yet.

Do you nedd some information to get work it?
Doglio92
 
Posts: 29
Joined: Thu Apr 17, 2014 8:07 pm
languages_spoken: Italian
ODROIDs: U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby voodik » Wed Aug 20, 2014 2:38 am

Can you post logcat dmesg lsmod output to pastebin.com ?
please restart board, try to enable wifi after that post logs.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby Mugga » Wed Aug 20, 2014 4:11 am

voodik wrote:Can you post logcat dmesg lsmod output to pastebin.com ?
please restart board, try to enable wifi after that post logs.

Not sure if it was meant for me but anyway:
Logcat:
http://pastebin.com/wr3ff0Hd
dmesg&lsusb
http://pastebin.com/5K7K2wVE
Last edited by Mugga on Wed Aug 20, 2014 4:46 am, edited 1 time in total.
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby voodik » Wed Aug 20, 2014 4:27 am

Found it :) i build libhardware_legcay from wrong repo ))) And its not load Ralink module. Compilling ))
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby bluc » Wed Aug 20, 2014 8:34 am

How do I capture a log im getting lots of micro freezing on u2 with latest build. Device freezes for a couple of seconds at a time.
bluc
 
Posts: 93
Joined: Sun Apr 28, 2013 2:24 pm
languages_spoken: english

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby Doglio92 » Wed Aug 20, 2014 4:24 pm

voodik wrote:Can you post logcat dmesg lsmod output to pastebin.com ?
please restart board, try to enable wifi after that post logs.


logcat
http://pastebin.com/5vZ8SHt8

dmesg
http://pastebin.com/cegu3tV6

lsmod
http://pastebin.com/yM2bmscA
Doglio92
 
Posts: 29
Joined: Thu Apr 17, 2014 8:07 pm
languages_spoken: Italian
ODROIDs: U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby stadros83 » Wed Aug 20, 2014 4:37 pm

Thanks for this new Rom !

So I've tested my devices and :

My touchscreen is working well !!
Wifi is working well !!
Bluetooth also (after a reboot, don't know why).
GPS also.
3G Dongle aslo (Huawei E173).

But I have the same issue as the previous build : sometimes when I start my ODROID the fan is running but nothing shows up on the screen. I don't even have the "cyanogen" logo.
I need to stop the ODROID and start it again.


So it's nearly perfect :) !
stadros83
 
Posts: 87
Joined: Tue Apr 08, 2014 1:42 am
languages_spoken: english/french

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby stadros83 » Wed Aug 20, 2014 6:47 pm

I also try to run Antutu to check this and it stops before the end (around 87%).
And the score is only of 16800 (but I think that's because it crashes).

With Quadrant the result is around 6100.

Can someone test it and tell me if he has the same results ?
stadros83
 
Posts: 87
Joined: Tue Apr 08, 2014 1:42 am
languages_spoken: english/french

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby voodik » Wed Aug 20, 2014 9:54 pm

stadros83 wrote:Thanks for this new Rom !

But I have the same issue as the previous build : sometimes when I start my ODROID the fan is running but nothing shows up on the screen. I don't even have the "cyanogen" logo.
I need to stop the ODROID and start it again.

So it's nearly perfect :) !


Maybe kernel panic occurred, you can only see it with usb-uart connected.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby stadros83 » Wed Aug 20, 2014 11:29 pm

Well I have a USB UART but I don't know how to use it to search for this "kernel panic" :lol: .
stadros83
 
Posts: 87
Joined: Tue Apr 08, 2014 1:42 am
languages_spoken: english/french

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby Mugga » Thu Aug 21, 2014 7:11 am

voodik wrote:Found it :) i build libhardware_legcay from wrong repo ))) And its not load Ralink module. Compilling ))

Great! Can't wait to test it. Are compiling a whole new rom version?

By the way, the green screen issue in the first alpha is also gone with the new version, keep up the good work. :D
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby vesyoliy » Fri Aug 22, 2014 2:23 pm

Hello. How Skype works in this CM?
vesyoliy
 
Posts: 31
Joined: Wed Mar 19, 2014 2:48 pm
languages_spoken: english
ODROIDs: U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0002

Unread postby bluc » Sun Aug 24, 2014 11:31 am

Bluetooth streaming fails after about 5 minutes I didnt edit my bluetooth details it "just worked" do I need to edit the bluetooth id etc as mentioned in first post
Code: Select all
Edit last line in /system/ueventd.odroidu.rc
/dev/bus/usb/001/005      0660    bluetooth bluetooth
change USB bus and device id according your device

to get reliable bluetooth?

EDIT: anyone else able to try streaming music to a Bluetooth headset to see if the audio stops after 5-10 minutes so I can rule out a faulty Bluetooth dongle?
bluc
 
Posts: 93
Joined: Sun Apr 28, 2013 2:24 pm
languages_spoken: english

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby voodik » Fri Aug 29, 2014 4:25 am

Update :idea:

For RT5370 Wifi add to build.
Code: Select all
ro.hardkernel.wifi2=true
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby Mugga » Fri Aug 29, 2014 7:40 am

voodik wrote:Update :idea:

For RT5370 Wifi add to build.
Code: Select all
ro.hardkernel.wifi2=true


Thx for the update. Wifi is finally working with the mentioned modification to the build.prop. WPS is also working in your release, in the official release it doesn't work. But the bluetooth is now broken. In the last built and the first, bluetooth was working out of the box. I then tried adding the proper id and bus to the ueventd.odroidu.rc, but it doesn't work. My bluetooth dongle is creating 4 devices: 0a5c:4500, 0a5c:4502, 0a5c:4503, 0a5c:2148. I tried every combination of the id, but nothing.

Logcat:
http://pastebin.com/UmvuWQf7

USB-DAC playback speed is now like it should be. Recording quality is still pretty bad. One last issue I couldn't fix no matter which version I'm using, is using Sygic. Maybe you've seen the thread, he just says that there is no internet connection, eventough there is. Maybe you got a hint what to do.
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

trying 2014-08-28

Unread postby nate.sewell » Fri Aug 29, 2014 10:20 am

looking forward to trying alpha 3, to see if my asus bt400 bluetooth 4.0 dongle is supported now
nate.sewell
 
Posts: 8
Joined: Sun Jul 27, 2014 5:59 am
languages_spoken: english
ODROIDs: U3 rev0.5

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby Mugga » Fri Aug 29, 2014 9:37 pm

I just tried another old sitecom bluetooth dongle I've got, and this one works out of the box. Finally Sygic is working, I don't know why it was suddenly working, but I'm happy. For me the only issues that would make it perfect, are getting a clear microphone input, via headphone jack or usb-dac. And maybe to get my external keyboard/mouse working: http://www.amazon.de/Perixx-PERIPAD-701-Touchpad-Tastatur-Beleuchtung/dp/B005OYCB6I. I will post a dmesg later.
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby Killer Turtle » Sat Aug 30, 2014 12:08 am

Mugga wrote:I just tried another old sitecom bluetooth dongle I've got, and this one works out of the box. Finally Sygic is working, I don't know why it was suddenly working, but I'm happy. For me the only issues that would make it perfect, are getting a clear microphone input, via headphone jack or usb-dac. And maybe to get my external keyboard/mouse working: http://www.amazon.de/Perixx-PERIPAD-701-Touchpad-Tastatur-Beleuchtung/dp/B005OYCB6I. I will post a dmesg later.



Glad to hear sygic is working. I sent you a PM on the keyboard, as it sounds like a problem I came across as well.
Killer Turtle
 
Posts: 156
Joined: Fri Feb 21, 2014 10:17 am
languages_spoken: english
ODROIDs: U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby voodik » Sat Aug 30, 2014 9:11 am

Mugga wrote:I just tried another old sitecom bluetooth dongle I've got, and this one works out of the box. Finally Sygic is working, I don't know why it was suddenly working, but I'm happy. For me the only issues that would make it perfect, are getting a clear microphone input, via headphone jack or usb-dac. And maybe to get my external keyboard/mouse working: http://www.amazon.de/Perixx-PERIPAD-701-Touchpad-Tastatur-Beleuchtung/dp/B005OYCB6I. I will post a dmesg later.

Could you try headphone jack microphone with this kernel ?
http://oph.mdrjr.net/voodik/4412/temp/zImage
I tested it with SGS3 headphones ;)

About DAC, i receive my dac at end of September, after that i start to work on DAC support.
p.s.

Thanks for all donations, using them I bought USB DAC for development :)
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby Mugga » Sat Aug 30, 2014 11:03 pm

voodik wrote:
Mugga wrote:I just tried another old sitecom bluetooth dongle I've got, and this one works out of the box. Finally Sygic is working, I don't know why it was suddenly working, but I'm happy. For me the only issues that would make it perfect, are getting a clear microphone input, via headphone jack or usb-dac. And maybe to get my external keyboard/mouse working: http://www.amazon.de/Perixx-PERIPAD-701-Touchpad-Tastatur-Beleuchtung/dp/B005OYCB6I. I will post a dmesg later.

Could you try headphone jack microphone with this kernel ?
http://oph.mdrjr.net/voodik/4412/temp/zImage
I tested it with SGS3 headphones ;)

About DAC, i receive my dac at end of September, after that i start to work on DAC support.
p.s.

Thanks for all donations, using them I bought USB DAC for development :)


Yeah, great! The heavy noise even with no microphone attached is gone with this kernel and sound quality is good enough for doing voice commands. Now If it is possible, it would be great if you can do usb-dac output and headphone jack input. Now only one is working at a time.
Hardware:
Odroid U3 @ CM-11.0 for U3 2014-08-18 Alpha 0.0003
Mugga
 
Posts: 69
Joined: Thu Jul 31, 2014 7:45 pm
languages_spoken: english
ODROIDs: ODROID U3

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby voodik » Sat Aug 30, 2014 11:47 pm

Mugga wrote:Yeah, great! The heavy noise even with no microphone attached is gone with this kernel and sound quality is good enough for doing voice commands. Now If it is possible, it would be great if you can do usb-dac output and headphone jack input. Now only one is working at a time.


About DAC, i receive my dac at end of September, after that i start to work on DAC support.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io
User avatar
voodik
 
Posts: 1419
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby bluc » Sun Aug 31, 2014 9:05 am

voodik do you have any Bluetooth issues streaming audio to a headset or Bluetooth speaker etc? Trying to work out if software or hardware. causing my issue

Anyone else getting green screen on boot have been getting it heaps on this build and on the official image.
EDIT: just bought an official Bluetooth dongle see if that solves the issue with the Bluetooth.
bluc
 
Posts: 93
Joined: Sun Apr 28, 2013 2:24 pm
languages_spoken: english

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby dirtyrobinson » Thu Sep 04, 2014 3:38 pm

I wanted try CM and see if I get better results with it over the stock android 4.4 but I'm having serious issues with the update process. Granted I'm having the same issue regardless of what version I update to but I'm not 100% I'm clear on how to install CM on the U3. Do I have to build this version of CM to install it or can I just update the odroid version?

I initially installed the official Android 4.4.2 image and then updated it to the latest but after updating it restarted, did something for a few minutes then restarted and then I'm left with a blinking heartbeat and a no signal screen. This is the same for updating the official image 4.4.4 alpha v2 as mentioned on page 2 (from Doglio92) of this thread and then immediately updated with voodik's update again mentioned in the same reply on page 2. Again, it restarted and left me with a heartbeat. I waited an hour hoping it was still doing something but it apparently wasn't.

I apologize if I'm missing directions in this thread but can you verify how to install CM 11 on Odroid U3? I downloaded http://www.odroid.in/mirror/dn.odroid.c ... er.img.zip wrote the image using win32diskimager and from here I booted Android and immediately went to the updater, downloaded http://oph.mdrjr.net/voodik/4412/Androi ... update.zip I then validated the file and then clicked restart (not dd). From here it immediately restarted, did something for about 5 minutes, restarted, then the fan turned on and the blue light went to a dim blinking heartbeat indefinitely. Now I can't boot anything and am forced to have to start over. I tried this 3 times with the same results each time.

I appreciate any help, if this isn't an issue related to CM 11 update then I apologize for inserting this issue and will make a new thread.

Edit: I'm gonna leave this here for now but after going through the thread again, I some how skipped a page and saw someone had the same problem on page 4. I'm gonna try your posted solution to his response and then edit this post accordingly.
dirtyrobinson
 
Posts: 36
Joined: Sun Jan 19, 2014 8:49 am
languages_spoken: english
ODROIDs: Odroid U3 & C1

Re: CM-11.0 for U3 2014-08-18 Alpha 0.0003

Unread postby bluc » Thu Sep 04, 2014 6:50 pm

How long you letting it sit after flashing? Takes a few minutes to boot.

Sent from my TF600T using Tapatalk
bluc
 
Posts: 93
Joined: Sun Apr 28, 2013 2:24 pm
languages_spoken: english

PreviousNext

Return to Android

Who is online

Users browsing this forum: No registered users and 3 guests