RS232/RS485 Converter Circuit Receiving Problem

Moderators: odroid, mdrjr

RS232/RS485 Converter Circuit Receiving Problem

Unread postby candylily19 » Wed Jul 20, 2016 12:23 pm

Hi,
I'm trying to make an RS232/RS485 converter circuit. I used a circuit from http://airborn.com.au/layout/232cnv/232to485.html and i changed some components on that circuit. Then i established my converter circuit that i linked the scheme.
I used copper pour as ground and i connected lacking ground connections with additional wires after the board was prepared. To test my circuit, I used another RS232/RS485 converter circuit which I know that is working without a problem. I connected A and B outputs of my circuit's RS485 connector to the A and B outputs of other circuit's connector. Then i connected these two converter circuits to computer with RS232 USB cable. I tested the communication between these circuits using CuteCOM serial communication terminal. I used two terminals for my circuit and other. (Baud Rate:9600)
I observed that data is transmitting from my converter circuit to other but not receiving from other circuit to mine.
I also tested the other converter circuit with another RS232/RS485 converter circuit which I know that is working without a problem, and i realised that there is not any problem during transmitting and recieving process, so data can be sended and recieved.
These are the list of the changes that i made on original scheme in for my converter scheme;
1. Maxim's MAX232CWE was used instead of ICL232.
2. Texas Instruments' SN65HVD3082E was used instead of 75176.
3. As voltage regulator, Exar's SPX3819 was used instead of LM2936Z5.
4. As transistor, BC256A (pnp) was used instead of BC557 (pnp).
5. 22 uF capacitors were used instead of 2.2 uF, for the ones connected to MAX232CWE.
6. On original scheme, a 6 pin connector was used as RS485 connector and two pins were used for A,B connections, one pin was connected for ground, one pin was connected to the 9th pin (RI - Ring Indicator) of the RS232 connector with a jumper. Unlike these, in my circuit, 2 pin connector was used as RS485 connector and only A,B connecitons were made. (RI and ground connections were not used.)
7. On original circuit, A and B pins of SN65HVD3082E which from http://www.kynix.com/Detail/1202429/SN65HVD3082EDGKR.html Transreciever were terminated with a 120 Ohm resistor and a jumper. I did not do this on my circuit.
I'm investigating about the problem which can be related with changes that i made on original circuit or another reason. I will be very happy if you share your idea about the problem of just transmitting and not recieving data on my converter circuit. Best regards.
candylily19
 
Posts: 6
Joined: Tue Jul 19, 2016 6:22 pm
languages_spoken: english

Re: RS232/RS485 Converter Circuit Receiving Problem

Unread postby odroid » Wed Jul 20, 2016 1:36 pm

Do you run the CuteCom on ODROID-U3 Ubuntu?
User avatar
odroid
Site Admin
 
Posts: 29075
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Android

Who is online

Users browsing this forum: No registered users and 2 guests