Ubuntu Server 14.04 LTS for U3 [20140604]

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Thu Jun 05, 2014 10:20 pm

Update server images are now updated to 14.04.

Its a complete new image. (new debootstrap).

This image is a server image.
It's ubuntu-minimal + task server.
Its small and don't have Xorg installed.

Credentials are:
Username: root
Password: odroid

This image also makes obsolete the kernel-update utility and uses the odroid-utility.sh (already installed).

Download URL:
http://odroid.in/ubuntu_14.04lts/


Changelog:
- 20140604 - First release

pws
Posts: 71
Joined: Fri Apr 18, 2014 7:52 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by pws » Fri Jun 06, 2014 2:28 am

Thank you.

Any ETA for a Desktop version?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Fri Jun 06, 2014 2:30 am


pws
Posts: 71
Joined: Fri Apr 18, 2014 7:52 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by pws » Fri Jun 06, 2014 2:42 am

Really?

The version I downloaded and initially installed required /etc/resolv.conv to be manually edited as it apparently wasn't correctly regenerated, nor could it include your updated odroid-utility, etc. being only recently updated?

Will Memeka's work not be repackaged and redistributed be more consistent with your recent Server and corresponding XU Desktop releases?

It would be seemingly a nice thing to do, if your intent is to make it your official initial 14.04 release.

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Fri Jun 06, 2014 3:53 am

pws wrote:Really?

The version I downloaded and initially installed required /etc/resolv.conv to be manually edited as it apparently wasn't correctly regenerated, nor could it include your updated odroid-utility, etc. being only recently updated?

Will Memeka's work not be repackaged and redistributed be more consistent with your recent Server and corresponding XU Desktop releases?

It would be seemingly a nice thing to do, if your intent is to make it your official initial 14.04 release.
Ouch.. I'm sorry that those issue made such bad impression on you.
I'll make images based on that image for our X/X2 and U series.

pws
Posts: 71
Joined: Fri Apr 18, 2014 7:52 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by pws » Fri Jun 06, 2014 4:44 am

mdrjr wrote: Ouch.. I'm sorry that those issue made such bad impression on you.
I'll make images based on that image for our X/X2 and U series.
It's not that it left me with a bad impression, but rather it surprised me, as there were known issues remaining which should likely be cleaned up if wishing to designate it as the company's official release. Not to mention it would seem like a good thing to do, to simplify future support. (Please accept my apology, I did not mean to imply otherwise.)

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Fri Jun 06, 2014 5:19 am

pws wrote:
mdrjr wrote: Ouch.. I'm sorry that those issue made such bad impression on you.
I'll make images based on that image for our X/X2 and U series.
It's not that it left me with a bad impression, but rather it surprised me, as there were known issues remaining which should likely be cleaned up if wishing to designate it as the company's official release. Not to mention it would seem like a good thing to do, to simplify future support. (Please accept my apology, I did not mean to imply otherwise.)
No need to apologize.

Thats because for me.. those issues are so irrelevant that.. well.. I didn't care.
But seeing what you guys want :)

I'll work on that :)

manuel220
Posts: 5
Joined: Sat Apr 12, 2014 4:45 am
languages_spoken: english spanish
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by manuel220 » Tue Jun 10, 2014 5:30 am

What would be the main difference between this image and the one on this post:

http://forum.odroid.com/viewtopic.php?f=8&t=4613


Thanks.

User avatar
meveric
Posts: 10271
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2
Has thanked: 13 times
Been thanked: 102 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by meveric » Tue Jun 10, 2014 3:02 pm

The image i used was based on linaro but since linaro did not offer 14.04 support back then all parts should be replaced by canonical due to updating process.
All in all they should be similar but not identically.
I don't think it really makes much of a difference, besides the scripts coming from hardkernel.
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

srdz
Posts: 30
Joined: Sat Jun 07, 2014 8:10 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by srdz » Mon Jun 16, 2014 2:19 am

where is topic about this version ?
lubuntu-14.04lts-desktop-armhf-odroidu_20140612

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Mon Jun 16, 2014 2:22 am

srdz wrote:where is topic about this version ?
lubuntu-14.04lts-desktop-armhf-odroidu_20140612
There's on global thread for that :)
http://forum.odroid.com/viewtopic.php?f=29&t=5234

User avatar
DavidTangye
Posts: 57
Joined: Thu May 16, 2013 10:50 pm
languages_spoken: english
ODROIDs: Currently running XU4 as my desktop
Also had a U2, U3, XU3-Lite (it broke), and 10 * C1's in the past.
Location: Gold Coast, Queensland, Australia
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by DavidTangye » Mon Jun 16, 2014 9:21 pm

I am running an installation of public-trusty-dev-center-18052014.img (as per [New Image] Ubuntu 14.04 Trusty Dev Center 18/05/2014 U2/U3 - http://forum.odroid.com/viewtopic.php?f=29&t=4823). It seems to be quite a badly hacked version. Its main problems that I have discovered so far (This is tested on a U2. I have no working U3, so cannot confirm whether these work in them, but as I understand it, the U2 and U3 should work the same for desktop etc functionality):
  • A weird problem in /boot. The key files in there are copied, not linked, which is very odd for any linux installation. 'sudo ln -s ...' does not work in there so its not possible to same space by creating symlinks.
  • Related to the above: upgrading and installing new packages all fail as this partition runs out of room because the kernel and initrd files duplicated.

    Code: Select all

    Setting up initramfs-tools (0.103ubuntu4.2) ...
    update-initramfs: deferring update (trigger activated)
    Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
    ln: failed to create hard link '/boot/initrd.img-3.8.13.18.dpkg-bak' => '/boot/initrd.img-3.8.13.18': Operation not permitted
    update-initramfs: Generating /boot/initrd.img-3.8.13.18
    
    gzip: stdout: No space left on device
    E: mkinitramfs failure cpio 141 gzip 1
    update-initramfs: failed for /boot/initrd.img-3.8.13.18 with 1.
    dpkg: error processing package initramfs-tools (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     initramfs-tools
    E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Logout locks up the ODroid U2. I get t blank screen. to recover, I 'sudo reboot' via ssh from another machine.
  • /etc/resolv.conf is not a link to /run/resolvconf.resolv.conf, so there is no DNS resolution, so ntp fails, so the clock is wrong, etc etc. This is fixable by defining a symlink, just as standard ubuntu has it. The question is though, why is this sort of thing messed around with?
  • Screenshots did not work: To fix this I installed package scrot
  • /etc/hosts did not look right. I changed it to how ubuntu has it -

    Code: Select all

    $ cat /etc/hosts
    127.0.0.1 localhost localhost.localdomain
    127.0.1.1 [name from /etc/hosts]
  • There is no graphic character decoration in Midnight Commander -S darkfar.ini. I have not seen this problem for many years, and I think this might be a termcap issue, or somethign like it where a supporting config directory is removed.
  • It is based on Lubuntu, but does not look like a standard install of ubuntu minimal/base + the Lubuntu 'task'.
  • Why not use Xubuntu task like your 201305 release? The U2, U3 does not need Lubuntu. It handles the extra of Xubuntu easily and Xubuntu gives a better set of desktop configuration utilities etc.
I am not certain of some of the above description, but I hope you get the general idea. Given the above, it looks like standard ubuntu has been badly hacked, so I have no faith in public-trusty-dev-center-18052014.img

Is it possible to just release a non-GUI ubuntu plus whatever replacement packages are needed for your graphics hardware? I think they would be set up as something like 'conflicting, replacement dependent packages' in either a ppa or submitted into the ubuntu repos. Then users should be able to choose whether they want the Ubuntu, Xubuntu or Lubuntu desktop. Otherwise, dont you need to set up your own 'ODroid Desktop' debian 'task' based on / cloned from either the Ubuntu, Xubuntu or Lubuntu desktop?

User avatar
memeka
Posts: 4315
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 1 time
Been thanked: 12 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by memeka » Mon Jun 16, 2014 10:28 pm

Since I created the image, I will answer. Also, this would have been more suitable on the image thread not hijacking this one.

1) /boot is using FAT32, which has no support for symlinks. you are coming maybe from x86 linux, where /boot is ext2 - the idea here is to be able to mount /boot on a windows PC in case you messed up the kernel - and yes, there is a number of ways you can do that. It's the same like all the other images, so that message about failing to create the hardlink would appear on all.
2) the boot partition is not that big - and the default kernel has a HUGE number of modules (almost every day @mdrjr gets requests to enable yet another module) - for a total of >20MB initrd, then the uInitrd created from initrd is another 20MB. To facilitate recovery (see #1) I also created copies of kernel and uInitrd => almost full partition. I usually use way smaller kernels so this was not an issue for me. If you follow the image thread, you will see a solution that removes the backup files when the ubuntu update wants to regenerate initrd.
3) you are the first to complain about logout
4) resolv.conf -> yes I forgot to recreate the link. When creating the image, I had to chroot into it (there was no kernel installed yet), and in the chroot environment that link was not working obviously since the right file was outside the chroot, hence I manually created it to be able to install packages in chroot, and forgot about it.
5) I don't see "screenshot" as a OS feature, is just an app.
6) ubuntu installer may add 127.0.1.1 for the hostname, I prefer 127.0.0.1. a while ago ubuntu was using 127.0.0.1 as well. i'm getting old what can i say. oh, let me say this: there is no ubuntu installer working on arm, otherwise you would not need to get this image, would you?
7) no idea about the termcap - maybe your ssh client has the wrong TERM ?
8) It is not based on Lubuntu, it is based on Ubuntu CORE. And I don't like the task stuff, since it installs more packages than I like. So it actually this image has less packages installed than Lubuntu, and some of them maybe non-standard (e.g. leafpad sucks, medit is much better; lxmusic is a joke - I spent time trying many lightweight players until I chose deadbeef - and is much better).
9) xfwm is not working properly in 14.04, it has some artifacts. initially i created a xubuntu image, but there were several issues - I don't think you'll see xubuntu 14.04 for the u2/3 (or at least not with armsoc + r4p0 drivers). see threads of people that upgraded xubuntu complaining.

10) it's a clean CORE release + apt-get install stuff from default repo (many dev packages) + visual customisation for the odroid user (which you can just remove by deleting the ~/.config folders if you wanna get back to stock look) + odroid xbmc + odroid custom gstreamer + hacked snappy player to use samsung mfc hardware acceleration. yeah it's hacked to give you goodies you don't have in a standard release. if you are not happy with that, apt-get purge them and install the xubuntu task - see how good that is :)

Hope I answered your questions...

PS - before settling for LXDE, I have tried gnome, xfce, cinnamon (compiled latest version) and MATE (compiled latest version) - only one i did not try was unity. Only LXDE and MATE works properly on these graphics drivers. MATE is not in ubuntu repos, and the mate repos don't have ARM versions - so LXDE is the most repo-frienly atm.

User avatar
DavidTangye
Posts: 57
Joined: Thu May 16, 2013 10:50 pm
languages_spoken: english
ODROIDs: Currently running XU4 as my desktop
Also had a U2, U3, XU3-Lite (it broke), and 10 * C1's in the past.
Location: Gold Coast, Queensland, Australia
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by DavidTangye » Tue Jun 17, 2014 8:30 pm

Many thanks for the background info. It helps explain a lot, and I am sure others will be very interested to read it too, especially points 1,2 & 8 to 10.

laika
Posts: 2
Joined: Thu Jun 19, 2014 10:21 pm
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by laika » Thu Jun 19, 2014 10:28 pm

I get the follwing errors when trying to update the kernel via /usr/local/bin/kernel_update.sh

Code: Select all

E: /usr/share/initramfs-tools/hooks/fixrtc failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.8.13.23 with 1.
I've been googling around for a while but I can't fix it. Any ideas?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Thu Jun 26, 2014 9:34 am

shouldn't be harmful as I recall..

TinGoose
Posts: 28
Joined: Thu Aug 22, 2013 12:22 am
languages_spoken: english
ODROIDs: X2, U2, lots of U3, XU, XU3, lots of W
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by TinGoose » Fri Jul 04, 2014 7:47 pm

Where can I found settings for UART console? I want to disable any OS output to UART (ttySAC1) port. Some time ago I used /etc/inittab file, but it is gone in this version. Is it enough now just to change values in boot.scr?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Sat Jul 05, 2014 7:04 am

Serial console login is defined on /etc/init/auto-serial-console.conf

thenoots
Posts: 10
Joined: Mon Feb 17, 2014 11:01 pm
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by thenoots » Mon Jul 07, 2014 5:01 am

Hello.
After installing the Ubuntu server 14.04 on my U3 I experience some strange sound coming from the fan, as described here: http://forum.odroid.com/viewtopic.php?f ... ise#p41776
Is there any fix for that?
Thanks!

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Mon Jul 07, 2014 12:09 pm

thenoots wrote:Hello.
After installing the Ubuntu server 14.04 on my U3 I experience some strange sound coming from the fan, as described here: http://forum.odroid.com/viewtopic.php?f ... ise#p41776
Is there any fix for that?
Thanks!
I think newer kernels should have this fixed :P

thenoots
Posts: 10
Joined: Mon Feb 17, 2014 11:01 pm
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by thenoots » Mon Jul 07, 2014 4:58 pm

mdrjr wrote: I think newer kernels should have this fixed :P
This version uses the 3.8.13.23 kernel. I tried updating it with the odroid-utility. Unfortunately after the update the U3 hangs at the screen posted here: http://forum.odroid.com/viewtopic.php?f ... 3&start=20 . It seems it doesnt recognize the partition table after the update.
What is the latest kernel update for Ubuntu server 14.04 that the odroid-utility can fetch for the U3 and that works?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Mon Jul 07, 2014 5:59 pm

All works. There's a log file saved on the eMMC. its on /root

Please paste it here.

thenoots
Posts: 10
Joined: Mon Feb 17, 2014 11:01 pm
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by thenoots » Tue Jul 08, 2014 2:04 am

OK, here is the log generated after the kernel update:

Code: Select all

root@odroid-server:~# cat kernel_update-log-2014.07.07-16.53.txt
tar: Removing leading `/' from member names
update-initramfs: Generating /boot/initrd.img-3.8.13.23
Image Name:   uInitrd 3.8.13.23
Created:      Mon Jul  7 16:55:40 2014
Image Type:   ARM Linux RAMDisk Image (uncompressed)
Data Size:    2155530 Bytes = 2105.01 kB = 2.06 MB
Load Address: 00000000
Entry Point:  00000000
root@odroid-server:~#
Before the update I had 3.8.13.23 and after the update 3.8.13.23 :)
The fan coil still makes noises at 55 degrees celsius - just before it starts working..

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Tue Jul 08, 2014 8:10 am

NIce :)

On /sys there's a file that you can control the start duty for the PWM :)

find /sys -name start_duty

You can experiment with values from 0 to 255 :)
just echo 0-255 > that.file

johnsmith
Posts: 1
Joined: Tue Jul 08, 2014 8:26 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by johnsmith » Tue Jul 08, 2014 8:39 pm

Hi!

I'm looking to setup a headless file server and torrent client and the odroid-u3 sounds good. This would be my first non android arm computer so I'm quite ignorant! I have some questions regarding Linux distros for the odroid u3:

1. Is hardkernel the only place to get compiled distros for the odroid-u3?

2. In the distros compiled by hardkernel, do you provide updates for the kernel and all the user packages?

3. How far behind the official (Ubuntu or whatever) kernel and user updates are you?

My concern is that you won't keep up fast enough with security patches for the torrent client or anything else that happens to be reachable from the outside world from my box. Should I be concerned?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Wed Jul 09, 2014 12:22 am

1. Either hardkernel or community. There are guides on how to make your on Ubuntu from Scratch.

2. We don't provide ANY user packages those are acquired directly from the distro itself and yes we do provide kernel updates almost on a daily basis.

3. As I said above we don't build our own custom distros.. we use regular packages from available distros. Hardkernel has only armv7 boards that are supported by all major distros.

thenoots
Posts: 10
Joined: Mon Feb 17, 2014 11:01 pm
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by thenoots » Wed Jul 09, 2014 7:03 am

mdrjr wrote:NIce :)

On /sys there's a file that you can control the start duty for the PWM :)

find /sys -name start_duty

You can experiment with values from 0 to 255 :)
just echo 0-255 > that.file
Done it. Thanks mdrjr.
Apparently 65 is the lowest I can use to start the fan slowly and without noise. :)

User avatar
DavidTangye
Posts: 57
Joined: Thu May 16, 2013 10:50 pm
languages_spoken: english
ODROIDs: Currently running XU4 as my desktop
Also had a U2, U3, XU3-Lite (it broke), and 10 * C1's in the past.
Location: Gold Coast, Queensland, Australia
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by DavidTangye » Wed Jul 16, 2014 11:20 am

David Tangye wrote:There is no graphic character decoration in Midnight Commander -S darkfar.ini. I have not seen this problem for many years, and I think this might be a termcap issue, or somethign like it where a supporting config directory is removed.
memeka wrote: 7) no idea about the termcap - maybe your ssh client has the wrong TERM ?
FYI: It looks like I have fixed this when I installed "language-pack-en":
I also set /etc/default/locale:

Code: Select all

LANG=en_AU.utf8
and ran

Code: Select all

update-locale && dpkg-reconfigure localepurge
"dpkg-reconfigure localepurge" is used to check and add any locales to a 'keep list'. All other language files should disappear and not bog future package upgrades down. After logging out and back in mc (and ssh) seem to be displaying everything properly.

Anton
Posts: 7
Joined: Sat Jul 12, 2014 7:59 am
languages_spoken: english,russian
ODROIDs: ODROID-U3
ODROID-XU
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by Anton » Sun Jul 27, 2014 2:32 am

Hi all! ) Can i use custom kernel from kernel.org? I can't compile it couse some file from 'firmware blobs' are missing.

root@odroid-server:/usr/src/linux-3.15.6# cat .config | grep "CONFIG_EXTRA_FIRMWARE"
CONFIG_EXTRA_FIRMWARE="edid/1024x768.bin edid/1280x1024.bin edid/1280x720.bin edid/1680x1050.bin edid/1920x1080.bin"
CONFIG_EXTRA_FIRMWARE_DIR="firmware"

I found at "Documentation/EDID" missing files except one 1280x720.S
I cannot create it because i don't know modeline parameters ((
Where i can find it? or may be anybody knows modeline for this resolution? (dpi, dot clock and etc )
Last edited by Anton on Sun Jul 27, 2014 8:01 am, edited 1 time in total.

ThoPo
Posts: 11
Joined: Fri Jan 24, 2014 5:22 pm
languages_spoken: english, german
ODROIDs: U3 Community Edition
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by ThoPo » Sun Jul 27, 2014 3:45 am

after the odroid is fully booted i cant connect to it

Code: Select all

root@posibuntu:/# ssh 192.168.178.43
ssh: connect to host 192.168.178.43 port 22: Connection refused
how can i fix that?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Sun Jul 27, 2014 4:03 am

If its fully booted... ssh is working...

shit's'cool
Posts: 17
Joined: Thu Jul 31, 2014 1:18 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by shit's'cool » Fri Aug 01, 2014 1:42 am

How can I?

Code: Select all

apt-get update
apt-get upgrade
And I can't install anything at all. Need mysql for owncloud.
Seems the sources are empty.

shit's'cool
Posts: 17
Joined: Thu Jul 31, 2014 1:18 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by shit's'cool » Sat Aug 02, 2014 3:46 am

It works! My bad. Sorry!
Thougt it doesn't work but actually there is no package to upgrade and the package mysql doesn't exist. It is calles mysql-server.
Owncloud is already running, just need to deploy it. Happy!

Hadmut
Posts: 5
Joined: Mon Aug 04, 2014 6:26 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Not booting

Unread post by Hadmut » Mon Aug 04, 2014 6:37 am

Hi,

I just purchased a U3 and tried to install Ubuntu 14.04 with the images provided, i.e.

ubuntu-14.04lts-lubuntu-odroid-u-20140612.img.xz
ubuntu-14.04lts-server-odroid-u-20140604.img.xz

I used two 32gb sd cards (different brands), but with both images and both cards always the same problem: Only the red led is lit, and when turning the device on, the HDMI monitor wakes up, shows nothing, and after some seconds complains that there is no signal, and goes back to sleep.

I could mount the cards on a regular pc, file system looks good.

I even tried a third card with just 1GB (yes, I am aware that the images don't fit on 1G, but that should still be enough to make the device boot, and I wanted to test another sd card brand).

Any idea? Is that a known problem?

regards
Hadmut

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Mon Aug 04, 2014 8:27 am

Create your own thread.

shit's'cool
Posts: 17
Joined: Thu Jul 31, 2014 1:18 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by shit's'cool » Tue Aug 05, 2014 7:46 pm

Sorry. New toy made me giddy. Now I got it work. Flashing via Windows with the tool offered in this forum did the trick.

Got an import issue which certainly belongs here:
Made a security test via https://www.ssllabs.com/ssltest/ and it turned out that OpenSSL is exploitable!

More informaition about it:
https://community.qualys.com/blogs/secu ... xploitable

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Tue Aug 05, 2014 10:52 pm

Nope it doesn't belong here.. it belongs to Canonical... On their Bugtrack on Launchpad

shit's'cool
Posts: 17
Joined: Thu Jul 31, 2014 1:18 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by shit's'cool » Tue Aug 05, 2014 10:59 pm

Oh no!
I did it again!
o0

shit's'cool
Posts: 17
Joined: Thu Jul 31, 2014 1:18 am
languages_spoken: english
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by shit's'cool » Thu Aug 07, 2014 1:15 pm

Actually this openssl test turned out to be crap and some research revealed that the openssl version is heartbeat bugfixed. Splendid!

avsxx
Posts: 24
Joined: Sat Aug 09, 2014 6:15 pm
languages_spoken: english
ODROIDs: U3+
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by avsxx » Fri Aug 15, 2014 11:58 pm

Good job, I should say! Went all the ways smoothly, no sinle hitch!
4) there's even a directory, /etc/resolvconf. dunno why bother with that!
5) oh. import(1), maybe some other gimp utilities
6) localhost must be 127.0.0.1
7) I've got a bunch of termcaps from various unices, pls pm me if you care. ssh doesn't use it, definitely, but the shell it launches, it really does (or doesn't, maybe it looks in terminfo like bash or uses some defaults in the worst case). Have anybody had the problems? I daresay, I might be of some help, fighting those unix shells all my life...
Thank you!

sirtea
Posts: 2
Joined: Wed Aug 27, 2014 10:29 pm
languages_spoken: english spanish
ODROIDs: odroid u3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by sirtea » Wed Aug 27, 2014 10:39 pm

Hi all,

After trying this image coming from an old ubuntu-desktop image, debian from odroid.us (a year without updates!) and arch linux arm, y must admit I have fallen in love with this version. There's only one thing that I haven't accomplished yet: running LXC (I have done this several times int a debian i386)

My problem is after an "apt-get install lxc", and a successful "lxc-create -n <name> -t <distro>", I fail to boot the images, both for distros/templates "debian" and "ubuntu".

Code: Select all

root@odroid:/var/lib/lxc/test/rootfs# lxc-start -n test -d
lxc-start: command get_cgroup failed to receive response
root@odroid:/var/lib/lxc/test/rootfs# lxc-start -n test   
lxc-start: No such file or directory - mount failed '/dev/pts/ptmx'->'/dev/ptmx'
lxc-start: failed to setup the new pts instance
lxc-start: failed to setup the container
lxc-start: invalid sequence number 1. expected 2
lxc-start: failed to spawn 'test'
root@odroid:/var/lib/lxc/test/rootfs# 
I have some issues with kernel options, as shown in lxc-checkconfig

Code: Select all

root@odroid:/var/lib/lxc/test/rootfs# lxc-checkconfig | grep missing
User namespace: missing
Multiple /dev/pts instances: missing
Cgroup sched: missing
Cgroup memory controller: missing
root@odroid:/var/lib/lxc/test/rootfs# 
¿Has anyone hit this issue and have a workaround?

Thanks in advance

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Wed Aug 27, 2014 11:57 pm

Try updating the kernel (odroid-utility in my signature) I did enabled a few options that was missing :)

sirtea
Posts: 2
Joined: Wed Aug 27, 2014 10:29 pm
languages_spoken: english spanish
ODROIDs: odroid u3
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by sirtea » Thu Aug 28, 2014 6:05 pm

After kernel update, lxc works great.
Many thanks

harry123
Posts: 12
Joined: Wed May 28, 2014 1:38 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by harry123 » Sat Aug 30, 2014 4:16 pm

hi, I have been trying this one.

1) kernel update script breaks after downloading the update
2) since release 4.6.14 the apt-get update does not want to update any packages. is this realistic?

harry

remarks: iptables is missing in built. install is no big deal and should be mandatory for a server built...

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Sun Aug 31, 2014 4:08 am

harry123 wrote:hi, I have been trying this one.

1) kernel update script breaks after downloading the update
2) since release 4.6.14 the apt-get update does not want to update any packages. is this realistic?

harry

remarks: iptables is missing in built. install is no big deal and should be mandatory for a server built...
1) Logs? Where are they?
2) 4.6.14? What?

Nope.. Iptables is not mandatory...

User avatar
meveric
Posts: 10271
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2
Has thanked: 13 times
Been thanked: 102 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by meveric » Sun Aug 31, 2014 6:03 pm

mdrjr wrote: 2) 4.6.14? What?
--> Ubuntu Server 14.04 LTS for U3 [20140604] <--- 04.06.2014 ---> 4.6.14 ;)
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Mon Sep 01, 2014 7:04 am

Did you tested odroid utility or the kernel-update?

harry123
Posts: 12
Joined: Wed May 28, 2014 1:38 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by harry123 » Tue Sep 02, 2014 1:27 am

i first started "odroid-utility.sh", and selected "kernel update" from the menu. what log do you need?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by mdrjr » Tue Sep 02, 2014 3:24 am

On /root there's a log.. :)

harry123
Posts: 12
Joined: Wed May 28, 2014 1:38 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Ubuntu Server 14.04 LTS for U3 [20140604]

Unread post by harry123 » Tue Sep 02, 2014 4:19 am

ok, kernel update was running ok, still system now hangs on reboot and is not starting anymore...

seems i have to re-flash the sd-card again, that sucks...

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 1 guest