USB3 camera device not detected after soft reboot

Moderators: odroid, mdrjr

USB3 camera device not detected after soft reboot

Unread postby dahe » Fri Mar 24, 2017 10:47 pm

Hi,

i have sometimes the problem that my usb3 camera device is not always detected by the ODROID after a soft reboot. If I run into this problem the issue could only be resolved by unplugging the power supply of the ODROID.

If the device is not detected i could see the following messages from the kernel:
Jan 1 12:06:15 odroid kernel: [ 53.489544] [c2] usb 3-1.1.3: device not accepting address 5, error -62
Jan 1 12:06:15 odroid kernel: [ 53.564824] [c0] usb 3-1.1.3: new high-speed USB device number 6 using xhci-hcd
Jan 1 12:06:20 odroid kernel: [ 58.564476] [c1] xhci-hcd xhci-hcd.2.auto: Timeout while waiting for address device command
Jan 1 12:06:25 odroid kernel: [ 63.769481] [c1] xhci-hcd xhci-hcd.2.auto: Timeout while waiting for address device command
Jan 1 12:06:25 odroid kernel: [ 63.974457] [c1] usb 3-1.1.3: device not accepting address 6, error -62

Also sometimes my ethernet interface is missing and I see the same syslog messages:

Jan 2 00:50:59 odroid kernel: [ 15.329432] [c4] xhci-hcd xhci-hcd.5.auto: Timeout while waiting for address device command
Jan 2 00:50:59 odroid kernel: [ 20.539423] [c5] xhci-hcd xhci-hcd.5.auto: Timeout while waiting for address device command
Jan 2 00:50:59 odroid kernel: [ 20.749422] [c5] usb 6-1: device not accepting address 3, error -62
Jan 2 00:50:59 odroid kernel: [ 25.919420] [c5] xhci-hcd xhci-hcd.5.auto: Timeout while waiting for address device command
Jan 2 00:50:59 odroid kernel: [ 31.129421] [c5] xhci-hcd xhci-hcd.5.auto: Timeout while waiting for address device command
Jan 2 00:50:59 odroid kernel: [ 31.339408] [c5] usb 6-1: device not accepting address 4, error -62
Jan 2 00:50:59 odroid kernel: [ 36.509419] [c4] xhci-hcd xhci-hcd.5.auto: Timeout while waiting for address device command
Jan 2 00:50:59 odroid kernel: [ 41.719446] [c2] xhci-hcd xhci-hcd.5.auto: Timeout while waiting for address device command
Jan 2 00:50:59 odroid kernel: [ 41.934432] [c2] usb 6-1: device not accepting address 5, error -62
Jan 2 00:50:59 odroid kernel: [ 41.943539] [c2] hub 6-0:1.0: unable to enumerate USB device on port 1
Jan 2 00:50:59 odroid kernel: [ 42.020595] [c0] usb 4-1.1: Device not responding to set address.

Is this a known problem with the xhci? As I have seen this issue now on 3 ODROIDS.
Do you have any solution or workaround for this issue?

Greetings
dahe
dahe
 
Posts: 3
Joined: Fri Mar 24, 2017 10:07 pm
languages_spoken: english

Re: USB3 camera device not detected after soft reboot

Unread postby odroid » Sat Mar 25, 2017 4:50 am

I think USB 3.0 hub device driver seems to have an issue with "reboot" process when a video device is attached.
Can you check the lsusb output?
Which kernel version do you use?
User avatar
odroid
Site Admin
 
Posts: 29098
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: USB3 camera device not detected after soft reboot

Unread postby dahe » Mon Mar 27, 2017 10:48 pm

Hi,

my USB3 camera is not used as a video device and my USB3 device is connected via a hub (tested with different hubs, behavior always the same).
I tested different kernel version and have not seen any difference.

Following kernel versions used:
Linux odroid 3.10.105-136 #1 SMP PREEMPT Thu Mar 23 21:56:48 UTC 2017 armv7l armv7l armv7l GNU/Linux
Linux odroid 3.10.69 #1 SMP PREEMPT Thu Feb 12 15:22:14 BRST 2015 armv7l armv7l armv7l GNU/Linux

Which kernel version should I use? I run the 4.9 test image and no usb3 device worked...

This is lsusb if the device is detected:

odroid@odroid:~$ lsusb
Bus 006 Device 002: ID 0bda:8153 Realtek Semiconductor Corp.
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 2676:ba03
Bus 004 Device 003: ID 2109:0811 VIA Labs, Inc. Hub
Bus 004 Device 002: ID 05e3:0616 Genesys Logic, Inc. hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 2109:3431 VIA Labs, Inc. Hub
Bus 003 Device 003: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

In the error case my USB3 camera is not listed. Do you have any information why the ethernet interface sometimes also disappear if a USB3 device is connected?

This is for example lsusb when the ethernet interface is missing:
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 2676:ba03
Bus 004 Device 002: ID 05e3:0616 Genesys Logic, Inc.
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 413c:2107 Dell Computer Corp.
Bus 003 Device 003: ID 2109:2811
Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Do you have a support address? Could not find any on your homepage.

Greetings
David
dahe
 
Posts: 3
Joined: Fri Mar 24, 2017 10:07 pm
languages_spoken: english

Re: USB3 camera device not detected after soft reboot

Unread postby odroid » Tue Mar 28, 2017 5:09 am

Oh.. you are using the XU4 not XU.
You posted on a wrong sub-forum.

It is a know issue in Kernel 4.9 with XU4 onboard USB 3.0 hub chip.
And we are fixing some related issues in this dedicated development forum.
viewforum.php?f=146

Do you have a support address? Could not find any on your homepage.

No. all the technical supports has been done in this forum only.
User avatar
odroid
Site Admin
 
Posts: 29098
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: USB3 camera device not detected after soft reboot

Unread postby dahe » Tue Mar 28, 2017 3:13 pm

Do the issues also persist in the Kernel 3.10.XX? I tried the Kernel 4.9 but there was no usb3 device detected. At the moment I achieve the best results with the Kernel 3.10.69.
dahe
 
Posts: 3
Joined: Fri Mar 24, 2017 10:07 pm
languages_spoken: english

Re: USB3 camera device not detected after soft reboot

Unread postby odroid » Tue Mar 28, 2017 3:36 pm

The USB 3.0 detection in Kernel 4.9 issue will be fixed in several days.
User avatar
odroid
Site Admin
 
Posts: 29098
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Issues

Who is online

Users browsing this forum: No registered users and 1 guest