switch to performance governor no longer working

Post Reply
SevenW
Posts: 36
Joined: Sat Oct 26, 2013 4:50 am
languages_spoken: english
ODROIDs: XU
Has thanked: 0
Been thanked: 0
Contact:

switch to performance governor no longer working

Post by SevenW »

Hi,

I was able to switch two times to performance mode with:

Code: Select all

echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
But this stopped working (without changing SW) and the ssh session I perform this in does no longer respond. The echo commanf never completes.
When I open another ssh, trying to cat the file also hangs in the same manner, and system can no longer perform a reboot

I am using the xbmc image of hgblob, with 3.4.67 kernel.
Any ideas?

max00
Posts: 4
Joined: Fri Nov 22, 2013 5:28 pm
languages_spoken: english, german
ODROIDs: -XU
Has thanked: 0
Been thanked: 0
Contact:

Re: switch to performance governor no longer working

Post by max00 »

Hi,

have you figured out a way to solve this problem - I'm trying to force the performance governor for the xbmc-image (as you considered) but actually the echo command doesn't finish for me as well...

usee
Posts: 113
Joined: Thu Sep 26, 2013 4:28 am
languages_spoken: english
ODROIDs: ODROID-XU, U3, XU3, C1, Weather board, show1
Has thanked: 0
Been thanked: 0
Contact:

Re: switch to performance governor no longer working

Post by usee »

Do you do it as root in shh or as sudo in normal session?
sudo echo performance > /sys/dev....

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 60 times
Contact:

Re: switch to performance governor no longer working

Post by memeka »

i think sudo does not work for redirections, i.e. will do sudo echo , but not sudo in writing the file => permission error.
so best do it as root.

edit: or use sudo tee :)

SevenW
Posts: 36
Joined: Sat Oct 26, 2013 4:50 am
languages_spoken: english
ODROIDs: XU
Has thanked: 0
Been thanked: 0
Contact:

Re: switch to performance governor no longer working

Post by SevenW »

It did not work for a while, even after a installed a complete new image from hgblob. The next day I was able to do a couple of successful switches again. I could not find a correlation with other programs interfering, such as XBMC. My testing was done logged in as root.

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 60 times
Contact:

Re: switch to performance governor no longer working

Post by memeka »

Install cpufrequtils
and create a file /etc/default/cpufrequtils where you specify the performance gorvernor.
Here's is mine, as an example (I'm using ondemand, but with 800MHz minimum freq instead of 250):

Code: Select all

ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED=1600000
MIN_SPEED=800000

max00
Posts: 4
Joined: Fri Nov 22, 2013 5:28 pm
languages_spoken: english, german
ODROIDs: -XU
Has thanked: 0
Been thanked: 0
Contact:

Re: switch to performance governor no longer working

Post by max00 »

memeka wrote:Install cpufrequtils
and create a file /etc/default/cpufrequtils where you specify the performance gorvernor.
Here's is mine, as an example (I'm using ondemand, but with 800MHz minimum freq instead of 250):

Code: Select all

ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED=1600000
MIN_SPEED=800000
Thanks, this finally worked for me.

Post Reply

Return to “General Chat”

Who is online

Users browsing this forum: No registered users and 2 guests