OFFICIAL Debian Jessie for -XU [20140103]

Post Reply
mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

OFFICIAL Debian Jessie for -XU [20140103]

Unread post by mdrjr » Sat Aug 31, 2013 2:04 am

Here we go.. Debian Jessie updated! For ODROID XU.

To keep this image light, I used LXDE/Gnome instead of traditional ones.

Users are the usual:

root/odroid
odroid/odroid

Download links: http://odroid.in/Debian_XU/
Kernel Modules Request: http://forum.odroid.com/viewtopic.php?f=64&t=1985


* 20130827 (wheezy)
* Initial Version

* 20130927 (Jessie)
* updated bootloader with larger buffer
* kernel: more modules enabled
* kernel: improved HDMI compatibility
* kernel: UHS-1 (sdxc) card support
* hwcomposer: hot plug fix
* fixed sound
* updated to jessie
* Gnome3 and XFCE4 installed

* 20140103 (Jessie)
* Updated OS
* XU Lite Compatibility

User avatar
memeka
Posts: 4313
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 0
Been thanked: 12 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by memeka » Sun Sep 08, 2013 10:24 pm


User avatar
memeka
Posts: 4313
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 0
Been thanked: 12 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by memeka » Sun Sep 08, 2013 10:28 pm

Related to the above issue, you sometimes get:

Code: Select all

[info] Will now halt.
[  459.087117] exynos-xhci exynos-xhci.0: Host not halted after 16000 microseconds.
[  459.093917] max77802-rtc max77802-rtc: max77802_rtc_enable_wtsr: disable WTSR
[  459.129123] max77802_rtc_shutdown: WTSR_SMPL reg(0x00)
[  459.132948] max77802_rtc_shutdown: success to disable WTSR
[  459.138961] max77802-rtc max77802-rtc: max77802_rtc_enable_smpl: disable SMPL
[  459.186898] Device failed to respond within 50 poweroff time. Forcefully powering down the device
[  459.194847] Disabling non-boot CPUs ...
[  459.207005] CPU1: shutdown
[  459.218709] CPU2: shutdown
[  459.229977] CPU3: shutdown
[  459.233346] Power down.
[  459.234641] odroidxu_power_off : set PS_HOLD low
[  459.239071] odroidxu_power_off: Should not reach here! (poweroff_try:1)
[  460.238397] odroidxu_power_off: Should not reach here! (poweroff_try:2)
[  461.236308] odroidxu_power_off: Should not reach here! (poweroff_try:3)
[  462.234337] odroidxu_power_off: Should not reach here! (poweroff_try:4)
[  463.232252] odroidxu_power_off: Should not reach here! (poweroff_try:5)
and reboots instead of poweroff

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by mdrjr » Mon Sep 09, 2013 3:57 am

Yep.. I'm aware... Sometimes it happens..

User avatar
memeka
Posts: 4313
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 0
Been thanked: 12 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by memeka » Mon Sep 09, 2013 6:39 am

Any way to fix the sound?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by mdrjr » Mon Sep 09, 2013 10:19 am

memeka wrote:Any way to fix the sound?
I didn't tried to update to Jessie yet..

User avatar
memeka
Posts: 4313
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 0
Been thanked: 12 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by memeka » Tue Sep 10, 2013 7:17 am

Is there any special setting for the sound?
I tried building an image with wheezy, and got the same errors...

Code: Select all

speaker-test 1.0.27.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 32768
Period size range from 32 to 16384
Using max buffer size 32768
Periods = 4
Unable to set hw params for playback: Invalid argument
Setting of hwparams failed: Invalid argument

Code: Select all

[  116.365240] Not yet supported!
[  116.366977] asoc: machine hw_params failed: -22

janrinze
Posts: 76
Joined: Thu Sep 19, 2013 4:31 am
languages_spoken: english
ODROIDs: ODROID-XU-E
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by janrinze » Thu Sep 19, 2013 4:45 am

Hi,

I have downloaded the image and dd it to my sdcard. However when i power on the XU only the leds blink but nothing else happens..
Any suggestions?

janrinze
Posts: 76
Joined: Thu Sep 19, 2013 4:31 am
languages_spoken: english
ODROIDs: ODROID-XU-E
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by janrinze » Thu Sep 19, 2013 5:41 am

Instead of dd-ing it to an SD-card I dd it to the emmc and voila! it works :-)
No HDMI due to errors in dmesg about fb not being created.. So no X or consoles yet but i do have ssh connection :-)

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by mdrjr » Thu Sep 19, 2013 5:52 am

janrinze wrote:Instead of dd-ing it to an SD-card I dd it to the emmc and voila! it works :-)
No HDMI due to errors in dmesg about fb not being created.. So no X or consoles yet but i do have ssh connection :-)
Make sure that your screen is on the proper input before powering it on.. HDMI should work.

janrinze
Posts: 76
Joined: Thu Sep 19, 2013 4:31 am
languages_spoken: english
ODROIDs: ODROID-XU-E
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by janrinze » Thu Sep 19, 2013 6:52 am

The image stopped working after a reboot.
I will try the xubuntu image and see if it is more stable. Since i have no uart cable i can't see where it hangs.

janrinze
Posts: 76
Joined: Thu Sep 19, 2013 4:31 am
languages_spoken: english
ODROIDs: ODROID-XU-E
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by janrinze » Thu Sep 19, 2013 9:51 pm

The XUbuntu image works quite well and seems more stable.
How much i would like to have Debian, this is a good alternative.
I might be back to try the Debian image at a later point.

User avatar
memeka
Posts: 4313
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 0
Been thanked: 12 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by memeka » Thu Sep 19, 2013 11:15 pm

I have a stable Debian jessie image (upgraded from wheezy) :)

risk
Posts: 3
Joined: Tue Sep 24, 2013 2:00 pm
languages_spoken: english
ODROIDs: odroid-xu
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by risk » Tue Sep 24, 2013 2:20 pm

I used the normal procedure.
a) md5 check the image (all ok)
b) extract the image using 7zip
c) format the sdcard using default allocation
d) write the image to the sdcard using win32imagewriter for ODROID v1.1
e) insert the card into odroid with hdmi, keyboard connected to the device.
f) then power up the system

The debian image doesnt seem to work. I keep facing the flashing blue <-> green led's. Having said that, Android and Ubuntu (september) image works just fine. By that i mean, I can actually see the home screen of both os from my tv.

I would love to provide logs, but there is absolutely no output to tv (via hdmi).

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by mdrjr » Wed Sep 25, 2013 3:20 am

I'll update the debian image as well to match the updates done on Ubuntu :)

risk
Posts: 3
Joined: Tue Sep 24, 2013 2:00 pm
languages_spoken: english
ODROIDs: odroid-xu
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Wheezy for -XU

Unread post by risk » Wed Sep 25, 2013 1:28 pm

Thank you very much. I will be eagerly waiting for the new changes.

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU [20130927]

Unread post by mdrjr » Fri Sep 27, 2013 3:29 pm

* 20130927
* updated bootloader with larger buffer
* kernel: more modules enabled
* kernel: improved HDMI compatibility
* kernel: UHS-1 (sdxc) card support
* hwcomposer: hot plug fix
* fixed sound
* updated to jessie
* Gnome3 and XFCE4 installed

User avatar
sert00
Posts: 745
Joined: Sun Feb 24, 2013 12:26 am
languages_spoken: english,italian
ODROIDs: ODROID-U2*2__ODROID-U3__ODROID-XU-E__ODROID-XU-Ebeta__ODROID-C1__ODROID-XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by sert00 » Fri Sep 27, 2013 10:45 pm

thank you!very pleased to read it supports UHS-I cards,i can finally DD it on my 16gb card. :D
2x Odroid-U2
2x Odroid-XU-E
Odroid-U3
Odroid-C1+
Odroid-XU4
Lcd touch panel 10.1"
....and many of the goodies available....

usee
Posts: 113
Joined: Thu Sep 26, 2013 4:28 am
languages_spoken: english
ODROIDs: ODROID-XU, U3, XU3, C1, Weather board, show1
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by usee » Sat Sep 28, 2013 7:57 am

I copied (dd) the latest jessie image into sd card (8 GB) and booted teh board.
It was a success at first attempt.
Both voice and video are working.
Thanks a lot! :!:

risk
Posts: 3
Joined: Tue Sep 24, 2013 2:00 pm
languages_spoken: english
ODROIDs: odroid-xu
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Wheezy for -XU [20130927]

Unread post by risk » Sat Sep 28, 2013 1:27 pm

mdrjr wrote:* 20130927
* updated bootloader with larger buffer
* kernel: more modules enabled
* kernel: improved HDMI compatibility
* kernel: UHS-1 (sdxc) card support
* hwcomposer: hot plug fix
* fixed sound
* updated to jessie
* Gnome3 and XFCE4 installed
Thank you very much! this image works great!

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Wheezy for -XU [20130927]

Unread post by mdrjr » Sat Sep 28, 2013 1:31 pm

risk wrote:
mdrjr wrote:* 20130927
* updated bootloader with larger buffer
* kernel: more modules enabled
* kernel: improved HDMI compatibility
* kernel: UHS-1 (sdxc) card support
* hwcomposer: hot plug fix
* fixed sound
* updated to jessie
* Gnome3 and XFCE4 installed
Thank you very much! this image works great!
Good :) You don't know how happy I am knowing that you are happy ;)

osterluk
Posts: 311
Joined: Sun Feb 24, 2013 2:07 am
languages_spoken: English
ODROIDs: Odroid-U2
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by osterluk » Sun Sep 29, 2013 4:03 am

I had a little trouble booting this image, u-boot.scr is missing from the first partition so the boot aborts at the u-boot prompt.

I wrote up some notes to help others:
http://odroid.us/mediawiki/index.php?ti ... d-boot.scr

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by mdrjr » Sun Sep 29, 2013 5:05 am

osterluk wrote:I had a little trouble booting this image, u-boot.scr is missing from the first partition so the boot aborts at the u-boot prompt.

I wrote up some notes to help others:
http://odroid.us/mediawiki/index.php?ti ... d-boot.scr
It doesnt use boot.scr. uses boot.ini

Youbare mixing 4412 with 5410 here :)

osterluk
Posts: 311
Joined: Sun Feb 24, 2013 2:07 am
languages_spoken: English
ODROIDs: Odroid-U2
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by osterluk » Sun Sep 29, 2013 12:22 pm

Maybe so, but I don't see how... The bootcmd looks for boot.scr

I flashed directly from the posted image. My u-boot prompt looks reasonable, so does the version:

Exynos5410 # ver

U-Boot 2012.07 (Sep 13 2013 - 13:53:58) for Exynos5410
arm-eabi-gcc (GCC) 4.4.3
GNU ld (GNU Binutils) 2.19
Exynos5410 #


uname -a shows:
Linux odroid-jessie 3.4.5 #1 SMP PREEMPT Mon Sep 23 21:41:25 BRT 2013 armv7l GNU/Linux

And the u-boot env shows:
Exynos5410 # print
baudrate=115200
bootargs=fb_x_res=1280 fb_y_res=720 hdmi_phy_res=720 vout=hdmi led_blink=1 fake_fb=false
bootcmd= mmc rescan 0:1; mmc rescan 0:2; if run loadbootscript_1; then run bootscript; else if run loadbootscript_2; then run bootscript; else ;
bootdelay=1
bootscript=source 40008000
copy_uboot_emmc2sd=emmc open 0;movi r z f 0 40000000;emmc close 0;movi w f 1 40000000;emmc open 0;movi r z b 0 40000000;emmc close 0;movi w b 1 40000000;emmc open 0;movi r z u 0 4000000;
copy_uboot_sd2emmc=movi r f 0 40000000;emmc open 1;movi w z f 1 40000000;emmc close 1;movi r b 0 40000000;emmc open 1;movi w z b 1 40000000;emmc close 1;movi r u 0 40000000;emmc open 1;;
default_bootcmd=echo >>> Run Default Bootcmd <<<;movi read kernel 0 40008000;bootz 40008000
filesize=47930
hk_current_version=2
hk_version=2
loadbootscript_1=echo >>> Load Boot Script from mmc 0:1 <<<;fatload mmc 0:1 40008000 boot.scr
loadbootscript_2=echo >>> Load Boot Script from mmc 0:2 <<<;fatload mmc 0:2 40008000 boot.scr
loadbootscript_3=echo >>> Load Boot Script from mmc 1:1 <<<;fatload mmc 1:1 40008000 boot.scr
loadbootscript_4=echo >>> Load Boot Script from mmc 1:2 <<<;fatload mmc 1:2 40008000 boot.scr
rootfslen=100000
stderr=serial
stdin=serial
stdout=serial
verify=if test $hk_version != $hk_current_version;then;fatload mmc 0:1 40008000 u-boot.bin;emmc open 0;movi w z u 0 40008000;emmc close 0;setenv hk_version $hk_current_version;save;resei

Environment size: 1763/16380 bytes
Exynos5410 #


I forget how to erase the u-boot env so the default values set in firmware are regenerated. How about a hint?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by mdrjr » Sun Sep 29, 2013 12:38 pm

Stock and supplied env:

Code: Select all

Exynos5410 # prin
baudrate=115200
bootargs=fb_x_res=1280 fb_y_res=720 vout=hdmi led_blink=1
bootcmd=    cfgload;    mmc rescan 0:1; mmc rescan 0:2;    if run loadbootscript_1;         then run bootscript;     else        if run loadbootscript_2;           then run bootscript;        else            run ;
bootdelay=1
bootscript=source 40008000
copy_uboot_emmc2sd=emmc open 0;movi r z f 0 40000000;emmc close 0;movi w f 1 40000000;emmc open 0;movi r z b 0 40000000;emmc close 0;movi w b 1 40000000;emmc open 0;movi r z u 0 40000000;emmc close 0;movi w u 1 4;
copy_uboot_sd2emmc=movi r f 0 40000000;emmc open 1;movi w z f 1 40000000;emmc close 1;movi r b 0 40000000;emmc open 1;movi w z b 1 40000000;emmc close 1;movi r u 0 40000000;emmc open 1;movi w z u 1 40000000;emmc ;
default_bootcmd=echo >>> Run Default Bootcmd <<<;movi read kernel 0 40008000;bootz 40008000
loadbootscript_1=echo >>> Load Boot Script from mmc 0:1 <<<;fatload mmc 0:1 40008000 boot.scr
loadbootscript_2=echo >>> Load Boot Script from mmc 0:2 <<<;fatload mmc 0:2 40008000 boot.scr
loadbootscript_3=echo >>> Load Boot Script from mmc 1:1 <<<;fatload mmc 1:1 40008000 boot.scr
loadbootscript_4=echo >>> Load Boot Script from mmc 1:2 <<<;fatload mmc 1:2 40008000 boot.scr
rootfslen=100000
stderr=serial
stdin=serial
stdout=serial
note the cfgload... this is the one ;)

to clear u-boot

Code: Select all

env def -f
save
:)

obh
Posts: 1
Joined: Wed Oct 02, 2013 9:24 am
languages_spoken: english
ODROIDs: xu
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by obh » Sun Oct 13, 2013 6:45 am

Can you add apt-get -y install initramfs-tools to the kernel-update.sh
I was using the debian-wheezy-base-7.0-odroidxu as initial base and it probably did not include this package.
kernel-update.sh made an empty uInitrd and booting failed with missing RAM disk.

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by mdrjr » Mon Oct 14, 2013 10:35 am

This is not my image.. if you grabber it somewhere.. It will probably be unsupported since its not a official image..

hkU2
Posts: 12
Joined: Fri Oct 11, 2013 2:04 am
languages_spoken: english
ODROIDs: XU
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by hkU2 » Sun Nov 03, 2013 4:57 pm

This is the only image that will boot off my eMMC!
I am now trying to customize it a bit and see if i like it.

First thing I did was to turn it into an as close as possible "rolling release" by moving to the "unstable" repos (sid),
and I am liking it so far, I'm glad I gave it a chance.

Thanks for this image, mdrjr!

alexei
Posts: 41
Joined: Sun Oct 20, 2013 8:35 am
languages_spoken: english, russian
ODROIDs: XU+E, U3
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by alexei » Fri Nov 08, 2013 12:35 am

What is the commit hash of the kernel which was built for this image? Is it tagged in github.com/hardkernel/linux repo? Thanks in advance.

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20130927]

Unread post by mdrjr » Fri Nov 08, 2013 8:02 am

alexei wrote:What is the commit hash of the kernel which was built for this image? Is it tagged in github.com/hardkernel/linux repo? Thanks in advance.
Download the kernel update script run it and grab the latest source on git.

gernst48
Posts: 8
Joined: Thu Oct 24, 2013 7:32 am
languages_spoken: english
ODROIDs: ODROID-XU
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by gernst48 » Sat Jan 11, 2014 2:39 am

There is a problem with NFS in 20140103.

If I start nfs-common I get the following error:
[FAIL] Starting NFS common utilities: statd idmapd failed!
Investigating this a little bit deeper I found that the rpc.idmapd causing the error.

When I start the rpc.idmapd manually in forground the following happens:
rpc.idmapd -vvvvv -f
rpc.idmapd: libnfsidmap: using (default) domain: gill
rpc.idmapd: libnfsidmap: Realms list: 'GILL'
rpc.idmapd: libnfsidmap: loaded plugin /lib/arm-linux-gnueabihf/libnfsidmap/nsswitch.so for method nsswitch

rpc.idmapd: Expiration time is 600 seconds.
rpc.idmapd: Opened /proc/net/rpc/nfs4.nametoid/channel
rpc.idmapd: Opened /proc/net/rpc/nfs4.idtoname/channel
rpc.idmapd: main: fcntl(/var/lib/nfs/rpc_pipefs/nfs): Invalid argument

Searching the internet what causes such an error I found the following:
------------------------------------------------------------------------------------------------
I was trying to get NFS working today but kept running into errors.
Whenever I tried to start imapd, I would keep getting this error -
rpc.idmapd[12599]: main: fcntl(/var/lib/nfs/rpc_pipefs/nfs): Invalid argument
Turns out, I didn’t have dnotify support enabled in the kernel.
------------------------------------------------------------------------------------------------

Looks like you did the same.

rschwiet
Posts: 2
Joined: Fri Dec 27, 2013 11:27 am
languages_spoken: english
ODROIDs: ODROID XU LITE
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by rschwiet » Tue Jan 21, 2014 1:06 pm

I've tried editing the network interfaces to give my odroid a static IP, but the auto local thing confuses me, and everytime I add a static IP to a eth0 line it no longer connects, advice?

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by mdrjr » Tue Jan 21, 2014 3:44 pm

rschwiet wrote:I've tried editing the network interfaces to give my odroid a static IP, but the auto local thing confuses me, and everytime I add a static IP to a eth0 line it no longer connects, advice?
man interfaces or google "debian /etc/network/interfaces"

elsaghir
Posts: 19
Joined: Mon Jul 15, 2013 10:38 pm
languages_spoken: english
ODROIDs: ODROID-X2
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by elsaghir » Fri Jan 31, 2014 12:03 pm

Hi mdrjr, thank you so much for great support... :)
I just got two of the ODROID-XU+E and running this build on it.
I noticed I can not get my keyboard working on it? I am not sure if it is because I have it on a USB switch? because it is not seeing by the board at all.
I will have to connect it directly and see.
As I always working with SPI, I will ask how to enable SPI on this build?
I found there is a spi_Master in /sys/class which has spi1.0
But, nothing in the /dev/spi*
Any thoughts?
Thank you so much,

Edit:
I connected my Keyboard directly to it and it works fine. So, it does not like keyboard to be on a USB hub.
Last edited by elsaghir on Sat Feb 01, 2014 6:03 am, edited 2 times in total.

elsaghir
Posts: 19
Joined: Mon Jul 15, 2013 10:38 pm
languages_spoken: english
ODROIDs: ODROID-X2
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by elsaghir » Fri Jan 31, 2014 12:05 pm

rschwiet wrote:I've tried editing the network interfaces to give my odroid a static IP, but the auto local thing confuses me, and everytime I add a static IP to a eth0 line it no longer connects, advice?
This is what I did to get the static IP working
http://embedded-development-world.blogs ... id-x2.html

michele
Posts: 2
Joined: Fri Dec 13, 2013 10:56 pm
languages_spoken: english, italian
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by michele » Tue Feb 04, 2014 12:32 am

How can I install chromium on this image? Apt doesn't have the package... Thanks
--Michele

User avatar
memeka
Posts: 4313
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 0
Been thanked: 12 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by memeka » Tue Feb 04, 2014 6:44 am

download the ubuntu one, and install all dependencies manually.
or google debian chromium

gernst48
Posts: 8
Joined: Thu Oct 24, 2013 7:32 am
languages_spoken: english
ODROIDs: ODROID-XU
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by gernst48 » Fri Apr 04, 2014 1:35 am

Updating the kernel today and facing the following error:

-----------------------------------------------------------------------------------------
*** Download Release: LATEST
*** Found board ODROID-XU
*** Debian Found
*** Starting Kernel Update for Debian
Reading package lists... Done
Building dependency tree
Reading state information... Done
axel is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Initializing download: http://builder.mdrjr.net/tools/boot.scr_ubuntu_xu.tar
File size: 307200 bytes
Opening output file boot.scr_ubuntu.tar
Starting download

Connection 4 finished ]
Connection 2 finished ]
Connection 0 finished ]
[100%] [..................................................] [ 246,4KB/s] [00:00]

Downloaded 300,0 kilobytes in 1 second. (246,45 KB/s)
Initializing download: http://builder.mdrjr.net/kernel-3.4/LAT ... dxu.tar.xz
File size: 27242060 bytes
Opening output file odroidxu.tar.xz
Starting download

Connection 1 finished ]
Connection 2 finished ]
Connection 0 finished ]
Connection 3 timed out ]
Connection 4 timed out
Connection 3 finished ]
[100%] [..................................................] [ 435,5KB/s] [00:00]

Downloaded 26,0 megabytes in 1:01 seconds. (435,52 KB/s)
*** Backing Up current kernel to /root/kernel-backup-2014.04.03-18.20.tar.gz
tar: Removing leading `/' from member names
*** Unpacking new Kernel and Modules
*** Starting kernel update
*** Clearing old kernel
*** Installing new zImage
*** Installing new modules
Installing new uInitrd
depmod: ERROR: could not open directory /lib/modules/3.4.75: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
update-initramfs: Generating /boot/initrd.img-3.4.84
mkinitramfs: for root 0 missing mmcblk0p2 /sys/block/ entry
mkinitramfs: workaround is MODULES=most
mkinitramfs: Error please report the bug
update-initramfs: failed for /boot/initrd.img-3.4.84 with 1.
mkimage: Can't open /boot/initrd.img-3.4.84: No such file or directory
*** Installing new boot.scr's
*** Updating Exynos5 HW Composer
Initializing download: http://builder.mdrjr.net/tools/debian_hwcomposer.tar
File size: 563200 bytes
Opening output file /tmp/Kupdate-LATEST/hwc.tar
Starting download

Connection 1 finished ]
Connection 0 finished ]

Downloaded 550,0 kilobytes in 2 seconds. (274,53 KB/s)
*** HW Composer updated!
*** Installing Kernel Headers
*** Headers installed
*** Check /boot for new available boot.scr's!!!
-----------------------------------------------------------------------------------------

Yes I update also the kernel-update.sh script.

What's wrong here ?

Thanks Ernst

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by mdrjr » Sat Apr 05, 2014 12:17 am

What debian image is that?

gernst48
Posts: 8
Joined: Thu Oct 24, 2013 7:32 am
languages_spoken: english
ODROIDs: ODROID-XU
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by gernst48 » Sat Apr 05, 2014 2:27 am

Yours, 3.4.75 from Jan 2014.

But I have some special things running:
The root device is a md device, so I must add some modules to initrd.

In the mean time I found a fix:
I changed in the file /etc/initramfs-tools/initramfs.conf the line
MODULES=dep
to
MODULES=most

Now everything is running.

But I have some other problems with your image:
I have to add the debug parameter to the boot command line in /boot/boot.ini
setenv bootrootfs "console=tty1 console=ttySAC2,115200n8 debug root=/dev/md0 rootwait ro"
or the kernel hangs when the md root device is activated.

Some times there is also a kernel BUG (look at the attached file):
kernel BUG at drivers/iommu/exynos-iommu.c:773
but the system is still booting and running.

Any idea ? or do you need some more information ?

Thanks Ernst
Attachments
Kernel-Error.txt
(67.71 KiB) Downloaded 127 times

gernst48
Posts: 8
Joined: Thu Oct 24, 2013 7:32 am
languages_spoken: english
ODROIDs: ODROID-XU
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by gernst48 » Sun Apr 06, 2014 10:46 pm

I got now an other kernel error (look at the attached file).
More or less always during boot, but the system is still booting and running.

Unable to handle kernel NULL pointer dereference at virtual address 00000050

Thanks Ernst.
Attachments
Kernel-Error-2.txt
(61.9 KiB) Downloaded 134 times

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by mdrjr » Sun Apr 06, 2014 11:09 pm

You can safely ignore that .. its just the gscaler crashing.. nothing that we use on Linux

User avatar
peepo
Posts: 76
Joined: Mon Feb 03, 2014 7:01 am
languages_spoken: English
ODROIDs: U3 eMMC, XU lite emmc
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by peepo » Tue Apr 08, 2014 5:02 pm

dd latest jessie to SD card, ssh in, looking good!! ~:"

xrandr Can't open display

dmesg:
[ 11.948376] s5p-hdmi exynos5-hdmi: HDMI interrupt changed to internal
[ 12.047566] s5p-hdmi exynos5-hdmi: unplugged

however hdmi cable is connected, monitor worked out of box with android

what to do?

okay, so for whatever reason monitor now working after reboot, editing xorg.conf etc...

thanks again for this!!!

~:"

well the keymapping is all wrong but...

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by mdrjr » Tue Apr 08, 2014 11:19 pm

update the kernel

User avatar
peepo
Posts: 76
Joined: Mon Feb 03, 2014 7:01 am
languages_spoken: English
ODROIDs: U3 eMMC, XU lite emmc
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by peepo » Sun Apr 20, 2014 1:46 am

I had excellent experience with Jessie, but recently ran update upgrade, few errors reported and on reboot, jessie eth0 all looks good but cant ping router.
I tried to resolve the issue without any success, so trying xubuntu build.

if anyone has similar problem and resolves please post details as I love debian.

an XU server build would suit, ie no X11 etc...

~:"

curtisnewton
Posts: 57
Joined: Sat Mar 01, 2014 4:26 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: OFFICIAL Debian Jessie for -XU [20140103]

Unread post by curtisnewton » Sun Oct 16, 2016 3:56 am

"odroid is not in the sudoers file"

what on earth are we gonna be able to do if we are not even admin on the system ???

edit : wow, just found out root is enabled with odroid password
come on....

Post Reply

Return to “Other OS”

Who is online

Users browsing this forum: No registered users and 1 guest