[Ubuntu] Updated Chromium doesn't work.

[Ubuntu] Updated Chromium doesn't work.

Unread postby odroid » Wed Mar 23, 2016 1:40 pm

Today's Chromium update by Canonical broke the functionality.
Chromium version = 49.0.2623.87-Oubuntu0.15.10.1.1222
Code: Select all
[2457:2457:0322/182419:ERROR:sandbox_linux.cc(334)] InitializeSandbox() called with multiple threads in process gpu-process
Segmentation fault


Please report this issue to Canonical.


We need to keep using this previous release until they fix it.
https://launchpad.net/ubuntu/+source/ch ... ld/9053018

Remove installed Chromium Ver 49.
Code: Select all
sudo apt-get remove --purge chromium-browser
sudo apt-get autoremove


Download older version(Ver 48) deb packages.
Code: Select all
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb


Install the downloaded packages.
Code: Select all
sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
sudo dpkg -i chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb


Mark "HOLD" to prevent unintended upgrade.
Code: Select all
sudo apt-mark hold chromium-browser



Additional notes for C2 users !
In /etc/chromium-browser/default file, add -
Code: Select all
CHROMIUM_FLAGS="--disable-namespace-sandbox"

The first launching of the Chromium may take 4~6 minutes.
User avatar
odroid
Site Admin
 
Posts: 22716
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby zarcondeegrissom » Wed Mar 23, 2016 8:01 pm

It works. And as I'm doing this instant, make a backup. I hadn't done anything drastic to Linux, so I didn't think a back up image of my eMMC drive was necessary before updating, that was a mistake.
A computer is a Tool that is supposed to make our lives easier, not make our lives wait for the computer. - ZDG
zarcondeegrissom
 
Posts: 40
Joined: Sun Feb 28, 2016 11:33 pm
Location: New England
languages_spoken: english
ODROIDs: Odroid XU4

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby stretch » Thu Mar 24, 2016 11:49 am

I tried the fix and got the following result. Thanks for any help

odroid@odroid64:~$ sudo dpkg -i chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb
(Reading database ... 189756 files and directories currently installed.)
Preparing to unpack chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb ...
Unpacking chromium-browser:armhf (48.0.2564.116-0ubuntu1.1229) over (48.0.2564.116-0ubuntu1.1229) ...
dpkg: dependency problems prevent configuration of chromium-browser:armhf:
chromium-browser:armhf depends on libasound2 (>= 1.0.16).
chromium-browser:armhf depends on libgconf-2-4 (>= 3.2.5).
chromium-browser:armhf depends on libgnome-keyring0 (>= 3.2.2-2~); however:
Package libgnome-keyring0:armhf is not installed.
chromium-browser:armhf depends on libnspr4 (>= 2:4.9-2~) | libnspr4-0d (>= 1.8.0.10); however:
Package libnspr4:armhf is not installed.
chromium-browser:armhf depends on libnss3 (>= 2:3.13.4-2~) | libnss3-1d (>= 3.12.4); however:
Package libnss3:armhf is not installed.
chromium-browser:armhf depends on libxss1; however:
Package libxss1:armhf is not installed.
chromium-browser:armhf depends on libxtst6; however:
Package libxtst6:armhf is not installed.
chromium-browser:armhf depends on libnss3; however:
Package libnss3:armhf is not installed.

dpkg: error processing package chromium-browser:armhf (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu4) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160322.1-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
chromium-browser:armhf
stretch
 
Posts: 7
Joined: Sat Mar 12, 2016 10:51 pm
languages_spoken: english
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby lsvg » Thu Mar 24, 2016 4:36 pm

try "apt-get install -f" ..it should install all dependecies and also chrome.
User avatar
lsvg
 
Posts: 41
Joined: Thu Mar 03, 2016 7:26 am
languages_spoken: english
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby MacFizz » Thu Mar 24, 2016 6:33 pm

Didn't work for me either.
Fixed it installing chromium through apt
Code: Select all
sudo apt install chromium-browser

So basically back to square one, but then install the previous version over it:
Code: Select all
sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
sudo dpkg -i chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb

All dependencies are met and it works...
MacFizz
 
Posts: 17
Joined: Tue Mar 15, 2016 12:04 am
languages_spoken: english, french
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby MacFizz » Thu Mar 24, 2016 7:09 pm

I might have spoken too fast...
Chromium does launch without segfault but can't display anything but the "aw snap" message...
MacFizz
 
Posts: 17
Joined: Tue Mar 15, 2016 12:04 am
languages_spoken: english, french
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ChrisR » Thu Mar 24, 2016 8:07 pm

MacFizz wrote:I might have spoken too fast...
Chromium does launch without segfault but can't display anything but the "aw snap" message...


Macfizz - try this:

In /etc/chromium-browser/default file, add -
Code: Select all
CHROMIUM_FLAGS="--disable-namespace-sandbox"


Worked for my C2
ChrisR
 
Posts: 13
Joined: Wed Feb 10, 2016 1:04 am
languages_spoken: english
ODROIDs: XU4, C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby MacFizz » Thu Mar 24, 2016 10:58 pm

@ChrisR thx, that did the trick.
Now it seems to be working.
I hope either one of Firefox and Chromium get fixed for arm64 soon (and stay fixed may I add).
MacFizz
 
Posts: 17
Joined: Tue Mar 15, 2016 12:04 am
languages_spoken: english, french
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby dkfuel » Fri Mar 25, 2016 3:18 am

Confirmed that all of the above works! Just make sure you do all of the above or it won't work. Thanks guys --- gotta have a working browser for a Kiosk device!

P.S. Make *sure* you mark it as hold!
dkfuel
 
Posts: 5
Joined: Tue Mar 15, 2016 5:15 am
languages_spoken: english
ODROIDs: C-2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby cyrrel » Fri Mar 25, 2016 6:23 pm

Does not work for me. Chromium started but no page will be shown. Strange behavior
cyrrel
 
Posts: 12
Joined: Wed Mar 16, 2016 7:49 pm
languages_spoken: english, german, danish
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby petevine » Fri Mar 25, 2016 9:57 pm

Never noticed, probably due to using `--use-gl=none`
petevine
 
Posts: 132
Joined: Thu Aug 06, 2015 4:41 am
languages_spoken: english
ODROIDs: C1, MXQ PRO+

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby mmiszczuk » Sat Mar 26, 2016 3:45 am

How enable gpu acceleration on chromium 48.0.2564.116 on ubuntu 16.04? youtube run very bad. Maybe upgrade drivers, but how?
mmiszczuk
 
Posts: 21
Joined: Sat Mar 26, 2016 3:43 am
languages_spoken: english
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby keithphw » Sat Mar 26, 2016 10:28 am

Hi,
Thanks for the proposed fix. Unfortunately for me, I tried the recommended upgrades in the first post but Chromium still won't open, it reports "error while loading shared libraries: libsound.so.2: cannot open shared object file: No such file or directory"
I suppose I'll just wait for a fix by Canonical.
Can you recommend a third browser that works on the odroid-c2 besides firefox or chromium?
EDIT: I tried epiphany browser but it also depends on some packages that aren't installed, such as libasound2:armhf and 6 others.
Cheers,
Keith
keithphw
 
Posts: 62
Joined: Sat Mar 26, 2016 9:59 am
languages_spoken: english
ODROIDs: c2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby Johnrednex » Sat Mar 26, 2016 9:24 pm

Hi,
Almost the same issue. Chromium was working, but it displayed an error message in the console for each mouse click.
Then I removed and reinstalled chromium-browser. I also did @ChrisR trick.

Now an other issue : Chronium starts but the window closes 2 seconds after. :/
Odroid - C2
User avatar
Johnrednex
 
Posts: 1
Joined: Sat Mar 26, 2016 9:00 pm
languages_spoken: french, english
ODROIDs: ODROID - C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby stmicro » Sat Mar 26, 2016 10:01 pm

This guide is really helpful for me.
Chromium works on my C2 again. Thank you.
stmicro
 
Posts: 200
Joined: Tue Apr 28, 2015 4:23 pm
Location: shenzhen
languages_spoken: english, chinese
ODROIDs: 2 x C1+, 2 x C2
1 x XU-L, 2 x XU3-L, 3 x U3, 2 x U2, 9 x XU4

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby magiceye04 » Sun Mar 27, 2016 6:39 am

For me it did not work.

After i updated Ubuntu today (about 500 new packages (not knowing for what...)) Chromium started, stayed for 10 second und closed itself.
After i did the steps in Post #1, Chromium showed not even a window. just in the Taskbar was a hint for some seconds.
If there are some more steps necessary, please edit Post #1.

But i think Ubuntu crashed completely by the update, because all other browsers also dont work.
magiceye04
 
Posts: 8
Joined: Sat Mar 26, 2016 10:24 pm
languages_spoken: english, german
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby odroid » Sun Mar 27, 2016 1:18 pm

I've tried again with the C2 board this morning.
I freshly installed our official Ubuntu OS image "ubuntu64-16.04lts-mate-odroid-c2-20160226.img" to minimize side effect.
And ran "sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade". and reboot the C2.
It took around 30 minutes with my 16G eMMC. Micro-SD card might need more time.

After tons of updates, I had the problematic Chromium 49.0.2623.87 and it didn't work.
And followed below steps on the command line (via ssh).

Code: Select all
sudo apt-get remove --purge chromium-browser
sudo apt-get autoremove
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb
sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
sudo dpkg -i chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb

But I met some dependency error messages.
So I tried to install the latest chromium again to fix the broken dependency.
Code: Select all
sudo apt-get install chromium-browser:armhf
sudo apt-get -f install

And overwrote the previous version.
Code: Select all
sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
sudo dpkg -i chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb


And edited the chromium settings file.
Code: Select all
sudo nano /etc/chromium-browser/default

Put this flag in that file.
Code: Select all
CHROMIUM_FLAGS="--disable-namespace-sandbox"


Finally the chromium-browser works now.
User avatar
odroid
Site Admin
 
Posts: 22716
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby keithphw » Sun Mar 27, 2016 2:44 pm

Thanks, Chromium works now.
But unfortunately my sound doesn't work. I wonder if it's because I left out the 'sudo apt-get dist-upgrade'. I only did 'sudo apt-get update && sudo apt-get upgrade'.
Can I clarify that your sound works on youtube and your upgrade step before repairing Chromium was:
sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get upgrade
As is written here:
http://odroid.com/dokuwiki/doku.php?id= ... _note_v1.1
Cheers,
Keith
keithphw
 
Posts: 62
Joined: Sat Mar 26, 2016 9:59 am
languages_spoken: english
ODROIDs: c2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby odroid » Sun Mar 27, 2016 2:58 pm

HDMI sound works.

Try to change the audio output path.
Menu -> System -> Control Center -> Sound -> Output Tap -> ODROID-HDMI Analog Stereo.
User avatar
odroid
Site Admin
 
Posts: 22716
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby keithphw » Sun Mar 27, 2016 3:43 pm

Ok thanks.
For some reason I can't see a 'Sound' option there. But no worries, I'll re-flash the emmc card and start over, doing the full upgrade with
sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get upgrade
Cheers,
Keith
keithphw
 
Posts: 62
Joined: Sat Mar 26, 2016 9:59 am
languages_spoken: english
ODROIDs: c2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby BlackPPoint » Wed Mar 30, 2016 2:07 pm

keithphw wrote:...I'll re-flash the emmc card and start over, doing the full upgrade with
sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get upgrade
...


Isn't it should be "update -> upgrade -> dist-upgrade" ?
BlackPPoint
 
Posts: 47
Joined: Fri Mar 18, 2016 1:29 am
Location: Russia
languages_spoken: russian, english
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby idpitt » Wed Mar 30, 2016 7:17 pm

All good again having followed the posted instructions. Chromium starts far faster than before as an added bonus too.
idpitt
 
Posts: 3
Joined: Wed Sep 17, 2014 7:52 am
languages_spoken: english
ODROIDs: u3x

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby keithphw » Wed Mar 30, 2016 9:06 pm

BlackPPoint wrote:
keithphw wrote:...I'll re-flash the emmc card and start over, doing the full upgrade with
sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get upgrade
...


Isn't it should be "update -> upgrade -> dist-upgrade" ?

Hmm, I don't know I'm sorry. Perhaps it doesn't matter since the odroid c2 wiki has it as I wrote and I didn't notice any errors:
http://odroid.com/dokuwiki/doku.php?id= ... _note_v1.1
keithphw
 
Posts: 62
Joined: Sat Mar 26, 2016 9:59 am
languages_spoken: english
ODROIDs: c2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby odroid » Wed Mar 30, 2016 9:11 pm

Normally the sequence doesn't matter.
But "upgrade -> dist-upgrade" is much more logical.
I will update the WiKi very soon.
User avatar
odroid
Site Admin
 
Posts: 22716
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby xardoz » Wed Mar 30, 2016 9:19 pm

So is there going to be a new image released with a working browser (Chromium) included? The most recent includes the broken Chromium, would be nice to not have to fix something before you can even use it. Refering to --> ubuntu64-16.04lts-mate-odroid-c2-20160226.img.xz

Thank you.
xardoz
 
Posts: 8
Joined: Fri Mar 04, 2016 12:06 am
languages_spoken: english

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby odroid » Wed Mar 30, 2016 9:30 pm

0226 image already had the working chromium v48.
The first launching time just takes up to several minutes.
User avatar
odroid
Site Admin
 
Posts: 22716
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby xardoz » Wed Mar 30, 2016 10:04 pm

Ok I got it, I did not expect when you said it took some minutes to launch first time that it would appear on taskbar then totally disappear for those minutes before finally launching again.

Thank you.
xardoz
 
Posts: 8
Joined: Fri Mar 04, 2016 12:06 am
languages_spoken: english

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby xardoz » Thu Mar 31, 2016 1:08 am

So just in case someone wants to start from scratch this is what I did:

1. Installed image: ubuntu64-16.04lts-mate-odroid-c2-20160226.img.xz
2. Booted up and first thing ran command: apt-mark hold chromium-browser
3. Tested that Chromium browser did in fact work.
4. Went through the apt-get update, apt-get upgrade, apt-get dist-upgrade cycle.
5. Installed pepperflash for flash capability per here: viewtopic.php?f=52&t=16461

Now I am back in business.
xardoz
 
Posts: 8
Joined: Fri Mar 04, 2016 12:06 am
languages_spoken: english

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby KC7NOA » Thu Mar 31, 2016 3:07 pm

Did not work for me ....
KC7NOA
 
Posts: 763
Joined: Wed Feb 27, 2013 2:25 pm
languages_spoken: english
ODROIDs: Odroid-X2(blown HDMI output)
Odroid-C2 to replace X2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby odroid » Fri Apr 01, 2016 9:07 am

It worked for me.
What error messages you met?
User avatar
odroid
Site Admin
 
Posts: 22716
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Sun Apr 03, 2016 9:42 pm

Hello all,

So, I'm new to scripting and this one's basic, but it does all of the steps listed in this thread which are required to get Chromium working. Hope this helps.

EDIT: Script modified after correction made to the sed command on line 21.
EDIT2: more tweaks. No problems now! I hope...
Attachments
ChromiumFix.sh
(1.15 KiB) Downloaded 395 times
Last edited by ColonelPanic on Wed Apr 06, 2016 8:26 am, edited 2 times in total.
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby mikronauts » Tue Apr 05, 2016 4:56 am

Tried

sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
sudo dpkg -i chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb

but those packages are now missing...
http://Mikronauts.com ... Home of RoboPi, Pi Rtc Dio, Pi Jumper, EZasPi
mikronauts
 
Posts: 225
Joined: Wed Aug 27, 2014 4:28 am
Location: Langley, BC, Canada
languages_spoken: english
ODROIDs: odroid-w, odroid c1

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Tue Apr 05, 2016 5:01 am

Code: Select all
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby mikronauts » Tue Apr 05, 2016 5:49 am

Thank you.

(NOT Surprisingly) after the wget's dpkg -i installed them fine!

Even better - Chromium worked!

Please excuse the old man moment.

ColonelPanic wrote:
Code: Select all
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-codecs-ffmpeg-extra_48.0.2564.116-0ubuntu1.1229_armhf.deb
wget https://launchpad.net/ubuntu/+source/chromium-browser/48.0.2564.116-0ubuntu1.1229/+build/9053018/+files/chromium-browser_48.0.2564.116-0ubuntu1.1229_armhf.deb
http://Mikronauts.com ... Home of RoboPi, Pi Rtc Dio, Pi Jumper, EZasPi
mikronauts
 
Posts: 225
Joined: Wed Aug 27, 2014 4:28 am
Location: Langley, BC, Canada
languages_spoken: english
ODROIDs: odroid-w, odroid c1

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Tue Apr 05, 2016 9:46 am

No worries! My script removes the packages after install to create space.
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby cyrrel » Tue Apr 05, 2016 3:38 pm

Hi again,

am I the only one where the browser starts up after all that but isn't able to load a webpage?
I mean I am using the 32bit Firefox now, but a bit frustrating it is anyways :/
cyrrel
 
Posts: 12
Joined: Wed Mar 16, 2016 7:49 pm
languages_spoken: english, german, danish
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby odroid » Tue Apr 05, 2016 3:42 pm

Run the FireFox on the command line and see what's wrong.
User avatar
odroid
Site Admin
 
Posts: 22716
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby mmiszczuk » Wed Apr 06, 2016 12:30 am

ColonelPanic wrote:Hello all,

So, I'm new to scripting and this one's basic, but it does all of the steps listed in this thread which are required to get Chromium working. Hope this helps.

How run this script? I downloaded to desktop.
mmiszczuk
 
Posts: 21
Joined: Sat Mar 26, 2016 3:43 am
languages_spoken: english
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Wed Apr 06, 2016 12:37 am

Are you familiar with the command line? I would put the script in the root directory and then run

./ChromiumFix.sh

answer y to all prompts
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ErikKnowles » Wed Apr 06, 2016 4:15 am

The script mostly works -- *thank you* for providing it.

One note: the line that adds "disable-namespace-sandbox" to /etc/chromium-browser/default needs to add "--disable-namespace-sandbox" instead.
ErikKnowles
 
Posts: 7
Joined: Wed Sep 16, 2015 1:46 am
languages_spoken: english
ODROIDs: XU4

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Wed Apr 06, 2016 5:35 am

Thank you for pointing that out, Erik. Script has been modified with the change (sed command on line 21). I always appreciate feedback, so if anyone finds mistakes, please let me know.

Funny thing is, I tested the original script on my C2 and it worked fine! Apologies if it's caused anyone else any issues.
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby gu3miles » Thu Apr 07, 2016 11:12 am

I did the above instructions... But did not work.

However, after I ran:
Code: Select all
sudo apt-get install chromium-browser:armhf
sudo apt-get -f install


Doing this worked, and now chrome opens, and stays open.
gu3miles
 
Posts: 2
Joined: Thu Apr 07, 2016 11:11 am
languages_spoken: english
ODROIDs: c2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Thu Apr 07, 2016 11:53 am

Which instructions? After running my script or something else?
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby davidlt9 » Sun Apr 10, 2016 6:29 am

I re-flashed my emmc chip and then ran the software updater.
Neither chromium or firefox worked.

I was able to get firefox running by doing this:
sudo apt-get install firefox:armhf

I then tried the script provided by ColonelPanic and that didn't work
Next I tried this:
sudo apt-get install chromium-browser:armhf
sudo apt-get -f install

Neither method fixed chromium. Was I supposed to uninstall it at some point?
davidlt9
 
Posts: 24
Joined: Sun Mar 20, 2016 12:52 am
languages_spoken: english
ODROIDs: C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby HerbsMix » Sun Apr 10, 2016 7:48 am

Thanks for script. I also fixed my Raspberry P12 after changing user name at the end of script.
HerbsMix
 
Posts: 63
Joined: Fri Dec 05, 2014 7:51 am
languages_spoken: english
ODROIDs: ODROID-XU3

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Mon Apr 11, 2016 5:35 pm

Vi the script and add
Code: Select all
set -x
to the very top line. run the script with

Code: Select all
./ChromiumFix.sh > CF.log
add the output of the log to this thread, it should tell me where/how it's failing.

davidlt9 wrote:I re-flashed my emmc chip and then ran the software updater.
Neither chromium or firefox worked.

I was able to get firefox running by doing this:
sudo apt-get install firefox:armhf

I then tried the script provided by ColonelPanic and that didn't work
Next I tried this:
sudo apt-get install chromium-browser:armhf
sudo apt-get -f install

Neither method fixed chromium. Was I supposed to uninstall it at some point?
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby Code4SaleLLC » Thu Apr 14, 2016 6:47 pm

No love for the C2, but the script did fix some RasPi's!

I will try it on some other boards as well (and report back).

Thank you!

I shall spread the word (and give credit as due).

Great Job! Thank you!
Code4SaleLLC
 
Posts: 26
Joined: Wed Nov 25, 2015 10:45 pm
languages_spoken: english
ODROIDs: XU4

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby Code4SaleLLC » Thu Apr 14, 2016 7:58 pm

Code4SaleLLC wrote:but the script did fix some RasPi's!


Oh! Chrome runs for a bit, then crashes on the Pi's. Still no love on the C2.

Sorry. I know a lot of work went into this (and please don't give up just yet).

What can I do to help?
Code4SaleLLC
 
Posts: 26
Joined: Wed Nov 25, 2015 10:45 pm
languages_spoken: english
ODROIDs: XU4

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby kutakmir » Fri Apr 15, 2016 9:17 pm

Is there any other browser that works?

For those who got it working: Would you mind sharing the img or 100% working script with the rest of us?

EDIT:
I got midori working ;)

sudo apt-get install midori
kutakmir
 
Posts: 11
Joined: Fri Mar 18, 2016 8:30 pm
languages_spoken: english
ODROIDs: odroid c2

Re: [Ubuntu] Updated Chromium doesn't work.

Unread postby ColonelPanic » Mon Apr 18, 2016 6:11 pm

Could you add
Code: Select all
set -x
to the script, run it, and tell me how it's failing? You could do
Code: Select all
./ChromiumFix.sh > test.log
to have to output printed to a text file, which may be easier to reference, or paste to this thread. I would be happy to try and fix it, if I know what the problem is.

Code4SaleLLC wrote:
Code4SaleLLC wrote:but the script did fix some RasPi's!


Oh! Chrome runs for a bit, then crashes on the Pi's. Still no love on the C2.

Sorry. I know a lot of work went into this (and please don't give up just yet).

What can I do to help?
Anything that can go wrong, w̤͉̺̠͔̗̤͈̙̜̻̩͖͙̲̬̒̑̔̅ͨ́ͦͭ̆̒̓́̊ͤͦ̎́͢͠͠͠ͅi̵̶͖̜̩͍̟̼̼̼̰̰̪̝̭̳̞̹͙͖̎̂̑͛̄̌̄ͩ̾̾̆̑ͤ͝ḻ̯̦̣͚͎̝̝͉̬͉̩͈̞̒ͩ̔ͧͮ͗ͩ̆ͤͪ̑͗͆ͭ͗͐͘͡l̵̸̛̛̞̯͕͎̦̤̫̅ͣ͑̈̈̎ͮ̽̎̿̿͑ ̡̢͚͉̳̹͚̤̯̪̬̟̙̭ͬ͒ͥ́̏̾̑ͣͤ̀̀ͩ̍̉̋͗͘͟͡ͅͅg̸̨̺͎͎͌ͭ̾͂ͫ͆́͒͒͋͂̒͌͆̑̏̎͢ͅo͒̋ͥ̃͊̏ͥ́́͏̰̻̘̼͚̣̗͚̹͎̠̙͕̝ ̸̢͓͓̘̣̹̗̬̗̫̤͇͕ͮ̄ͩͣ̃̔̕͝w̢̨̢̩̫͇̗͚̻̙͖̻̦͕̾̅̓̋͑͋͋ͣ̾ͤ̈͞r̶̦̰͓̮̤̯͚̪͖͇͓̝͎ͩ̐̈͋͐͘ǫ̸ͦ̾̏̽͢͏̣̦̙̯͎͕̣̗ṋ̢̯͉̙͈̥͙̺̳̟͍̜̀ͯ̌̇ͪ̄̀͟͟g͚͖̼̺͖͚̫̼͚̥͍̱̺̜͕̺͚̣ͪ̐̎ͫ̈̿̆ͦ̀́͡ ̌ͦ̉̃͏̶̨̙̞̜̞̮̪̰͕̲
ColonelPanic
 
Posts: 17
Joined: Sun Apr 03, 2016 9:19 pm
languages_spoken: english
ODROIDs: Odroid C2

Next

Return to News

Who is online

Users browsing this forum: No registered users and 4 guests