Playing with upstream (Exynos4412)

Share here your ideas for new projects
Post Reply
Obloczkus
Posts: 3
Joined: Thu Mar 13, 2014 6:42 pm
languages_spoken: english, polish
ODROIDs: U3
Has thanked: 0
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by Obloczkus »

If You can, please share with emmc-recovery image with the latest u-boot.
Cheers

jonB
Posts: 4
Joined: Sat Mar 23, 2019 5:53 am
languages_spoken: english, italian, brazilian portuguese
ODROIDs: U3
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by jonB »

This is great news! Have had my good old U3 on jessie for way too long. Hoping to find some documentation as this is as first for me on this board. I appreciate if you have any links to point me to to get started. Thanks.

X-MAN
Posts: 2
Joined: Mon Jun 01, 2020 6:50 pm
languages_spoken: english, german
ODROIDs: U3+
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Playing with upstream (Exynos4412)

Post by X-MAN »

Did someone have the login for the hexdump images? I want to login via SSH, thanks.

User avatar
meveric
Posts: 11192
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2, H2 (J4105), GoA, C4
Has thanked: 50 times
Been thanked: 412 times
Contact:

Re: Playing with upstream (Exynos4412)

Post by meveric »

the login is on the github page..
user: linux
password: changeme
These users thanked the author meveric for the post:
anatife (Wed Jul 22, 2020 5:15 am)
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

X-MAN
Posts: 2
Joined: Mon Jun 01, 2020 6:50 pm
languages_spoken: english, german
ODROIDs: U3+
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Playing with upstream (Exynos4412)

Post by X-MAN »

Thanks. Found it myself about an hour ago. It's a little bit hidden =) I also upgraded it to 20.04 LTS. Works like a charm :D Boinc running very good. Nearly half the computing time as on 14.04
Image
These users thanked the author X-MAN for the post:
odroid (Tue Jun 02, 2020 9:26 am)

User avatar
meveric
Posts: 11192
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2, H2 (J4105), GoA, C4
Has thanked: 50 times
Been thanked: 412 times
Contact:

Re: Playing with upstream (Exynos4412)

Post by meveric »

yeah I used the image as well, removed the XUbuntu desktop and installed MATE as well as updated to Ubuntu 20.04.
I also installed a freshly build Kernel 5.7 without any alteration, just straight from upstream no changes whatsoever.
Worked right out of the box.
3D was working via LIMA opensource driver, which does even support OpenGL 2.1.

It was "ok-ish" but performance is really not that great only about 30~33 FPS in glmark2-es2 and glmark2.
But hey it means you can run from default Kernels with no patches :)
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

EWIuser
Posts: 22
Joined: Sat Dec 27, 2014 11:25 pm
languages_spoken: French and English
ODROIDs: U3
Location: Montreal, Quebec Canada
Has thanked: 0
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by EWIuser »

Hey guys is this update to 20.04 also valid for the U3 ? I thought it was only available in 64bit and the U3 is 32bit.
Also is there a procedure written somewhere on how to transfer this image to EMMC on a U3 ?

3dfx
Posts: 15
Joined: Thu Aug 07, 2014 12:48 am
languages_spoken: English
ODROIDs: H2+, U3
Location: Bulgaria
Has thanked: 4 times
Been thanked: 2 times
Contact:

Re: Playing with upstream (Exynos4412)

Post by 3dfx »

@meveric, would you please provide a little bit more info on the kernel installation?
Did you compile it yourself, or it was precompiled?
Can you provide any short tutorial?
Thank you in advance!

ScottE
Posts: 4
Joined: Thu Nov 20, 2014 1:47 am
languages_spoken: english
ODROIDs: ODROID-U2
Has thanked: 0
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by ScottE »

I have 5.7.x (current 5.7.2, ala vanilla-sources on Gentoo) working on my odroid-u2, but am struggling with USB. EHCI works enough for the NIC to work if I disable DWC2, but the external USB ports don't work (and looks like OHCI doesn't probe properly).

Code: Select all

    0.953903] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.960442] ehci-exynos: EHCI Exynos driver
[    0.965182] exynos-ehci 12580000.ehci: EHCI Host Controller
[    0.970169] exynos-ehci 12580000.ehci: new USB bus registered, assigned bus number 1
[    0.978065] exynos-ehci 12580000.ehci: irq 46, io mem 0x12580000
[    1.005241] exynos-ehci 12580000.ehci: USB 2.0 started, EHCI 1.00
[    1.005816] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.07
[    1.013933] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.021157] usb usb1: Product: EHCI Host Controller
[    1.026013] usb usb1: Manufacturer: Linux 5.7.2-scotte ehci_hcd
[    1.031900] usb usb1: SerialNumber: 12580000.ehci
[    1.036989] hub 1-0:1.0: USB hub found
[    1.040342] hub 1-0:1.0: 3 ports detected
[    1.044869] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.050495] ohci-exynos: OHCI Exynos driver
[    1.054830] usbcore: registered new interface driver usb-storage
[    1.348662] hid: raw HID events driver (C) Jiri Kosina
[    1.405220] usb 1-2: new high-speed USB device number 2 using exynos-ehci
[    1.606577] usb 1-2: New USB device found, idVendor=0424, idProduct=9730, bcdDevice= 1.00
[    1.612585] usb 1-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    1.623027] smsc95xx v1.0.6
[    1.721591] smsc95xx 1-2:1.0 eth0: register 'smsc95xx' at usb-12580000.ehci-2, smsc95xx USB 2.0 Ethernet, ce:6a:2d:3a:a2:da
If I enable DWC2 (which is the right thing to do), then USB doesn't seem to probe at all, and I see errors related to dwc. :-/

Anyone have a working "modern" config I can compare against? (or have some clues about my current config that's attached? Note that it's headless/multimedia-less.)
Attachments
572_scotte-config.txt
(80.16 KiB) Downloaded 40 times

ScottE
Posts: 4
Joined: Thu Nov 20, 2014 1:47 am
languages_spoken: english
ODROIDs: ODROID-U2
Has thanked: 0
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by ScottE »

ScottE wrote:
Wed Jun 17, 2020 4:34 am
I have 5.7.x (current 5.7.2, ala vanilla-sources on Gentoo) working on my odroid-u2, but am struggling with USB. EHCI works enough for the NIC to work if I disable DWC2, but the external USB ports don't work (and looks like OHCI doesn't probe properly).
Looks like this patch at least fixes external USB up enough that I can use EHCI based umass and rtk network adapters:

Code: Select all

--- a/drivers/usb/core/message.c
+++ b/drivers/usb/core/message.c
@@ -2018,6 +2018,9 @@
                struct usb_interface *intf = cp->interface[i];

                if (intf->dev.of_node &&
+                   /* Fix odroud-u2/u3 USB
+                   From https://lore.kernel.org/lkml/26ff3deb-4b8d-7dd2-2418-d56f6dcea313@samsung.com/ */
+                   of_device_is_compatible(intf->dev.of_node, NULL) &&
                    !of_device_is_available(intf->dev.of_node)) {
                        dev_info(&dev->dev, "skipping disabled interface %d\n",
                                 intf->cur_altsetting->desc.bInterfaceNumber);


anatife
Posts: 18
Joined: Wed May 14, 2014 10:52 am
languages_spoken: english french spanish c c++ java perl python
ODROIDs: U3 , C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by anatife »

I have a couple of problems and I hope someone can assist.

After the log-in screen, I get a blank screen. How to diagnose this? I am able to get a terminal (e.g. ctrl-alt-F2) if I don't log in. I have apt-get updated/upgraded.

Second problem, is it possible to resize the SD card to use the full space? I wrote hexdump's image to a 16 GB SD card.

It is *awesome* to have Debian Buster for my U3. Thank you, friends!

hexdump
Posts: 18
Joined: Sat Jan 26, 2019 12:37 am
languages_spoken: english, german
ODROIDs: odroid u3
Has thanked: 0
Been thanked: 15 times
Contact:

Re: Playing with upstream (Exynos4412)

Post by hexdump »

@anatife there is a script to extend the root fs to the full space of the sd card in /root - just run it and / should use all remaining space afterwards ...

btw. i have built new odroid images, which have a new u-boot (v2020.07) with /boot/uEnv.txt support and a separat dtb for the u3 (without the plus - called u3noplus) ... you can find them here: https://github.com/hexdump0815/imagebui ... /200719-01

i'm not reading this forum here regularly, so maybe consider opening an issue on the above git repo in case of problems or ideas, but please do not expect professional grade response times :)

more info: some notes about building mainline u-boot for the u3 and how to write it to sd or emmc: https://github.com/hexdump0815/u-boot-m ... readme.exy

best wishes - hexdump

anatife
Posts: 18
Joined: Wed May 14, 2014 10:52 am
languages_spoken: english french spanish c c++ java perl python
ODROIDs: U3 , C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by anatife »

Hello hexdump, it's kind of you to reply! I know that you do this for fun and not for the riches. (o;

I did the resize commands manually and it worked well. Video is still not working but having Debian Buster with ssh is good enough for my needs.

I'll join your project on github. Thank you for the new images!

hexdump
Posts: 18
Joined: Sat Jan 26, 2019 12:37 am
languages_spoken: english, german
ODROIDs: odroid u3
Has thanked: 0
Been thanked: 15 times
Contact:

Re: Playing with upstream (Exynos4412)

Post by hexdump »

i got my hands on an odroid x meanwhile and have added support for it to my u-boot build and my images now ... i have built new debian buster and ubuntu bionic images for the odroid u3/x2/x and maybe u2/u too - i have no access to any u2/u, so i cannot test them - feel free to donate me one if you have one and like to :) ... the images are available now here:
https://github.com/hexdump0815/imagebui ... /200823-01

kernel build info:
https://github.com/hexdump0815/linux-ma ... readme.exy

u-boot build info:
https://github.com/hexdump0815/u-boot-m ... readme.exy

they are based on the linux kernel v5.4.58 and have some other small fixes and changes. besides them i have also added a ubuntu focal test build of my dev branch at the same place ... some of the changes of the dev branch are mentioned on the download link above

in case you want try to do something completely different with your odroid, you might give my odroid u3/x2/x build of the sonaremin a try, which is a virtual modular synthesizer based on vcvrack:
https://github.com/hexdump0815/sonaremi ... v7l.img.gz

best wishes - hexdump
These users thanked the author hexdump for the post (total 3):
AreaScout (Mon Aug 24, 2020 3:19 pm) • robgue (Tue Aug 25, 2020 1:40 pm) • 3dfx (Tue Aug 25, 2020 10:07 pm)

robgue
Posts: 5
Joined: Thu Mar 28, 2013 5:49 am
languages_spoken: english
ODROIDs: U2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by robgue »

Thanks for this! I'm going to get my old U2 out of the junk drawer.

LiquidAcid
Posts: 1094
Joined: Fri Oct 11, 2013 11:07 pm
languages_spoken: english
ODROIDs: X2
Has thanked: 0
Been thanked: 2 times
Contact:

Re: Playing with upstream (Exynos4412)

Post by LiquidAcid »

Pushed odroid-5.4.y and odroid-5.8.y to my repo. I also migrated from Gentoo to Debian 10 on the board, since compilation of some packages is just not feasible anymore (due to increasing amount of memory consumption, in particular during the linking stage).

Surprisingly the migration worked rather smoothly. I just prepared a Debian 10 armhf environment on my desktop via debootstrap --foreign --arch=armhf and then allocated some space on the X2's SD card and moved the environment there. Then I just changed to bootloader to use the Debian filesystem as rootfs, /bin/sh as init and rootfs r/w mounting. First boot was done via serial console where I did the second stage of debootstrap, after which I changed init back to default. Second boot already got me a working Debian environment. Things are still a bit rough around the edges, but it's coming along.
These users thanked the author LiquidAcid for the post:
odroid (Thu Sep 03, 2020 9:32 am)

jonB
Posts: 4
Joined: Sat Mar 23, 2019 5:53 am
languages_spoken: english, italian, brazilian portuguese
ODROIDs: U3
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by jonB »

hexdump wrote: imagebuilder scripts available at:
https://github.com/hexdump0815/imagebuilder
Hi hexdump,

Have been playing with your imagebuilder script... thanks for sharing - quite useful to revive my Odroid-U3 into something quite useful...At the moment am trying to add module fuse to it to attach external storage... but need to dig deeper on how to achieve this... any pointers or info please?

Also, the imagebuilder script does it support cross-compilation i.e. build a u3 arm image from a different device like x64 or another arm device?

Thanks in advance.

hansan
Posts: 11
Joined: Fri Jan 03, 2014 6:47 am
languages_spoken: English, Dutch, German, Japanese
ODROIDs: ODROID-U3
2x ODROID-HC1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by hansan »

anatife wrote:
Sat Jul 25, 2020 8:57 pm
Video is still not working but having Debian Buster with ssh is good enough for my needs.
Dear Anatife,

I believe I have the same issue. I can "login" with lightdm but I end up with a black screen. Both the Debian buster and the ubuntu 18.04 image have this problem for me. Were you able to solve this?

Needless to say is the ssh access working great.

Kind regards.

Hansan

hexdump
Posts: 18
Joined: Sat Jan 26, 2019 12:37 am
languages_spoken: english, german
ODROIDs: odroid u3
Has thanked: 0
Been thanked: 15 times
Contact:

Re: Playing with upstream (Exynos4412)

Post by hexdump »

@anatife @hansen - can you maybe give this image a try: https://github.com/hexdump0815/imagebui ... dev.img.gz - this is my dev image for ubuntu focal and for me it works perfectly fine on a odroid x, x2 and u3 and two different monitors (1280x1024 and 1980x1080, both via hdmi or vga to hdmi adapters) - if this image does not work neither then you might try to play around with forcing a certain hdmi mode (something like drm.edid_firmware=edid/1280x1024.bin or video=HDMI-A-1:1280x1024@60 on the kernel cmdline - for a mode the monitor supports of course)

@jonB for adding fuse support you might need to build a new kernel - see: https://github.com/hexdump0815/linux-ma ... readme.exy for how i build the kernel ... the scripts are not ment for cross compiling - i'm always building kernels and images on arm boxes directly

btw. i'm currently testing how useable those devices (2gb versions) are as desktop system and i'm surprised how well this works - i'm typing this on an odroid x2 overclocked to 1.7ghz right now which i'm currently using as my main desktop system using my above mentioned focal dev image - not that bad for an 8 years old sbc which was never really ment as a desktop system (ok - not as fast as a contemporary pc or laptop, but still quite useable)

i also noticed that even suspend/resume is working on the u3 (not yet tested on the x2) - tested with the same focal dev image - suspend via xfce logout menu and resume via that button on the u3 - root fs is on a usb stick in this case

best wishes - hexdump
These users thanked the author hexdump for the post:
hansan (Sat Oct 31, 2020 6:50 am)

hansan
Posts: 11
Joined: Fri Jan 03, 2014 6:47 am
languages_spoken: English, Dutch, German, Japanese
ODROIDs: ODROID-U3
2x ODROID-HC1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by hansan »

Dear Hexdump,

Thanks for your work on this. I will check the ubuntu focal image and report back to you. In all honesty I cannot really exclude a questionable micro HDMI cable.

Greetings,

Han

mories
Posts: 33
Joined: Fri Mar 21, 2014 6:23 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

How to get the kernel to define /dev/fb0

Post by mories »

I want to use framebuffer-vncserver (VNC server for Linux framebuffer devices), but neither in the hexdump's last image for U3 nor in other vanilla 5.4.y kernels that I have compiled, /dev/fb0 is generated.
In old hardkernel's 3.8.y kernel there was /dev/fb0.
Someone knows how to configure a kernel 5.4.y for such a device to be created in U3.?

hansan
Posts: 11
Joined: Fri Jan 03, 2014 6:47 am
languages_spoken: English, Dutch, German, Japanese
ODROIDs: ODROID-U3
2x ODROID-HC1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by hansan »

The new ubuntu focal image did not work for me. That means the screen still stays black and I do not get an graphical login prompt on my monitor. On my TV I can get a text mode terminal; but it does not fully reproduce... and the graphical login does not show up. I assume that this means that my micro-hdmi cable is bad. I will get a new cable / micro HDMI to HDMI adapter and try again.

I have installed the image to a 32Gbyte micro sd card. I did do

Code: Select all

sudo apt-get update
sudo apt-get upgrade
I have added my boot log (dmesg) and Xorg log maybe it shows why my screen stays black. (I did not recognize a clear error....)

To be continued....
Attachments
tv-Xorg.0.log
Xorg log on TV 1920x1080
(17.53 KiB) Downloaded 9 times
tv-dmesg.log
dmesg boot log on tv 1920x1080
(37.82 KiB) Downloaded 6 times
monitor-Xorg.0.log
Xorg log on monitor 1920x1080
(17.53 KiB) Downloaded 8 times
monitor-dmesg.log
dmesg boot log on monitor 1920x180
(37.47 KiB) Downloaded 6 times

nijhawank
Posts: 43
Joined: Sat Aug 03, 2013 7:35 am
languages_spoken: english
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Playing with upstream (Exynos4412)

Post by nijhawank »

For the people who get black screen after logging, try removing video=HDMI-A-1:1280x1024@60 from the extlinux.conf

hansan
Posts: 11
Joined: Fri Jan 03, 2014 6:47 am
languages_spoken: English, Dutch, German, Japanese
ODROIDs: ODROID-U3
2x ODROID-HC1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by hansan »

by nijhawank » Fri Oct 16, 2020 6:09 am
For the people who get black screen after logging, try removing video=HDMI-A-1:1280x1024@60 from the extlinux.conf
I can more or less confirm this. When I use something to fix a monitor format (I mainly checked 1920x1080) with

Code: Select all

video=HDMI-A-1:1920x1080@60
my screen stays black but with the following

Code: Select all

video=HDMI-A-1:e
I can get a login screen when I restart the display manager (lightdm).

So I think that things / timing is rather sensitive, but my cable is / was not the problem. My monitor has a resolution of 1920x1200 and this format is not supported; this can be also a reason why things don't work. However on my 1920x1080 television was I also not successful.

I have this in my "extlinux.conf":

Code: Select all

linux@changeme:~$ cat /boot/extlinux/extlinux.conf 
TIMEOUT 30
DEFAULT linux

MENU TITLE odroid u3 boot options

LABEL linux
      MENU LABEL linux
      LINUX ../zImage-5.4.58-stb-exy+
      INITRD ../initrd.img-5.4.58-stb-exy+
# odroid u3
      FDT ../dtb-5.4.58-stb-exy+/exynos4412-odroidu3noplus.dtb
# use this line instead of the one below in case hdmi video is unstable for a 1024x768 video mode
#      APPEND earlycon console=ttySAC1,115200n8 console=tty1 mem=2047M smsc95xx.macaddr=ba:5d:6d:41:68:6f root=PARTUUID=cf4c6c41-02 ro loglevel=8 rootwait net.ifnames=0 pv6.disable=1 fsck.repair=yes drm.edid_firmware=edid/1024x768.bin video=HDMI-A-1:e
#      APPEND earlycon console=ttySAC1,115200n8 console=tty1 mem=2047M smsc95xx.macaddr=ba:5d:6d:41:68:6f root=PARTUUID=cf4c6c41-02 ro loglevel=8 rootwait net.ifnames=0 ipv6.disable=1 fsck.repair=yes drm.edid_firmware=edid/1920x1080.bin video=HDMI-A-1:1920x1080@60
# this line works for me:
      APPEND earlycon console=ttySAC1,115200n8 console=tty1 mem=2047M smsc95xx.macaddr=ba:5d:6d:41:68:6f root=PARTUUID=cf4c6c41-02 ro loglevel=8 rootwait net.ifnames=0 ipv6.disable=1 fsck.repair=yes video=HDMI-A-1:e
Furthermore I have added the following line to my rc.local to restart the lightdm.service after 20 seconds. (This time is relative arbitrary; I can imagine that moving the service to a later start time with systemd could work as well.)

Code: Select all

linux@changeme:~$ tail /etc/rc.local
# uncomment this to get rid of the blinking blue led
#echo none > /sys/class/leds/led1:heart/trigger

# I question if this all is working
MYLOG=/var/log/hanrc.log

echo `date` >> ${MYLOG}
(sleep 20;  /usr/bin/systemctl restart lightdm.service 2>&1 >> ${MYLOG}) &

exit 0
This makes that I am greeted by a login screen and I can login into the desktop version. So a success !!

I do have sometimes a bit of a "wiggle" in the screen; just if the timing of the video signal gets lost. Occasionally is the screen becoming black for a few seconds. Maybe it is due to my unsupported monitor size....

Next I have to get this image on my emmc and I am up and running again!
Thanks for making these images and kernels for this Odroid U3!!

hansan
Posts: 11
Joined: Fri Jan 03, 2014 6:47 am
languages_spoken: English, Dutch, German, Japanese
ODROIDs: ODROID-U3
2x ODROID-HC1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Playing with upstream (Exynos4412)

Post by hansan »

Just an update from my side.

It was not the success I thought; the occasional wiggle in the screen was a bit distracting. But the monitor started to become black quite often and I had to change to the console and back to get my screen back. I think there went something wrong with the timing in the HDMI which doesn't did work with my monitor. (Nothing special: an AOC P2460Pxqu https://eu.aoc.com/de/monitors/p2460pxqu/support

I have upgraded my kernel to version 5.9.0 with the information from here: https://github.com/hexdump0815/linux-ma ... readme.exy and now is the image on my monitor not becoming black anymore. (The wiggle is occasionally still there.) My compliments to hexdump for his good work on this.

I did had to correct this post. I forgot one patch and therefore was my Mali driver not working / not loaded. When i use the right patches is it of course working.

For now I am quite satisfied. Greetings!

Post Reply

Return to “The Ideas”

Who is online

Users browsing this forum: No registered users and 2 guests