Why is there is no SSL support for the forum?

Share here your ideas for new projects

Moderators: meveric, mdrjr, odroid

Why is there is no SSL support for the forum?

Unread postby xymantec » Tue Apr 11, 2017 12:49 pm

Why is there no SSL support for the forum? This is basic security for any web application and it's users privacy.
My signature, something cool and "original" for everyone to admire...
User avatar
xymantec
 
Posts: 18
Joined: Fri Mar 24, 2017 5:00 am
Location: Woodland, WA
languages_spoken: english, spanish, italian, portoguese
ODROIDs: C2

Re: Why is there is no SSL support for the forum?

Unread postby brad » Tue Apr 11, 2017 4:57 pm

xymantec wrote:Why is there no SSL support for the forum? This is basic security for any web application and it's users privacy.


Especially as the username and password is transferred over plain text on the login page, I agree this forum needs to be SSL'ed and certificates cost almost nothing these days.
brad
 
Posts: 553
Joined: Tue Mar 29, 2016 1:22 pm
Location: Australia
languages_spoken: english
ODROIDs: C2

Re: Why is there is no SSL support for the forum?

Unread postby odroid » Tue Apr 11, 2017 4:59 pm

We will learn what is the SSL and how to add it our forum server. :oops:
User avatar
odroid
Site Admin
 
Posts: 24051
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Why is there is no SSL support for the forum?

Unread postby memeka » Tue Apr 11, 2017 5:04 pm

odroid wrote:We will learn what is the SSL and how to add it our forum server. :oops:


https://letsencrypt.org/ issues free certificates, don't need to pay anything (but i think you need to update it often).
User avatar
memeka
 
Posts: 3529
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART

Re: Why is there is no SSL support for the forum?

Unread postby mad_ady » Wed Apr 12, 2017 7:00 pm

They have some scripts which handle updating automatically
User avatar
mad_ady
 
Posts: 2197
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2

Re: Why is there is no SSL support for the forum?

Unread postby synportack24 » Thu Apr 20, 2017 8:30 am

And ta-da! Now the forum supports HTTPS!
User avatar
synportack24
 
Posts: 105
Joined: Sat Jan 10, 2015 10:16 am
Location: 대한민국 - 안양시
languages_spoken: English, German, Korean
ODROIDs: C0, C1, C1+, C2, XU4

Re: Why is there is no SSL support for the forum?

Unread postby brad » Thu Apr 20, 2017 6:19 pm

synportack24 wrote:And ta-da! Now the forum supports HTTPS!


Yes great news, thanks hardkernel!
brad
 
Posts: 553
Joined: Tue Mar 29, 2016 1:22 pm
Location: Australia
languages_spoken: english
ODROIDs: C2

Re: Why is there is no SSL support for the forum?

Unread postby elatllat » Fri Apr 21, 2017 1:31 am

nice
elatllat
 
Posts: 511
Joined: Tue Sep 01, 2015 8:54 am
languages_spoken: english
ODROIDs: XU4

Re: Why is there is no SSL support for the forum?

Unread postby rooted » Fri Apr 21, 2017 5:29 am

It is nice, the forum no longer exhibits terrible speeds in the US since the upgrade as well.

Thanks Hardkernel, that was driving me mad occasionally :)
User avatar
rooted
 
Posts: 3652
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1
C1+
C2
XU3 Lite
XU4
VU7+
HiFi Shield 2
Smart Power (original)

Re: Why is there is no SSL support for the forum?

Unread postby elatllat » Fri Apr 21, 2017 5:41 am

elatllat
 
Posts: 511
Joined: Tue Sep 01, 2015 8:54 am
languages_spoken: english
ODROIDs: XU4

Re: Why is there is no SSL support for the forum?

Unread postby rooted » Fri Apr 21, 2017 6:29 am


Good catch, enabling the expiry caching feature would save them quite a bit of bandwidth over a months time.
User avatar
rooted
 
Posts: 3652
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1
C1+
C2
XU3 Lite
XU4
VU7+
HiFi Shield 2
Smart Power (original)

Re: Why is there is no SSL support for the forum?

Unread postby xymantec » Sun Apr 30, 2017 8:36 am

Nice, now I actually feel comfortable logging in lol...
User avatar
xymantec
 
Posts: 18
Joined: Fri Mar 24, 2017 5:00 am
Location: Woodland, WA
languages_spoken: english, spanish, italian, portoguese
ODROIDs: C2

Re: Why is there is no SSL support for the forum?

Unread postby indium » Mon May 01, 2017 3:54 am

xymantec wrote:Nice, now I actually feel comfortable logging in lol...

yup, this sounds like a Tampax advertisement. :lol:
indium
 
Posts: 89
Joined: Thu May 28, 2015 2:27 pm
Location: Ukraine
languages_spoken: english, ukrainian

Re: Why is there is no SSL support for the forum?

Unread postby EarBiteR » Mon May 01, 2017 6:02 am

Its nice that the forums are now ssl secured!

The 'remember' option when logging on only lasts a couple days for me so I would like to see that fixed.

It would also be nice to have a 'mark all topics read and CLOSE tab' option available.
EarBiteR
 
Posts: 9
Joined: Wed Mar 18, 2015 12:13 pm
languages_spoken: english
ODROIDs: C2 running libre-elec

Re: Why is there is no SSL support for the forum?

Unread postby xymantec » Wed May 03, 2017 2:53 pm

indium wrote:
xymantec wrote:Nice, now I actually feel comfortable logging in lol...

yup, this sounds like a Tampax advertisement. :lol:


You would know right? I am not sure how wanting to be secure makes you a fool but whatever bro have fun with that.
User avatar
xymantec
 
Posts: 18
Joined: Fri Mar 24, 2017 5:00 am
Location: Woodland, WA
languages_spoken: english, spanish, italian, portoguese
ODROIDs: C2

Re: Why is there is no SSL support for the forum?

Unread postby umiddelb » Mon Jun 12, 2017 2:39 pm

Thank you!
umiddelb
 
Posts: 411
Joined: Thu Jan 29, 2015 6:42 am
languages_spoken: English, German
ODROIDs: ODROID-C1, ODROID-XU4, ODROID-C2

Re: Why is there is no SSL support for the forum?

Unread postby elatllat » Fri Jul 28, 2017 9:31 pm

Please change
<script type="text/javascript" src="http://wcs.naver.net/wcslog.js"></script>
to
<script src="//wcs.naver.net/wcslog.js"></script>
in the footer if you want that tracking to work for those without an ad blocker.
Attachments
Screen Shot 2017-07-28 at 08.25.12.png
Screen Shot 2017-07-28 at 08.25.12.png (20.8 KiB) Viewed 216 times
elatllat
 
Posts: 511
Joined: Tue Sep 01, 2015 8:54 am
languages_spoken: english
ODROIDs: XU4

Re: Why is there is no SSL support for the forum?

Unread postby neal » Thu Aug 03, 2017 5:46 pm

elatllat wrote:Please change
<script type="text/javascript" src="http://wcs.naver.net/wcslog.js"></script>
to
<script src="//wcs.naver.net/wcslog.js"></script>
in the footer if you want that tracking to work for those without an ad blocker.


Changed! thanks elatllat!

BTW, this is wired to me.
Maybe I don't understand phpbb cache system.

There is the file cached by the forum server. Nobody added NAVER analytics you find it.
I just guess, PHPBB cache system running while NAVER BOT gathering their log on our forum.
Anyway, I'm not sure to modify the cached file by hard coded. and it works.
neal
 
Posts: 16
Joined: Fri Apr 14, 2017 10:02 am
languages_spoken: english


Return to The Ideas

Who is online

Users browsing this forum: No registered users and 1 guest