enable kgdb on odroid-q2 kernel. compile error

Moderators: mdrjr, odroid

enable kgdb on odroid-q2 kernel. compile error

Unread postby aapril » Thu Dec 26, 2013 12:49 pm

Hi
I'm trying to use kgdb to debug.
using kernel_android4.2_4412 and enable kgdb.
Has anyone met this error before?
---------------------------------------------------------------------------------------
kernel/debug/debug_core.c: In function 'dbg_touch_watchdogs':
kernel/debug/debug_core.c:450:2: error: implicit declaration of function 'rcu_cpu_stall_reset'
make[2]: *** [kernel/debug/debug_core.o] Error 1
make[2]: *** Waiting for unfinished jobs....
CC kernel/power/process.o

How to fix this?

Thanks
aapril
 
Posts: 3
Joined: Thu Dec 26, 2013 12:44 pm
languages_spoken: english
ODROIDs: Q2

Re: enable kgdb on odroid-q2 kernel. compile error

Unread postby odroid » Thu Dec 26, 2013 1:10 pm

Which BSP version do you try?
If you use the Kernel 3.4, there are many issues probably.

Android 4.1.x with Kernel 3.0 seems to be better.
User avatar
odroid
Site Admin
 
Posts: 28863
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: enable kgdb on odroid-q2 kernel. compile error

Unread postby keener2u » Wed Jan 15, 2014 3:02 pm

I am seeing the same error with multiple kernel versions from git including 3.0.51 and also from the kernel included with the BSP and the CM10.1 and 10.2 kernel. I just moved over to the odroid-3.8.y branch and everything seems to compile ok. Unfortunately there doesn't look to be an odroidu2_android_sdmmc_defconfig to compile against.
keener2u
 
Posts: 2
Joined: Wed Jan 15, 2014 6:48 am
languages_spoken: english
ODROIDs: odroid-u2

Re: enable kgdb on odroid-q2 kernel. compile error

Unread postby odroid » Wed Jan 15, 2014 6:21 pm

The 3.8 Kernel is not compatible with Android.
It is only for generic Linux like Ubuntu.

We tried to fix that KGDB issue.
But we couldn't do because of very complex dependancies. Sorry about that.
User avatar
odroid
Site Admin
 
Posts: 28863
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: enable kgdb on odroid-q2 kernel. compile error

Unread postby aapril » Thu Jan 16, 2014 3:45 pm

odroid wrote:Which BSP version do you try?
If you use the Kernel 3.4, there are many issues probably.

Android 4.1.x with Kernel 3.0 seems to be better.

I'm using Android4.2 with kernel3.0
aapril
 
Posts: 3
Joined: Thu Dec 26, 2013 12:44 pm
languages_spoken: english
ODROIDs: Q2

Re: enable kgdb on odroid-q2 kernel. compile error

Unread postby aapril » Thu Jan 16, 2014 3:50 pm

odroid wrote:The 3.8 Kernel is not compatible with Android.
It is only for generic Linux like Ubuntu.

We tried to fix that KGDB issue.
But we couldn't do because of very complex dependancies. Sorry about that.


can you give a bit more describe what this issue about? Is the linux kernel's issue or related to odroid?
Do you know any version of kernel can work with kgdb in odroid?

Thanks
aapril
 
Posts: 3
Joined: Thu Dec 26, 2013 12:44 pm
languages_spoken: english
ODROIDs: Q2


Return to ODROID-Q2

Who is online

Users browsing this forum: No registered users and 3 guests