Linux-odroid-3.0.y problem

Moderators: mdrjr, odroid

Linux-odroid-3.0.y problem

Unread postby sslab » Wed Apr 10, 2013 12:50 am

Hello,
In the Linux-odroid-3.0.y (y=70) source tree, I disabled the "android low memory killer" staging device driver and compiled it with odroidq_ubuntu_defconfig.
The compilation was succeeded (Ubuntu 12.10+gcc-linux-armeabihf), but the zImage can not be booted.
Can you check what's the problem?
Thank you.
sslab
 
Posts: 19
Joined: Wed Feb 27, 2013 12:23 pm
languages_spoken: english
ODROIDs: Odroid-Q2

Re: Linux-odroid-3.0.y problem

Unread postby mdrjr » Wed Apr 10, 2013 1:09 am

What parameters are you using to boot the kernel?
Are you using mem=2047M ?
mdrjr
Site Admin
 
Posts: 11691
Joined: Fri Feb 22, 2013 11:34 pm
Location: Brazil
languages_spoken: english, portuguese
ODROIDs: -

Re: Linux-odroid-3.0.y problem

Unread postby sslab » Wed Apr 10, 2013 12:26 pm

Here is the parameters in the boot.scr.
bootcmd: fatload mmc 0:1 0x40008000 zImage; fatload mmc 0:1 0x42000000 uInitrd; boom 0x40008000 0x42000000
bootargs: console=tty1 console=ttySAC1,115200n8 root=/dev/mmcbl1p2 rootwait ro
The same parameters I used to boot the Ubuntu Desktop.
sslab
 
Posts: 19
Joined: Wed Feb 27, 2013 12:23 pm
languages_spoken: english
ODROIDs: Odroid-Q2

Re: Linux-odroid-3.0.y problem

Unread postby mdrjr » Wed Apr 10, 2013 3:12 pm

add to bootargs mem=2047M
mdrjr
Site Admin
 
Posts: 11691
Joined: Fri Feb 22, 2013 11:34 pm
Location: Brazil
languages_spoken: english, portuguese
ODROIDs: -

Re: Linux-odroid-3.0.y problem

Unread postby sslab » Wed Apr 10, 2013 6:10 pm

Still failed to boot using the following bootargs: console=tty1 console=ttySAC1,115200n8 mem=2047M
Any dependence on the toolchain version?
sslab
 
Posts: 19
Joined: Wed Feb 27, 2013 12:23 pm
languages_spoken: english
ODROIDs: Odroid-Q2

Re: Linux-odroid-3.0.y problem

Unread postby mdrjr » Wed Apr 10, 2013 7:10 pm

sslab wrote:Still failed to boot using the following bootargs: console=tty1 console=ttySAC1,115200n8 mem=2047M
Any dependence on the toolchain version?


Linaro GCC 4.7 or 4.6
mdrjr
Site Admin
 
Posts: 11691
Joined: Fri Feb 22, 2013 11:34 pm
Location: Brazil
languages_spoken: english, portuguese
ODROIDs: -

Re: Linux-odroid-3.0.y problem

Unread postby sslab » Wed Apr 10, 2013 7:46 pm

Toolchain version is OK, arm-linux-gnueabihf-gcc-4.7.3 .
I tried again using a clean machine.
It still failed.
Any problem with the odroidq_ubuntu_defconfig on Odroid-Q2?
Thank you!
sslab
 
Posts: 19
Joined: Wed Feb 27, 2013 12:23 pm
languages_spoken: english
ODROIDs: Odroid-Q2


Return to ODROID-Q2

Who is online

Users browsing this forum: No registered users and 2 guests