Failed to boot from nvme

Post Reply
manelcab
Posts: 2
Joined: Mon May 09, 2022 1:26 am
languages_spoken: english
ODROIDs: odroid-m1
Has thanked: 0
Been thanked: 0
Contact:

Failed to boot from nvme

Post by manelcab »

Hi, I am Manel, the M1 is my first Odroid SBC.

I've installed the Ubuntu OS image by OTP way into my nvme , I've tested both Ubuntu images from https://wiki.odroid.com/odroid-m1/os_im ... ntu/ubuntu

When I restart M1 Ubuntu begins to load (I can see the ubuntu logo) but after some seconds it finish with the two types of messages:
Most of times the error is the following:
1652452415347.jpg
1652452415347.jpg (817.59 KiB) Viewed 267 times
And sometimes the error is:
1652455620855.jpg
1652455620855.jpg (926.02 KiB) Viewed 267 times
The same process but using SD card runs Ubuntu ok without any problem (but previously I have to disconnect physically nvme device)

In petitboot shell I've checked that I can read the contents of nvme, remounted in r/w and testes that it is possible to write, no problems here.
Also, I've tried to install by netboot but the installation process is hunged.

The nvme model is: Patriot P300 M.2 PCIe Gen 3 x4 128GB SSD NVMe M.2 - P300P128GM28
814fPBhbIEL._AC_SL1500_.jpg
814fPBhbIEL._AC_SL1500_.jpg (127.75 KiB) Viewed 267 times
I've updated petitboot by pb-update, current version: dev.20220424

Boot arguments: quiet splash plymouth.ignore-serial-consoles earlycon=uart8250,mmio32,0xfe660000 console=tty1 pci=nomsi fsck.mode=force fsck.repair=yes mtdparts=sfc_nor:0x20000@e0000..... console=ttyFIQ0

Thank you very much

User avatar
tobetter
Posts: 9809
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 625 times
Been thanked: 1652 times
Contact:

Re: Failed to boot from nvme

Post by tobetter »

I'm afraid your NVMe is not compatible to boot off with Petitboot, I have another NVMe that does not boot after Petitboot (Silicon Power).

manelcab
Posts: 2
Joined: Mon May 09, 2022 1:26 am
languages_spoken: english
ODROIDs: odroid-m1
Has thanked: 0
Been thanked: 0
Contact:

Re: Failed to boot from nvme

Post by manelcab »

tobetter wrote:I'm afraid your NVMe is not compatible to boot off with Petitboot, I have another NVMe that does not boot after Petitboot (Silicon Power).
Hi, thank you for info, if so then that's a pitty :(
Thanks

Enviado desde mi M2007J3SG mediante Tapatalk


Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest