Ubuntu does not boot

Post Reply
sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Ubuntu does not boot

Post by sushmitha.rao »

I have Ubuntu desktop running on 16gb emmc module. I installed thingsboard.io on Ubuntu desktop. After power off when I power on the board again.. It does not go to the login page for ubuntu. It appears just a black screen with ubuntu logo at the bottom.

User avatar
tobetter
Posts: 10969
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 737 times
Been thanked: 1868 times
Contact:

Re: Ubuntu does not boot

Post by tobetter »

sushmitha.rao wrote:
Wed Sep 07, 2022 4:59 pm
I have Ubuntu desktop running on 16gb emmc module. I installed thingsboard.io on Ubuntu desktop. After power off when I power on the board again.. It does not go to the login page for ubuntu. It appears just a black screen with ubuntu logo at the bottom.
Can you introduce how you installed thingsboard.io?
Did you check the file system whether it's corrupted or not?

sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Ubuntu does not boot

Post by sushmitha.rao »

I installed via terminal through commands at https://thingsboard.io/docs/user-guide/install/ubuntu/

Also, I want to know how do I reset my M1 board

User avatar
tobetter
Posts: 10969
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 737 times
Been thanked: 1868 times
Contact:

Re: Ubuntu does not boot

Post by tobetter »

sushmitha.rao wrote:
Wed Sep 07, 2022 5:08 pm
I installed via terminal through commands at https://thingsboard.io/docs/user-guide/install/ubuntu/

Also, I want to know how do I reset my M1 board
I don't think any command in the page breaks the OS, so it would be file system has some error or something else. When you boot next time, connect USB keyboard and press ALT-F1 or F7 whatever the keys and check if you can have login prompt rather thank Ubuntu logo screen. Also check your eMMC file system if it's corrupted or not.

If you meant hardware reset, one easy ways is remove the DC cable or add a switch to the pin header in the photo.
Image
These users thanked the author tobetter for the post:
sushmitha.rao (Wed Sep 07, 2022 6:56 pm)

sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Ubuntu does not boot

Post by sushmitha.rao »

I think the commands are corrupting the OS. I tried the same with OS installed on sdcard. After installation, when I reboot the OS is corrupted.

Also, how do I check if the file system is corrupted if the system does not boot at all.

User avatar
tobetter
Posts: 10969
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 737 times
Been thanked: 1868 times
Contact:

Re: Ubuntu does not boot

Post by tobetter »

sushmitha.rao wrote:
Wed Sep 07, 2022 6:55 pm
I think the commands are corrupting the OS. I tried the same with OS installed on sdcard. After installation, when I reboot the OS is corrupted.

Also, how do I check if the file system is corrupted if the system does not boot at all.
You need yet another Linux machine like PC and check the file system using fsck on it, your SD card must be attached using SD card reader. Highly do not recommend to run SD card which is slow storage and weak, it could system runs slowly. Use eMMC or SSD or NVMe on ODROID-M1.

sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Ubuntu does not boot

Post by sushmitha.rao »

When I try to boot from eMMC module, it says PCIe link fail.
rk-pcie 3c0800000.pcie: failed to initialise host

User avatar
tobetter
Posts: 10969
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 737 times
Been thanked: 1868 times
Contact:

Re: Ubuntu does not boot

Post by tobetter »

sushmitha.rao wrote:
Wed Sep 07, 2022 7:53 pm
When I try to boot from eMMC module, it says PCIe link fail.
rk-pcie 3c0800000.pcie: failed to initialise host
Do you have any PCIe device installed to ODROID-M1? Otherwise, the error message is normal.

sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Ubuntu does not boot

Post by sushmitha.rao »

This is the message I see on screen when i boot the device


Code: Select all

[
1.154263] spi_master spio: cannot find modallas for /spi@fe610000/pcfg-pull
-none-dry-level-1
[
1.154315] spi_master spio: cannot find modalias for /spi@fe610000/pcfg-pull
-none
[
1.154356] spi_master spio: cannot find modalias for /spi@fe610000/pcfg-pull
-LO
[
1.157849] dwc3 fcc00000.dwc3: Failed to get clk
'ref':
1.161767] dwc3 fd000000. dwc3: Failed to get clk
'ref
-2
-2
[
[
[
I
I
1.330945]
.. r pum remotecti v2.0 init
1.383592] rk817-battery rkB17-battery: Failed to find matching dt id
1.384002] rk817-charger rkB17-charger: Failed to find matching dt id
1.417615] cpu cpuo: failed to find power model node
1.446534] mmc0: Unknown controller version (5). You may experience problems
1.4799271 rockchip, bus bus-npu: Failed to get leakage
I
1.482485] rksfc_base v1.1 2016-01-08
1.483228] rkflash_dev_init enter
1.486236] rkflash_dev_init device register as mtd dev, ret=
[
1.5177661 mali fde60000.gpu: dev_pm_opp_set _regulators: no regulator (shade
cores) found:
-19
I
1.519505] asoc-simple-card rk809-sound: ASOC: DAPM unknown pin Headphones
[
1.530292] rkgmac-dumac feza0000.ethernet: no regulator found
[
1.535766] rk_gmac-dumac feza0000.ethernet: rk_get _eth_addr: mac address: 00
:le:06:51:01:97
[
1.668036] devfreq fde60000.gpu: Couldn't update frequency transition informatior
1.670875] asoc-simple-card rk809-sound: ASoC: DAPM unknown pin Headphones
BusyBox v1.30.1 (Ubuntu 1:1.30.1-4ubuntu6.4) built-in shell (ash)
Enter
*help
for a list of built-in commands.
(initramfs) [
[
12.240571] rk-pcie 3c0800000.pcle: PCIe Link Fail
12.240654] rk-pcie 3c0800000.pcie: failed to initialize host
Attachments
I get this when i boot the device
I get this when i boot the device
399F1FFA-3021-47D0-B2DE-65F1AC3296E2.jpeg (1.22 MiB) Viewed 467 times

User avatar
tobetter
Posts: 10969
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 737 times
Been thanked: 1868 times
Contact:

Re: Ubuntu does not boot

Post by tobetter »

Do you have PCI stroage attached on your ODROID-M1?
Which storage did you flash the OS image?
What do you see if you run blkid in the command line in the screen you posted?

sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Ubuntu does not boot

Post by sushmitha.rao »

No I donot have PCI Storage attached to Odroid
The OS is flashed on 16GB eMMc module.
This is the result I get from running blkid command
Attachments
9CE9BA41-30E9-446C-BB52-2B742F290C94.jpeg
9CE9BA41-30E9-446C-BB52-2B742F290C94.jpeg (309.79 KiB) Viewed 464 times

User avatar
tobetter
Posts: 10969
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 737 times
Been thanked: 1868 times
Contact:

Re: Ubuntu does not boot

Post by tobetter »

sushmitha.rao wrote:
Thu Sep 08, 2022 12:03 am
No I donot have PCI Storage attached to Odroid
The OS is flashed on 16GB eMMc module.
This is the result I get from running blkid command
If you do not have PCI device, please do not bother the message. It's normal since the kernel check PCI device all the time on booting and gives an error if no PCI device is attached or it's failed to be initiated.

You have two partitions on eMMC, and for some reason the root file system is corrupted and failed to mount it on booting. So please do run fsck to check the partition on another Linux PC.

User avatar
odroid
Site Admin
Posts: 40074
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2841 times
Been thanked: 1602 times
Contact:

Re: Ubuntu does not boot

Post by odroid »

Or, simply freshly flash the OS image via Petitboot if there is no important data in the eMMC.

sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Ubuntu does not boot

Post by sushmitha.rao »

tobetter wrote:
Thu Sep 08, 2022 12:06 am
sushmitha.rao wrote:
Thu Sep 08, 2022 12:03 am
No I donot have PCI Storage attached to Odroid
The OS is flashed on 16GB eMMc module.
This is the result I get from running blkid command
If you do not have PCI device, please do not bother the message. It's normal since the kernel check PCI device all the time on booting and gives an error if no PCI device is attached or it's failed to be initiated.

You have two partitions on eMMC, and for some reason the root file system is corrupted and failed to mount it on booting. So please do run fsck to check the partition on another Linux PC.
I did run fsck on the emmc module.. It says disk clean

sushmitha.rao
Posts: 22
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Ubuntu does not boot

Post by sushmitha.rao »

odroid wrote:
Thu Sep 08, 2022 10:32 am
Or, simply freshly flash the OS image via Petitboot if there is no important data in the eMMC.
I reinstalled the OS on eMMC but whenever I install something on the system like docker or any iot platform, the OS is corrupted and doesnot boot again

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 2 guests