OS is getting corrupted

Post Reply
sushmitha.rao
Posts: 21
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

OS is getting corrupted

Post by sushmitha.rao »

I installed 2 iot platforms on M1, one after the other ofcourse, the system works fine until I reboot. The OS is corrupted once I try to reboot.

User avatar
mctom
Posts: 1961
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polish
ODROIDs: OGA, XU4, C2, M1
Location: Gdansk, Poland
Has thanked: 224 times
Been thanked: 280 times
Contact:

Re: OS is getting corrupted

Post by mctom »

How do you know it's corrupted?
Punk ain't no religious cult, punk means thinking for yourself!

Maintainer of PiStackMon

sushmitha.rao
Posts: 21
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by sushmitha.rao »

mctom wrote:
Fri Sep 16, 2022 7:49 pm
How do you know it's corrupted?
Attachments
9CE9BA41-30E9-446C-BB52-2B742F290C94.jpeg
9CE9BA41-30E9-446C-BB52-2B742F290C94.jpeg (165.37 KiB) Viewed 367 times

User avatar
tobetter
Posts: 10600
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 696 times
Been thanked: 1803 times
Contact:

Re: OS is getting corrupted

Post by tobetter »

sushmitha.rao wrote:
Fri Sep 16, 2022 11:55 pm
mctom wrote:
Fri Sep 16, 2022 7:49 pm
How do you know it's corrupted?
This is duplicated,
viewtopic.php?f=212&t=45216

Still the problem happens even after reflashing an image? Which image exactly did you flash?
Please share more, output of cat /proc/cmdline and the line with root=UUID in boot.scr, it's in the first partition.

sushmitha.rao
Posts: 21
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by sushmitha.rao »

I reinstalled the OS the system was working fine. When I install a new IoT platform or docker and then restart the problem occurs again. I have installed the latest ubuntu image provided by hardkernel. It is ubuntu-20.04 gnome desktop-odroidm1-20220531.img

I have attached the output from cat /proc/cmdline and may I know how to access the boot.scr
Attachments
5D7B262B-A401-4ABA-B57B-25964EB15C7A.jpeg
5D7B262B-A401-4ABA-B57B-25964EB15C7A.jpeg (994.42 KiB) Viewed 315 times

User avatar
tobetter
Posts: 10600
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 696 times
Been thanked: 1803 times
Contact:

Re: OS is getting corrupted

Post by tobetter »

Please provide full instruction what you made to install IoT and Docker such that I can reproduce on my end.
The error what you showed in the photo is just like the disk partition is corrupted which should not happen with a regular Linux commands.

sushmitha.rao
Posts: 21
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by sushmitha.rao »


moonpyk
Posts: 8
Joined: Tue Sep 20, 2022 4:00 am
languages_spoken: english
ODROIDs: M1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by moonpyk »

I had the exact same issue today, my steps to reproduce :

Use a USB to NVME dongle to flash a latest ODROID M1 Ubuntu Server image on a NVME SSD.
Boot from it on the M1 using the dongle, boots fine. Simply reboot the OS, on next boot you'll have @sushmitha.rao output.

Strangely I have no problem whatsoever if after flashing the the NVME SSD I plug it directly in the NVME slot of the M1 board.

References :
* Dongle -> https://www.amazon.fr/gp/product/B097H7JZVG
* NVME SSD -> https://www.amazon.fr/gp/product/B086BGWNY8

User avatar
tobetter
Posts: 10600
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 696 times
Been thanked: 1803 times
Contact:

Re: OS is getting corrupted

Post by tobetter »

moonpyk wrote:
Tue Sep 20, 2022 5:28 am
I had the exact same issue today, my steps to reproduce :

Use a USB to NVME dongle to flash a latest ODROID M1 Ubuntu Server image on a NVME SSD.
Boot from it on the M1 using the dongle, boots fine. Simply reboot the OS, on next boot you'll have @sushmitha.rao output.

Strangely I have no problem whatsoever if after flashing the the NVME SSD I plug it directly in the NVME slot of the M1 board.

References :
* Dongle -> https://www.amazon.fr/gp/product/B097H7JZVG
* NVME SSD -> https://www.amazon.fr/gp/product/B086BGWNY8
When you have the same screen, what's the output of cat /proc/cmdline and ls -l /dev/nvme* and lspci?

moonpyk
Posts: 8
Joined: Tue Sep 20, 2022 4:00 am
languages_spoken: english
ODROIDs: M1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by moonpyk »

I'm gonna try to corrupt it again for you :)

EDIT : I can't today, I don't have any spare keyboard available.

User avatar
tobetter
Posts: 10600
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 696 times
Been thanked: 1803 times
Contact:

Re: OS is getting corrupted

Post by tobetter »

moonpyk wrote:
Tue Sep 20, 2022 5:40 am
I'm gonna try to corrupt it again for you :)

EDIT : I can't today, I don't have any spare keyboard available.
Please do not post the issue here and there, sometimes confusing... :D

moonpyk
Posts: 8
Joined: Tue Sep 20, 2022 4:00 am
languages_spoken: english
ODROIDs: M1
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by moonpyk »

I've been tinkering with the board a lot, and did different tests, the answers I gave in the other topics were not related to this one (don't get confused) :)

Code: Select all

cat /proc/cmdline
root=/dev/nvme0n1p2 rootwait ro quiet earlycon=uart8250,mmio32,0xfe660000 pci=nomsi fsck.mode=force fsck.repair=yes mtdparts=sfc_nor:0x20000@0xe0000(env),0x200000@0x100000(uboot),0x100000@0x300000(splash),0xc00000@0x400000(firmware) console=tty1
lspci
0002:20:00.0 PCI bridge: Fuzhou Rockchip Electronics Co., Ltd Device 3566 (rev 01)
0002:21:00.0 Non-Volatile memory controller: Micron/Crucial Technology Device 540a (rev 01)
Hope it helps

sushmitha.rao
Posts: 21
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by sushmitha.rao »

I did cut the power off and reconnected it. Could it be the reason for corruption?

User avatar
tobetter
Posts: 10600
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 696 times
Been thanked: 1803 times
Contact:

Re: OS is getting corrupted

Post by tobetter »

sushmitha.rao wrote:
Wed Sep 21, 2022 6:04 pm
I did cut the power off and reconnected it. Could it be the reason for corruption?
Possible if OS is installed to SD card.

sushmitha.rao
Posts: 21
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by sushmitha.rao »

tobetter wrote:
Wed Sep 21, 2022 6:09 pm
sushmitha.rao wrote:
Wed Sep 21, 2022 6:04 pm
I did cut the power off and reconnected it. Could it be the reason for corruption?
Possible if OS is installed to SD card.
The same thing happens with eMMC as well

User avatar
tobetter
Posts: 10600
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 696 times
Been thanked: 1803 times
Contact:

Re: OS is getting corrupted

Post by tobetter »

sushmitha.rao wrote:
Wed Sep 21, 2022 7:07 pm
tobetter wrote:
Wed Sep 21, 2022 6:09 pm
sushmitha.rao wrote:
Wed Sep 21, 2022 6:04 pm
I did cut the power off and reconnected it. Could it be the reason for corruption?
Possible if OS is installed to SD card.
The same thing happens with eMMC as well
Do you have the same screen this when you think the storage is corrupted?
download/file.php?id=16232

If so, please share the outputs of

Code: Select all

sudo lsblk -l
cat /proc/cmdline
ls -l /dev/mmcblk*
sudo fdisk -l

sushmitha.rao
Posts: 21
Joined: Tue May 24, 2022 11:46 pm
languages_spoken: english
ODROIDs: Odroid M1, Odroid N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: OS is getting corrupted

Post by sushmitha.rao »

I cannot any commands with sudo
Attachments
E744E79B-6911-4FAF-8F51-23A09B78094E.jpeg
E744E79B-6911-4FAF-8F51-23A09B78094E.jpeg (721.85 KiB) Viewed 159 times

User avatar
tobetter
Posts: 10600
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 696 times
Been thanked: 1803 times
Contact:

Re: OS is getting corrupted

Post by tobetter »

sushmitha.rao wrote:
Wed Sep 21, 2022 8:14 pm
I cannot any commands with sudo
That's ok.

Something strange is that the screen shows that your OS does not mount the root file system, this does not look like your memory card is corrupted. Maybe corrupted, but not sure until you run fsck to the 2nd partition. When you have a chance to try again, add rootwait to the kernel parameter. In Petitboot, move the cursor to the OS entry and press e, then move the kernel parameter then add "rootwait" in the same line. Back to Petitboot and select the boot entry to start it.

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 3 guests