HC4 doesn't see second disk

Post Reply
ChriO
Posts: 3
Joined: Mon Aug 09, 2021 1:43 am
languages_spoken: english, german, french, polish, (italian)
ODROIDs: odroid-hc4
Has thanked: 0
Been thanked: 0
Contact:

HC4 doesn't see second disk

Post by ChriO »

Some time ago a I was desperate to have ZFS on an Odroid HC4 and after some trying found
Armbian 21.05.8 Buster with Linux 5.10.57-meson64
on which I could compile ZFS module. Then I moved everything from the SD card to filesystems in a ZFS pool.
It boots from SD card, though. And has been working fine for several months.
Recently I bought another HC4 and took the current Armbian image for it:
Armbian 22.08.8 Jammy with Linux 5.19.17-meson64
Everything works fine.
Tried this image on the older HC4 and it doesn't see the second SSD.
In the syslog I found this message:

ata1: SATA link down (SStatus 0 SControl 300)

Is it a firmware problem?

Googling hasn't help.
Any idea anyone?

Thanks for your time.
Chris

ruppi
Posts: 181
Joined: Fri Feb 22, 2013 11:13 pm
languages_spoken: korean
Location: South Korea
Has thanked: 0
Been thanked: 19 times
Contact:

Re: HC4 doesn't see second disk

Post by ruppi »

Are you saying that one of HC4's two SATA ports works well and the other is not recognized?
For your information, a typical SATA connector has a 50 connectivity life.
I think SATA connector is suspected of poor contact, so why don't you clean contact point of SATA connector with alcohol?

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests