HC-4 USB stopped working

Post Reply
jimx
Posts: 2
Joined: Sat Aug 21, 2021 9:26 pm
languages_spoken: english,chinese
Has thanked: 0
Been thanked: 0
Contact:

HC-4 USB stopped working

Post by jimx »

Hi,

I just got my HC-4 today and I tested it with an sd card with the official ubuntu image (ubuntu-20.04-4.9-minimal-odroid-c4-hc4-20201212.img) installed. It booted successfully and I got to the login pretty quickly. Then I connected a USB hub with a keyboard and the wifi module 5b and it recognized the keyboard but not the wifi module (which showed up as a cdrom device). I did a full system upgrade on the ethernet and then the kernel recognized the wifi module as an NIC and I can connect to wifi with nmcli. At that point everything worked so I unplugged everything except the power cable, the sd card and the wifi module and connected to the board with ssh over wifi. Then I began to install some packages that I need and suddenly lost the connection. At first I thought it was the unstable network so I unplugged the power and rebooted the board. But the board didn't showed up on my wireless router so I connected a monitor to the board to see what was wrong. Then I began to find out the USB port didn't work as expected. Specifically, I tried to connect the board to:

1. just the keyboard. This worked normally and it can respond to my input.
2. just the wifi module. It didn't work and I can see some "device descriptor read/64, error -xx" message in dmesg.
3. a USB hub with both the keyboard and the wifi module. It didn't work either and there was not any message about USB device in dmesg as if no device was plugged in at all. The LED on the USB hub wasn't on either.

At first I suspected it was a power issue because the wifi module and the USB hub drew more power than the keyboard. But I was using the official 15V/4A power supply so there should be enough power. I didn't have any USB hub with external power supply so I wasn't sure. I could only reboot the board for several times and then the USB became completely dead. It didn't even respond to the keyboard. The only way I could connect to the board was ssh over ethernet. And there was no error/USB connected/disconnected messages showing up in dmesg. I burned the official ubuntu image to the sd card again in case there were some misconfigurations but the problem still persisted. Also, lsusb -t showed only two devices:

/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/2p, 480M

which didn't look normal at all. I remembered that when I ran lsusb to find the wifi module when the USB port did work there were more USB devices than that.

Can you please help me with this issue? Apart from the USB port everything else seems fine. I can connect to the board with ssh over ethernet and it can mount a sata disk without any problem but still I want to get the USB port to work in case I mess up with the network configuration. Thanks in advance!

cam_l
Posts: 3
Joined: Sun Aug 22, 2021 9:53 am
languages_spoken: english
ODROIDs: HC2, HC4
Has thanked: 0
Been thanked: 0
Contact:

Re: HC-4 USB stopped working

Post by cam_l »

Same issue, same output.

There were issues from the outset with recognising mouse / keyboard / KVM devices - garbled output from keyboard, no wireless mouse. USB storage key worked initially but shortly stopped and have tried different devices, reboots, reinstalls with both official and armbian images etc and still no luck.

Seems like could be a power issue, one of my low power usb devices lights up when plugged in to other machines, but not on HC4 usb port. This happened after about an hour or two power on, about 10mins after first plugging in usb key. It would be great if someone could tell me how to confirm if this is a software v hardware issue because the shipping cost for RMA is half the cost of the unit!

User avatar
tobetter
Posts: 8388
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1323 times
Contact:

Re: HC-4 USB stopped working

Post by tobetter »

Would you guys run the commands below and capture the screen to share with me?
Please do attach any USB device - keyboard/mouse/Wifi - and sshing to HC4 to run these.

Code: Select all

uname -a
ifconfig eth0
lsusb -t
Thank you.

jimx
Posts: 2
Joined: Sat Aug 21, 2021 9:26 pm
languages_spoken: english,chinese
Has thanked: 0
Been thanked: 0
Contact:

Re: HC-4 USB stopped working

Post by jimx »

Code: Select all

root@odroid:~# uname -a
Linux odroid 4.9.236-63 #1 SMP PREEMPT Wed Dec 9 22:25:50 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux
root@odroid:~# ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.7  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::c3e7:da35:bf9b:6823  prefixlen 64  scopeid 0x20<link>
        ether 00:1e:06:49:0c:15  txqueuelen 1000  (Ethernet)
        RX packets 2795  bytes 2201348 (2.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1779  bytes 114004 (114.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 21  

root@odroid:~# lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/2p, 480M
root@odroid:~#
The output is the same with or without the wifi module attached.

cam_l
Posts: 3
Joined: Sun Aug 22, 2021 9:53 am
languages_spoken: english
ODROIDs: HC2, HC4
Has thanked: 0
Been thanked: 0
Contact:

Re: HC-4 USB stopped working

Post by cam_l »

I do not have usb wifi, just tried keyboard, mouse, kvm and storage. Output is the same.
Currently running Armbian. Happy to put official image back on if it helps.

Code: Select all

root@odroidhc4:/# uname -a
Linux odroidhc4 5.10.57-meson64 #21.05.8 SMP PREEMPT Mon Aug 9 12:44:31 UTC 2021 aarch64 GNU/Linux

root@odroidhc4:/# ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet ***.***.*.**  netmask ***.***.***.*  broadcast ***.***.*.***
        ether **:**:**:**:**:**  txqueuelen 1000  (Ethernet)
        RX packets 8641  bytes 1501730 (1.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13449  bytes 15296624 (14.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 15  

root@odroidhc4:/# lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/2p, 480M

User avatar
tobetter
Posts: 8388
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1323 times
Contact:

Re: HC-4 USB stopped working

Post by tobetter »

@jimx, For RMA, please contact your local distributor where you have purchased or send an email to odroid at hardkernel dot com if you have purchased it from Hardkernel.

@cam_l, please do share the MAC address of your HC4.

Thank you.

cam_l
Posts: 3
Joined: Sun Aug 22, 2021 9:53 am
languages_spoken: english
ODROIDs: HC2, HC4
Has thanked: 0
Been thanked: 0
Contact:

Re: HC-4 USB stopped working

Post by cam_l »

00:1e:06:49:0d:1c

Not really interested in RMA. I got this direct from hardkernel and like I said the shipping cost for RMA is half the cost of the unit!

I would be interested in confirming if this is a known issue or not.

User avatar
tobetter
Posts: 8388
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1323 times
Contact:

Re: HC-4 USB stopped working

Post by tobetter »

cam_l wrote:
Tue Aug 24, 2021 6:24 pm
00:1e:06:49:0d:1c

Not really interested in RMA. I got this direct from hardkernel and like I said the shipping cost for RMA is half the cost of the unit!

I would be interested in confirming if this is a known issue or not.
Thanks, it's an hardware issue and happened to several users AFAIK.

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 1 guest