OGA WPA3 Issues

Post Reply
User avatar
Quinn64
Posts: 1
Joined: Mon Jan 29, 2024 9:58 am
languages_spoken: english
ODROIDs: OGA Rev 1.1
Has thanked: 0
Been thanked: 0
Contact:

OGA WPA3 Issues

Post by Quinn64 »

I have an OGA 1.1 and it has issues connecting to APs that support WPA3. Even if the AP is running in WPA3 + WPA2 hybrid mode, the OGA will not successfully connect. I have to set the AP to only use WPA2 to get the OGA to connect.

Does anybody else have similar issues? Is there a way to get the OGA to treat APs with hybrid WPA3 + WPA2 encryption as a regular WPA2 only AP?

User avatar
odroid
Site Admin
Posts: 42478
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 3705 times
Been thanked: 2079 times
Contact:

Re: OGA WPA3 Issues

Post by odroid »


User avatar
rooted
Posts: 10627
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 822 times
Been thanked: 736 times
Contact:

Re: OGA WPA3 Issues

Post by rooted »

Yes I have the same issue but I haven't tried the Ubuntu based factory ROM which may work correctly. I simply created a separate SSID for devices which have this limitation (a lot of IOT devices can't connect to WPA3 even with WPA2/3 enabled).

In this case a bug report could be made for the ROM developer.

User avatar
Masked Witch
Posts: 1
Joined: Wed May 01, 2024 7:22 am
languages_spoken: english
ODROIDs: ODROID-Go Advance
Has thanked: 0
Been thanked: 0
Contact:

Re: OGA WPA3 Issues

Post by Masked Witch »

Same issue here. I tried Ubuntu ES version 2.2 and NetworkManager or its version of WPA Supplicant is able to successfully push it to use WPA2, so it does work. That doesn't really solve the issue for Batocera or other distributions that just let the firmware determine how it's going to connect.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest