VICE for OGA

Game ROMs compatibility, performance and new cores
Post Reply
riq
Posts: 25
Joined: Fri Feb 14, 2020 9:18 pm
languages_spoken: english
Has thanked: 4 times
Been thanked: 7 times
Contact:

VICE for OGA

Post by riq »

Hi,

In case you want to play some Commodore 64 games, here are the instructions to have VICE running in OGA:
https://gitlab.com/ricardoquesada/odroi ... ice-oga.md

Of course, you should run games that don't require keyboard interaction. But even than is possible by using the VICE's built-in virtual keyboard.

Missing:
Assign OGA buttons to VICE, like have F1,F3,F5,F7 mapped. Have "swap joystick port" mapped, and probably "Y' and "N" (used by many cracked games).
These users thanked the author riq for the post (total 2):
odroid (Wed Mar 11, 2020 8:55 am) • joy (Wed Mar 11, 2020 12:25 pm)

User avatar
odroid
Site Admin
Posts: 41864
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 3433 times
Been thanked: 1920 times
Contact:

Re: VICE for OGA

Post by odroid »

Thank you for sharing!
Nice to see another useful emulator which works with AreaScout's SDL2 port.

CISKO
Posts: 83
Joined: Tue Feb 25, 2020 5:44 pm
languages_spoken: spanish - english
ODROIDs: Odroid go advance - Odroid Go Super
Has thanked: 28 times
Been thanked: 18 times
Contact:

Re: VICE for OGA

Post by CISKO »

I use vicex64 with games in vsf format (no loads) and the controls mapped one by one,no need for a keyboard

riq
Posts: 25
Joined: Fri Feb 14, 2020 9:18 pm
languages_spoken: english
Has thanked: 4 times
Been thanked: 7 times
Contact:

Re: VICE for OGA

Post by riq »

CISKO wrote:
Wed Mar 11, 2020 4:22 pm
I use vicex64 with games in vsf format (no loads) and the controls mapped one by one,no need for a keyboard
ah. of course, VSF files! thanks for the tip.

Tinkerpete
Posts: 53
Joined: Tue Oct 16, 2018 3:46 pm
languages_spoken: english
ODROIDs: Odroid-Go
Has thanked: 0
Been thanked: 0
Contact:

Re: VICE for OGA

Post by Tinkerpete »

I want use this manual again for installing vice on my odroid-go advance. But it need git and install git with

sudo apt-get install git

gives:

odroid@goadvance:~$ sudo apt-get install git
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
git-man liberror-perl libgdbm-compat4 libgdbm5 libperl5.26 patch perl
perl-modules-5.26
Suggested packages:
gettext-base git-daemon-run | git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-cvs git-mediawiki git-svn gdbm-l10n ed diffutils-doc
perl-doc libterm-readline-gnu-perl | libterm-readline-perl-perl make
The following NEW packages will be installed:
git git-man liberror-perl libgdbm-compat4 libgdbm5 libperl5.26 patch perl
perl-modules-5.26
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.1 MB/10.2 MB of archives.
After this operation, 71.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Ign:1 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 perl-modules-5.26 all 5.26.1-6ubuntu0.5
Ign:2 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 libperl5.26 arm64 5.26.1-6ubuntu0.5
Ign:3 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 perl arm64 5.26.1-6ubuntu0.5
Ign:4 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 git-man all 1:2.17.1-1ubuntu0.7
Ign:5 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 git arm64 1:2.17.1-1ubuntu0.7
Ign:1 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 perl-modules-5.26 all 5.26.1-6ubuntu0.5
Err:2 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 libperl5.26 arm64 5.26.1-6ubuntu0.5
404 Not Found [IP: 2620:2d:4000:1::19 80]
Err:3 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 perl arm64 5.26.1-6ubuntu0.5
404 Not Found [IP: 2620:2d:4000:1::19 80]
Ign:4 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 git-man all 1:2.17.1-1ubuntu0.7
Err:5 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 git arm64 1:2.17.1-1ubuntu0.7
404 Not Found [IP: 2620:2d:4000:1::19 80]
Ign:1 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 perl-modules-5.26 all 5.26.1-6ubuntu0.5
Ign:4 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 git-man all 1:2.17.1-1ubuntu0.7
Err:1 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 perl-modules-5.26 all 5.26.1-6ubuntu0.5
404 Not Found [IP: 2620:2d:4000:1::19 80]
Err:4 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 git-man all 1:2.17.1-1ubuntu0.7
404 Not Found [IP: 2620:2d:4000:1::19 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/po ... .5_all.deb 404 Not Found [IP: 2620:2d:4000:1::19 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/po ... _arm64.deb 404 Not Found [IP: 2620:2d:4000:1::19 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/po ... _arm64.deb 404 Not Found [IP: 2620:2d:4000:1::19 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/po ... .7_all.deb 404 Not Found [IP: 2620:2d:4000:1::19 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/po ... _arm64.deb 404 Not Found [IP: 2620:2d:4000:1::19 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
odroid@goadvance:~$

Any tipps?

User avatar
mad_ady
Posts: 11755
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4 (HC1, HC2), C1+, C2, C4 (HC4), N1, N2, N2L, H2, H3+, Go, Go Advance, M1, M1S
Location: Bucharest, Romania
Has thanked: 656 times
Been thanked: 1197 times
Contact:

Re: VICE for OGA

Post by mad_ady »

404 errors in apt usually means your package list is outdated. Do a sudo apt-get update before.

Post Reply

Return to “Game emulations”

Who is online

Users browsing this forum: No registered users and 1 guest