LineageOS 18.1 for Odroid-GoS

Third party OS images and hardware mods
User avatar
rooted
Posts: 8876
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 743 times
Been thanked: 407 times
Contact:

Re: LineageOS 18.1 for Odroid-GoS

Post by rooted »

megatyler30 wrote:I've been having issues with multiple apps crashing immediately upon opening it (PSPlay, F-Droid, Chiaki). Any suggestions on how to fix this? Also is there a discord for LineageOS on Odroid Super? Would be nice to have all the users in one place.
Android needs to be ran from eMMC so this sort of thing is common, only thing you can do is find the fastest SD card with high IOPS and hope for the best.

notime2d8
Posts: 316
Joined: Thu Dec 11, 2014 4:40 am
languages_spoken: english
Has thanked: 93 times
Been thanked: 128 times
Contact:

Re: LineageOS 18.1 for Odroid-GoS

Post by notime2d8 »

megatyler30 wrote:
Wed Nov 17, 2021 12:10 pm
I've been having issues with multiple apps crashing immediately upon opening it (PSPlay, F-Droid, Chiaki). Any suggestions on how to fix this? Also is there a discord for LineageOS on Odroid Super? Would be nice to have all the users in one place.
Please try the upload from today, and restart after it settles from the first boot. Those three apps work for me in testing. I also think the user base for this is small. But I do get notifications for this thread and can usually reply.
These users thanked the author notime2d8 for the post:
megatyler30 (Sun Nov 21, 2021 2:35 am)
If I say something that sounds smart or like i know what i'm talking about....i'm faking it.

megatyler30
Posts: 5
Joined: Sat Oct 30, 2021 4:01 am
languages_spoken: english
ODROIDs: Odroid Go Super
Has thanked: 2 times
Been thanked: 1 time
Contact:

Re: LineageOS 18.1 for Odroid-GoS

Post by megatyler30 »

notime2d8 wrote:
Sat Nov 20, 2021 9:16 am
megatyler30 wrote:
Wed Nov 17, 2021 12:10 pm
I've been having issues with multiple apps crashing immediately upon opening it (PSPlay, F-Droid, Chiaki). Any suggestions on how to fix this? Also is there a discord for LineageOS on Odroid Super? Would be nice to have all the users in one place.
Please try the upload from today, and restart after it settles from the first boot. Those three apps work for me in testing. I also think the user base for this is small. But I do get notifications for this thread and can usually reply.
They do indeed work (well mostly) in the newest version. Thank you for the helpful responses :)

Also, even if the userbase is small, I find a discord helps as people will naturally trickle in even if you don't expect it. And it's a better place to show off things we've managed to figure out and ask smaller questions that don't really fit in a forum thread. Ultimately up to you if you want to, I just think it would be neat to get the small userbase together in one place.

notime2d8
Posts: 316
Joined: Thu Dec 11, 2014 4:40 am
languages_spoken: english
Has thanked: 93 times
Been thanked: 128 times
Contact:

Re: LineageOS 18.1 for Odroid-GoS

Post by notime2d8 »

megatyler30 wrote:
Sun Nov 21, 2021 1:59 am
notime2d8 wrote:
Sat Nov 20, 2021 9:16 am
megatyler30 wrote:
Wed Nov 17, 2021 12:10 pm
I've been having issues with multiple apps crashing immediately upon opening it (PSPlay, F-Droid, Chiaki). Any suggestions on how to fix this? Also is there a discord for LineageOS on Odroid Super? Would be nice to have all the users in one place.
Please try the upload from today, and restart after it settles from the first boot. Those three apps work for me in testing. I also think the user base for this is small. But I do get notifications for this thread and can usually reply.
They do indeed work (well mostly) in the newest version. Thank you for the helpful responses :)

Also, even if the userbase is small, I find a discord helps as people will naturally trickle in even if you don't expect it. And it's a better place to show off things we've managed to figure out and ask smaller questions that don't really fit in a forum thread. Ultimately up to you if you want to, I just think it would be neat to get the small userbase together in one place.
Do you know which codec you're using for streaming? H264 or H265/HEVC? Do both work? I think with HEVC the image messes up when you get over a certain resolution.
If I say something that sounds smart or like i know what i'm talking about....i'm faking it.

megatyler30
Posts: 5
Joined: Sat Oct 30, 2021 4:01 am
languages_spoken: english
ODROIDs: Odroid Go Super
Has thanked: 2 times
Been thanked: 1 time
Contact:

Re: LineageOS 18.1 for Odroid-GoS

Post by megatyler30 »

So both work. My computer is having graphical artifacting (on display only, not on the OGS) for hevc ever since I messed with the drivers a few days ago so I can't test it in detail until I get it fixed but it doesn't seem to have issues on the OGS for me.
These users thanked the author megatyler30 for the post:
notime2d8 (Sun Nov 21, 2021 1:07 pm)

User avatar
MoreFoxBeans2
Posts: 1
Joined: Wed Nov 24, 2021 8:44 am
languages_spoken: English
ODROIDs: GO Super, GO Advance
Location: Denver, Colorado, USA
Has thanked: 0
Been thanked: 0
Contact:

Re: LineageOS 18.1 for Odroid-GoS

Post by MoreFoxBeans2 »

Hello! I've been trying to install LineageOS on my ODROID-GO Super but it keeps getting stuck.
The device gets past the part where it says "Resizing in progress" and reboots successfully. After it reboots it starts the little blue installing animation thingy, and this is where it gets stuck. I've let it go for hours but it shows no sign of doing anything. I flashed my micro-SD with both the latest version (w/ GAPPS) and an older version (no GAPPS) and left it for ~3 hours each time.
My U-Boot version is 2017.09-g4102e41302-dirty if that helps.

notime2d8
Posts: 316
Joined: Thu Dec 11, 2014 4:40 am
languages_spoken: english
Has thanked: 93 times
Been thanked: 128 times
Contact:

Re: LineageOS 18.1 for Odroid-GoS

Post by notime2d8 »

MoreFoxBeans2 wrote:
Wed Nov 24, 2021 9:11 am
Hello! I've been trying to install LineageOS on my ODROID-GO Super but it keeps getting stuck.
The device gets past the part where it says "Resizing in progress" and reboots successfully. After it reboots it starts the little blue installing animation thingy, and this is where it gets stuck. I've let it go for hours but it shows no sign of doing anything. I flashed my micro-SD with both the latest version (w/ GAPPS) and an older version (no GAPPS) and left it for ~3 hours each time.
My U-Boot version is 2017.09-g4102e41302-dirty if that helps.
I just added a note to the downloads post. But you need a 32gb minimum SD card. If you have less than that, the data partition isn't created and it doesn't boot. Boot time is less than 2mins tops with a slow SD card.
If I say something that sounds smart or like i know what i'm talking about....i'm faking it.

Post Reply

Return to “Projects”

Who is online

Users browsing this forum: No registered users and 3 guests