Page 1 of 1

new N2 doesn't work

Posted: Sat Sep 21, 2019 4:05 am
by aaabaaab
Hi,

I bought 2 Odroid N2. On one I've installed Android without any difficulty.

Unfortunately the second one seems to be dead: I've inserted the microSD with the Android image but the screen remains black. Red light is on and the blue one is blinking but nothing happens even after 15-20 minutes...

I've tried also an Ubuntu image but no luck.

Any ideas ? :roll:

Re: new N2 doesn't work

Posted: Sat Sep 21, 2019 7:09 am
by elatllat
AFAIK Blue blinking light generally means it has booted, do you have a uart?

Re: new N2 doesn't work

Posted: Sat Sep 21, 2019 2:43 pm
by aaabaaab
No, I don't

Re: new N2 doesn't work

Posted: Sat Sep 21, 2019 2:47 pm
by tobetter
The problem is the board does not show anything to your display? Can you do ssh to Ubuntu image? Or can you try to boot from SPI flash memory?

Re: new N2 doesn't work

Posted: Sat Sep 21, 2019 3:12 pm
by mad_ady
What kind of display/resolution do you have?

Re: new N2 doesn't work

Posted: Sat Sep 21, 2019 4:00 pm
by aaabaaab
Indeed, the board doesn't show anything. The screen is black and then it says there is no signal and goes in standby.

I've tried both with Android and Ubuntu images.

How can I boot from SPI flash memory ?

Re: new N2 doesn't work

Posted: Sat Sep 21, 2019 7:43 pm
by mad_ady
Use a 1080p screen and flip the boot switch to spi. See if you get a screen displayed.

Re: new N2 doesn't work

Posted: Sun Sep 22, 2019 1:54 am
by aaabaaab
I've tried but got exactly the same: No signal message...

Re: new N2 doesn't work

Posted: Sun Sep 22, 2019 2:17 am
by mad_ady
Something may be wrong with video output then. Have you tested the same display with the other N2?

Re: new N2 doesn't work

Posted: Sun Sep 22, 2019 2:32 am
by aaabaaab
Yes. The second N2 I've got works perfectly with the same display.

Re: new N2 doesn't work

Posted: Mon Sep 23, 2019 8:33 am
by odroid
I think one you for N2 boards seemed to be damaged unknown electrical shock.

Please contact "odroid at hardkernel dot com" with a link of this post.
They will help your RMA process if you purchased the board from our web-store directly.
Otherwise, contact your local distributor/reseller.
Sorry for the inconvenience caused.

Re: new N2 doesn't work

Posted: Tue Sep 24, 2019 9:58 am
by dsystems
Hello, I just received my new N2, CoreElec special edition today. I have a boot problem too but mine will not go past the Petiboot screen. The CoreElec SD is firmly in place and the switch is on the SD position. I also tried another MicroSD with the Ubuntu Mate image and get the same issue. I'm sure I am forgetting a setting somewhere. Can you please help?

Re: new N2 doesn't work

Posted: Tue Sep 24, 2019 10:37 am
by tobetter
dsystems wrote:
Tue Sep 24, 2019 9:58 am
Hello, I just received my new N2, CoreElec special edition today. I have a boot problem too but mine will not go past the Petiboot screen. The CoreElec SD is firmly in place and the switch is on the SD position. I also tried another MicroSD with the Ubuntu Mate image and get the same issue. I'm sure I am forgetting a setting somewhere. Can you please help?
Please do create your own thread for your issue next time.

Please download the update image from the link and copy to COREELECT partition of your SD card as spiboot.img.
https://wiki.odroid.com/odroid-n2/os_im ... ev20190705

Before power cycle, place the boot select switch to SPI and attach your SD card to the slot, Petitboot in SPI will start to update and it will give you CoreELEC boot entry on next boot. If you have further question about Petitboot, please visit the link.
viewtopic.php?f=182&t=33873

Re: new N2 doesn't work

Posted: Tue Sep 24, 2019 10:52 am
by dsystems
OK, thank you. I have Dev.20190416 so should I use 20190417 ?

Re: new N2 doesn't work

Posted: Tue Sep 24, 2019 11:12 am
by dsystems
I used dev.20190705 and it works great. Thank you so much. 대단히 감사합니다

Re: new N2 doesn't work

Posted: Thu Oct 03, 2019 10:36 am
by grapenose
Having same problems as dsytems.
Do I need to use Etcher to copy the image to the SD card or just copy and rename.
I tried to copy and rename but it failed to update the SPI image.
Will try Etcher next

Re: new N2 doesn't work

Posted: Thu Oct 03, 2019 2:11 pm
by tobetter
grapenose wrote:
Thu Oct 03, 2019 10:36 am
Having same problems as dsytems.
Do I need to use Etcher to copy the image to the SD card or just copy and rename.
I tried to copy and rename but it failed to update the SPI image.
Will try Etcher next
If you are meaning to update Petitboot, download the latest firmware and copy the file to uSD as spiboot.img. After attaching the uSD, you must flip the boot switch to SPI and do power cycle.

Re: new N2 doesn't work

Posted: Thu Oct 03, 2019 2:37 pm
by grapenose
Box arrived yesterday, powered on and Coreelec screen came up twice then all I had was a rectangle in the top left hand corner of the screen. Lights seemed to be right but no OS

Downloaded latest firmware.
Copied to SD without using Etcher?
Renamed but not recognised by box.Still has the old version ending in 416.
Lucky I had a SD reader.

Re: new N2 doesn't work

Posted: Thu Oct 03, 2019 4:39 pm
by tobetter
grapenose wrote:
Thu Oct 03, 2019 2:37 pm
Box arrived yesterday, powered on and Coreelec screen came up twice then all I had was a rectangle in the top left hand corner of the screen. Lights seemed to be right but no OS

Downloaded latest firmware.
Copied to SD without using Etcher?
Renamed but not recognised by box.Still has the old version ending in 416.
Lucky I had a SD reader.
Are you trying to install CoreELEC or Petitboot?
For CoreELEC, you should use Ether and for Petitboot, you should copy the firmware file to uSD.

Re: new N2 doesn't work

Posted: Fri Oct 04, 2019 7:47 am
by grapenose
Trying to install Petitboot and then CoreELEC.
Does it matter what the file system is for the SD card?
I think I had it as FAT32.
Have a Ubuntu NUC, would it help to use that to add the firmware to the SD card?
Will have another go with different SD cards.

Re: new N2 doesn't work

Posted: Fri Oct 04, 2019 11:57 am
by tobetter
grapenose wrote:
Fri Oct 04, 2019 7:47 am
Trying to install Petitboot and then CoreELEC.
Does it matter what the file system is for the SD card?
I think I had it as FAT32.
Have a Ubuntu NUC, would it help to use that to add the firmware to the SD card?
Will have another go with different SD cards.
For Petitboot, download the latest firmware (ver.20190705) and copy it as spiboot.img to SD card (FAT32 or EXT2). Then flip the boot select switch to SPI after attaching the SD card, then the firmware in SPI will start to update itself.
The CoreELEC already works with Petitboot, so if you properly flash CoreELEC to a memory card then Petitboot will show it up.

Re: new N2 doesn't work

Posted: Fri Oct 04, 2019 2:07 pm
by grapenose
Tried with SD card as ext4.
Did not update.
Installed both coreELEC and Android pie on SD cards . Both worked,
Will stick with present firmware version and try again later.
Thanks for your help