Reboot hangs on 4.9.y-upstream kernel

Locked
blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Wed Jun 12, 2019 1:18 am

Anyone else having this issue? Upstream kernel for N2 will hang when issues a reboot command.

https://github.com/hardkernel/linux/tre ... y-upstream

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Wed Jun 12, 2019 1:27 am

blisstik wrote:
Wed Jun 12, 2019 1:18 am
Anyone else having this issue? Upstream kernel for N2 will hang when issues a reboot command.

https://github.com/hardkernel/linux/tre ... y-upstream
Do you have any log you have after reboot?
You can keep your issue in this thread, also can track with this one as well.
viewtopic.php?f=176&t=35007&p=257360&hi ... ty#p257360

blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Wed Jun 12, 2019 4:00 am

How do get you the log? Doesn't it get cleared at boot?

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Wed Jun 12, 2019 8:07 am

blisstik wrote:
Wed Jun 12, 2019 4:00 am
How do get you the log? Doesn't it get cleared at boot?
It would not be easy if you don't have an USB-to-serial debugging board. What's the OS image running the kernel?

blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Thu Jun 13, 2019 5:41 am


blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Thu Jun 20, 2019 10:14 pm

So I installed watchdog service and purposely crashed the kernel via the Wiki guide. It works in that scenario but reboots still hang and SSH is not accessible at that time. I don't have a USB-to-serial debugging board.

I looked online for other solutions. Most I've read was changing grub config but this image doesn't even have grub installed. Any other things I can try?

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Thu Jun 20, 2019 11:20 pm

blisstik wrote:
Thu Jun 20, 2019 10:14 pm
So I installed watchdog service and purposely crashed the kernel via the Wiki guide. It works in that scenario but reboots still hang and SSH is not accessible at that time. I don't have a USB-to-serial debugging board.

I looked online for other solutions. Most I've read was changing grub config but this image doesn't even have grub installed. Any other things I can try?
Sorry for the late response, I've updated the branch with another two commits. A couple of users said the hang issue seems to be disappeared after these patches. I am planning to update the branch next week after having tested and will see this issue intensively.
https://github.com/hardkernel/linux/com ... y-upstream

blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Fri Jun 21, 2019 9:26 am

I recompiled the latest upstream kernel and it did not fix the issue. The reboot process is initiated by typing "reboot" as odroid user.

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Fri Jun 21, 2019 9:32 am

Sorry about that, as I mentioned I will look into the kernel next week for sure while sorting out the branch -upstream and will let you know if still "reboot" makes a problem.

If you have a chance, please do the same test with CoreELEC image which has more commits based on the HK -upstream branch.

"Tapatalk wishes you to have fun with ODROID"


blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Fri Jun 21, 2019 11:13 am

I tried the latest CoreELEC nightly image based on 182 kernel and reboot worked. I think their OS is 32bit

https://github.com/CoreELEC/linux-amlog ... ic-4.9.182

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Fri Jun 21, 2019 12:08 pm

blisstik wrote:
Fri Jun 21, 2019 11:13 am
I tried the latest CoreELEC nightly image based on 182 kernel and reboot worked. I think their OS is 32bit

https://github.com/CoreELEC/linux-amlog ... ic-4.9.182
Thanks for updating, I've started to merge their changes to HK branch and need some time to remove some changes which are specific for CE. Since I already have the updated branch, I would finish by the end of next week and can upload to HK Github branch odroidn2-4.9.y-upstream. At the same time, I will start to test the branch for the official release to odroidn2-4.9.y.
Please allow me to have a week for the work and I will update you.

blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Fri Jun 21, 2019 12:11 pm

Sounds good TY!

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Thu Jun 27, 2019 12:24 pm

blisstik wrote:
Fri Jun 21, 2019 12:11 pm
Sounds good TY!
The branch has been updated, please let me know how it works with you.
viewtopic.php?f=176&t=35007&p=260706#p260706

blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Thu Jun 27, 2019 2:59 pm

reboot and shutdown now work! thank you!

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Thu Jun 27, 2019 3:03 pm

blisstik wrote:
Thu Jun 27, 2019 2:59 pm
reboot and shutdown now work! thank you!
Thank you for updating, please keep posting if you found any issue on the branch. It would be greatly appreciated.

blisstik
Posts: 14
Joined: Tue Jun 11, 2019 4:28 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by blisstik » Thu Jun 27, 2019 3:21 pm

I did post on another thread about kodi still not launching unless 1080p resolution is set...

User avatar
tobetter
Posts: 3699
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 117 times
Contact:

Re: Reboot hangs on 4.9.y-upstream kernel

Unread post by tobetter » Thu Jun 27, 2019 3:43 pm

blisstik wrote:
Thu Jun 27, 2019 3:21 pm
I did post on another thread about kodi still not launching unless 1080p resolution is set...
Thanks, I've read it. Maybe it would be nice to keep tracking the issue on this thread and this thread could be marked as "SOLVED".
viewtopic.php?f=176&t=35007

Locked

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest