Odroid N2 - poor wifi signal quality

Post Reply
ObrZlobr
Posts: 2
Joined: Fri May 22, 2020 7:08 am
languages_spoken: english, czech
ODROIDs: Odroid N2
Has thanked: 0
Been thanked: 0
Contact:

Odroid N2 - poor wifi signal quality

Post by ObrZlobr » Fri May 22, 2020 7:33 am

Hello,

I have Odroid-N2 with CoreELEC 9.2.2. For internet connection i'm using wifi modul 5a on 2,4 GHz network. I have problem with very bad signal quality - slightly over 40% to my router 3m distant, with no obsticles (89% when the router is 15 cm away from Odroid). Internet connection is very slow and unstable because of this. It's not a problem of the router - my Raspberry PI 3b+ can connect to it with stable connection and signal quality slightly below 90%. I also tested the wifi modul 5a in PC and worked very well. I also tried to do a new installation of CoreELEC - without any improve.

Do you have any idea what could be causing this issues?

User avatar
rooted
Posts: 7642
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 680 times
Been thanked: 183 times
Contact:

Re: Odroid N2 - poor wifi signal quality

Post by rooted » Fri May 22, 2020 7:38 am

It's likely interference, you could try a USB extension cable to get the dongle away from the device.

ObrZlobr
Posts: 2
Joined: Fri May 22, 2020 7:08 am
languages_spoken: english, czech
ODROIDs: Odroid N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid N2 - poor wifi signal quality

Post by ObrZlobr » Fri May 22, 2020 7:59 am

Thanks for reply.
I tried to use USB extension cable - no improvement. I also forgot to mention - I've already tried to use OTG cable with even worse result. Any other possible solutions?

User avatar
rooted
Posts: 7642
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 680 times
Been thanked: 183 times
Contact:

Re: Odroid N2 - poor wifi signal quality

Post by rooted » Fri May 22, 2020 9:14 am

You could try changing the channel on the router, some devices are more sensitive than others to interference.

Or perhaps try a different driver.

Your issue seems similar to this:

viewtopic.php?p=293209#p293209

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: Perforator40 and 2 guests