SD card slot doesn't work

Post Reply
sjwlaoda
Posts: 23
Joined: Tue Jun 04, 2019 10:44 am
languages_spoken: english
ODROIDs: n2
Has thanked: 0
Been thanked: 1 time
Contact:

SD card slot doesn't work

Unread post by sjwlaoda » Wed Jun 12, 2019 6:10 pm

Hi
I bought 3 odroidn2 boards recently, two of them work correctly, but one board cannot boot from SD card.
I booted the from the SPI flash memory, and it cannot find the /dev/mmcblk*, while other two boards are OK.
Have you ever seen this issue? and is it possible to boot from USB? (currently I don't have emmc card)

User avatar
tobetter
Posts: 3502
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 22 times
Been thanked: 92 times
Contact:

Re: SD card slot doesn't work

Unread post by tobetter » Wed Jun 12, 2019 6:32 pm

sjwlaoda wrote:
Wed Jun 12, 2019 6:10 pm
Hi
I bought 3 odroidn2 boards recently, two of them work correctly, but one board cannot boot from SD card.
I booted the from the SPI flash memory, and it cannot find the /dev/mmcblk*, while other two boards are OK.
Have you ever seen this issue? and is it possible to boot from USB? (currently I don't have emmc card)
This is the new issue for ODROID-N2 if it does not show any /dev/mmcblk1*. I think you have tested the same SD card with the other two boards, it would be SD card slot or circuit is damaged. But why I am not able to commit that it's hardware problem is we use SD card in order to flash SPI memory on the production. So if the board can boot from SPI, SD had worked with the board and another testing procedure has been passed. Can you try another SD card?

sjwlaoda
Posts: 23
Joined: Tue Jun 04, 2019 10:44 am
languages_spoken: english
ODROIDs: n2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: SD card slot doesn't work

Unread post by sjwlaoda » Wed Jun 12, 2019 7:37 pm

tobetter wrote:
Wed Jun 12, 2019 6:32 pm
sjwlaoda wrote:
Wed Jun 12, 2019 6:10 pm
Hi
I bought 3 odroidn2 boards recently, two of them work correctly, but one board cannot boot from SD card.
I booted the from the SPI flash memory, and it cannot find the /dev/mmcblk*, while other two boards are OK.
Have you ever seen this issue? and is it possible to boot from USB? (currently I don't have emmc card)
This is the new issue for ODROID-N2 if it does not show any /dev/mmcblk1*. I think you have tested the same SD card with the other two boards, it would be SD card slot or circuit is damaged. But why I am not able to commit that it's hardware problem is we use SD card in order to flash SPI memory on the production. So if the board can boot from SPI, SD had worked with the board and another testing procedure has been passed. Can you try another SD card?
I have tried 3 SD cards, the result is the same.
but you are right, the SD slot can take affect, with the SD card in the slot, I can get the blue LED flashing, and the keyboard can work, but ethernet port doesn't work, and the display keeps gray.
I don't have serial cable, so I don't know what the problem is.
Do you have any experience on this? (The board can at least find the kernel image, but cannot find the file system?)

User avatar
tobetter
Posts: 3502
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 22 times
Been thanked: 92 times
Contact:

Re: SD card slot doesn't work

Unread post by tobetter » Wed Jun 12, 2019 8:04 pm

sjwlaoda wrote:
Wed Jun 12, 2019 7:37 pm
tobetter wrote:
Wed Jun 12, 2019 6:32 pm
sjwlaoda wrote:
Wed Jun 12, 2019 6:10 pm
Hi
I bought 3 odroidn2 boards recently, two of them work correctly, but one board cannot boot from SD card.
I booted the from the SPI flash memory, and it cannot find the /dev/mmcblk*, while other two boards are OK.
Have you ever seen this issue? and is it possible to boot from USB? (currently I don't have emmc card)
This is the new issue for ODROID-N2 if it does not show any /dev/mmcblk1*. I think you have tested the same SD card with the other two boards, it would be SD card slot or circuit is damaged. But why I am not able to commit that it's hardware problem is we use SD card in order to flash SPI memory on the production. So if the board can boot from SPI, SD had worked with the board and another testing procedure has been passed. Can you try another SD card?
I have tried 3 SD cards, the result is the same.
but you are right, the SD slot can take affect, with the SD card in the slot, I can get the blue LED flashing, and the keyboard can work, but ethernet port doesn't work, and the display keeps gray.
I don't have serial cable, so I don't know what the problem is.
Do you have any experience on this? (The board can at least find the kernel image, but cannot find the file system?)
If the board doesn't reboot all the time when the blue LED is flashing, then it founds the root file system. But didn't you say that the board cannot boot from SD card? Now it boots? There were ethernet problems on certain board, but it's kinda fixed after replacing U-boot. Which OS image do you flash on the ethernet faulty board?

sjwlaoda
Posts: 23
Joined: Tue Jun 04, 2019 10:44 am
languages_spoken: english
ODROIDs: n2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: SD card slot doesn't work

Unread post by sjwlaoda » Wed Jun 12, 2019 11:11 pm

what I meant cannot boot was because I was unable to make it boot into console. it's great if it can still work.
I am using ubuntu-18.04.2-4.9-minimal-odroid-n2-20190329.img.xz from the wiki page, so the uboot is expected to have problems in this image? where can I find the new one?

User avatar
tobetter
Posts: 3502
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 22 times
Been thanked: 92 times
Contact:

Re: SD card slot doesn't work

Unread post by tobetter » Wed Jun 12, 2019 11:17 pm

sjwlaoda wrote:
Wed Jun 12, 2019 11:11 pm
what I meant cannot boot was because I was unable to make it boot into console. it's great if it can still work.
I am using ubuntu-18.04.2-4.9-minimal-odroid-n2-20190329.img.xz from the wiki page, so the uboot is expected to have problems in this image? where can I find the new one?
U-boot will be uploaded whenever the repository is updated.
https://github.com/hardkernel/u-boot/releases

sjwlaoda
Posts: 23
Joined: Tue Jun 04, 2019 10:44 am
languages_spoken: english
ODROIDs: n2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: SD card slot doesn't work

Unread post by sjwlaoda » Wed Jun 12, 2019 11:28 pm

thanks, I will try it tomorrow

User avatar
tobetter
Posts: 3502
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 22 times
Been thanked: 92 times
Contact:

Re: SD card slot doesn't work

Unread post by tobetter » Wed Jun 12, 2019 11:46 pm

sjwlaoda wrote:
Wed Jun 12, 2019 11:28 pm
thanks, I will try it tomorrow
Sure, please let me have the MAC address of the board and share how it goes after reflash the U-boot.

sjwlaoda
Posts: 23
Joined: Tue Jun 04, 2019 10:44 am
languages_spoken: english
ODROIDs: n2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: SD card slot doesn't work

Unread post by sjwlaoda » Thu Jun 13, 2019 2:53 pm

tobetter wrote:
Wed Jun 12, 2019 11:46 pm
sjwlaoda wrote:
Wed Jun 12, 2019 11:28 pm
thanks, I will try it tomorrow
Sure, please let me have the MAC address of the board and share how it goes after reflash the U-boot.
I have tried u-boot-odroidn2-22.tar.gz, u-boot-odroidn2-31.tar.gz and u-boot-odroidn2-37.tar.gz, all of these cannot work, the phenomenon is the same.
Is it the MAC address on the label that attached on the board?
forum.odroid.com >
00:1E:06:42:1A:3D

sjwlaoda
Posts: 23
Joined: Tue Jun 04, 2019 10:44 am
languages_spoken: english
ODROIDs: n2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: SD card slot doesn't work

Unread post by sjwlaoda » Fri Jun 14, 2019 4:48 pm

sjwlaoda wrote:
Thu Jun 13, 2019 2:53 pm
tobetter wrote:
Wed Jun 12, 2019 11:46 pm
sjwlaoda wrote:
Wed Jun 12, 2019 11:28 pm
thanks, I will try it tomorrow
Sure, please let me have the MAC address of the board and share how it goes after reflash the U-boot.
I have tried u-boot-odroidn2-22.tar.gz, u-boot-odroidn2-31.tar.gz and u-boot-odroidn2-37.tar.gz, all of these cannot work, the phenomenon is the same.
Is it the MAC address on the label that attached on the board?
forum.odroid.com >
00:1E:06:42:1A:3D
Hi tobetter

I changed boot.ini to output to display, so I find the issue, you can check the following two pictures:
IMG_20190614_154124.jpg
IMG_20190614_154124.jpg (624.85 KiB) Viewed 166 times
IMG_20190614_153832.jpg
IMG_20190614_153832.jpg (903.75 KiB) Viewed 166 times
Do you know why it can find the first partition in sd card (contains kernel image), but cannot find the filesystem partition?

User avatar
tobetter
Posts: 3502
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 22 times
Been thanked: 92 times
Contact:

Re: SD card slot doesn't work

Unread post by tobetter » Sat Jun 15, 2019 5:38 pm

@sjwlaoda, The reason why it does not boot is present in the second picture, that is "UUID=e139ce870-* does not exist". This is because the kernel failed to look for the root file system that its UUID is set as "e139ce870-*". Don't know why if the image is flash with other SD cards. You can check the UUIDs of file systems in each SD card and find out if the one is different. UUID can be listed with blkid per file system.

Please check if UUID of the faulty SD card is matching with root=UUID=... in the boot.ini. They have to be matched.

sjwlaoda
Posts: 23
Joined: Tue Jun 04, 2019 10:44 am
languages_spoken: english
ODROIDs: n2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: SD card slot doesn't work

Unread post by sjwlaoda » Mon Jun 17, 2019 12:41 pm

tobetter wrote:
Sat Jun 15, 2019 5:38 pm
@sjwlaoda, The reason why it does not boot is present in the second picture, that is "UUID=e139ce870-* does not exist". This is because the kernel failed to look for the root file system that its UUID is set as "e139ce870-*". Don't know why if the image is flash with other SD cards. You can check the UUIDs of file systems in each SD card and find out if the one is different. UUID can be listed with blkid per file system.

Please check if UUID of the faulty SD card is matching with root=UUID=... in the boot.ini. They have to be matched.
Hi, I have resolved this issue. the board can recognize my fourth sd card which is a 8GB sd card. While my previous tested 3 sd cards are 16GB.

Update: it is not the size of 8GB/16GB issue, I also have some 8GB sdcards cannot be recognized. is it a known issue?

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 1 guest