Powerkey "Sleep Now" troubleshooting

Post Reply
GetMeCoffee
Posts: 3
Joined: Thu Jan 13, 2022 1:56 am
languages_spoken: english
ODROIDs: N2+
Has thanked: 1 time
Been thanked: 0
Contact:

Powerkey "Sleep Now" troubleshooting

Post by GetMeCoffee »

Greetings! I am new to Odroid and have been playing with an N2+ that will become my new media center. I'm running Android on the latest (20211227) image with Kodi 19.1 (from F-Droid). I have a Harmony One remote configured for the HardKernel Odroid N2.

I'm trying to troubleshoot the sleep mode. I have the power button configured in Odroid Settings to "Sleep Now". When I first began playing with the board, hitting the power button would blank the screen and the red light stayed on and the blue light continued blinking. As far as I could tell, the system wasn't really asleep. Later, after moving the unit across the room to my big TV, the system began using a much deeper sleep. The blue light was off and the red light was dim. Worked great until I moved it back to my test bench. It worked a couple times on my test bench and now is back to only going in a light sleep.

I'm not having much luck figuring out what is preventing the deeper sleep. I am seeing a message "cectx ff80023c.aocec: aocec_early_suspend, suspend sts:1" but I believe that I was seeing this even when the unit was going to deep sleep. I would appreciate any help in troubleshooting/correcting this issue.

Thank you!

User avatar
rooted
Posts: 8999
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 745 times
Been thanked: 422 times
Contact:

Re: Powerkey "Sleep Now" troubleshooting

Post by rooted »

Try disabling CEC

GetMeCoffee
Posts: 3
Joined: Thu Jan 13, 2022 1:56 am
languages_spoken: english
ODROIDs: N2+
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Powerkey

Post by GetMeCoffee »

rooted wrote:
Thu Jan 13, 2022 7:05 pm
Try disabling CEC
The CEC options are all greyed out, but they appear to be deselected (except "One key play" which is in the on position, but again, greyed out). Is there another place to turn this off?

User avatar
rooted
Posts: 8999
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 745 times
Been thanked: 422 times
Contact:

Re: Powerkey "Sleep Now" troubleshooting

Post by rooted »

I'm not sure how in Android, in Linux this can be done in the boot.ini
These users thanked the author rooted for the post:
GetMeCoffee (Sat Jan 15, 2022 1:46 am)

GetMeCoffee
Posts: 3
Joined: Thu Jan 13, 2022 1:56 am
languages_spoken: english
ODROIDs: N2+
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Powerkey "Sleep Now" troubleshooting

Post by GetMeCoffee »

I dug around in boot.ini and env.ini and found that while boot.ini sets "prevent_sleep" to 0, env.ini sets it to "1". This is the default setting in the ROM. I never knowingly changed it. Nonetheless, changing it (in env.ini, set to 0) allowed the system to suspend (almost*) properly. I also had to reboot without the OTG attached (OTG prevents sleep, but it seems it is detected at boot).

Anyone know if there is a GUI setting somewhere that adjusts "prevent_sleep"?

* The system now sleeps when the powerkey is pressed. However, the system is also setting the alarm to some random value (I've seen anything from 14S to 4259S) and the system wakes itself after that time and either puts itself back to deep sleep (again setting the alarm) or just sits there in the light sleep (freeze?) mode. Anyone have any ideas of how to get the alarm to 0S (zero seconds) so it doesn't wake back up on its own?

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 3 guests