SPDIF output not working

Post Reply
Argentum_90
Posts: 19
Joined: Sat Nov 02, 2019 1:42 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

SPDIF output not working

Post by Argentum_90 »

Hello,

I have been trying to get audio output from the N2 but I can't.

I am using this board for Optical and Coaxial output:
https://es.aliexpress.com/item/32961776 ... 63c01Jb9K5

It's for computer motherboards, but it has 5V power and the 3 pins for the GPIO of the ODROID N2. I think it should work. I can see the red led illuminated in the optical output.

Then I set the SPDIF output on the Android settings and reboot. No sound coming from SPDIF.

Any ideas?
Thanks

User avatar
joerg
Posts: 1175
Joined: Tue Apr 01, 2014 2:14 am
languages_spoken: german, english, español
ODROIDs: C1, C1+, C2, N1, N2, C4
Location: Germany
Has thanked: 63 times
Been thanked: 139 times
Contact:

Re: SPDIF output not working

Post by joerg »

Have you used this pins at J7?

Code: Select all

GND 	1
SPDIF Output 	2
5.0V 	3 

Argentum_90
Posts: 19
Joined: Sat Nov 02, 2019 1:42 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: SPDIF output not working

Post by Argentum_90 »

joerg wrote:
Sun Aug 02, 2020 9:16 pm
Have you used this pins at J7?

Code: Select all

GND 	1
SPDIF Output 	2
5.0V 	3 
Yes

User avatar
joerg
Posts: 1175
Joined: Tue Apr 01, 2014 2:14 am
languages_spoken: german, english, español
ODROIDs: C1, C1+, C2, N1, N2, C4
Location: Germany
Has thanked: 63 times
Been thanked: 139 times
Contact:

Re: SPDIF output not working

Post by joerg »

OK, if you have red light, then normally should audio be there. Do you have another spdif source to check if your receiver setting is correct? I have for example an usb audio adapter with spdif out (Behringer UCA222) and when I have audio on the head phone jack, then I am sure there is audio also on the spdif out. Only to check if the receiving device is receiving something. Then I have also anther USB audio adapter with a SPDIF IN and I can check with Audacity if there is a signal.
I don't know if you have checked this already. Hope it helps.

Argentum_90
Posts: 19
Joined: Sat Nov 02, 2019 1:42 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: SPDIF output not working

Post by Argentum_90 »

Yes. I tried with two SPDIF receivers and still no audio.

ForestBoy
Posts: 8
Joined: Fri Jul 31, 2020 8:39 am
languages_spoken: english
ODROIDs: N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: SPDIF output not working

Post by ForestBoy »

Hi Argentum_90, did you ever get the SPDIF out to work?

I have the same board from AliExpress and can't get it to work using pin 2 on the J7.
I know my receiver SPDIF works, as it decodes optical from another source.

User avatar
joerg
Posts: 1175
Joined: Tue Apr 01, 2014 2:14 am
languages_spoken: german, english, español
ODROIDs: C1, C1+, C2, N1, N2, C4
Location: Germany
Has thanked: 63 times
Been thanked: 139 times
Contact:

Re: SPDIF output not working

Post by joerg »

The secret is the model of transmitting diode. They don't explain on their selling page. Once this is known, we would have a chance to look into the datasheet to find the cause.

Luke.go
Posts: 551
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english
Has thanked: 65 times
Been thanked: 66 times
Contact:

Re: SPDIF output not working

Post by Luke.go »

Did you change settings for spdif from Odroid settings?

ForestBoy
Posts: 8
Joined: Fri Jul 31, 2020 8:39 am
languages_spoken: english
ODROIDs: N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: SPDIF output not working

Post by ForestBoy »

Yes. Using both of these guides....

https://kodi.wiki/view/Settings/System/Audio
https://kodi.wiki/view/Audio_quickstart_guide

I've set the audio output device to SPDIF, turned on Audio Passthrough, with Passthrough device being the SPDIF one as as well.
I don't even get the LED to light up in the Toslink socket thingy.

User avatar
joerg
Posts: 1175
Joined: Tue Apr 01, 2014 2:14 am
languages_spoken: german, english, español
ODROIDs: C1, C1+, C2, N1, N2, C4
Location: Germany
Has thanked: 63 times
Been thanked: 139 times
Contact:

Re: SPDIF output not working

Post by joerg »

To make a basic test, can you connect it to GND, 5V, and the signal input alternating to GND and 5V? The light should go on and off. If no, then it is out of function.
Then, can you see any information on the transmitter, which model it is?
Further you could also measure the pin 2 on J7 with a meter. It should have high value, either 5V or 3.3V - I don't remember - but not 0V.
If it is 0V, then it's clear that you don't get light. Then the root cause need to be searched in the settings and the operating system.

ForestBoy
Posts: 8
Joined: Fri Jul 31, 2020 8:39 am
languages_spoken: english
ODROIDs: N2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: SPDIF output not working

Post by ForestBoy »

That for the tip.
I tried that and got nothing, so I guess the SPDIF board is busted.

Cheers.

User avatar
joerg
Posts: 1175
Joined: Tue Apr 01, 2014 2:14 am
languages_spoken: german, english, español
ODROIDs: C1, C1+, C2, N1, N2, C4
Location: Germany
Has thanked: 63 times
Been thanked: 139 times
Contact:

Re: SPDIF output not working

Post by joerg »

If you have skills to solder, you could buy one of this from Cliff:
https://www.ebay.de/itm/224143464033?mk ... olid=11000
I use it with my car interface board and it is working well.
Or this one from Everlight, but it's harder to get:
https://www.ebay.de/i/193649202403?chn= ... XsQAvD_BwE
IMG_20190312_151420.jpg
IMG_20190312_151420.jpg (80.21 KiB) Viewed 143 times

Post Reply

Return to “Android”

Who is online

Users browsing this forum: Baidu [Spider] and 3 guests