Page 1 of 1

Force a kernel update?

Posted: Sun May 26, 2019 6:25 am
by skeetre
I had updated my Ubuntu and had the 4.9.170+ kernel... but I screwed something up so I copied over the old boot partition and can now boot into my system, but I am running on the older 4.9.162 kernel, have no wifi drivers, and actually the only driver listed when I do lsmod is uas. Any ideas before I just reflash the image?
I'm guessing the modules aren't loading cause they're for the 4.9.170 kernel, but I don't have that kernel anymore.

I think what was really messing me up was that I removed my usb thumb drive when running Android and then forgot to put it back in and my ubuntu was trying to mount /dev/sda5 as my /home directory and it wasn't there. Once I put the thumbdrive back, I was able to boot up. Just no more wifi or updated kernel. I was also trying to get some of my other wifi devices to work, a tplink ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n and a trendnet ID 148f:3573 Ralink Technology, Corp. RT3573.

Thanks!

Re: Force a kernel update? [solved]

Posted: Sun May 26, 2019 9:39 am
by skeetre
Well, I didn't figure out how to actually 'update' the kernel... but I did use an extra microSD card to boot from, download all updates, then copy over the files from it to my eMMC and boot up... and guess what? I have the latest kernel, 4.9.177-28, and all 3 of my wifi devices work. Using the trendnet wifi I'm getting:
Ping ms 41, Download Mbps 138.23, Upload Mbps 18.47

When I think about it, I guess I really didn't have much on the eMMC and could have reflashed it, especially since I have most things on my thumbdrive in the /home folder. But oh well, got it to work without re-flashing.

Re: Force a kernel update?

Posted: Sun May 26, 2019 2:04 pm
by mad_ady
I don't remember what the kernel package name is on the N2, but you can reinstall it with sudo apt-get install --reinstall linux-image-n2

Re: Force a kernel update?

Posted: Sun May 26, 2019 5:07 pm
by meveric
HardKernel's new Kernels are all named "linux-odroid" not linux-image anymore :)
so I'd check for linux-odroid-n2 or something like that

Re: Force a kernel update?

Posted: Tue May 28, 2019 11:04 am
by odroid
Right!
This one worked for me.

Code: Select all

sudo apt install --reinstall linux-odroid-n2