[SOLVED] H2+ No ethernet lights or connection

Post Reply
spacemanspiffee
Posts: 5
Joined: Fri Nov 20, 2020 12:42 am
languages_spoken: english
ODROIDs: H2+
Has thanked: 0
Been thanked: 1 time
Contact:

[SOLVED] H2+ No ethernet lights or connection

Post by spacemanspiffee »

I was using my H2+ today to run my CNC machine (that is it's sole purpose in life) and the ethernet connection dropped out and there are now no lights on the ethernet port.

It shows no ethernet connections and rebooting has no effect. I'm not super great with linux, but I can fumble my way around. Any tips on identifying whether this is a hardware or software issue would be greatly appreciated.

User avatar
odroid
Site Admin
Posts: 36930
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1595 times
Been thanked: 1072 times
Contact:

Re: H2+ No ethernet lights or connection

Post by odroid »

lspci command might be helpful.

Code: Select all

odroid@H2:~$ lspci
.
.
.
.
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 04)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 04)
BTW, which Linux distro and kernel version have you used?

spacemanspiffee
Posts: 5
Joined: Fri Nov 20, 2020 12:42 am
languages_spoken: english
ODROIDs: H2+
Has thanked: 0
Been thanked: 1 time
Contact:

Re: H2+ No ethernet lights or connection

Post by spacemanspiffee »

Thanks for the tip, the lspci command basically told me that it didn't look like there was an issue with the Odroid and so I started looking at other things and it turns out it was the mesa card that the Odroid was connected to was acting up.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest