H2 with intel uhd graphics driver display problem

Post Reply
bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

H2 with intel uhd graphics driver display problem

Unread post by bamdad » Thu Aug 08, 2019 7:06 pm

Dear All;
I've a new H2, fully functional, tested and running (tested with Ubuntu/Win 8.1/Win 10). The problem is, when I install Intel UHD graphics, LCD display detects an out of range signal and goes blank. I've tried the following:
-Tested with Win10 (1709/19H1) with Intel various Intel UHD drivers including the most recent (100.7000)
-Tried changing resolution (LCD native resolution is 1920x1080) anything from lowest up to 1920x1080.
-The display refresh rate is set at 60Hz, there is no other value to change this to. (weird problem here was that Microsoft driver which does generate correct display signal, has only 64Hz refresh rate to select, even then, the LCD reports 60Hz refresh rate)
-Tried changing the power settings to Optimal performance for Intel drivers on all power profiles.
-Drivers for the LCD is also installed (Samsung P23700)
-Tried Safe mode, it works but with Microsoft Generic Driver
-Low resolution boot mode does not work.
-Tried defining a custom resolution with Intel driver, did not work.

Is there any thing I've been missing here? Has anyone run into this issue?

Please note that display works with Microsoft Generic Driver, so I think the cable/LCD/ODROID hardware cannot be at fault here. Also please note that in order to get display working on linux, I had to pass nomodeset to grub.

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by odroid » Thu Aug 08, 2019 7:14 pm

We tried Intel video driver version 26.20.100.6912 on Windows 10 two weeks ago and it worked fine with a 4K/60hz HDMI 2.0 display.

Did you have no problem with Ubuntu OS?

bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by bamdad » Fri Aug 09, 2019 3:26 am

Hello there;
Ubuntu 19.04 works if you pass -nomodeset parameter to grub, otherwise no. Is there any way I can do the same (i.e the -nomodeset parameter) to the intel graphics driver? I don't think that 1920x1080p@60Hz requires HDMI 2.0 bandwidth, as my monitor does that quite comfortably with all the graphics adapters that I have... Is there any diagnostics information available from intel graphics drivers?
Please note that I can boot win 10 into safe mode (I have changed the boot menu policy, so that I can use F8 for the boot menu), and every time I remove the intel drivers (thus forcing the Microsoft drivers) I get back the display. Please also note that I can communicate with the machine as I have tinyVNC installed on it, and I have other working machines. Any advice?
Also it would be best if you could tell me the build number of your windows 10 installation.

Many thanks
.b

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by odroid » Fri Aug 09, 2019 10:13 am

I'm writing this reply on my H2 which runs Ubuntu 19.04. I didn't change any grub options.

Code: Select all

odroid@h2:~$ sudo lshw -c video
  *-display                 
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:135 memory:a0000000-a0ffffff memory:90000000-9fffffff ioport:f000(size=64) memory:c0000-dffff
Did you change any display/video options in the BIOS settings?


BTW, we tested this Windows (30 days trial).
Edition : Windows 10 Pro
Version : 1903
OS build : 18362.239

bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by bamdad » Fri Aug 09, 2019 6:24 pm

Dear Odroid;

Here is the output of lshw -c video (as root) on my ubuntu 19.04 installation:


description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: latency=0
resources: memory:a0000000-a0ffffff memory:90000000-9fffffff ioport:f000(size=64) memory:c0000-dffff


I did not change anything in bios except boot parameters before installing ubuntu, just to make sure that bios settings are as they should be, I did a reset on bios by removing the cmos battery, waiting, and powering back on again (with the battery plugged). This seems to have effect, as I have disabled the bios splash screen to see any bios messages there might be, but it is back on again.

Regarding windows, I have tried setting DVMT memory allocations (512MB static, MAX dynamic, and many settings in between), I have also tried disabling HD-Audio, all to no avail. Windows has video with Microsoft drivers, generates out-of-range signal with Intel drivers.

By the way, as I can see, your lshw -c video shows IRQ 135, mine does not, is there any problem here?

Many thanks
.b

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by odroid » Fri Aug 09, 2019 6:52 pm

There must be "driver=i915" in the configuration string if the internal GPU detected well.
Since you are the first customer who raised this issue, I think your board seems to have an odd hardware problem.

Did you buy your H2 board from our web-store directly? or your local distributor?

BTW, I will help you early next week again since it is already Friday evening here in Korea.

bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by bamdad » Fri Aug 09, 2019 7:40 pm

Dear Odroid;
Thanks for your time and efforts, I have removed the nomodeset option from the kernel grub tries to boot, this results in a blank display on my monitor (monitor goes to power saving mode, as the signal is out of its range) but produces the following as the result of lshw -c video (run as root)

*-display
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:130 memory:a0000000-a0ffffff memory:90000000-9fffffff ioport:f000(size=64) memory:c0000-dffff


I will try to check the system with another monitor to see if I can improve on this. please note that my monitor is a Samsung Syncmaster P23700, and can be considered quite old, as it receives its input on DVI, I have to use a HDMI-to-DVI adapter (I use the same adapter for other machines, and it occurs to me that they work). I will try to test a DisplayPort to HDMI converter to see if anything changes.

Many thanks
.b

bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by bamdad » Fri Aug 09, 2019 10:57 pm

Dear Odroid;
I've checked the H2 with a Sony 48" TV, and it works, both in Windows 10 and in Ubuntu 19.04 (with and without nomodeset kernel option). Is there anyway to check the EDID that the graphics receives from the monitor?
I'll post any further information I get from this issue.

Many thanks for your time and attention
.b

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by odroid » Mon Aug 12, 2019 9:52 am

Good to hear the Sony TV works fine at least.

Can you try a custom resolution mode to override the EDID info from P23700.
https://www.intel.com/content/www/us/en ... ivers.html

bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by bamdad » Mon Aug 12, 2019 6:30 pm

Dear Odroid;
The custom resolutions with the latest version of Intel driver (100.7000) did not work. I tried the same modeline from XOrg running on an XU3 to define a custom resolution but it also did not work. The older non-dch drivers did not even detect the monitor connected to the hdmi port (there was only intel WIDI display available for selection). the interesting point is that I could make the entire system work with the DisplayPort using a DisplayPort to DVI adapter. I will try some other HDMI to DVI adapters to see if anything changes.

.b

NeoRaist
Posts: 1
Joined: Wed Aug 14, 2019 5:44 pm
languages_spoken: english spanish
ODROIDs: H2
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by NeoRaist » Wed Aug 14, 2019 6:16 pm

Hi,
I have a similar issue as bamdad, so I think better not to open a new topic. (also first post, hi everyone)
I have a H2 board and I installed ubuntu in a nmve disk. For the installation I used a Benq screen with a HDMI to DVI cable, and everything went fine.
Then I moved the H2 to a SHARP TV, 1920x1080, with HDMI-HDMI cable, but after boot, bios grub and linux letters, tv goes blank. With nomodeset in grub, login works, but resolution is set to something like 1024x768 and no option to change it.
Then in login window, i noticed I have Mate with Wayland, I assume I installed it somehow when I installed mate (because I don't like the "new" ubuntu and I allways install mate in my computers) and that way i managed to login (without nomodeset in grub) but almost nothing works in mate-wayland.
I tried with ubuntu-wayland and it works; no nomodeset in grub and fullhd resolution. But I don't know how to get the wayland configuration and move it to xorg.
Another thing i tried, connect the computer screen to the h2, boot, login in no-wayland and then connect the SHARP tv, that works fine, but after reboot is not recognized anymore.
I want to try with a DisplayPort to HDMI cable, but I don't have it yet.

bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by bamdad » Fri Aug 23, 2019 6:01 am

Dear All;
Sorry to bump this up again, but to bring every one interested up-to-date, I have performed tests with different HDMI to DVI adapters and with a cable (direct HDMI-to-DVI cable, without adapters) with the same effect. When Intel UHD drivers kick in, display goes to power-saving mode. My current work-arounds are as follows:
-don't use intel drivers, microsoft drivers do not produce display blanking symptoms. in linux, pass -nomodeset to grub.
-use a displayport to dvi adapter. display works fine with intel drivers, both in linux (-nomodeset is not required here) and windows.

Please also note that I tested the system with an LCD TV set, HDMI-to-HDMI connection worked fine there.
Has anybody got any better ideas? Any method to further debug this issue and maybe narrow it down a little bit more?

.b

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by odroid » Fri Aug 23, 2019 9:16 am

It seems to be worth to try an EDID parsing with the problematic monitors.
I saw some old monitors send out some wrong EDID information and the display driver could be crazy.

bamdad
Posts: 9
Joined: Thu Aug 08, 2019 6:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: H2 with intel uhd graphics driver display problem

Unread post by bamdad » Sat Aug 24, 2019 3:15 am

Dear Odroid;
The same monitor works with Odroid XU3-lite, and with many other graphics adapters (one that I currently use is an NVidia GT610). Also works with Raspberry PI 3 B. When I check the X logs on XU3, it seems that the board can receive correct monitor capabilities, and can generate correct modelines accordingly.

.b

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest